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Software and hardware requirements to complete all exercises 

Software Requirements: Quartus® Prime Lite or Standard Edition version 18.0 or 18.1 

Hardware Requirements: ARROW MAX1000 Board 
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1. Introduction 
 

The In-System Sources & Probes Editor allows you to easily control any internal signal and provides 

you with a completely dynamic debugging environment. Traditional debugging techniques often 

involve using an external pattern generator to exercise the logic and a logic analyzer to study the 

output waveform during runtime. You can make the debugging cycle more efficient when you can 

drive any internal signal manually within your design. This feature can be especially helpful for 

prototyping your design, such as creating a virtual interface, emulating external data and 

monitoring, changing run time constant on the fly. 

Lab Notes: Many of the names that the lab asks you to choose for files, components, 

and other objects in this exercise must be spelled exactly as directed. This 

nomenclature is necessary because the pre-written software application 

includes variables that use the names of the hardware peripherals. Naming 

the components differently can cause errors. 

 

2. Getting Started 
 

The first objective is to ensure that you have all the necessary hardware items and software 

installed so that the lab can be completed successfully. Below is a list of items required to 

complete this lab: 

- MAX1000 Board (10M08SAU169C8G) 

- USB Cable 

- Lab files: InSystem_Debug_lab_template: Template files are required to complete the lab.  

Includes: insystem_debug_lab.vhd, insystem_debug_lab.sdc, 

insystem_debug_lab_pinout.csv 

- Quartus Prime 18.0 Lite was used for this lab. Previous/newer versions should work (If no 

Quartus Prime is installed, refer to MAX1000 User Guide for instructions) 

- Installed Arrow USB Drivers (If not, refer to MAX1000 User Guide for instructions) 

- Personal computer or laptop running 64-bit Linux / Windows 7 or later with at least an 

Intel i3 core (or equivalent), 4GB RAM and 12 GB of free hard disk space 

- A desire to learn! 
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3. Project with MAX1000 
 

3.1 New Quartus Prime project 
 

3.1.1 New project creation 
 

3.1.1.1 If not already open, from the Start menu or the Desktop, open the Quartus Prime 18.0 Lite 

software. 

 

3.1.1.2 Create a new project using the New Project Wizard: File → New Project Wizard.  

 

 
 

3.1.1.3 Click Next. 

 

3.1.1.4 Configure the New Project Wizard directory, name and top-level entity information: 

 

▪ Enter a directory in which you will store your Quartus project files for this design, for 

example, C:/MAX1000/InSystem_Debug_lab 

▪ Specify the name of the project: InSystem_Debug_lab 

▪ Specify the name of the top-level entity: InSystem_Debug_lab 

https://www.arrow.com/
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3.1.1.5 Click Next. 

 

3.1.1.6 On the Project Type page, select “Empty project” and click Next. 
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4.1.1.1 On the Add Files page, add source files to the project by clicking on the  button and 

browse into the lab files folder where you will locate the provided design files and add: 

 

▪ insystem_debug_lab.vhd 

▪ insystem_debug_lab.sdc 

 

 
 

3.1.1.7 Click Next. 

 

3.1.1.8 Specify Family and Device Settings. Use pull-down menus to select MAX10 family or enter 

the part number in the Name Filter text box. The part number is 10M08SAU169C8G. 

 

 
 

3.1.1.9 Click Finish.  

https://www.arrow.com/
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3.2 Design entry 
 

3.2.1 Add PLL to the Quartus Project 
 

3.2.1.1 From the IP Catalog panel on the left side, expand the menus for the Basic Functions → 

Clocks; PLLs and Resets → PLL and double click on ALTPLL. 

 

If the IP catalog is not visible, then right click on the toolbar and select IP catalog. 

 

 
 

3.2.1.2 On the Save IP Variation window, enter the following information. 

 

▪ IP variation file name: <project_directory>/PLL 

▪ IP variation file type: VHDL 

 

 
 

3.2.1.3 Click OK.  

https://www.arrow.com/
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3.2.1.4 Under General/Modes tab (page 1 of 12) of PLL MegaWizard change the frequency of clock 

input to 12 MHz. This source is provided by the internal oscillator in the MAX10 FPGA. 

 

 
 

3.2.1.5 Click Next. 

 

3.2.1.6 Under Input/Lock tab (page 2 of 12) uncheck ‘areset’ input and locked output option.  

 

 
 

3.2.1.7 Click Next until you reach the Output Clocks tab (page 6 of 12).  

https://www.arrow.com/


 

MAX1000 P a g e  | 8 www.arrow.com 
In-System Sources & Probes Lab  February 2019 

 

3.2.1.8 Under the clk c0 tab (page 6 of 12) select “Enter output clock parameters” and set Clock 

division factor to 1560. Leave the rest as default.  

 

 
 

3.2.1.9 Click Finish. This will take you to the Summary tab (page 12 of 12). Click Finish again to 

close ALTPLL MegaWizard Manager. 

 

3.2.1.10 In the pop-up Quartus Prime IP Files accept all defaults and click Yes. 
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3.2.2 Add 1. In-System Sources & Probes to the Quartus Project 
 

3.2.2.1 From the IP Catalog panel, expand the menus for the Basic Functions → Simulation; 

Debug and Verification → Debug and Performance and add Altera In-System Sources & 

Probes. 

 
 

3.2.2.2 In the New IP Variation window enter DUTY_ISSP for the Entity name and leave the rest 

as default. 

 

 
 

3.2.2.3 Press OK. 
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3.2.2.4 Enter DUTY for the Instance ID. Set 8 for the Probe Port Width and 4 for the Source Port 

Width. 

 

 
 

3.2.2.5 Click Generate HDL… button on the bottom right of Parameter Editor window. 

 

3.2.2.6 On the Generation window, enter the following information. 

 

▪ Create HDL design files for synthesis: VHDL 

▪ Uncheck Create timing and resource estimates for third-party EDA synthesis tools. 

▪ Uncheck Create block symbol file (.bsf) 

▪ Create simulation model: None 

 

  

https://www.arrow.com/
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3.2.2.7 Click Generate and when the Save System is completed, click Close. 

 

 
 

3.2.2.8 When the generate process completed, click Close. 

 

 
 

3.2.2.9 Click Finish button to close Parameter Editor window. 

 

3.2.2.10 Click Close on pop-up window. 

 

 
 

  

https://www.arrow.com/
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3.2.2.11 It generates IP pointer files for both synthesis (.qip) and simulation (.sip) that will point 

Quartus to all the necessary design files needed to synthesize or simulate the Platform 

Designer system. Press OK to close as the .qip file will be added to the project later. The 

In-System Sources and Probes Editor does not support simulation, so no need to add the 

.sip file. 

 

 
 

3.2.3 Add 2. In-System Sources & Probes to the Quartus Project 
 

3.2.3.1 From the IP Catalog panel, expand the menus for the Basic Functions → Simulation; 

Debug and Verification → Debug and Performance and add Altera In-System Sources & 

Probes. 

 
 

3.2.3.2 In the New IP Variation window enter SWITCH_ISSP for the Entity name and leave the rest 

as default. 
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3.2.3.3 Press OK. 

 

3.2.3.4 Enter SWIN for the Instance ID. Set 0 for the Probe Port Width and 3 for the Source Port 

Width. 

 

 
 

3.2.3.5 Click Generate HDL… button on the bottom right of Parameter Editor window. 

 

3.2.3.6 On the Generation window, enter the following information and click Generate. 

 

▪ Create HDL design files for synthesis: VHDL 

▪ Uncheck Create timing and resource estimates for third-party EDA synthesis tools. 

▪ Uncheck Create block symbol file (.bsf) 

▪ Create simulation model: None 

 

3.2.3.7 Click Close when the Save System completed. 

 

3.2.3.8 When the generate process completed, click Close. 
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3.2.3.9 Click Finish button to close Parameter Editor window. 

 

3.2.3.10 Close both pop-up windows. 

 

3.2.3.11 Choose Project → Add/Remove Files in Project... from the Quartus Prime menu. 

 

3.2.3.12 Click on the  button and browse through the synthesis directories: 

<project_directory>/DUTY_ISSP/synthesis/ and open DUTY_ISSP.qip. 

 

3.2.3.13 Add SWITCH_ISSP.qip to the project from <project_directory>/SWITCH_ISSP/synthesis 

 

 
 

3.2.3.14 Click Apply and OK. 
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3.2.4 Design modification 
 

Notes: Up to this point, the original design is done. If you want, you can continue with 3.3 point 

with pin assignment, compilation and programming the board for the testing purpose 

in order to see the original function of the project, and then come back to continue 

with this 3.2.4 point. 

 

3.2.4.1 Open insystem_debug_lab.vhd. 

 

3.2.4.2 Uncomment line 44-46, line 113-115 and line 123 by deleting “--" characters at the 

beginning of the lines or select the desired lines and click on  button on the toolbar of 

text editor. 

 

3.2.4.3 Comment line 98 and line 103 by writing “--" at the beginning of the lines or select the 

lines and click on  button. 

 

3.2.4.4 Add the following component declarations in the architecture section. There should be a 

commented area indicating where exactly around line 59. 

 
component DUTY_ISSP 
port( probe  : in std_logic_vector(7 downto 0); 

source : out std_logic_vector(3 downto 0)); 
end component; 
 
 
component SWITCH_ISSP 
port( source : out std_logic_vector(2 downto 0)); 
end component; 

 

3.2.4.5 Add the following component instantiations in the architecture section after the word 

‘begin’. There should be a commented area where exactly around line 78. 

 
pwm_debug : DUTY_ISSP 
port map( probe => probe, 
   source => source); 
 
 
sw : SWITCH_ISSP 
port map(source => iSW); 

 

3.2.4.6 Save the modification by clicking on  button or File → Save. 

 

  

https://www.arrow.com/
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3.3 Compile design 
 

3.3.1 Import pin assignments 
 

3.3.1.1 Select Assignments → Import Assignments… 

 

3.3.1.2 Add source file by clicking on the  button and browse into the lab file folder where you 

will locate the provided design files and add insystem_debug_lab_pinout.csv. 

 

 
 

3.3.1.3 Press OK. 

 

3.3.1.4 Open Pin Planner by clicking on  button on the toolbars, or Assignments → Pin Planner 

in order to check the import. In the Pin Planner you should see the following: 

 

 
 

3.3.1.5 Close the Pin Planner. 
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3.3.2 Compiling the Design 
 

3.3.2.1 Start Compilation by clicking on  button on the toolbars, or Processing → Start 

Compilation. 

 

There should be no errors. If there are errors, they should be fixed before re-compilating. 

The 100% in the lower right corner or a green checkmark next to the Compile Design in 

the Compilation task window indicates that the compilation was successful. 

 

 
 

3.3.2.2 Connect your MAX1000 board to your PC using an USB cable. Since the Arrow USB Blaster 

should be already installed, the Window’s Device Manager should display the following 

entries are highlighted in red (port number may differ depending on your PC): 

 

 

 

https://www.arrow.com/
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3.4 In-System Sources and Probes 
 

3.4.1 Editor setup 
 

3.4.1.1 Select Tools → In-System Sources and Probes Editor from the menu. 

 

3.4.1.2 The In-System Sources and Probes Editor will open. Click OK to close the pop-up window. 

 

 
 

3.4.1.3 If your board is automatically detected, then you can skip the following steps and continue 

with the 3.4.1.7 point. 

 

3.4.1.4 Click on the Setup… button in the top right corner. 
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3.4.1.5 Double click Arrow-USB-Blaster entry in the Hardware Setup tab. The Currently selected 

hardware should now show Arrow-USB-Blaster [USB0] (depending on your PC, the USB 

port number may variant). 

 

 
 

3.4.1.6 Click Close and press OK to close the pop-up windows. 

 

3.4.1.7 The hardware configuration window should be updated as follows. 

 

 
 

3.4.1.8 Click on  button to choose the programming file. 

 

3.4.1.9 Navigate to <project_directory>/output_files/ and open the InSystem_Debug_lab.sof 

file. 

 

3.4.1.10 Click OK to close pop-up window. 
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3.4.1.11 Click on  button to program the board. When the configuration is complete, the 

message box in the middle should write “Ready to acquire” and update the Instance 

Manager window. 

 

 
 

3.4.1.12 Choose Manual for Probe read interval and leave the default 1 s value. 

 

3.4.1.13 Change the maximum size of Event log to 64 and leave Continuously for Write source 

data. 

 

 
 

3.4.1.14 In the waveform window, type Direction in the alias cell of P[7..0], Duty Cycle for S[3..0] 

and Channel for S[2..0]. Expand the nodes. 
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3.4.2 Testing the board 
 

3.4.2.1 Select DUTY and SWIN instance and click  on button to run. The status should be 

“Unloading data” for both instances and starts to draw the waveform. 

 

 
 

3.4.2.2 Set all source node of Duty Cycle to 1 by clicking on the Data cell next to them. After this 

one LED is lighting on the MAX1000 board and you should see the following waveform. 

 

 
 

3.4.2.3 Repeat the previous step with any value you like and observe that the brightness of LED 

will change. 

 

3.4.2.4 By setting a value for Channel, you can change the channel of Duty Cycle input, and in this 

way, you can set different value for the PWMs. Set different values for Channel and Duty 

Cycle and observe the change on the board. 

 

3.4.2.5 The Direction output only changes, when you set b1111 or b0000 for Duty Cycle. If you set 

b1111, the belonged output will be ‘1’ until you set b0000 and vice versa. 

 

 
 

3.4.2.6 Click  button to stop running. 

 

 

CONGRATULATIONS! YOU HAVE SUCCESSFULLY COMPLETED THE IN-SYSTEM 

SOURCES & PROBES LAB!  

https://www.arrow.com/
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5 Revision History 
 

Version Change Log Date of Change 
V1.0 Initial Version 06/02/2019 
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6 Legal Disclaimer 

ARROW ELECTRONICS  

EVALUATION BOARD LICENSE AGREEMENT  
By using this evaluation board or kit (together with all related software, firmware, components, and 

documentation provided by Arrow, “Evaluation Board”), You (“You”) are agreeing to be bound by the terms and 

conditions of this Evaluation Board License Agreement (“Agreement”). Do not use the Evaluation Board until You 

have read and agreed to this Agreement. Your use of the Evaluation Board constitutes Your acceptance of this 

Agreement.  

PURPOSE 

The purpose of this evaluation board is solely intended for evaluation purposes. Any use of the Board beyond 

these purposes is on your own risk. Furthermore, according the applicable law, the offering Arrow entity 

explicitly does not warrant, guarantee or provide any remedies to you with regard to the board.  

LICENSE  

Arrow grants You a non-exclusive, limited right to use the enclosed Evaluation Board offering limited features 

only for Your evaluation and testing purposes in a research and development setting. Usage in a live environment 

is prohibited. The Evaluation Board shall not be, in any case, directly or indirectly assembled as a part in any 

production of Yours as it is solely developed to serve evaluation purposes and has no direct function and is not 

a finished product.  

EVALUATION BOARD STATUS  

The Evaluation Board offers limited features allowing You only to evaluate and test purposes. The Evaluation 

Board is not intended for consumer or household use. You are not authorized to use the Evaluation Board in any 

production system, and it may not be offered for sale or lease, or sold, leased or otherwise distributed for 

commercial purposes.  

OWNERSHIP AND COPYRIGHT  

Title to the Evaluation Board remains with Arrow and/or its licensors. This Agreement does not involve any 

transfer of intellectual property rights (“IPR) for evaluation board. You may not remove any copyright or other 

proprietary rights notices without prior written authorization from Arrow or it licensors.  

RESTRICTIONS AND WARNINGS  

Before You handle or use the Evaluation Board, You shall comply with all such warnings and other instructions 

and employ reasonable safety precautions in using the Evaluation Board. Failure to do so may result in death, 

personal injury, or property damage.  

You shall not use the Evaluation Board in any safety critical or functional safety testing, including but not limited 

to testing of life supporting, military or nuclear applications. Arrow expressly disclaims any responsibility for such 

usage which shall be made at Your sole risk.  

WARRANTY  

Arrow warrants that it has the right to provide the evaluation board to you. This warranty is provided by Arrow 

in lieu of all other warranties, written or oral, statutory, express or implied, including any warranty as to 

merchantability, non-infringement, fitness for any particular purpose, or uninterrupted or error-free operation, 

all of which are expressly disclaimed. The evaluation board is provided “as is” without any other rights or 

warranties, directly or indirectly.  

You warrant to Arrow that the evaluation board is used only by electronics experts who understand the dangers 

of handling and using such items, you assume all responsibility and liability for any improper or unsafe handling 

or use of the evaluation board by you, your employees, affiliates, contractors, and designees.  
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LIMITATION OF LIABILITIES  

In no event shall Arrow be liable to you, whether in contract, tort (including negligence), strict liability, or any 

other legal theory, for any direct, indirect, special, consequential, incidental, punitive, or exemplary damages 

with respect to any matters relating to this agreement. In no event shall arrow’s liability arising out of this 

agreement in the aggregate exceed the amount paid by you under this agreement for the purchase of the 

evaluation board.  

IDENTIFICATION 

You shall, at Your expense, defend Arrow and its Affiliates and Licensors against a claim or action brought by a 

third party for infringement or misappropriation of any patent, copyright, trade secret or other intellectual 

property right of a third party to the extent resulting from (1) Your combination of the Evaluation Board with 

any other component, system, software, or firmware, (2) Your modification of the Evaluation Board, or (3) Your 

use of the Evaluation Board in a manner not permitted under this Agreement. You shall indemnify Arrow and its 

Affiliates and Licensors against and pay any resulting costs and damages finally awarded against Arrow and its 

Affiliates and Licensors or agreed to in any settlement, provided that You have sole control of the defense and 

settlement of the claim or action, and Arrow cooperates in the defense and furnishes all related evidence under 

its control at Your expense. Arrow will be entitled to participate in the defense of such claim or action and to 

employ counsel at its own expense.  

RECYCLING  

The Evaluation Board is not to be disposed as an urban waste. At the end of its life cycle, differentiated waste 

collection must be followed, as stated in the directive 2002/96/EC. In all the countries belonging to the European 

Union (EU Dir. 2002/96/EC) and those following differentiated recycling, the Evaluation Board is subject to 

differentiated recycling at the end of its life cycle, therefore: It is forbidden to dispose the Evaluation Board as 

an undifferentiated waste or with other domestic wastes. Consult the local authorities for more information on 

the proper disposal channels. An incorrect Evaluation Board disposal may cause damage to the environment and 

is punishable by the law. 

 

https://www.arrow.com/
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