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Software and hardware requirements to complete all exercises 

Software Requirements: Quartus® Prime Lite or Standard Edition version 18.0 or 18.1 

Hardware Requirements: ARROW MAX1000 Board 
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1. Introduction 
 

This tutorial provides comprehensive information to help you understand how to analyze and 

verify your Intel FPGA design within Quartus Prime software. This lab explains how to use 

Embedded Logic Analyzer megafunction, and gives detailed, step-by-step procedures on how to 

set up and run Embedded Logic Analyzer.  

Lab Notes: Many of the names that the lab asks you to choose for files, components, 

and other objects in this exercise must be spelled exactly as directed. This 

nomenclature is necessary because the pre-written software application 

includes variables that use the names of the hardware peripherals. Naming 

the components differently can cause errors. There are also other similar 

dependencies within the project that require you to enter the correct 

names. 

 

2. Getting Started 
 

The first objective is to ensure that you have all the necessary hardware items and software 

installed so that the lab can be completed successfully. Below is a list of items required to 

complete this lab: 

- MAX1000 Board (10M08SAU169C8G) 

- USB Cable 

- Lab files: SignalTap_lab_template: Template files are required to complete the lab. 

Includes: uart_tx.vhd, uart_tx.sdc 

- Quartus Prime 18.0 Lite was used for this lab. Previous/newer versions should work (If no 

Quartus Prime is installed, refer to MAX1000 User Guide for instructions) 

- Installed Arrow USB Drivers (If not, refer to MAX1000 User Guide for instructions) 

- Personal computer or laptop running 64-bit Linux / Windows 7 or later with at least an 

Intel i3 core (or equivalent), 4GB RAM and 12 GB of free hard disk space 

- A desire to learn! 

  

https://www.arrow.com/


 

MAX1000 P a g e  | 3 www.arrow.com 
SignalTap Lab  January 2019 

 

3. SignalTap overview 
 

The SignalTap Embedded Logic Analyzer megafunction, which is provided with Quartus Prime 

software allows you to analyze and verify System-on-a-Programmable Chip (SOPC) designs. It is a 

powerful tool that lets you capture signals from internal FPGA nodes while the device is running 

in system, which gives you non-instructive access to signals from internal device nodes. 

The Arrow USB Blaster, which is the onboard programming interface of MAX1000, provide analysis 

support, allowing you to transfer signal data to the Quartus Prime software. Using the intuitive 

Quartus interface, you can select signals, set up triggering events, configure memory, and display 

waveforms. You can also use data retrieved by Embedded Logic Analyzer to debug and verify your 

design. 
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4. Project with MAX1000 
 

4.1 Quartus Prime project 
 

4.1.1 Create a new Quartus Prime project 
 

4.1.1.1 If not already open, from the Start menu or the Desktop, open the Quartus Prime 18.0 Lite 

software. 

 

4.1.1.2 Create a new project using the New Project Wizard: File → New Project Wizard.  

 

 
 

4.1.1.3 Click Next. 

 

4.1.1.4 Configure the New Project Wizard directory, name and top-level entity information: 

 

▪ Enter a directory in which you will store your Quartus project files for this design, for 

example, C:/MAX1000/SignalTap_lab 

▪ Specify the name of the project: signaltap_lab 

▪ Specify the name of the top-level entity: uart_tx 

https://www.arrow.com/
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4.1.1.5 Click Next. 

 

4.1.1.6 On the Project Type page, select “Empty project” and click Next.  
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4.1.1.7 On the Add Files page, add source files to the project by clicking on the  button and 

browse into the lab files folder where you will locate the provided design files and add: 

 

▪ uart_tx.vhd 

▪ uart_tx.sdc 

 

 
 

4.1.1.8 Click Next. 

 

4.1.1.9 Specify Family and Device Settings. Use pull-down menus to select MAX10 family or enter 

the part number in the Name Filter text box. The part number is 10M08SAU169C8G. 

 

 
 

4.1.1.10 Click Finish.  

https://www.arrow.com/
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4.2 Design entry 
 

Overview: In this module you will add missing components to your design. 

 

4.2.1 Add PLL to the Quartus project 
 

4.2.1.1 From the IP Catalog panel on the left side, expand the menus for the Basic Functions → 

Clocks; PLLs and Resets → PLL and double click on ALTPLL. 

 

If the IP catalog is not visible, then right click on the toolbar and select IP catalog. 

 

 
 

4.2.1.2 On the Save IP Variation window, enter the following information. 

 

▪ IP variation file name: <project_directory>/PLL 

▪ IP variation file type: VHDL 

 

 
 

4.2.1.3 Click OK.  

https://www.arrow.com/
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4.2.1.4 Under General/Modes tab (page 1 of 12) of PLL MegaWizard change the frequency of clock 

input to 12 MHz. This source is provided by the internal oscillator in the MAX10 FPGA. 

 

 
 

4.2.1.5 Click Next. 

 

4.2.1.6 Under Input/Lock tab (page 2 of 12) uncheck ‘areset’ input and locked output option.  
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4.2.1.7 Click Next until you reach the Output Clocks tab (page 6 of 12). 

 

4.2.1.8 Under the clk c0 tab (page 6 of 12) select “Enter output clock frequency” and set 0.1152 

MHz.  

 

 
 

4.2.1.9 Click Finish. This will take you to the Summary tab (page 12 of 12). Click Finish again to 

close ALTPLL MegaWizard Manager. 

 

4.2.1.10 In the pop-up Quartus Prime IP Files accept all defaults and click Yes. 
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4.2.1.11 In the search bar of IP Catalog, type “counter”, and add LPM_COUNTER. 

 

 
 

4.2.1.12 On the Save IP Variation window, enter the following information. 

 

▪ IP variation file name: <project_directory>/COUNTER 

▪ IP variation file type: VHDL 

 

 
 

4.2.1.13 Click OK. 

 

4.2.1.14 On the General Parameter Settings tab (page 1 of 5) accept all defaults and click Next. 

 

  

https://www.arrow.com/
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4.2.1.15 On the General 2 Parameter Settings tab (page 2 of 5) select Count Enable and click Next. 

 

 
 

4.2.1.16 On the Optional Inputs tab (page 3 of 5) select Load. 

 

 
 

4.2.1.17 Click Finish. This will take you to the Summary tab (page 5 of 5). Click Finish again to close 

LPM_COUNTER MegaWizard Manager.  

https://www.arrow.com/
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4.2.1.18 In the pop-up Quartus Prime IP Files accept all defaults and click Yes. 

 

 
 

4.2.1.19 In the search bar of IP Catalog, type “shift”, and add LPM_SHIFTREG. 

 

 
 

4.2.1.20 On the Save IP Variation window, enter the following information. 

 

▪ IP variation file name: <project_directory>/SHIFTREGISTER 

▪ IP variation file type: VHDL 

 

 
 

4.2.1.21 Click OK. 
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4.2.1.22 On the General tab (page 1 of 4) set the output pus to 10 bits. For the outputs only select 

Serial shift data output and for the input only select Parallel data input. 

 

 
 

4.2.1.23 Click Next.  

 

4.2.1.24 On the Optional Inputs tab (page 2 of 4) only select Set for Synchronous inputs. 
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4.2.1.25 Click Finish. This will take you to the Summary tab (page 4 of 4). Click Finish again to close 

LPM_SHIFTREG MegaWizard manager. 

 

4.2.1.26 In the pop-up Quartus Prime IP Files accept all defaults and click Yes. 

 

 
 

4.2.1.27 Double click on uart_tx to open top-level entity. 

 

4.2.1.28 Right click in the text editor and select Insert Template form the pop-up menu. 

 

4.2.1.29 In the Insert Template window, expand the “Megafunction” and after it the “VHDL 

Components”. The three components that were created can now be seen. Click on 

PLL.cmp to see the template code. 
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4.2.1.30 Move the cursor where the “PLL component declaration” place is marked in the 

architecture section of uart_tx.vhd and click Insert. 

If you want, you can delete the comment lines. 

 

 
 

4.2.1.31 Repeat these steps with COUNTER.cmp and SHIFTREGISTER.cmp. 

 

4.2.1.32 If you inserted all three components declaration into the source code, close Insert 

Template window. 

 

4.2.1.33 Save your design by clicking on  button or select File → Save from the menu. 
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4.2.2 Analysis and Synthesis 

 

4.2.2.1 Run Analysis and Synthesis by clicking on  button on the toolbars, or Processing → Start 

→ Analysis and Synthesis. 

 

There should be no errors. If there are errors, they should be fixed before continuing. If 

there are no errors the compilation task windows should look like this: 

 

 
 

4.2.3 Pin Assignments 

 

4.2.3.1 Open Pin Planner by clicking on  button on the toolbars, or Assignments → Pin Planner. 
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4.2.3.2 In the bottom table, type PIN_H6 in Location column of the CLK. 

 

 
 

4.2.3.3 Repeat the previous step with the following assignments: 

 

Node Name Pin Location 

BTN PIN_E6 

UART_TX PIN_H8 

 

4.2.3.4 Double click in the I/O Standard column of BTN to open a drop-down list and change the 

2.5V (default) to 3.3 V Schmitt Trigger. 

 

4.2.3.5 Change the I/O Standard of CLK and UART_TX to 3.3-V LVTTL. 

 

 
 

4.2.3.6 Close the Pin Planner, the settings are automatically saved. 
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4.3 Analysis 
 

Overview: In this module you will setup the SignalTap II environment and run it on your 

MAX1000 board. 

 

4.3.1 SignalTap setup 
 

4.3.1.1 In the Quartus Prime, select in the menu Tools → Signal Tap Logic Analyzer. 

 

 
 

4.3.1.2 Right click on the auto_signaltap_0 instance and select Rename Instance from the pop-up 

menu. Rename it to uart_interface. 

 

4.3.1.3 Double click in the Setup tab to add nodes. 
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4.3.1.4 In the Node Finder select Signal Tap: pre-synthesis for the Filter and click on List. 

 

 
 

4.3.1.5 Select BTN, iCTRL and UART_TX and click on  button. 

 

4.3.1.6 Expand “COUNTER:datagen” and select q node group. Click on  button. 

 

 
 

4.3.1.7 Click Insert and close the Node Finder window. 
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4.3.1.8 Only leave Trigger Enable for BTN and uncheck it for the other nodes. 

 

 
 

4.3.1.9 Right click in the Trigger Conditions cell of BTN and select Rising Edge. 

 

 
 

4.3.1.10 In the Signal Configuration window on the right side, click on the  button to browse 

the clock signal. 

 

4.3.1.11 In the Node Finder window, make sure, that the Signal Tap: pre-synthesis is selected for 

the Filter, and click on the List button. 
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4.3.1.12 In the Matching Nodes window expand “PLL:clock” and select c0. Click on  button. 

 

 
 

4.3.1.13 Click OK to close window. 

 

4.3.1.14 Leave the other parameters of Signal Configuration by default. 

After you have set the nodes, you should look the following settings: 
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4.3.1.15 Save the analyzer setting by clicking on  button or File → Save and enter the following 

information: 

 

▪ File name: uart_tx 

▪ Save as type: Signal Tap Logic Analyzer Files (*.stp) 

▪ Make sure that “Add file to current project” option is checked. 

 

 
 

4.3.1.16 Click Save. 

 

4.3.1.17 In the Quartus Prime pop-up window click Yes to add this file to the current project. 

 

 
 

4.3.2 Compiling the Design 

 

4.3.2.1 Before the compilation, make sure, that uart_interface instance is enabled in SignalTap. 

 

 
 

4.3.2.2 Start Compilation by clicking on  button on the toolbars, or Processing → Start 

Compilation.  

 

This process is also available in SignalTap not only in Quartus. Use one that is more 

comfortable for you. 

 

https://www.arrow.com/
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There should be no errors. If there are errors, they should be fixed before re-compilating. 

The 100% in the lower right corner or a green checkmark next to the Compile Design in 

the Compilation task window indicates that the compilation was successful. 

 

 
 

4.3.3 Configuration 

 

4.3.3.1 Connect your MAX1000 board to your PC using an USB cable. Since the Arrow USB Blaster 

should be already installed, the Window’s Device Manager should display the following 

entries are highlighted in red (port number may differ depending on your PC): 
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4.3.3.2 Open the SignalTap window and click on the Setup… button in the top right corner. 

 

 
 

4.3.3.3 Double click Arrow-USB-Blaster entry in the Hardware Setup tab. The Currently selected 

hardware should now show Arrow-USB-Blaster [USB0] (depending on your PC, the USB 

port number may variant). 

 

 
 

4.3.3.4 Click Close. 

 

4.3.3.5 The hardware configuration window should be updated as follows. 

 

 
 

4.3.3.6 Click on  button to choose the programming file. 

 

4.3.3.7 Navigate to <project_directory>/output_files/ and select the uart_tx.sof file. 

 

4.3.3.8 Click Open. 
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4.3.3.9 Click on  button to program the board. When the configuration is complete, the 

message box in the middle should write “Ready to acquire”. 

 

 
 

4.3.4 Analyze the design 

 

4.3.4.1 Click on  button to run analysis. When you pressed it, the status of uart_interface 

instance should change to “Waiting for trigger”. 

 

This analyzer type is a single acquisition, it runs only once after triggering.  

 

 
 

4.3.4.2 Press the user button on MAX1000 board to generate a trigger signal for the analyzer. The 

trigger is the rising edge of the BTN, so the analyzing will start when you release the 

button. 

 

 
 

4.3.4.3 You can zoom into the waveform by selecting the section of the examination by mouse. 

 

 
 

4.3.4.4 On the data screen you can see that the data is enabled on the rising edge of iCLK and it 

sends the data to the serial UART_TX output. The transmission signal contains a start bit, 

8 bits data, starting with LSB, and one stop bit.  
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4.3.4.5 On the timescale the default setup is the sample numbers, where each number represents 

a clock period. You can change it by right click on the timescale and select Time Units… 

from the pop-up menu. 

 

 
 

4.3.4.6 In the Time Units window set the time to 0.1152 MHz and press OK. After this process you 

can check the waveforms with horizontal µs scale. 

 

 
 

4.3.5 Design modification 

 

4.3.5.1 In Quartus Prime search “datagen : COUNTER” component instantiation in the 

architecture section of uart_tx-vhd after the word ‘begin’. Modify the counter enable and 

synchronous load in the port map to:  

 

cnt_en => ‘1’, 

sload => ‘0’, 

 

 
 

4.3.5.2 Save the modification by clicking on  button or select File → Save from the menu. 
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4.3.6 Recompilation and reconfiguration 

 

4.3.6.1 Start Compilation by clicking on  button on the toolbars, or Processing → Start 

Compilation.  

 

There should be no errors. If there are errors, they should be fixed before re-compilating. 

The 100% in the lower right corner or a green checkmark next to the Compile Design in 

the Compilation task window indicates that the compilation was successful. 

 

 
 

4.3.6.2 Open the SignalTap window and make sure, that the hardware, device and the SOF 

manager have not changed.  

 

 
 

4.3.6.3 Click on  button to program the board. You do not need to browse again the 

configuration file, because after the reconfiguration it updates automatically. 
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When the configuration is complete, the message box in the middle should write “Ready 

to acquire”. 

 

 
 

4.3.7 Analyze the design 

 

4.3.7.1 Click on  button to run analysis. When you pressed it, the status of uart_interface 

instance should change to “Waiting for trigger”. 

 

This is the running mode of the analyzer, it runs until you stop it and refresh the waveform 

on every triggering. 

 

 
 

4.3.7.2 Press the user button on MAX1000 board to generate a trigger signal for the analyzer. The 

trigger is the rising edge of the BTN, so the analyzing will start when you release the 

button. 

 

Please note, because of the free running, you could have different data on the counter 

and accordingly, the UART signal may differ.  

 

 
 

4.3.7.3 Zoom into the waveform and press the user button on MAX1000 board several times to 

see, how the autorun analysis work. 

 

4.3.7.4 Click on  button to stop the analysis. 

 

 

CONGRATULATIONS! YOU HAVE SUCCESSFULLY COMPLETED THE SIGNALTAP 

LAB! 
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5 Revision History 
 

Version Change Log Date of Change 
V1.0 Initial Version 24/01/2019 
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6 Legal Disclaimer 

ARROW ELECTRONICS  

EVALUATION BOARD LICENSE AGREEMENT  
By using this evaluation board or kit (together with all related software, firmware, components, and 

documentation provided by Arrow, “Evaluation Board”), You (“You”) are agreeing to be bound by the terms and 

conditions of this Evaluation Board License Agreement (“Agreement”). Do not use the Evaluation Board until You 

have read and agreed to this Agreement. Your use of the Evaluation Board constitutes Your acceptance of this 

Agreement.  

PURPOSE 

The purpose of this evaluation board is solely intended for evaluation purposes. Any use of the Board beyond 

these purposes is on your own risk. Furthermore, according the applicable law, the offering Arrow entity 

explicitly does not warrant, guarantee or provide any remedies to you with regard to the board.  

LICENSE  

Arrow grants You a non-exclusive, limited right to use the enclosed Evaluation Board offering limited features 

only for Your evaluation and testing purposes in a research and development setting. Usage in a live environment 

is prohibited. The Evaluation Board shall not be, in any case, directly or indirectly assembled as a part in any 

production of Yours as it is solely developed to serve evaluation purposes and has no direct function and is not 

a finished product.  

EVALUATION BOARD STATUS  

The Evaluation Board offers limited features allowing You only to evaluate and test purposes. The Evaluation 

Board is not intended for consumer or household use. You are not authorized to use the Evaluation Board in any 

production system, and it may not be offered for sale or lease, or sold, leased or otherwise distributed for 

commercial purposes.  

OWNERSHIP AND COPYRIGHT  

Title to the Evaluation Board remains with Arrow and/or its licensors. This Agreement does not involve any 

transfer of intellectual property rights (“IPR) for evaluation board. You may not remove any copyright or other 

proprietary rights notices without prior written authorization from Arrow or it licensors.  

RESTRICTIONS AND WARNINGS  

Before You handle or use the Evaluation Board, You shall comply with all such warnings and other instructions 

and employ reasonable safety precautions in using the Evaluation Board. Failure to do so may result in death, 

personal injury, or property damage.  

You shall not use the Evaluation Board in any safety critical or functional safety testing, including but not limited 

to testing of life supporting, military or nuclear applications. Arrow expressly disclaims any responsibility for such 

usage which shall be made at Your sole risk.  

WARRANTY  

Arrow warrants that it has the right to provide the evaluation board to you. This warranty is provided by Arrow 

in lieu of all other warranties, written or oral, statutory, express or implied, including any warranty as to 

merchantability, non-infringement, fitness for any particular purpose, or uninterrupted or error-free operation, 

all of which are expressly disclaimed. The evaluation board is provided “as is” without any other rights or 

warranties, directly or indirectly.  

You warrant to Arrow that the evaluation board is used only by electronics experts who understand the dangers 

of handling and using such items, you assume all responsibility and liability for any improper or unsafe handling 

or use of the evaluation board by you, your employees, affiliates, contractors, and designees.  
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LIMITATION OF LIABILITIES  

In no event shall Arrow be liable to you, whether in contract, tort (including negligence), strict liability, or any 

other legal theory, for any direct, indirect, special, consequential, incidental, punitive, or exemplary damages 

with respect to any matters relating to this agreement. In no event shall arrow’s liability arising out of this 

agreement in the aggregate exceed the amount paid by you under this agreement for the purchase of the 

evaluation board.  

IDENTIFICATION 

You shall, at Your expense, defend Arrow and its Affiliates and Licensors against a claim or action brought by a 

third party for infringement or misappropriation of any patent, copyright, trade secret or other intellectual 

property right of a third party to the extent resulting from (1) Your combination of the Evaluation Board with 

any other component, system, software, or firmware, (2) Your modification of the Evaluation Board, or (3) Your 

use of the Evaluation Board in a manner not permitted under this Agreement. You shall indemnify Arrow and its 

Affiliates and Licensors against and pay any resulting costs and damages finally awarded against Arrow and its 

Affiliates and Licensors or agreed to in any settlement, provided that You have sole control of the defense and 

settlement of the claim or action, and Arrow cooperates in the defense and furnishes all related evidence under 

its control at Your expense. Arrow will be entitled to participate in the defense of such claim or action and to 

employ counsel at its own expense.  

RECYCLING  

The Evaluation Board is not to be disposed as an urban waste. At the end of its life cycle, differentiated waste 

collection must be followed, as stated in the directive 2002/96/EC. In all the countries belonging to the European 

Union (EU Dir. 2002/96/EC) and those following differentiated recycling, the Evaluation Board is subject to 

differentiated recycling at the end of its life cycle, therefore: It is forbidden to dispose the Evaluation Board as 

an undifferentiated waste or with other domestic wastes. Consult the local authorities for more information on 

the proper disposal channels. An incorrect Evaluation Board disposal may cause damage to the environment and 

is punishable by the law. 
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