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Software and hardware requirements to complete all exercises 

Software Requirements: Quartus® Prime Lite or Standard Edition version 18.0 or 18.1 

Hardware Requirements: ARROW MAX1000 Board 
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1. Introduction 
 

This tutorial provides comprehensive information to help you understand how to create a 

software project for a Nios II processor system in an Intel FPGA and run the software project on 

your MAX1000 board. The Nios II processor core is a soft intellectual property (IP) processor that 

you download (along with other hardware components that comprise the Nios II system) onto an 

Intel FPGA. This tutorial introduces you to the basic software development flow for the Nios II 

processor.  

Lab Overview: This lab teaches you how to create an embedded system implemented in 

programmable logic. You will build a processor-based hardware system 

and run software on it. As the lab progresses, you will see how quick and 

easy it is to build entire systems using Quartus Platform Designer (formerly 

Qsys) tools to configure and integrate pre-verified IP blocks. 

Project Details: The lab will guide you through creating an embedded system using 

Platform Designer. This system will be able to retrieve data from internal 

ADC of MAX10 and the on-board accelerometer of the MAX1000. 

Depending on the data received by the Nios II processor, the LEDs will react 

to the Y-axis. 

Lab Notes: Many of the names that the lab asks you to choose for files, components, 

and other objects in this exercise must be spelled exactly as directed. This 

nomenclature is necessary because the pre-written software application 

includes variables that use the names of the hardware peripherals. Naming 

the components differently can cause the software application to fail. 

There are also other similar dependencies within the project that require 

you to enter the correct names. 
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2. Getting Started 
 

The first objective is to ensure that you have all the necessary hardware items and software 

installed so that the lab can be completed successfully. Below is a list of items required to 

complete this lab: 

- MAX1000 Board (10M08SAU169C8G) 

- USB Cable 

- Lab files: Embedded_System_lab_template: Template files are required to complete the 

lab. Includes: embedded_system_lab.vhd, embedded_system_lab.sdc, accelerometer.c, 

embedded_system_lab_pinout.csv 

- Quartus Prime 18.0 Lite was used for this lab. Previous/newer versions should work (If no 

Quartus Prime is installed, refer to MAX1000 User Guide for instructions) 

- Installed Arrow USB Drivers (If not, refer to MAX1000 User Guide for instructions) 

- Personal computer or laptop running 64-bit Linux / Windows 7 or later with at least an 

Intel i3 core (or equivalent), 4GB RAM and 12 GB of free hard disk space 

- A desire to learn! 
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3. Design Flow 
 

Developing software for an embedded system on a programmable chip requires an understanding 

of the design flow between the Platform Designer (formerly Qsys) system integration tool and the 

Nios II Embedded Development Suite (EDS). Typically, designs begin with requirements and 

become inputs to system definitions. System definition is the first step in the design flow process. 

For this workshop, the design will be built and then the FPGA image will be downloaded into the 

board. The objective of the module is to review the development tools that will be used. 

 

 

The above diagram shows the typical design flow for the system design. The system definition is 

done with Platform Designer. The Nios II IDE uses the system description to create a new project 

for the software application. The output of the FPGA design is a FPGA image that is used to 

configure the FPGA. The output of the software flow is an executable which runs on the Nios II 

processor. 
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4. Nios II Soft Core 
 

The Nios II processor delivers unprecedented flexibility for your cost-sensitive, real-time, safety-

critical, ASIC-optimized, and applications processing needs. The Nios II processor supports all 

Intel® FPGA and SoC families. 

 

Two different versions are available: 

 

▪ NIOS II / f  : License Fee, designed for high performance 

▪ NIOS II / e : Royalty Free, designed for fewest FPGA logic and memory resources 

 

There is a variety configuration options to choose from depending on the application’s needs. 

More information on the Nios II Processor can be found at: 

https://www.intel.com/content/www/us/en/products/programmable/processor/nios-ii.html 

 

 
 

Nios II soft core can also support a variety of embedded operating systems, with more information 

found at: 

https://www.intel.com/content/www/us/en/products/programmable/processor/nios-

ii/ecosystem.html 
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5. Implementing Nios II soft core in MAX1000 
 

In this module, you will create a Quartus Prime project for your embedded system design and 

create the software project to run on the Nios II processor. 

 

We will be using Platform designer to add and interconnect different components. The following 

components will be included in our system: 

 

▪ Clock source 

▪ PLL 

▪ Nios II Processor 

▪ On-Chip memory 

▪ SDRAM controller 

▪ ADC for measuring internal temperature of MAX10 

▪ SPI (3-Wire Serial for accelerometer interface) 

▪ Parallel I/O for LED output 

 

  

https://www.arrow.com/
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6. Project with MAX1000 
 

6.1 Quartus Prime project 
 

6.1.1 Create a new Quartus Prime project 
 

6.1.1.1 If not already open, from the Start menu or the Desktop, open the Quartus Prime 18.0 Lite 

software. 

 

6.1.1.2 Create a new project using the New Project Wizard: File → New Project Wizard.  

 

 
 

6.1.1.3 Click Next. 

 

6.1.1.4 Configure the New Project Wizard directory, name and top-level entity information: 

 

▪ Enter a directory in which you will store your Quartus project files for this design, for 

example, C:/MAX1000/Embedded_System_lab 

▪ Specify the name of the project: embedded_system_lab 

▪ Specify the name of the top-level entity: embedded_system_lab 

https://www.arrow.com/
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6.1.1.5 Click Next. 

 

6.1.1.6 On the Project Type page, select “Empty project” and click Next.  
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4.1.1.1 On the Add Files page, add source files to the project by clicking on the  button and 

browse into the lab files folder where you will locate the provided design files and add: 

 

▪ embedded_system_lab.vhd 

▪ embedded_system_lab.sdc 

 

 
 

6.1.1.7 Click Next.  

 

6.1.1.8 Specify Family and Device Settings. Use pull-down menus to select MAX10 family or enter 

the part number in the Name Filter text box. The part number is 10M08SAU169C8G. 

 

 
 

6.1.1.9 Click Finish.  

https://www.arrow.com/
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6.2 Design entry 
 

Overview: In this module you will use Platform Designer system integration tool to design your 

hardware system. You will add standard and custom components, make interface 

connections, assign clocks and generate HDL for the system. 

 

6.2.1 Add components to Platform Designer 
 

Platform Designer is a high-level system integration tool that allows you to quickly build a system 

using Intel IP block as well as custom components. The tool automatically creates interconnect 

logic between the components for easy design use. 

 

Platform Designer is made up of several components and automatically generates high 

performance interconnect between them. It allows you to connect components on an interface 

level, rather by signal by signal level. The tool understands the different types of interfaces and 

will only allow connections between interfaces of same type (i.e. a data master connects to a data 

slave, clock source to clock sink, etc.). 

 

6.2.1.1 Open Platform Designer from the Tools → Platform Designer or clicking on  button on 

the toolbar. 

 

6.2.1.2 In the new window, you should see a single clock source component, named clk_0 in the 

System Components tab. This tab shows all the components currently in your system. 

 

 
 

6.2.1.3 Double click on clk_0. 
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6.2.1.5 Set the Clock frequency to 12 MHz (12000000 Hz). 

Ensure that ‘Clock frequency is known’ parameter is enabled. 

 

 
 

6.2.1.6 Click on X on the parameter tab to close the parameter window. 

 

6.2.1.7 Right click on the clk_0 and select Rename. Rename the clock source to clk12mhz and 

press Enter. 

 

6.2.1.8 From the IP Catalog panel on the left side, expand the menus for the Basic Functions → 

Clocks; PLLs and Resets → PLL and double click on ALTPLL Intel FPGA IP. 
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6.2.1.9 Under General/Modes tab (page 1 of 11) of PLL MegaWizard change the frequency of clock 

input to 12 MHz. This source is provided by the internal oscillator in the MAX10 FPGA. 

 

 
 

6.2.1.10 Click Next. 

 

6.2.1.11 In Input/Lock tab (page 2 of 11) make sure that areset and locked output option are 

checked.  
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6.2.1.12 Click Next until you reach the Output Clocks tab (page 6 of 11). 

 

6.2.1.13 Under the clk c0 tab (page 6 of 11) select “Enter output clock frequency” and enter 80 

MHz.  

 

 
 

6.2.1.14 Click Next. 

 

6.2.1.15 Under the clk c1 tab (page 7 of 11) select Use this clock and enter 2 MHz for the output 

clock frequency.  
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6.2.1.16 Click Next. 

 

6.2.1.17 Under the clk c2 tab (page 8 of 11) select Use this clock and enter 80 MHz for the output 

clock frequency. Set the Clock phase shift to -90 deg.  

 

 
 

6.2.1.18 Click Finish. This will take you to the EDA tab (page 11 of 11). Click Finish again to close 

ALTPLL MegaWizard Manager. 

 

6.2.1.19 A component entitled altpll_0 should appear under Module Name. Rename this 

component to pll. 
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6.2.1.20 In the search bar of the IP Catalog, type “nios processor”, and double click on Nios II 

Processor. 

 

 
 

6.2.1.21 In the Main tab, ensure that the Nios II /e option is selected, and press Finish. 

 

 
 

6.2.1.22 Rename nios2_gen2_0 to nios. 
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6.2.1.23 In the search bar of the IP Catalog, type “onchip”, and add On-Chip Memory (RAM or 

ROM) Intel FPGA IP. 

 

 
 

6.2.1.24 Change the Total memory size to 16384 bytes. 

 

 
 

6.2.1.25 Accept the defaults for the remaining fields and press Finish. 

 

6.2.1.26 Rename onchip_memory2_0 to onchip. 

  

https://www.arrow.com/


 

MAX1000 P a g e  | 17 www.arrow.com 
Embedded System Lab  January 2019 

 

6.2.1.27 In the search bar of the IP Catalog, type “jtag”, and add JTAG UART Intel FPGA IP. 

 

 
 

6.2.1.28 Accept all defaults and press Finish. 

 

 
 

6.2.1.29 Rename jtag_uart_0 to jtag_uart. 
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6.2.1.30 In the search bar of the IP Catalog, type “sysid”, and add System ID Peripheral Intel FPGA 

IP. 

 

 
 

6.2.1.31 Edit the 32 bit System ID to any acceptable value you like, or just accept the default ID 

and press Finish. 

 

 
 

6.2.1.32 Rename sysid_qsys_0 to sysid. 

 

https://www.arrow.com/


 

MAX1000 P a g e  | 19 www.arrow.com 
Embedded System Lab  January 2019 

 

6.2.1.33 In the search bar of the IP Catalog, type “sdram” and add SDRAM Controller Intel FPGA 

IP. 

 

Note: This lab was done by Quartus Prime Lite Edition version 18.0. However, 

SDRAM Controller will only be supported in Quartus Prime Standard Edition 

in the future. If you are using a newer Quartus Prime Lite version and this IP 

is not available, then skip the following steps and continue with 6.2.1.36. 

 

 
 

6.2.1.34 Under the Memory Profile tab set 16 bits and accept the defaults for the remaining fields 

and click on the Timing tab.  
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6.2.1.35 On the Timing tab, set the following parameters: 

 

▪ Delay after powerup, before initialization: 200 µs 

▪ Duration of refresh command: 60 ns 

▪ Duration of precharge command: 15 ns 

▪ ACTIVE to READ or WRITE delay: 15 ns 

▪ Access time: 5 ns 

▪ Write recovery time: 12 ns 

 

 
 

6.2.1.36 Click Finish. 

 

6.2.1.37 Rename new_sdram_controller_0 to sdram. 

 

6.2.1.38 In the search bar of the IP Catalog, type “adc”, and add Modular ADC core Intel FPGA IP. 
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6.2.1.39 Verify that the core variant is Standard sequencer with Avalon-MM sample storage, and 

set the followings from the drop-down menu: 

 

▪ ADC Sample Rate: 50kHz 

▪ ADC Input Clock: 2 MHz 

▪ Reference Voltage Source: Internal 

▪ Internal Reference Voltage: 3.3 V 

 

Under the Channels tab click on TSD and select Use on-chip TSD. 

 

 
 

6.2.1.40 Click on the Sequencer tab and under the Conversion Sequence Channels set TSD for 

Slot1. 

 

 
 

6.2.1.41 Click Finish.  

https://www.arrow.com/
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6.2.1.42 Rename modular_adc_0 to adc. 

 

6.2.1.43 In the search bar of the IP Catalog, type “spi”, and add SPI (3 Wire Serial) Intel FPGA IP 

under Interface Protocols → Serial. 

 

 
 

6.2.1.44 Change the SPI Clock (SCLK) rate to 1 MHz or type ‘1m’ and the field will update. 

 

 
 

6.2.1.45 Accept the defaults for the remaining fields and click Finish.  

 

6.2.1.46 Rename spi_0 to spi. 
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6.2.1.47 In the search bar of the IP Catalog, type “pio”, and add PIO (Parallel I/O) Intel FPGA IP. 

 

 
 

6.2.1.48 Verify that the width is 8 bits and the direction is output.  

 

 
 

6.2.1.49 Accept the defaults for the remaining fields and click Finish. 

 

6.2.1.50 Rename pio_0 to leds. 
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There are multiple errors and warning in the bottom console indication that various ports are not 

connected, and the memory addresses are not correct. Ignore these for now, as we will address 

these connections and setups in the following steps. 

 

At this point, there are 10 components in the system and should look as follows: 
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6.2.1.52 Save your design File → Save and enter the following information. 

 

▪ File name: nios_subsystem 

▪ Files of type: Platform Designer System Files (*.qsys) 

 

 
 

6.2.1.53 Click Save. 

 

6.2.1.54 When the Save System Completed, then click Close. 
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6.2.2 Connections 
 

Overview: In the Connections column, hover over the connections and you will then be able to 

fill in dots to make the connections by clicking them. 

 

6.2.2.1 Create the following connection: clk12mhz | clk ↔ pll | inclk_interface 

 

The connection should look as follow: 

 

 
 

6.2.2.2 As in the previous step, make the following connections for the clock signal: 

 

Component A  Component B 

pll | c0 ↔ nios | clk 

pll | c0 ↔ onchip | clk1 

pll | c0 ↔ jtag_uart | clk 

pll | c0 ↔ sysid | clk 

pll | c0 ↔ sdram | clk 

pll | c0 ↔ adc | clk 

pll | c0 ↔ spi | clk 

pll | c0 ↔ leds | clk 

pll | c1 ↔ adc | adc_pll_clock 
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The connections should look as the follows: 

 

 
 

6.2.2.3 Make the following connections for the data and instruction bus: 

 

Component A  Component B 

nios | data_master ↔ pll| pll_slave 

nios | instruction_master ↔ onchip | s1 

nios | data_master ↔ onchip | s1 

nios | data_master ↔ jtag_uart | avalon_jtag_slave 

nios | data_master ↔ sysid | control_slave 

nios | data_master ↔ sdram | s1 

nios | data_master ↔ adc | sequencer_csr 

nios | data_master ↔ adc |sample_store_csr 

nios | data_master ↔ spi | spi_control_port 

nios | data_master ↔ leds | s1 
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The connections should look as the follows: 

 

 
 

6.2.2.4 Create the following connections for interrupt request:  

 

Component A  Component B 

nios | irq ↔ jtag_uart| irq 

nios | irq ↔ adc | sample_store_irq 

nios | irq ↔ spi | irq 

 

6.2.2.5 Make the following connection: 

 

pll | locked_conduit ↔ adc | adc_pll_locked 

 

6.2.2.6 Double click on the Export field next to the c2 of pll and name it dram_clk. 

 

6.2.2.7 Double click on the Export field next to the areset_conduit of pll and name it pll_areset. 

 

6.2.2.8 Double click on the Export field next to the wire of sdram and name it sdram. 

 

6.2.2.9 Double click on the Export field next to the external of spi and name it spi. 

 

https://www.arrow.com/
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6.2.2.10 Double click on the Export field next to the external_connection of leds and name it leds. 

 

6.2.2.11 Automatically create global reset by selecting System → Create Global Reset Network 

from the menu. 

 

6.2.2.12 Automatically assign base addresses for the peripherals by selecting System → Assign 

Base Addresses from the menu. 

 

6.2.2.13 Verify that your system is the same as below: 

 

 
 

6.2.2.14 Until these settings are applied, only 2 errors should be in the Messages window, 

because the reset and exception vector are not set. To set these vectors, double click on 

the Nios II component nios. The Nios II Processor parameter editor will reopen. 
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6.2.2.15 Click on Vectors tab and set Reset Vector and Exception Vector to onchip.s1. 

 

 
 

6.2.2.16 Review message window for remains errors. 

At this point should be no remaining errors in the message window. If there are, please 

refer again to the previous steps to resolve them. 

 

6.2.2.17 Save your design. 

 

6.2.3 Generate the Platform Designer System 
 

6.2.3.1 Select Generate → Generate HDL… from the menu or alternately click Generate HDL… 

button on the bottom right of the Platform Designer window. 
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6.2.3.2 On the Generation window, enter the following information. 

 

▪ Create HDL design files for synthesis: VHDL 

▪ Uncheck Create timing and resource estimates for third-party EDA synthesis tools. 

▪ Uncheck Create block symbol file (.bsf) 

▪ Create simulation model: None 

 

 
 

6.2.3.3 Click Generate. 

 

6.2.3.4 When the generate process completed, click Close. 

 

 
 

6.2.3.5 In the Platform Designer window, select Generate → Show Instantiation Template…  
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6.2.3.6 Select VHDL as the HDL Language. The following template will be shown which can be 

easily copied into your project, saving you valuable time. 

 

 
 

6.2.3.7 There are two parts that would need be copied to the top-level entity 

embedded_system_lab in Quartus Prime. 

 

▪ nios_subsystem component declaration (1. Highlighted in red) 

Copy this section and paste in the architecture section of embedded_system_lab.vhd. 

There should be a commented area indicating where exactly. 

▪ nios_subsystem component instantiation (2. Highlighted in blue) 

Copy this section and paste in the architecture section of embedded_system_lab.vhd 

after the word ‘begin’. There should be a commented area indicating where exactly. 

 

  

https://www.arrow.com/


 

MAX1000 P a g e  | 33 www.arrow.com 
Embedded System Lab  January 2019 

 

6.2.3.8 After copying close Instantiation Template window and click Finish button on the bottom 

right of the Platform Designer window. 

 

6.2.3.9 It generates IP pointer files for both synthesis (.qip) and simulation (.sip) that will point 

Quartus to all the necessary design files needed to synthesize or simulate the Platform 

Designer system. Press OK to close as the .qip file will be added to the project in the 

following steps. Simulation will not be discussed in this lab, so no need to add the .sip file. 

 

 
 

6.2.3.10 Choose Project → Add/Remove Files in Project... from the Quartus Prime menu. 

 

6.2.3.11 Click on the  button and browse through the synthesis directories: 

<project_directory>/nios_subsystem/synthesis/ and open nios_subsystem.qip. 

 

 
 

6.2.3.12 Click Apply and OK. 
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6.3 Compile design 
 

6.3.1 Import pin assignments 

 

6.3.1.1 Select Assignments → Import Assignments… 

 

6.3.1.2 Add source file by clicking on the  button and browse into the lab file folder where you 

will locate the provided design files and add embedded_system_lab_pinout.csv. 

 

 
 

6.3.1.3 Press OK. 

 

6.3.1.4 Open Pin Planner by clicking on  button on the toolbars, or Assignments → Pin Planner 

in order to check the import. In the Pin Planner you should see the following: 

 

 
 

6.3.1.5 Close the Pin Planner. 
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6.3.2 Compiling the Design 

 

6.3.2.1 Open the device settings window from Assignments → Device… and click on the Device 

and Pin Options… button. 

 

6.3.2.2 Click to the Configuration category. 

 

6.3.2.3 Set configuration mode to Single Uncompressed Image with Memory Initialization 

(256kbits UFM). 

 

 
 

6.3.2.4 Press OK to close Device and Pin Options window. Press again OK to close Device window. 

 

6.3.2.5 Start Compilation by clicking on  button on the toolbars, or Processing → Start 

Compilation. 
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There should be no errors. If there are errors, they should be fixed before re-compilating. 

The 100% in the lower right corner or a green checkmark next to the Compile Design in 

the Compilation task window indicates that the compilation was successful. 

 

 
 

6.3.3 Configuration 
 

6.3.3.1 Connect your MAX1000 board to your PC using an USB cable. Since the Arrow USB Blaster 

should be already installed, the Window’s Device Manager should display the following 

entries are highlighted in red (port number may differ depending on your PC): 
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6.3.3.2 Open the Quartus Prime Programmer from Tools → Programmer or double click on 

Program Device (Open Programmer) from the Task window. 

 

 
 

6.3.3.3 Click Hardware Setup… and double click Arrow-USB-Blaster entry in the Hardware Setup 

tab. The Currently selected hardware should now show Arrow-USB-Blaster [USB0] 

(depending on your PC, the USB port number may variant). 

 

 
 

6.3.3.4 Click Close. 
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6.3.3.5 Make sure the hardware setup is Arrow-USB-Blaster [USB0] and the mode is JTAG. Click 

Auto Detect. 

 

 
 

6.3.3.6 If the configuration has been added by default, you can skip the following steps and 

continue with the 6.3.4.11 point. 

 

6.3.3.7 Select 10M08SA device and click OK in the pop-up window. 

 

 
 

6.3.3.8 Click Change File... or double click <none> to choose the programming file. 

 

6.3.3.9 Navigate to <project_directory>/output_files/ and select the embedded_system_lab.sof 

file. 

 

6.3.3.10 Click Open. 
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6.3.3.11 Make sure the Programmer shows the correct file and the correct part in the JTAG chain 

and check the Program/Configure checkbox. 

 

 
 

6.3.3.12 Click Start to program the board. When the configuration is complete, the Progress bar 

should show 100% (Successful). 
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6.4 Software Design 
 

Overview: In this section, you will use the Nios II Software Build Tools (SBT) for Eclipse to quickly 

create a board support package (BSP) and a C software application to run on the Nios 

II processor. The software has already been provided for you in the lab files. 

 

6.4.1 Create a new software project 
 

6.4.1.1 From the main Quartus Prime window, start STB from Tools → Nios II Software Build Tools 

for Eclipse. 

 

6.4.1.2 The Eclipse Workspace Launcher will open. Click Browse… and choose the directory of 

your project. In this case it was C:\MAX1000\Embedded_System_lab\. 

 

 
 

6.4.1.3 Click OK and the Eclipse will open. 
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6.4.1.4 Select File → New → Nios II Application and BSP from Template. 

 

6.4.1.5 Click  to select the nios_subsystem.sopcinfo from your project directory and name the 

project embedded_system_lab. Select Blank Project from the Templates. 

 

 
 

6.4.1.6 Click Finish. 
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6.4.1.7 Eclipse will create two directories in the workspace, one for the application project and 

one for the BSP. The application directory (embedded_system_lab) is currently empty 

while the BSP directory (embedded_system_lab_bsp) contains software drivers, a 

system.h, header file, initialization source code and other software infrastructure. 

 

 
 

6.4.1.8 Right click on the embedded_system_lab_bsp project and select Properties from the pop-

up menu. 

 

6.4.1.9 In the Properties window select the Nios II BSP Properties tab. It may take a moment to 

load the settings. 

 

6.4.1.10 To keep the software footprint small so it fits our device, open the drop-down menu for 

Optimization level and change it to Level 2. Enable Reduced device drivers and Small C 

library options. As there is no C++ code, uncheck the Support C++ option. 
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6.4.1.11 Click Apply, and when it finished with Applying BSP Settings click OK to close Properties 

window. 

 

6.4.1.12 Right click on the embedded_system_lab_bsp project and select Nios II → BSP Editor… 

from the pop-up menu. 

 

6.4.1.13 The Nios II BSP Editor will open. In the Common settings under the main tab, ensure the 

settings are configured as below: 

 

 
 

Notice that since there is no operating system in this tab, the stdout, stdin, and stderr 

messages are reported through the JTAG UART that you will be able to see in the Nios II 

Console in Eclipse. On-chip memory will be used for processor code storage, data 

storage, the exception and interrupt stack. 
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6.4.1.14 Click on the Linker Script tab and set onchip in the Linker Region Name column for .heap, 

.rodata, .rwdata and .stack. 

 

 
 

Feel free to explore the BSP editor. The Drivers tab gives the user control over built into 

the BSP. The Linker Script tab provides a mechanism to adjust what memory regions are 

utilized for certain purposes. 

 

6.4.1.15 Click Generate button to update the PSB and select Exit to close it once the process is 

finished. 
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6.5 Accelerometer lab 
 

6.5.1 Add source code to the project 

 

Note: The C source file have been provided for you in this lab. All that needs to be done is to 

copy it to your workspace. 

 

6.5.1.1 From Windows Explorer, navigate to your main project directory. There you will find a file 

named accelerometer.c which you will need to copy to this project. 

 

6.5.1.2 Select the accelerometer.c file and drag it into the embedded_system_lab directory in 

Eclipse. Select the Copy files option in the pop-up and click OK. 

 

 
 

You should now see the new file appear under the embedded_system_lab project in the 

Project Explorer. 

 

6.5.2 Build the software 
 

6.5.2.1 Right click on the embedded_system_lab_bsp project and select Build Project from the 

pop-up menu. 
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6.5.2.2 When it finished, repeat the previous step for the embedded_system_lab application 

project. 

 

 
 

6.5.3 Run the application 
 

6.5.3.1 Select embedded_system_lab and go to Run → Run Configurations… and double click to 

Nios II Hardware to add a new configuration. 
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6.5.3.2 Rename it to Embedded System lab configuration and on the Project tab select 

embedded_system_lab from the drop-down menu for the Project name. 

 

 
 

6.5.3.3 Click on the Target Connection tab and click Refresh Connections button. The configured 

MAX1000 board should appear.  

 

 
 

6.5.3.4 Click Apply and Run. 
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6.5.3.5 After a few second, the Nios II Console should open at the bottom of the Eclipse. 

 

 
 

After this message, the software downloaded to MAX1000 will obtain the Y-axis data from 

its onboard accelerometer and toggle it’s LEDs accordingly to the tilt level. Every 10ms the 

Y-axis value will be sent to Nios II Console window. 

 

6.5.3.6 Stop the program running by clicking on  button on the top right corner of Nios II 

Console window. 

 

 
 

 

 

 

 

CONGRATULATIONS! YOU HAVE SUCCESSFULLY COMPLETED THE EMBEDDED 

SYSTEM LAB!  
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5 Revision History 
 

Version Change Log Date of Change 
V1.0 Initial Version 17/08/2017 

V2.0 - Update the naming of the tools within 
Quartus to accommodate the recent version 
changes 

- Update website links 
- Corrections / clarity changes 
- Added usage of areset conduit of the PLL 

component 
- New version of tools generated new names 

for conduit signals/base addresses, 
appropriate changes in nios_lab_top.vhd 
and main.c file to address that 

- Size of the onchip_ram block reduced to 
16kB from 32kB 

27/09/2018 

V3.0 - Improving the lab into the embedded 
system lab 

- Update the design, and make preparation 
for additional software labs: 
add ADC, SDRAM controller, renaming 
modules and files 

- Corrections / clarity changes 
- Formal changes 

17/01/2019 
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6 Legal Disclaimer 

ARROW ELECTRONICS  

EVALUATION BOARD LICENSE AGREEMENT  
By using this evaluation board or kit (together with all related software, firmware, components, and 

documentation provided by Arrow, “Evaluation Board”), You (“You”) are agreeing to be bound by the terms and 

conditions of this Evaluation Board License Agreement (“Agreement”). Do not use the Evaluation Board until You 

have read and agreed to this Agreement. Your use of the Evaluation Board constitutes Your acceptance of this 

Agreement.  

PURPOSE 

The purpose of this evaluation board is solely intended for evaluation purposes. Any use of the Board beyond 

these purposes is on your own risk. Furthermore, according the applicable law, the offering Arrow entity 

explicitly does not warrant, guarantee or provide any remedies to you with regard to the board.  

LICENSE  

Arrow grants You a non-exclusive, limited right to use the enclosed Evaluation Board offering limited features 

only for Your evaluation and testing purposes in a research and development setting. Usage in a live environment 

is prohibited. The Evaluation Board shall not be, in any case, directly or indirectly assembled as a part in any 

production of Yours as it is solely developed to serve evaluation purposes and has no direct function and is not 

a finished product.  

EVALUATION BOARD STATUS  

The Evaluation Board offers limited features allowing You only to evaluate and test purposes. The Evaluation 

Board is not intended for consumer or household use. You are not authorized to use the Evaluation Board in any 

production system, and it may not be offered for sale or lease, or sold, leased or otherwise distributed for 

commercial purposes.  

OWNERSHIP AND COPYRIGHT  

Title to the Evaluation Board remains with Arrow and/or its licensors. This Agreement does not involve any 

transfer of intellectual property rights (“IPR) for evaluation board. You may not remove any copyright or other 

proprietary rights notices without prior written authorization from Arrow or it licensors.  

RESTRICTIONS AND WARNINGS  

Before You handle or use the Evaluation Board, You shall comply with all such warnings and other instructions 

and employ reasonable safety precautions in using the Evaluation Board. Failure to do so may result in death, 

personal injury, or property damage.  

You shall not use the Evaluation Board in any safety critical or functional safety testing, including but not limited 

to testing of life supporting, military or nuclear applications. Arrow expressly disclaims any responsibility for such 

usage which shall be made at Your sole risk.  

WARRANTY  

Arrow warrants that it has the right to provide the evaluation board to you. This warranty is provided by Arrow 

in lieu of all other warranties, written or oral, statutory, express or implied, including any warranty as to 

merchantability, non-infringement, fitness for any particular purpose, or uninterrupted or error-free operation, 

all of which are expressly disclaimed. The evaluation board is provided “as is” without any other rights or 

warranties, directly or indirectly.  

You warrant to Arrow that the evaluation board is used only by electronics experts who understand the dangers 

of handling and using such items, you assume all responsibility and liability for any improper or unsafe handling 

or use of the evaluation board by you, your employees, affiliates, contractors, and designees.  
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LIMITATION OF LIABILITIES  

In no event shall Arrow be liable to you, whether in contract, tort (including negligence), strict liability, or any 

other legal theory, for any direct, indirect, special, consequential, incidental, punitive, or exemplary damages 

with respect to any matters relating to this agreement. In no event shall arrow’s liability arising out of this 

agreement in the aggregate exceed the amount paid by you under this agreement for the purchase of the 

evaluation board.  

IDENTIFICATION 

You shall, at Your expense, defend Arrow and its Affiliates and Licensors against a claim or action brought by a 

third party for infringement or misappropriation of any patent, copyright, trade secret or other intellectual 

property right of a third party to the extent resulting from (1) Your combination of the Evaluation Board with 

any other component, system, software, or firmware, (2) Your modification of the Evaluation Board, or (3) Your 

use of the Evaluation Board in a manner not permitted under this Agreement. You shall indemnify Arrow and its 

Affiliates and Licensors against and pay any resulting costs and damages finally awarded against Arrow and its 

Affiliates and Licensors or agreed to in any settlement, provided that You have sole control of the defense and 

settlement of the claim or action, and Arrow cooperates in the defense and furnishes all related evidence under 

its control at Your expense. Arrow will be entitled to participate in the defense of such claim or action and to 

employ counsel at its own expense.  

RECYCLING  

The Evaluation Board is not to be disposed as an urban waste. At the end of its life cycle, differentiated waste 

collection must be followed, as stated in the directive 2002/96/EC. In all the countries belonging to the European 

Union (EU Dir. 2002/96/EC) and those following differentiated recycling, the Evaluation Board is subject to 

differentiated recycling at the end of its life cycle, therefore: It is forbidden to dispose the Evaluation Board as 

an undifferentiated waste or with other domestic wastes. Consult the local authorities for more information on 

the proper disposal channels. An incorrect Evaluation Board disposal may cause damage to the environment and 

is punishable by the law. 
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