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Software and hardware requirements to complete all exercises 

Software Requirements: Quartus® Prime Lite or Standard Edition version 18.0 or 18.1 

Hardware Requirements: ARROW MAX1000 Board 

  



 

MAX1000 P a g e  | 2 www.arrow.com 
Authentication Flash Lab  February 2019 

 

1. Introduction 
 

This tutorial introduces the operation of authentication flash memory through a demo. This 

memory provides handshake between the controller and the memory to ensure enhanced 

security of the data transmitted between the two devices. 

Lab Notes: Many of the names that the lab asks you to choose for files, components, 

and other objects in this exercise must be spelled exactly as directed. This 

nomenclature is necessary because the pre-written software application 

includes variables that use the names of the hardware peripherals. Naming 

the components differently can cause errors. 

 

2. Getting Started 
 

The first objective is to ensure that you have all the necessary hardware items and software 

installed so that the lab can be completed successfully. Below is a list of items required to 

complete this lab: 

- MAX1000 Board (10M08SAU169C8G) 

- USB Cable 

- Lab files: Authentication_Flash_lab_template: Template files are required to complete the 

lab. It includes the archived project and all the C code and headers file for the Nios II soft 

processor. 

- Quartus Prime 18.0 Lite was used for this lab. Previous/newer versions should work (If no 

Quartus Prime is installed, refer to MAX1000 User Guide for instructions) 

- Installed Arrow USB Drivers (If not, refer to MAX1000 User Guide for instructions) 

- Personal computer or laptop running 64-bit Linux / Windows 7 or later with at least an 

Intel i3 core (or equivalent), 4GB RAM and 12 GB of free hard disk space 

- A desire to learn! 
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3. Project with MAX1000 
 

3.1 FPGA Configuration 
 

3.1.1 Restore archived project 
 

3.1.1.1 If not already open, from the Start menu or the Desktop, open the Quartus Prime 18.0 Lite 

software. 

 

3.1.1.2 Select Project → Restore Archived Project… 

 

3.1.1.3 Add archive project by clicking on the  button for archive name and browse into the lab 

files folder where you will locate the provided design files and add: 

 

▪ top.qar 

 

3.1.1.4 Enter a directory in which you will store your Quartus project files for this design, for 

example, C:/MAX1000/Authentication_Flash_lab. 

 

 
 

3.1.1.5 Click OK. 
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3.1.2 Compiling the Design 
 

3.1.2.1 Start Compilation by clicking on  button on the toolbars, or Processing → Start 

Compilation. 

 

The 100% in the lower right corner or a green checkmark next to the Compile Design in 

the Compilation task window indicates that the compilation was successful. 

 

 
 

3.1.3 Configuration 
 

3.1.3.1 Connect your MAX1000 board to your PC using an USB cable. Since the Arrow USB Blaster 

should be already installed, the Window’s Device Manager should display the following 

entries are highlighted in red (port number may differ depending on your PC): 

 

  

https://www.arrow.com/


 

MAX1000 P a g e  | 5 www.arrow.com 
Authentication Flash Lab  February 2019 

 

3.1.3.2 Open the Quartus Prime Programmer from Tools → Programmer or double click on 

Program Device (Open Programmer) from the Task window. 

 

 
 

3.1.3.3 Click Hardware Setup… and double click Arrow-USB-Blaster entry in the Hardware Setup 

tab. The Currently selected hardware should now show Arrow-USB-Blaster [USB0] 

(depending on your PC, the USB port number may variant). 

 

 
 

3.1.3.4 Click Close. 
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3.1.3.5 Make sure the hardware setup is Arrow-USB-Blaster [USB0] and the mode is JTAG. Click 

Auto Detect. 

 

 
 

3.1.3.6 If the configuration has been added by default, you can skip the following steps and 

continue with the 3.1.3.11 point. 

 

3.1.3.7 Select 10M08SA device and click OK in the pop-up window. 

 

 
 

3.1.3.8 Click Change File... or double click <none> to choose the programming file. 

 

3.1.3.9 Navigate to the <project_directory>\ and select the top.sof file. 

 

3.1.3.10 Click Open. 
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3.1.3.11 Make sure the Programmer shows the correct file and the correct part in the JTAG chain 

and check the Program/Configure checkbox. 

 

 
 

3.1.3.12 Click Start to program the board. When the configuration is complete, the Progress bar 

should show 100% (Successful). 
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3.2 Software implementation 
 

3.2.1 Create a new software project 
 

3.2.1.1 From the main Quartus Prime window, start STB from Tools → Nios II Software Build Tools 

for Eclipse. 

 

3.2.1.2 The Eclipse Workspace Launcher will open. Click Browse… and choose the directory of 

your project. In this case it was C:\MAX1000\Authentication_Flash_lab. 

 

 
 

3.2.1.3 Click OK and the Eclipse will open. 

 

3.2.1.4 Select File → New → Nios II Application and BSP from Template. 

 

3.2.1.5 Click to select the nios_system.sopcinfo from your project directory and name the project 

auth_flash_lab. Select Blank Project from the Templates. 
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3.2.1.6 Click Finish. 

 

3.2.1.7 Eclipse will create two directories in the workspace, one for the application project and 

one for the BSP. 

 

 
 

3.2.1.8 Right click on the auth_flash_lab_bsp project and select Properties from the pop-up 

menu. 

 

3.2.1.9 In the Properties window select the Nios II BSP Properties tab. It may take a moment to 

load the settings. 

 

3.2.1.10 To keep the software footprint small so fits our device, enable Reduced device drivers 

and Small C library options. As there is no C++ code, uncheck the Support C++ option. 

 

 
 

3.2.1.11 Click Apply, and then OK. 
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3.2.2 Add source code to the project 
 

Note: The source files have been provided for you in this lab. All that needs to be done is to copy 

it to your workspace. 

 

3.2.2.1 From Windows Explorer, navigate to the lab files folder where you locate the provided 

design files.  

 

3.2.2.2 Select all files in source folder and drag it into the auth_flash_lab directory in Eclipse. 

Select the Copy files option in the pop-up and click OK. 

 

 
 

You should now see the new files appear under the auth_flash_lab project in the Project 

Explorer. 

 

 
 

3.2.3 Build the software 
 

3.2.3.1 Right click on the auth_flash_lab_bsp project and select Build Project from the pop-up 

menu. 
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3.2.3.2 Repeat the previous step for the auth_flash_lab application project. 

 

 
 

3.2.4 Run the application 
 

3.2.4.1 Select auth_flash_lab and go to Run → Run Configurations… and double click to Nios II 

Hardware to add a new configuration. 
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3.2.4.2 Rename it to Authentication Flash configuration and on the Project tab select 

auth_flash_lab from the drop-down menu for the Project name. 

 

 
 

3.2.4.3 Click on the Target Connection tab and click Refresh Connections button. The configured 

MAX1000 board should appear.  

 

 
 

3.2.4.4 Click Apply and Run. 
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3.2.4.5 After a few second, the Nios II Console should open at the bottom of the Eclipse. 

 

 
 

After this message, the software downloaded to MAX1000 and start to test the external 

flash memory. 

 

3.2.4.6 Stop the program running by clicking on  button on the top right corner of Nios II 

Console window. 

 

 

 

 

 

CONGRATULATIONS! YOU HAVE SUCCESSFULLY COMPLETED THE 

AUTHENTICATION FLASH LAB! 

  

https://www.arrow.com/
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5 Revision History 
 

Version Change Log Date of Change 
V1.0 Initial Version 15/11/2017 

V1.1 - Remove Arrow MAX1000 USB Driver 
installation 

- Remove Nios II EDS installation 
- Correction / clarity changes 
- Formal changes 

13/02/2019 
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6 Legal Disclaimer 

ARROW ELECTRONICS  

EVALUATION BOARD LICENSE AGREEMENT  
By using this evaluation board or kit (together with all related software, firmware, components, and 

documentation provided by Arrow, “Evaluation Board”), You (“You”) are agreeing to be bound by the terms and 

conditions of this Evaluation Board License Agreement (“Agreement”). Do not use the Evaluation Board until You 

have read and agreed to this Agreement. Your use of the Evaluation Board constitutes Your acceptance of this 

Agreement.  

PURPOSE 

The purpose of this evaluation board is solely intended for evaluation purposes. Any use of the Board beyond 

these purposes is on your own risk. Furthermore, according the applicable law, the offering Arrow entity 

explicitly does not warrant, guarantee or provide any remedies to you with regard to the board.  

LICENSE  

Arrow grants You a non-exclusive, limited right to use the enclosed Evaluation Board offering limited features 

only for Your evaluation and testing purposes in a research and development setting. Usage in a live environment 

is prohibited. The Evaluation Board shall not be, in any case, directly or indirectly assembled as a part in any 

production of Yours as it is solely developed to serve evaluation purposes and has no direct function and is not 

a finished product.  

EVALUATION BOARD STATUS  

The Evaluation Board offers limited features allowing You only to evaluate and test purposes. The Evaluation 

Board is not intended for consumer or household use. You are not authorized to use the Evaluation Board in any 

production system, and it may not be offered for sale or lease, or sold, leased or otherwise distributed for 

commercial purposes.  

OWNERSHIP AND COPYRIGHT  

Title to the Evaluation Board remains with Arrow and/or its licensors. This Agreement does not involve any 

transfer of intellectual property rights (“IPR) for evaluation board. You may not remove any copyright or other 

proprietary rights notices without prior written authorization from Arrow or it licensors.  

RESTRICTIONS AND WARNINGS  

Before You handle or use the Evaluation Board, You shall comply with all such warnings and other instructions 

and employ reasonable safety precautions in using the Evaluation Board. Failure to do so may result in death, 

personal injury, or property damage.  

You shall not use the Evaluation Board in any safety critical or functional safety testing, including but not limited 

to testing of life supporting, military or nuclear applications. Arrow expressly disclaims any responsibility for such 

usage which shall be made at Your sole risk.  

WARRANTY  

Arrow warrants that it has the right to provide the evaluation board to you. This warranty is provided by Arrow 

in lieu of all other warranties, written or oral, statutory, express or implied, including any warranty as to 

merchantability, non-infringement, fitness for any particular purpose, or uninterrupted or error-free operation, 

all of which are expressly disclaimed. The evaluation board is provided “as is” without any other rights or 

warranties, directly or indirectly.  

You warrant to Arrow that the evaluation board is used only by electronics experts who understand the dangers 

of handling and using such items, you assume all responsibility and liability for any improper or unsafe handling 

or use of the evaluation board by you, your employees, affiliates, contractors, and designees.  

 

https://www.arrow.com/
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LIMITATION OF LIABILITIES  

In no event shall Arrow be liable to you, whether in contract, tort (including negligence), strict liability, or any 

other legal theory, for any direct, indirect, special, consequential, incidental, punitive, or exemplary damages 

with respect to any matters relating to this agreement. In no event shall arrow’s liability arising out of this 

agreement in the aggregate exceed the amount paid by you under this agreement for the purchase of the 

evaluation board.  

IDENTIFICATION 

You shall, at Your expense, defend Arrow and its Affiliates and Licensors against a claim or action brought by a 

third party for infringement or misappropriation of any patent, copyright, trade secret or other intellectual 

property right of a third party to the extent resulting from (1) Your combination of the Evaluation Board with 

any other component, system, software, or firmware, (2) Your modification of the Evaluation Board, or (3) Your 

use of the Evaluation Board in a manner not permitted under this Agreement. You shall indemnify Arrow and its 

Affiliates and Licensors against and pay any resulting costs and damages finally awarded against Arrow and its 

Affiliates and Licensors or agreed to in any settlement, provided that You have sole control of the defense and 

settlement of the claim or action, and Arrow cooperates in the defense and furnishes all related evidence under 

its control at Your expense. Arrow will be entitled to participate in the defense of such claim or action and to 

employ counsel at its own expense.  

RECYCLING  

The Evaluation Board is not to be disposed as an urban waste. At the end of its life cycle, differentiated waste 

collection must be followed, as stated in the directive 2002/96/EC. In all the countries belonging to the European 

Union (EU Dir. 2002/96/EC) and those following differentiated recycling, the Evaluation Board is subject to 

differentiated recycling at the end of its life cycle, therefore: It is forbidden to dispose the Evaluation Board as 

an undifferentiated waste or with other domestic wastes. Consult the local authorities for more information on 

the proper disposal channels. An incorrect Evaluation Board disposal may cause damage to the environment and 

is punishable by the law. 

 

https://www.arrow.com/
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