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About This Guide

The Synopsys Sentaurus™ Workbench tool is the primary graphical front end for the
integration of TCAD Sentaurus simulation software into one environment.

Sentaurus Workbench provides a convenient framework to design, organize, and automatically
run complete TCAD simulation projects. Its graphical user interface drives various Synopsys
simulation and visualization tools as well as third-party tools, and automates the execution of
fully parameterized projects. Sentaurus Workbench also supports design-of-experiments,
extraction and analysis of results, optimization, and uncertainty analysis. It has an integrated
job scheduler to speed up simulations and takes full advantage of distributed, heterogeneous,
and corporate computing resources.

Related Publications

For additional information, see:

■ The documentation installed with the software package and available from the Sentaurus
Workbench Help menu.

■ The TCAD Sentaurus release notes, available on the Synopsys SolvNet® support site (see
Accessing SolvNet on page xiv).

■ Documentation available on SolvNet at https://solvnet.synopsys.com/DocsOnWeb.

Conventions

The following conventions are used in Synopsys documentation. 

Convention Description

Blue text Identifies a cross-reference (only on the screen).

Bold text Identifies a selectable icon, button, menu, or tab. It also indicates the name of a field or an 
option.

Courier font Identifies text that is displayed on the screen or that you must type. It identifies the names 
of files, directories, paths, parameters, keywords, and variables.

Italicized text Used for emphasis, the titles of books and journals, and non-English words. It also 
identifies components of an equation or a formula, a placeholder, or an identifier.
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Customer Support

Customer support is available through the Synopsys SolvNet customer support website and by
contacting the Synopsys support center.

Accessing SolvNet

The SolvNet support site includes an electronic knowledge base of technical articles and
answers to frequently asked questions about Synopsys tools. The site also gives you access to
a wide range of Synopsys online services, which include downloading software, viewing
documentation, and entering a call to the Support Center.

To access the SolvNet site:

1. Go to the web page at https://solvnet.synopsys.com.

2. If prompted, enter your user name and password. (If you do not have a Synopsys user name
and password, follow the instructions to register.)

If you need help using the site, click Help on the menu bar.

Contacting Synopsys Support

If you have problems, questions, or suggestions, you can contact Synopsys support in the
following ways:

■ Go to the Synopsys Global Support Centers site on synopsys.com. There you can find e-
mail addresses and telephone numbers for Synopsys support centers throughout the world.

■ Go to either the Synopsys SolvNet site or the Synopsys Global Support Centers site and
open a case online (Synopsys user name and password required).

Key+Key Indicates keyboard actions, for example, Ctrl+I (press the I key while pressing the Ctrl 
key).

Menu > Command Indicates a menu command, for example, File > New (from the File menu, select New).

Convention Description
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Contacting Your Local TCAD Support Team Directly

Send an e-mail message to:

■ support-tcad-us@synopsys.com from within North America and South America.

■ support-tcad-eu@synopsys.com from within Europe.

■ support-tcad-ap@synopsys.com from within Asia Pacific (China, Taiwan, Singapore,
Malaysia, India, Australia).

■ support-tcad-kr@synopsys.com from Korea.

■ support-tcad-jp@synopsys.com from Japan.
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CHAPTER 1 Introduction to Sentaurus 
Workbench

This chapter provides an overview of Sentaurus Workbench.

Functionality of Sentaurus Workbench

Sentaurus Workbench is the framework environment designed to simplify the use of Synopsys
TCAD tools. It frees you from typing system commands for handling data files or starting
applications. One of its main advantages is the possibility of parameterizing input files to run
simulation groups automatically. The main features of Sentaurus Workbench include:

■ The graphical user interface (GUI) simplifies the editing and handling of complex
simulation projects, and the flexible open tool interface makes it possible to plug in third-
party tools.

■ It allows for the flexible configuration and storing of the view of the project simulation
flow.

■ Simulations can be organized into projects and folders, which provide a clear overview of
the overall simulation environment.

■ The project database is mapped to the underlying native file systems and allows robust file
management in a multiuser distributed environment.

■ You can set up tool flows with multiple instances of the same tool.

■ Simulation parameters can be used in any input file, and the resulting simulation
experiments can be edited before running the simulations.

■ It is easy to build new simulation projects by copying parts of existing projects.

■ Many example projects are available to be copied and modified as required.

■ You can perform design-of-experiments, optimization, and statistical analysis.

■ The scheduler integrated into the GUI can schedule and monitor the running of simulation
projects.

■ There is easy access to backend scheduling systems to run large simulations in parallel on
a network of workstations and computing clusters.
Sentaurus™ Workbench User Guide 1
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Sentaurus Workbench Projects

A project consists of a family of scenarios. Each scenario consists of several experiments where
certain input variables take different values. Parameters can be introduced at any point in the
simulation flow, from the process to the device simulation phases.

A project exists as a directory in the file system. If a directory contains a .project file, this
indicates to Sentaurus Workbench that the current directory is a project directory.

A parameterized project is represented as a tree structure, shown in the Family Tree part of the
project view, which is derived from a simulation flow and a combination of all the parameter
values. Each level shown in the Family Tree corresponds to a simulation phase, as defined in
the simulation flow.

In the Family Tree, each node has a unique number – the node key (<nkey>). A real node
represents the end of a simulation phase and holds the output of the corresponding tool
instance. Sentaurus Workbench associates output to a node by adding the prefix n<nkey>_ to
all the output file names of the tool used.

You need to distinguish between real and virtual simulation phases. Real simulation phases
correspond to the execution of tool instances, and virtual simulation phases are introduced by
parameters and do not lead to any tool execution. In a real simulation phase, there are as many
tool instances as nodes in the corresponding tree level. Each tool instance is characterized by a
combination of parameter values that define the path from the root node to the tool instance
node.

The main attribute of a project is its runtime editing mode, which defines the editing and
running policy for that project. You can choose either the Locked mode or the Editable mode
(the default mode). Projects in the Locked mode have the maximum level of automation and
consistency; however, you are limited with regard to applying changes to a running project. In
contrast, projects in the Editable mode have maximum flexibility, while Sentaurus Workbench
partially delegates to you the responsibility of maintaining consistency between input data and
simulation results. You can change the runtime editing mode at any time in the preferences (see
Changing the Default Runtime Editing Mode of Projects on page 13).

Compatibility With Previous Versions

Sentaurus Workbench can load, edit, and run projects created in previous versions of the tool.
Sentaurus Workbench makes all of the necessary conversions automatically.

NOTE There is no guarantee that you can edit new projects using earlier
versions of Sentaurus Workbench.
2 Sentaurus™ Workbench User Guide
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Starting Sentaurus Workbench

You must set up environment variables before starting Sentaurus Workbench.

Setting Up Environment Variables

You must set up the following environment variables before starting Sentaurus Workbench: 

The following example illustrates the settings in a .cshrc file:

setenv STROOT /home/user/ST
setenv STRELEASE N-2017.09
setenv STDB $HOME/DBtest

Launching Sentaurus Workbench From the Command 
Line

You can launch Sentaurus Workbench from the command line by specifying:

swb [<options>] [<directory> | <file>]

where:

■ <options> can be any of the following:

• -a: Initializes the Sentaurus Workbench Advanced mode that includes the Optimizer
and Calibration menus.

• -b: Initializes the Sentaurus Workbench Basic mode that does not include the
Optimizer and Calibration menus.

• -default: Resets preferences to the default settings.

• -h: Displays help information.

• -hierarchical: Initializes hierarchical Sentaurus Workbench mode to work with
hierarchically organized projects.

STDB The directory where all user projects reside.

STRELEASE The version of Sentaurus Workbench. If not specified, the default is the
current version.

STROOT The location where the Synopsys TCAD software is installed.
Sentaurus™ Workbench User Guide 3
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• -nowait: Switches off license queueing.

Without this option, if you launch Sentaurus Workbench when no license is available,
Sentaurus Workbench queues for the license from the license manager and waits until
a license is available. If you launch Sentaurus Workbench with the -nowait option, it
will not queue for a license. If no license is available, Sentaurus Workbench exits.

• -plugin null: Switches off standard plug-ins.

• -traditional: Initializes traditional Sentaurus Workbench mode to work with
traditionally organized projects. This is the default.

• -v: Displays the version of Sentaurus Workbench.

• -verbose: Displays all messages.

■ <directory>: Specify a Sentaurus Workbench project directory.

■ <file>: Specify a compressed file with a Sentaurus Workbench project.

NOTE If you launch Sentaurus Workbench without either the -a or -b option,
it opens in the Basic mode.

Examples

Launch Sentaurus Workbench Basic mode:

swb &

swb -b &

Launch Sentaurus Workbench Basic mode and load a project directory:

swb /u/jbrown/sample_app/myproject &

Graphical User Interface

The main window of Sentaurus Workbench consists of the projects browser and tabs for the
Project Editor (Project tab) and the Scheduler (Scheduler tab).

Projects Browser

You can manage projects in the projects browser (the Projects panel) (see Figure 1 on page 5).
The projects are organized hierarchically as a tree. The tree displays the current file system as
specified by the setting of the STDB environment variable.
4 Sentaurus™ Workbench User Guide
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Directories are identified as Sentaurus Workbench project directories by the presence of
a .project file, and Sentaurus Workbench displays project directories like files with the 
icon. The color of this icon reflects the status of the project.

The projects browser shows a global view of the project database of the user as a hierarchy of
folders and projects. It features a tree representation to navigate through this hierarchy, to open
and close folders, and to load projects, and for diverse operations on entire projects and folders,
such as copying and moving projects. Additional hierarchies of folders and projects can be
attached to the projects browser.

NOTE Any folders under a project directory are not displayed. Sentaurus
Workbench does not work if there is a .project file anywhere above
STDB. 

Figure 1 Main window with projects browser (green box) and Project Editor view showing 
traditional horizontal flow orientation

Viewing Directories

The directories can be expanded or collapsed, allowing you to view the subdirectories and
project folders below directories. You can navigate the directories using keyboard and mouse
operations.

Right-click the Projects panel to display the context menu.
Sentaurus™ Workbench User Guide 5
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Attaching Root Directories

While you can specify the file system directory where all your projects reside using the STDB
environment variable, you can also include other directories at the same level, in the projects
browser.

Such a directory is a root directory, which typically contains a collection of folders and
projects, and it can also be a project directory.

To add a root directory to the projects browser:

1. In the Projects panel, right-click and select Folder > Attach Root.

2. In the Open Directory dialog box, navigate to the directory to be added.

3. Click OK.

NOTE Any directories above a root directory must not contain project
directories or .project files, which Sentaurus Workbench interprets as
project directories.

Updating the Status of Directories

In the projects browser, the status of the directory structure, attached root directories, and
projects is updated regularly. The interval for updates is set in the preferences. However, you
can update a project directory or root directory manually at any time.

To update the status of a directory:

■ Right-click the directory and select Refresh, or press the F5 key.

Project Editor

The Project Editor allows you to access, organize, and edit a database of simulation projects on
the Project tab. The simulation flow can be oriented horizontally (see Figure 1 on page 5) or
vertically (see Figure 2 on page 7).

The Project tab displays an individual project as a table of experiments and simulation results.
The rows from left to right in the horizontal flow orientation (see Figure 1) or columns from
top to bottom in the vertical flow orientation (see Figure 2) represent the simulation flow
followed by extracted results.

The simulation flow is the sequence of tools running the simulations steps, split by parameters.
Columns in the horizontal orientation (or rows in the vertical orientation) represent different
6 Sentaurus™ Workbench User Guide
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experiments and their corresponding parameter and variable values. You can add, remove, and
modify experiments, and control the running of experiments. 

Figure 2 Main window with Project Editor view showing vertical flow orientation

Scheduler

You can use the Scheduler to submit, terminate, and monitor the simulation jobs of a project.
You can also define scheduling queues and job-mapping restrictions. The Scheduler gives you
an overview of the running jobs and their distribution on the local area network.

To open the Scheduler:

■ Choose Scheduler > Show Scheduler, or click the Scheduler tab (see Figure 3 on page 8).

The Scheduler tab displays a table of running jobs with scheduling information, such as
running time and running host. Only jobs belonging to the selected project or folder are shown.
By default, Sentaurus Workbench shows the running jobs of the currently open project.
Sentaurus™ Workbench User Guide 7
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Figure 3 Main window of Sentaurus Workbench showing the Scheduler tab

Utilities

This section describes the different utilities available in Sentaurus Workbench.

gcleanup

This utility cleans up a project and performs all of the cleanup operations including the
renumbering of the tree (see Cleaning Up Projects From the Command Line on page 173).

gjob

This utility manages the execution of individual jobs and controls the evaluation of the job
prologue and epilogue, and the running of the corresponding simulation tool (see Launching a
Specific Job on page 145).
8 Sentaurus™ Workbench User Guide
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gsub

This utility consists of a simple command to submit jobs to the Scheduler for execution. It also
constitutes the interface of Sentaurus Workbench to different internal or external batch systems
(see Submitting Jobs to Queues on page 144).

gtclsh

This utility is a tool command language (Tcl) shell that has been extended with all of the
internal commands of Sentaurus Workbench, such as tree manipulation.

spp

This utility is the Sentaurus Workbench preprocessor that prepares a project for execution,
which includes:

■ Calculating an optimum execution graph from the simulation tree to use parallel computing
while enforcing start–completion job interdependencies.

■ Generating actual tool input files from user-provided templates to differentiate
experiments.

See Preprocessing Projects on page 162.

swbdiag

This utility is used to troubleshoot issues originating in customer environments that might
affect the behavior of Sentaurus Workbench (see Appendix E on page 291).

swblm

This daemon process is a dispatcher of interprocess communications between the Sentaurus
Workbench components swb, gjob, gsub, and spp. Sentaurus Workbench starts this process
automatically when needed. You do not need to terminate a running daemon process or to start
a new one manually (see Appendix E on page 291).
Sentaurus™ Workbench User Guide 9
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swbopt

This utility is available in the Sentaurus Workbench Advanced mode and is designed for
parametric studies in large-scale projects with hundreds of individual simulations, such as
automatic iterative optimization, sensitivity analysis, and uncertainty analysis. For more
information, see the Optimizer User Guide.
10 Sentaurus™ Workbench User Guide
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CHAPTER 2 Managing Projects

This chapter describes the operations that can be performed on
projects and directories using the projects browser.

Creating Project Directories

To create a project directory:

1. Choose Project > New > New Project, or press Ctrl+N.

A new project directory called untitled_project is added to the root directory.

2. Rename the project by right-clicking and selecting Rename.

3. Type the name of the project directory.

4. Press the Enter key.

NOTE Sentaurus Workbench prohibits the use of the following characters in
project names, including full paths: / \ ~ * ? $ ! " < > : [ ]
{ } = | ; <tab> <space> 

In addition, it is not recommended to use any of the following characters
in project names: , @ # ( ) ' ` + & ^ % 

Creating Folders

NOTE You cannot create folders inside project directories.

To create a folder:

1. Select a directory that is not a project directory.

2. Choose Project > New > New Folder, or right-click and select Folder > New Folder.

3. Type the name of the new folder.

4. Press the Enter key.
Sentaurus™ Workbench User Guide 11
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NOTE Sentaurus Workbench prohibits the use of the following characters in
folder names, including full paths: / \ ~ * ? $ ! " < > : [ ]
{ } = | ; <tab> <space> 

In addition, it is not recommended to use any of the following characters
in folder names: , @ # ( ) ' ` + & ^ % 

Opening Projects

To open a project:

■ Double-click the project in the projects browser.

Alternatively, to open a project:

1. Select the project in the projects browser.

2. Press the Enter key, or double-click the selection, or right-click and select Open.

Changing the Runtime Editing Mode of a Project

NOTE Projects must be in the writable area to change the runtime editing
mode.

You cannot change the runtime editing mode of a running project.

To change the runtime editing mode of a project:

1. Select a project in the Projects panel.

2. Right-click the project, select Project > Runtime Editing Mode and either:

• Locked for the Locked mode

• Editable for the Editable mode.

See Locked Runtime Editing Mode on page 147 and Editable Runtime Editing Mode on
page 148.
12 Sentaurus™ Workbench User Guide
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Changing the Default Runtime Editing Mode of Projects

The Editable mode is the default mode for projects. However, you can configure Sentaurus
Workbench to set up the runtime editing mode automatically for new projects and any old
projects that do not have a runtime editing mode selected.

To change the default runtime editing mode of projects:

1. Choose Edit > Preferences, or press the F12 key.

2. In the SWB Preferences dialog box, expand Project > Runtime Editing Mode > Default
Mode.

3. Select either Locked or Editable.

4. Click Apply.

Copying Projects or Folders

You can copy multiple projects or folders.

NOTE Projects and folders cannot be copied inside other projects.

NOTE If a project is copied over its original project, the new project is created
in the same folder with Copy_of_ prefixed to the project name. If a
folder is copied over its original folder, the new folder with all its
contents is created in the same parent folder with Copy_of_ prefixed to
the folder name.

To copy projects or folders:

1. In the Projects panel, select the required projects.

2. Press Ctrl+C, or right-click and select Copy.

3. Navigate to the required destination folder or keep the selection.

4. Press Ctrl+V, or right-click and select Paste.
Sentaurus™ Workbench User Guide 13
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Linking Projects

You can link two different projects, which allows you to refer to the simulation results of one
project in another project without executing the referred nodes.

In this section, such projects are called parent and child projects for demonstration purposes
only. A parent project contains Sentaurus Workbench parameters, variables, and output files
that also can be accessed in a child project.

The Bridge tool is used to link projects and must be added to the flow of a child project.
Synchronizing the two projects links them. The Sentaurus Workbench parameters of a parent
project are copied into the nodes of the Bridge tool after a child project is synchronized with a
parent project.

NOTE Sentaurus Workbench supports only one Bridge tool in a project. In
other words, you can link a child project to only one parent project.

Command File of the Bridge Tool

The command file of the Bridge tool specifies the name of a parent project and the nodes from
the parent project to be linked to a child project.

The Bridge tool supports the following instructions specified in its command file
bridge_tcl.cmd:

#noexec
set Parent "../Parent"
set ptools "sprocess IdVg"
set pvars "Vt Ioff Ion"
set PStoSync all
set infoLevel 3

In this example, the Parent setting contains the path to a parent project. The path can be either
an absolute or a relative path to a child project.

The ptools setting is a list of tools in a parent project. Parameters defined for these tools in a
parent project are copied into the Bridge parameters in a child project when the child and parent
projects are synchronized. If you omit this setting, Sentaurus Workbench copies the parameters
of all tools of a parent project.

The pvars setting contains a list of variables of a parent project to copy to a child project. If
you omit this setting, no variables are copied.
14 Sentaurus™ Workbench User Guide
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The PStoSync setting specifies the reference scenario in a parent project. It instructs
Sentaurus Workbench to copy parameters with the values of the given scenario. If you omit this
setting, all parameter values of a parent project will be copied to a child project, which is
equivalent to set PStoSync all.

Sentaurus Workbench logs the project synchronization into the syncwparent.log file. The
setting infoLevel sets the verbosity of output in the log file, which can range from 0 (no
output) to 3 (the most detailed output). The default is 0.

The presence of the Bridge tool in a project flow instructs the preprocessor to support the
following instructions for linking purposes:

■ @ppwd@: Path to a parent project as defined in the Bridge tool input

■ @ppwdout@: Path to the directory where output files of a parent project are stored if project
files are stored in a different location (see Chapter 12 on page 241)

■ @pnode|toolname@: Matching node in a parent project that corresponds to the tool
toolname 

NOTE There is no need to execute nodes of the Bridge tool, since the linking
occurs automatically during project preprocessing and execution. This
is the reason why the #noexec preprocessor directive is used in the
Bridge command file.

Synchronizing Dependent Projects

Different synchronization modes of parent and child projects are available under the Tools
menu when the Bridge tool is selected:

■ Tool > Clean and Synchronize With Parent Project 

This command performs the following operations:

• Removes all parameters under the Bridge tool of a child project

• Copies parameters of the required tools in a parent project to the Bridge tool of a child
project (required tools are set using ptools)

• Makes Sentaurus Workbench variables listed in pvars available in a child project after
preprocessing or execution

■ Tool > Synchronize With Parent Project 

This command performs the following operations:

• Finds parameters of the required tools in a parent project that have not been
synchronized yet and adds them to the Bridge tool of a child project (required tools are
set using ptools)
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• Adds values of synchronized parameters from a parent project that are not yet in a child
project

• Makes Sentaurus Workbench variables listed in pvars available in a child project after
preprocessing or execution

This command is useful when new parameters or variations are added to a parent project
while a child project already contains simulation results corresponding to the previous
parent state. In that case, you might not want to clean up the child project.

Figure 4 shows a parent project and child project synchronized with the Clean and
Synchronize With Parent Project command and executed. 

Figure 4 (Top) Parent project and (bottom) child project after synchronization and 
execution of the child project

Figure 5 on page 17 shows an example of using the Synchronize With Parent Project
command. The parameter mf with values 0.4 (default) and 0.5 is added to the Sentaurus Process
tool in the parent project. When the previously executed child project is synchronized without
cleaning, the default mf parameter value (0.4) is added to the previously executed experiments.
A new experiment corresponding to the new mf value (0.5) is added to the parent project.
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Figure 5 (Top) Parent project and (bottom) child project synchronized with the parent 
project without cleaning the child project

Saving Projects

To save the current project in the same directory:

■ Choose Project > Save, or press Ctrl+S.

To save a project with a different name or in a new directory (the entire contents of the project
directory are saved to the new directory):

■ Choose Project > Save As > Project.

To omit copying all of the preprocessed and node output files:

■ Choose Project > Save As > Clean Project.

To create a new project based on selected experiments:

■ Choose Project > Save Selected Experiments As > Project.

To create a new project based on selected experiments, but without copying the simulation
results:

■ Choose Project > Save Selected Experiments As > Clean Project.
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Automatically Saving Projects

You can configure Sentaurus Workbench to save your projects automatically. Sentaurus
Workbench periodically saves the currently opened project for your convenience.

NOTE Automatic saving takes effect only when projects are not running.

To switch on automatic saving of a project:

1. Choose Edit > Preferences, or press the F12 key.

2. In the SWB Preferences dialog box, expand Project > Auto Save.

3. Set Project Auto Save Interval (min) to a nonzero value specifying the interval in
minutes.

The default value of 0 means that this feature is switched off.

4. Click Apply.

Moving Projects or Folders

You can move projects and folders across directories by either a drag-and-drop operation or a
cut-and-paste operation.

NOTE The following restrictions apply when moving projects or folders:

• You cannot move projects opened in the projects browser or running
projects.

• You cannot move folders with any open or running project.

• You cannot place projects or folders inside projects.

• Projects without write permission are copied.

To move a project or folder using a drag-and-drop operation:

1. Select the project or folder in the Projects panel.

2. Drag the project or folder to the destination project or folder.

To move a project or folder using a cut-and-paste operation:

1. Select the project or folder in the Projects panel.

2. Press Ctrl+X, or right-click and select Cut.
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3. Navigate to the destination project or folder.

4. Press Ctrl+V, or right-click and select Paste.

Renaming Projects or Folders

NOTE Operations on the Family Tree directly act on the file system. Therefore,
any delete, move, or rename operation cannot be undone.

To rename a project or folder:

1. Select the project or folder.

2. Right-click and select Rename.

3. Type the new name.

4. Press the Enter key.

NOTE A file name must contain only characters permitted by the operating
system. Although the projects browser is configured to identify all
invalid characters, extreme file names are likely to cause unpredictable
behavior and might result in the loss of work.

Deleting Projects or Folders

You can delete multiple projects or folders.

NOTE This operation irreversibly removes project directories.

To delete a project or folder:

1. Select the project or folder in the Projects panel.

2. Choose Edit > Delete, or right-click and select Delete.

Accessing Project Documentation

You can attach a documentation file to a project. The file format must be PDF, and the file name
should be greadme.pdf. The file can contain any information about the project.
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To access a documentation file in Adobe Reader:

1. Select a project in the projects browser.

2. Choose Project > Properties > Documentation.

Exporting and Importing Projects

You can export projects and directories into a package.

NOTE You can redefine the default project export options in the SWB
Preferences dialog box by expanding Project > Export.

To export projects and directories:

1. Select one or more projects or data directories in the projects browser.

To make multiple selections, hold the Ctrl key when clicking.

2. Choose Project > Export.

The Export to Package dialog box is displayed (see Figure 6).

3. In the Package Name field, select the name and location of the package file.

4. In the Exclude Patterns field, type the patterns of files and directories to be excluded from
the package.

NOTE The exclude patterns are applied automatically (see Specifying Project
Exclude File Patterns on page 174).

5. Select from the following options:

• Export SWB Projects As Clean: Packages all Sentaurus Workbench projects in the
selected hierarchy as clean projects. The original projects are not cleaned up during
packaging.

• Compress Package (gzip): Compresses the package.

• Encrypt Package (openssl): Encrypts the package.

6. If you selected the Encrypt Package (openssl) option, you must type a key in the
Encryption Key field (see Encrypted Packages on page 22).
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NOTE The following characters are prohibited in an encryption key:

• Single quotation marks (')

• Backslash (\)

• Whitespace (space, tabulator, newline)

7. Click OK. 

Figure 6 Export to Package dialog box

To import projects and directories:

1. Double-click a .gzp or .tar file in the projects browser.

2. In the Unpacking dialog box (see Figure 7 on page 22), select one or more projects or
directories.

3. Click Save As to unpack and store the selected items at the specified location.

Click Extract All to unpack and store all the items from the file.
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Figure 7 Unpacking dialog box

Encrypted Packages

Many users have difficulties using email to send packaged Sentaurus Workbench projects.
Firewalls and email filters unpack the package, detect files with potentially dangerous
extensions (.cmd), and block those files or even the entire email message.

Encryption allows your package to go through email filters without problems. When unpacking
an encrypted package, Sentaurus Workbench uses a default encryption key. You can control the
encryption key and package your projects with specific keys for confidential deliveries.

If the package has been encrypted with a nondefault key, Sentaurus Workbench asks you to
enter this key when importing a packaged project.

NOTE With the default Synopsys encryption key swb, Sentaurus Workbench
guarantees successful importing of packaged projects by another user.
When you need additional security, package your project with a specific
encryption key and communicate it to the recipient of the package.

You cannot import a packaged project that is encrypted with an
unknown (or forgotten) key.
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It is not recommended to send extremely large packages (exceeding
1 GB). There might be unexpected issues with unpacking such packages
in different environments. In such cases, you should split the data into
several packages that individually are less than 1 GB.

Configuring Sentaurus Workbench to Exit Automatically

You might forget to exit Sentaurus Workbench, for example, before leaving for vacation or the
weekend. As the result, inactive tools keep checked out licenses. You can configure Sentaurus
Workbench to exit automatically if no user activity is registered for a given time.

To configure Sentaurus Workbench to exit automatically when there is no user activity:

1. Choose Edit > Preferences, or press the F12 key.

2. In the SWB Preferences dialog box, expand Auto Exit When Inactive > Inactivity Time-
Out (hours).

3. Specify the number of hours of inactivity after which time Sentaurus Workbench will exit.

If the time-out is set to 0, this feature is not activated.

4. For the Alert Before Time-Out (min) field, specify when a warning dialog box opens
before the tool exits.

If set to 0, no warning dialog box is shown before the tool exits.

5. Click Apply.

NOTE If you set up this feature for Sentaurus Workbench, it also applies to
Sentaurus Visual.

As soon as the inactivity time-out expires, Sentaurus Workbench or Sentaurus Visual exits and
prints a warning message to the terminal where it has been launched, for example:

WARNING: SWB has exited after 24 hours of user inactivity.

NOTE Unsaved changes in a project opened in Sentaurus Workbench are not
stored when the tool exits.

Resetting the Inactivity Time-Out

Click the mouse button or press any key in the user interface of Sentaurus Workbench or
Sentaurus Visual to reset the inactivity time-out.
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CHAPTER 3 View Settings

This chapter describes how to modify and save the view settings for
projects in Sentaurus Workbench.

View Settings for Projects

The Project tab consists of the following main sections: Family Tree, Experimental Plan,
Parameter Values, and Variable Values (see Figure 8). 

Figure 8 Different parts of the Project tab shown in the horizontal orientation

These sections, as well as other project view settings, can be configured by changing the default
view options in the preferences or selecting the appropriate commands from the View menu.
Your project view configuration is stored together with the project data. The next time you load
the project, its view settings are used automatically.

You can configure the project view settings on both the user level and the project level (see
Table 1). 

Table 1 Setting project views at project and user levels

Level Where to set Description

Project Commands are available from the 
View menu.

These view settings are stored in the .database file under the 
project directory and apply only to a specific project. The view 
settings are saved each time you save a project or switch to 
another project in the projects browser.

User Choose Edit > Preferences to 
open the SWB Preferences dialog 
box. Expand Table > Default 
View Options.

These view settings apply to all projects of a given user, unless 
the project does not have project-level view settings in 
the .database file.
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Project-level view settings override user-level settings. So, if a project does not have
the .database file, the default view settings from the preferences are applied. Otherwise, the
view settings from the .database file are used.

The project view on the Project tab can be oriented either horizontally or vertically. In this
chapter, view settings for horizontally oriented projects are considered. For vertically oriented
projects, the view settings apply in the same way. 

Figure 9 Different parts of the Project tab shown in the vertical orientation

Configuring the Default View Settings in Preferences

The default view settings are configured in the preferences (see Preferences on page 177).
These settings apply to any project that does not have project-level view settings, that is, the
project does not have the .database file in its directory.

NOTE It is recommended that you start by configuring the view settings in the
preferences. Specify them so that they match the view requirements for
most of your projects. You can customize these settings later for specific
projects.
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Restoring the Default View Settings in Preferences

The view settings stored in the .database file under the project directory override the settings
in the preferences.

To restore the default view settings in the preferences for the currently opened project:

■ Choose View > Restore Default View Options, or press Ctrl+8.

Configuring the Project Orientation

By default, Sentaurus Workbench displays projects in the horizontal orientation, where the tool
flow is shown in the topmost row from left to right, and parameterized experiments are rows of
the Family Tree (see Figure 8 on page 25).

Alternatively, you can display projects with a vertical orientation, where the tool flow is shown
in the leftmost column from top to bottom, and parameterized experiments are columns of the
Family Tree (see Figure 9 on page 26).

The project orientation depends on your preferences and the project structure. Some projects
are more convenient to display horizontally, while other projects are best viewed in a vertical
orientation.

To switch between horizontal and vertical orientations, either:

■ Choose View > Flow Orientation > Vertical.

■ Choose View > Flow Orientation > Horizontal.

The project orientation is stored in the .database file and is restored the next time you load
the project.

Setting the Project View Mode

Sentaurus Workbench allows you to display projects in two modes:

■ In full mode (default), the entire simulation flow is displayed (see Figure 1 on page 5).

■ In compact mode, only varying parameterization parts of the simulation flow with extracted
variables are displayed. All other parts of the flow are hidden. This mode allows you to
focus on the active parameterization part of the project and can be useful for large design-
of-experiments projects (see Figure 10 on page 28).

The mode is stored in the .database file and is restored the next time you load the project.
Sentaurus™ Workbench User Guide 27
N-2017.09



3: View Settings 
View Settings for Projects
To switch from full mode to compact mode:

■ Choose View > Flow View Mode > Compact.

To switch from compact mode to full mode:

■ Choose View > Flow View Mode > Full. 

Figure 10 Project view with compact mode activated

Customizing the View of the Current Project

You can customize the view of the current project by showing or hiding the following flow
elements manually:

■ Tool instance

■ Default tool step of a tool instance

■ Parameter step of a tool instance

■ Variable

To hide a flow element, for example, a parameter step:

■ Select a cell separation line to the right of the parameter name cell and drag the line to the
left until the cell disappears. Release the mouse button.

Alternatively, choose Parameter > Hide.

This operation hides the parameter step. To remind you that a flow element is hidden, Sentaurus
Workbench shows the corresponding cell separator line in bold (see Figure 11 on page 29).
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Figure 11 Project with hidden tools, parameters, and variables (red arrows indicate hidden 
flow elements)

To redisplay a hidden parameter step:

■ Select the bold cell separation line and drag the line to the right. Release the mouse button.

Alternatively, choose Parameter > Show.

You can show or hide other flow elements in a similar way.

For convenience, you can use the Customize Current View dialog box to show or hide different
flow elements in one step (see Figure 12 on page 30).

To display the Customize Current View dialog box:

■ Choose View > Customize Current View.

All your customizations are stored in the view settings .database file and are restored the next
time you load the project.
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Figure 12 Customize Current View dialog box
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Changing the Font of the Project View

You can change the font attributes of the project view for the currently open project.

To change the font of the project view:

1. Choose View > Table Options > Change Table Font.

The Change Font dialog box is displayed.

2. Select one of the following:

• The Apply System Default Font option specifies that Sentaurus Workbench
automatically detects the optimal font to use.

• The Choose Font from Dialog option displays the Font Selection dialog box (see
Figure 13) where you can select the font attributes that are available for the operating
system.

3. Click OK.

The next time the project is loaded, the font settings are applied. 

Figure 13 Font Selection dialog box

To apply a particular font to all projects:

1. Choose Edit > Preferences.

2. In the SWB Preferences dialog box, expand Table > Font.

3. Configure the font attributes in a similar way as configuring the font of the Family Tree.

4. Click Apply.
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NOTE Font attributes set up in the preferences apply to both the Family Tree
and the projects browser.

The font attributes of the Family Tree are stored in the .database file
and these attributes overwrite font settings in the preferences.

Changing the Application Font

Sentaurus Workbench uses the default system font as the default application font except for the
project view, that is, the main menus, projects browser, and dialog boxes.

You can change the attributes of the default application font in the user-level X configuration
file .Xdefaults using the standard X logical font description with the swb*font name, for
example:

swb*font: -adobe-helvetica-medium-r-n*-14-*-75-75-*-iso10646-1

To change the default application font used to preview node files in the Node Explorer and to
view output files, specify a fixed font with the swb*fixedfont name, for example:

swb*fixedfont: -*-courier-medium-r-*-*-20-*-*-*-*-*-*-*

Configuring the Column Width and Row Height

By default, Sentaurus Workbench automatically calculates the column widths and the row
heights to adjust the project data. You can customize the width of all columns and the height
of all rows in the project table by manually changing their size using mouse operations.

Sentaurus Workbench stores all the column widths and row heights in the view
settings .database file and applies these sizes the next time you load the project.

To restore the default column and row sizes at any time:

■ Choose View > Restore Default Cell Size, or press Ctrl+7.

Magnifying the Project View

You can change the magnification of the project view. When a project has a large Family Tree,
it can be useful to zoom out of the project view.

Sentaurus Workbench will display values in a smaller font size, which allows you to reduce the
cell size and to see a bigger part of the parameterization table at one time. Zooming in will
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result in the opposite effect. The font name and other font attributes are retained without change
(see Changing the Font of the Project View on page 31).

To zoom in to the project view:

■ Choose View > Zoom In, press Ctrl+Plus sign (+), or click the Zoom In button.

To zoom out of the project view:

■ Choose View > Zoom Out, press Ctrl+Minus sign (-), or click the Zoom Out button.

To switch the zoom off from a previously zoomed part of the project view:

■ Choose View > Zoom Off, press Ctrl+0, or click the Zoom Off button.

Freezing Columns and Rows

When a project has many tools and parametric steps, you might want to freeze a certain part of
the Family Tree and keep it visible on your screen when scrolling through the rest of the Family
Tree to the right.

For example, imagine a simulation setup that starts with a process simulation and remeshing
followed by multiple device tests. You might want to configure the project view so that the
process simulation and remeshing part remains visible on-screen when you scroll through the
device tests part (see Figure 14). 

Figure 14 Project with frozen columns (indicated by cells with black background)

To freeze columns or rows:

1. Select the columns in the parameter row or tool row.

2. Choose View > Freeze Rows/Columns.

Sentaurus Workbench freezes the selected columns, so they remain visible on-screen when you
scroll through the Family Tree. Frozen columns are shown in black, which identifies them the
next time you load the project.

To unfreeze columns or rows:

■ Choose View > Unfreeze Rows/Columns.
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In addition, you can select an arbitrary set of nodes and freeze it. As a result, Sentaurus
Workbench will determine the rectangular area of the Family Tree and freeze the area.

Copying Data to Other Tools

You can easily copy data from the table on the Project tab to other tools. Spreadsheet
applications support direct copy-and-paste operations of tabbed data.

Main Sections of Project View

The main sections of the project view are:

■ Family Tree

■ Experimental Plan

■ Parameter Values

■ Variable Values

Family Tree

The Family Tree shows the simulation flow, which is the backbone of all projects. It defines
the sequence of tools and parameters involved in the simulations. Each parameter belongs to a
tool instance, and experiments are arranged vertically. The table cells are either real or virtual
nodes associated with individual simulations.

To show or hide the Family Tree:

■ Choose View > Tree Options > Show Tree, or press the F1 key.
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Figure 15 Family Tree with horizontal orientation

Figure 15 shows different parts of the Family Tree including: 

Information title row Shows the titles of the main parts of project view such as Family
Tree and Variable Values.

Tool row Shows the icons of all tools of the project.

Tool label row 
(hidden in Figure 15)

Shows all tool labels directly below the tool row. In the SWB
Preferences dialog box, expand Default View Options and set
Display Tool Labels to true, and reload the project.

Tool comment row Shows comments about tools in the project.

Process name row Shows the process names for the parameters.

Parameter row Shows all parameters of the project.

Experiments column Shows all numbered experiments.

Tool Row

Tool Flow with Parameter Splits

Parameter
Row

Process
Name Row

Tool Comment
Row
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Title Row
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When the project view is oriented vertically, rows become columns and vice versa, so the
project view looks like Figure 16. 

Figure 16 Family Tree with vertical orientation

You can change the Family Tree view to display information about a node or from the node
status files. Use the commands available from View > Tree Options and View > Table
Options (see Table 30 on page 271).

NOTE To change views sequentially, click the  button.

Specifying a Tool Comment

You can specify comments for any tool in the project flow. The comments are displayed in the
tool comment row. Sentaurus Workbench displays this row when at least one tool contains a
comment. A comment is arbitrary multiline text.

To specify a tool comment:

1. Choose View > Table Options > Show Comments.

A text box appears below each tool icon in the tool flow.

2. Type the comment.

Sentaurus Workbench saves tool comments in the project directory in the gcomments.dat file
and displays the comments the next time you load the project.
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Specifying a Parameter Process Name

You can specify a process name for each parameter of all process tools in the tool flow. This
allows process engineers who often involve many process variations and splits in process
simulations to conveniently group process parameters. A process name is an arbitrary identifier
that can reflect certain process steps, splits, and so on.

When you create a Sentaurus Workbench parameter for any process tool, you can also specify
the process name to which this parameter belongs. The process name as well as the parameter
name can be changed later in the Parameter Properties dialog box.

Process names are displayed in a separate row immediately above the parameter row.

To specify a parameter process name:

■ Choose View > Table Options > Show Parameter Process Names.

Sentaurus Workbench saves the specified process names in the core project files and displays
them the next time you load the project.

NOTE Process names are supported for process simulators and process-aware
tools such as Sentaurus Process, Sentaurus Structure Editor, Sentaurus
Topography, Sentaurus Topography 3D, and Taurus™ TSUPREM-4™.

Showing the Tool Labels

In addition to tool icons, you can also display the tool label as rollover text. This feature is
switched off by default.

To switch on the feature:

■ Choose View > Tree Options > Hinting Tool Labels.

In addition, you can show the tool labels permanently in the tool label row.

To show the tool label row permanently:

■ Choose View > Table Options > Show Tool Labels.

Experimental Plan

The Experimental Plan view provides a way to view parametric combinations. It is used for
viewing purposes only. The header rows show all parameters and their values.
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For each experiment, all its parameter values are also shown in the Experimental Plan columns
in blue, under their corresponding values. This feature can be useful to observe certain patterns
in the variation of parameters.

To switch on or off the Experimental Plan view:

■ Choose View > Tree Options > Show Experimental Plan, or press the F2 key.

Parameter Values

The Parameter Values view contains the tools and their parameters on separate header rows. It
is used for viewing purposes only. The parameter value is shown for each experiment and for
each parameter.

To switch on or off the Parameter Values view:

■ Choose View > Tree Options > Show Parameters, or press the F3 key.

Variable Values

The Variable Values view is used for viewing, editing, deleting, and adding variables. By
default, it shows all variable types (see Variables on page 79).

To switch on or off the Variable Values view:

■ Choose View > Tree Options > Show Variables, or press the F4 key.

You can hide certain variable types using the Customize Current View dialog box (see
Customizing the View of the Current Project on page 28).

Nodes

Nodes are colored according to their status and are labeled with unique numbers called node
keys. All nodes in the Family Tree can be one of the following:

■ Real nodes correspond to real simulation phases. For example, if a tool has no parameters,
all nodes of this tool are real nodes.

Real nodes are colored according to the execution status of the corresponding simulation
job.

■ If a tool has parameters, the parameters introduce intermediate nodes, which do not usually
correspond to real simulation phases and, therefore, do not hold any results. These
intermediate nodes are virtual nodes.
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Virtual nodes are either light blue or white depending on whether you have chosen the
option View > Tree Options > Check Virtual Nodes.

NOTE Tools with split capabilities such as Sentaurus Process, Sentaurus
Structure Editor, and Taurus TSUPREM-4 can create real intermediate
nodes (see Split Points on page 131).

If the View > Tree Options > Check Virtual Nodes option is switched on, Sentaurus
Workbench shows the status of intermediate nodes as follows:

■ Real intermediate nodes are colored according to their status.

■ Virtual intermediate nodes are light blue.

The definitions of the different node colors are shown in the status bar of the main window (see
Configuring Node Colors).

For more information about a simulation, choose Nodes > Edit Properties.

Configuring Node Colors

Nodes are colored according to their status. The default color scheme for nodes is displayed in
the status bar (see Figure 17). 

Figure 17 Default node colors as shown in the status bar

Sentaurus Workbench recognizes Tk symbolic color names or hexadecimal 8-bit RGB values.
For details, go to http://www.tcl.tk/man/tcl8.6/TkCmd/colors.htm. 

Table 2 RGB values for the default colors of nodes

Node status Hexadecimal 8-bit RGB value

none #FFFFFF

queued #ACFF75

ready #7CFF75

pending #75FFA0

running #ADD8E6

done #FFD700

failed #FF0000

aborted #FF00FF
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To change the standard color scheme for better differentiation of colors on-screen:

1. Choose Edit > Preferences.

2. In the SWB Preferences dialog box, expand Table > Node Status Color.

3. Change the colors in one of the following ways:

• Specify the hexadecimal RGB value manually.

• Select the color from the Choose Color for Status dialog box, and click OK (see
Figure 18).

4. Click Apply.

New colors are applied immediately after reloading a project, and they apply to all Sentaurus
Workbench projects. 

Figure 18 Choose Color for Status dialog box for changing the color of a node status

Selecting Nodes With Mouse and Keyboard Operations

You can select nodes as for any spreadsheet application. You can make a typical rectangular
node selection using mouse operations.

virtual #E0FFFF

pruned #B3B3B3

folded #8465A5

Table 2 RGB values for the default colors of nodes

Node status Hexadecimal 8-bit RGB value
40 Sentaurus™ Workbench User Guide
N-2017.09



3: View Settings
Nodes
Alternatively, to select a large rectangular region where scrolling the Family Tree is needed:

1. Click the upper-left node of the required rectangular region.

2. Scroll the Family Tree until the lower-right node of the rectangular selection appears.

3. Click this node while holding the Shift key.

Clicking cells with experiment numbers results in selecting all the nodes belonging to these
experiments. Clicking tool or parameter cells while holding the Shift key allows you to select
all nodes belonging to the given tools or parameters.

When combining different selection techniques with the Ctrl key, you can make complex
selections containing multiple regions.

Viewing the Output Files of Nodes

Each real node can have several output files. You can view the contents of these files using
Sentaurus Visual (the default visualization tool in Sentaurus Workbench), Inspect, or the text
editor.

To view all output files of one or more nodes:

1. Select the nodes on the Project tab.

2. Choose Nodes > Quick Visualize, or click the Quick Visualize toolbar button.

All of the available output files for the selected nodes open in the default visualizer, Sentaurus
Visual. If no output files correspond to the selected nodes, Sentaurus Workbench launches the
default visualizer without any files.

To view all output files of one or more nodes with a specific visualization tool:

1. Select the nodes on the Project tab.

2. Click the Visualize toolbar button, and select the required visualizer.

All visualization tools available for the selected nodes are listed.

Alternatively, to make all visualization tools available, choose Nodes > Visualize.

If no output files correspond to a particular node, the visualizer will be launched empty.

To view the output files of nodes belonging to different projects:

1. Select multiple projects in the projects browser.

2. Select the required nodes of the currently open project on the Project tab.
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Viewing the output files of nodes displays those files belonging to the current project as well
as the output files belonging to nodes with the same node numbers in other selected projects (if
they exist).

NOTE The currently open project must be one of the selected projects in the
projects browser.

The visualization tools, the file patterns to visualize, and the maximum number of files are
configured in the tool database. By default, Sentaurus Workbench configures several viewers
as shown in Figure 19. 

Figure 19 Output files visualization menu

The visualization tools appear more than once in the following modes:

■ Select File: Sentaurus Workbench prompts you to select files for visualization.

■ Select by Type: Sentaurus Workbench allows you to visualize files according to type. This
mode is available for Sentaurus Visual only. If the number of such files exceeds the
maximum number specified in the tool database for this viewer, Sentaurus Workbench
prompts you to select files as in the Select File mode.

■ All Files: All files of the selected nodes are visualized without prompting. If the number of
such files exceeds the maximum number specified in the tool database for this viewer,
Sentaurus Workbench prompts you to select files as in the Select File mode. You will be
also prompted to select the target Sentaurus Visual instance if you have one or more
running Sentaurus Visual instances launched from the current Sentaurus Workbench
session (see Viewing the Output Files of Nodes in Sentaurus Visual on page 43).
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Sentaurus Workbench offers the following predefined file filters for the Select by Type mode:

■ All XY-Plot Files (*.plt, *.plx)

■ All Boundary Files (*bnd.tdr)

■ All Mesh Files (*msh.tdr)

■ All TDR Files (*.tdr)

Each file filter defines a list of file patterns separated by space. Additional file filters can be
created in the Sentaurus Visual Visualization dialog box (see Figure 20 on page 44). You also
can change the patterns of the existing file filters in the preferences (expand Visualization >
File Filters).

Any viewer can be defined as the default visualization tool in the tool database using the
variable WB_tool(default,visualizer). In Sentaurus Workbench, the default viewer is
Sentaurus Visual.

Viewing the Output Files of Nodes in Sentaurus Visual

Sentaurus Visual is the default visualization tool in Sentaurus Workbench. The comprehensive
integration of Sentaurus Workbench and Sentaurus Visual provides special capabilities that are
not available in Inspect.

You can view the output files in a new instance of Sentaurus Visual or in an already running
instance of Sentaurus Visual.

Sentaurus Workbench detects the Sentaurus Visual instances that you launched from the
current instance of Sentaurus Workbench, and it displays the Sentaurus Visual Visualization
dialog box (see Figure 20 on page 44).

To visualize the output files of nodes in Sentaurus Visual:

1. In the Sentaurus Visual Visualization dialog box, select files in the left pane.

See Selecting Files Using Filters on page 44.

2. Choose the instance of Sentaurus Visual to use in the right pane.

Already running Sentaurus Visual instances are noted as SWB_1, SWB_2, and so on. To
identify the corresponding instance of Sentaurus Visual, check the title of the main window
of Sentaurus Visual, which displays the same identification.

NOTE Sentaurus Workbench recognizes only those instances of Sentaurus
Visual that were launched from itself.
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3. Depending on the number of already running Sentaurus Visual instances launched from the
current Sentaurus Workbench session, you can choose to visualize selected files in either
the last-used Sentaurus Visual instance (the one you used last time to visualize files), or the
last-launched Sentaurus Visual instance, or a new Sentaurus Visual instance.

Sentaurus Workbench selects the correct Sentaurus Visual instance according to the
preferences (expand Visualization > Default S-Visual Instance, whose value can be Last
Used, Last Created, or New Instance).

The default behavior is to visualize the selected files in the last-used Sentaurus Visual
instance.

Click OK. 

Figure 20 Sentaurus Visual Visualization dialog box

Selecting Files Using Filters

The number of files that can be visualized can be very large. If you apply file filters using the
text box below the left pane, this will reduce the list, displaying only the files you want.

Each file filter specifies one or more file patterns, and only files matching at least one pattern
of the selected file filter is displayed. The following predefined file filters are available from
the list of the text box:

■ All XY-Plot Files (*.plt, *.plx)

■ All Boundary Files (*bnd.tdr)
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■ All Mesh Files (*msh.tdr)

■ All TDR Files (*.tdr)

■ S-Process Command File (*.cmd)

Alternatively, you can enter your own space-separated file patterns in the text box, and
Sentaurus Workbench automatically updates the list of matching files.

If you want to reuse a file filter, click the + button next to the text box and, in the dialog box
that is displayed, enter the name of the file filter. Next time, your file filter will appear in the
list of the text box and in the Select by Type menu (see Viewing the Output Files of Nodes on
page 41). Similarly, you can remove any of the file filters by clicking the - button. You also can
change the patterns of the existing file filters in the preferences (expand Visualization > File
Filters).

NOTE The initial list of files in the left pane of the Sentaurus Visual
Visualization dialog box is based on the file patterns defined for the
"svisual" viewer in the tool database. By default, this list contains the
output files of the selected nodes. File filters apply to the initial list of
files of the selected nodes.

Viewing Visualizer Nodes Simultaneously

You can view one or more visualizer nodes simultaneously. Visualizer nodes are those
belonging to either Sentaurus Visual or Inspect tool instances.

NOTE You cannot mix Sentaurus Visual and Inspect nodes in a selection.

To view visualizer nodes simultaneously:

1. Select one or more Sentaurus Visual or Inspect nodes on the Project tab.

2. Choose Nodes > Visualize > Run Selected Visualizer Nodes Together, or click the Run
Selected Visualizer Nodes Together toolbar button.

Sentaurus Workbench preprocesses the selected nodes, merges their input command files into
one command file, and runs the merged command file in the corresponding visualization tool
(Sentaurus Visual or Inspect).

The visualization tool always launches in interactive mode on the local host. You can view
selected visualizer nodes simultaneously at any time regardless of the project status and the
node dependencies. Sentaurus Workbench splits the visualization output into node-specific
parts, extracts the corresponding simulation results, and updates the extracted results in the
Family Tree.
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You can use this capability to extract and visualize the intermediate results of long-running
simulations. You can analyze the extracted data before a simulation is fully completed. For
example, you can see the intermediate results of a running 3D device simulation by visualizing
the next extraction Sentaurus Visual node. Doing this for multiple extraction nodes allows you
to compare the intermediate results.

A complex evaluation on half-finished data can fail, for example, to determine the maximum
of a curve, if the curve does not contain a maximum yet. It can be complicated to determine
whether a simulation has finished based only on the data. Therefore, in critical parts of the
Sentaurus Visual and Inspect input command files, you can specify a node-readiness check to
prevent this issue, for example:

set status @[gproject::GetNodeStatus @node|sdevice@]@
if { $status == "done" } {

# Sentaurus Device node is completed, so proceed with data evaluation
}

Comparing Command Files of Nodes

You can compare the content of command files of selected nodes using a comparison
application.

The default comparison application is tkdiff. You can change this in the preferences (choose
Edit > Preferences and, in the SWB Preferences dialog box, expand Utilities > Diff Tool).

To compare command files:

1. Select one or two nodes on the Project tab.

2. Choose Nodes > Visualize > Compare Command Files of Selected Nodes.

If one node is selected, Sentaurus Workbench compares its command file to the master
command file of the corresponding tool. If two nodes are selected, their command files are
compared.

Running Sentaurus Process Nodes Interactively

From Sentaurus Workbench, you can open the interface between Sentaurus Visual and
Sentaurus Process to interactively run the process flow of a selected Sentaurus Process node.
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To open the interface:

1. Select the required Sentaurus Process node.

2. Choose Nodes > Visualize > Sentaurus Visual - Sentaurus Process Link.

Sentaurus Workbench launches Sentaurus Visual with the already loaded Sentaurus Process
flow as shown in Figure 21.

Alternatively, choose Extensions > Run Sentaurus Visual - Sentaurus Process Link to open
the interface directly with an empty process flow. You must load the Sentaurus Process flow
manually. 

Figure 21 Interface to Sentaurus Visual showing loaded Sentaurus Process flow in right 
pane

See Sentaurus™ Process User Guide, Interface to Sentaurus Visual on page 6, for more
information about the interface.

Node Explorer

The Node Explorer assembles all node-related data and files in one place, which simplifies
navigating through node files, analyzing simulation results, and tracking simulation problems.

The Node Explorer is divided into two parts:

■ The upper part displays node properties, together with the defined parameters and extracted
data. 

■ The lower part allows you to navigate through node files.
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The features of the Node Explorer include:

■ Viewing the properties of the node.

■ Viewing the values of Sentaurus Workbench parameters defined on the node.

■ Viewing the data extracted from the node.

■ Navigating through node input and output files using buttons and file patterns.

■ Previewing text files in the text pane.

■ Visualizing node files with the viewer or editors defined in the tool database. 

Figure 22 Node Explorer
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To open the Node Explorer:

1. Select a node.

2. Choose Nodes > Node Explorer, or press the F7 key.

When the Node Explorer is displayed, it shows the end of the simulator standard output file.
The content of this file is updated dynamically when the node is running. 

Table 3 Buttons in Node Explorer

Button Description

All Node Files Displays all files that are associated with the current node. To determine these files, tool 
database file patterns are used.

Node Input Files Displays the input files of the current mode, which are registered in the tool database.

Node Output Files Displays the output files of the current node, which are registered in the tool database.

Standard Output Displays the standard output of the node simulation task.

Standard Error Displays the standard error of the node simulation task.

Job Log File Displays the job log file (output of node gjob process).

Prologue Displays the prologue section of the job log file.

Simulation Displays the simulation section of the job log file.

Epilogue Displays the epilogue section of the job log file.

Specifies the path to which a file pattern search is applied. By default, this is the project 
directory.

Apply Applies the file search based on the specified file pattern.

Launch Every file that is displayed in the upper list box has one or more associated viewers. This 
button opens the currently selected viewer together with the currently selected file.

Track the Problem Assists you to find the reason for a node failure. Sentaurus Workbench analyzes the 
prologue, simulation, and epilogue sections of the job log file for error messages. In 
addition, it checks the standard error and standard output files of the simulation for 
additional error information.

Search The Node Explorer looks for the specified pattern in the currently previewed file.

Refresh Updates the node information.
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Exporting Spreadsheets

This section describes how to export spreadsheets for viewing in spreadsheet applications or
Inspect.

Exporting a Spreadsheet to a Text File

A spreadsheet can be exported as a character-separated value file, which can be loaded into
different spreadsheet applications.

To export a spreadsheet to a text file:

1. Choose Experiments > Export > Text File.

2. Select the separation character (comma, tab, space, semicolon, user-defined).

3. Select additional options to include the header and column names if required.

4. Click OK.

5. Select the file name in the File dialog box.

6. Click Save.

To open spreadsheet software with the current view:

■ Choose Experiments > Export > Run Spreadsheet Application, or click the  button.

This saves the current view to a temporary text file and loads it with a spreadsheet application
that is configured in the preferences (expand Utilities > Spreadsheet Application).

Exporting a Spreadsheet to a Plot File

A spreadsheet can be exported for viewing in Inspect.

To export a spreadsheet to a plot file:

1. Choose Experiments > Export > Plot File.

2. Select the file name in the File dialog box.

3. Click Save.

To save the current view to a temporary plot file and load it into Inspect:

■ Choose Experiments > Export > Run Inspect.
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Viewing Log Files

To view the preprocessor and project log files for projects of Sentaurus Workbench:

■ Choose Project > Logs > Preprocessor or Project > Logs > Project.

To view Optimizer log files:

■ Choose Optimization > View Log.

Visualizing Response Surfaces

See Visualizing Response Surface Models on page 206.

View Settings for Scheduler

The Scheduler tab lists all the running nodes that belong to the selected running projects in the
projects browser. The status of nodes is updated based on the refresh frequency setting.

Modifying User-Level Tool Queues

To modify user-level tool queues (see Tool Associations on page 235):

1. Choose Scheduler > Configure Queues > User Queues.

The Configure User Queues dialog box is displayed (see Figure 23 on page 52).

2. Modify the tool queue assignments, and enter specific options associated with the
Scheduler.

3. Click OK.
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Figure 23 Configure User Queues dialog box

Modifying Project-Level Tool Queues

To modify project-level tool queues (see Tool Associations on page 235):

1. Choose Scheduler > Configure Queues > Project Queues.

The Configure Project Queues dialog box is displayed (see Figure 24 on page 53).

2. Modify the tool queue assignments.

These assignments apply only to a particular project.

3. Click OK.
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Figure 24 Configure Project Queues dialog box

Editing Queue Files

The Scheduler does not have an interface to add node constraints for user-level or project-level
queues. You can only do so by editing the user queue or project queue files manually.

To edit user queue files:

■ Choose Scheduler > Configure Queues > Edit User Queues.

To edit project queue files:

■ Choose Scheduler > Configure Queues > Edit Project Queues.
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CHAPTER 4 Editing Projects

This chapter describes how to edit projects in Sentaurus Workbench.

Read-Only and Writable Projects

Sentaurus Workbench projects must be placed in a disk-writable location to edit, preprocess,
and execute those projects. Sentaurus Workbench recognizes a disk-writable location by
analyzing user permissions of a project directory and project files.

A writable Sentaurus Workbench project must match the following criteria:

■ A project directory contains the file .project (it is a Sentaurus Workbench project).

■ A project directory is writable; users can create and delete files in the directory.

■ Files in the project directory are writable. Sentaurus Workbench checks user permissions
for several key project files.

A writable project in the Locked runtime editing mode can be cleaned, edited, preprocessed,
and executed only if the project is not running.

A writable project in the Editable runtime editing mode can be cleaned, edited, preprocessed,
and executed at any time.

NOTE Sentaurus Workbench does not require writable projects to be placed
under the STDB file hierarchy. Attached roots can contain writable
projects. Only user permissions and the runtime editing mode define the
writability of a project.

Undoing Changes

To undo a change:

■ Choose Edit > Undo or press Ctrl+Z.

NOTE Only tree modifications can be undone. Modified or deleted input or
output files cannot be restored.

The undo data is not released after saving a project.
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To release undo data, you can either:

■ Choose Project > Operations > Clean Up, or press Ctrl+L (see Chapter 8 on page 171).

■ Restart Sentaurus Workbench.

Limiting the Number of Changes

If you work with the same instance of Sentaurus Workbench for long periods, you can observe
that the Sentaurus Workbench process consumes considerable memory on the host where it
runs. The reason for such an increase in memory consumption is that Sentaurus Workbench
retains all the changes made to the Family Tree of a project to enable Sentaurus Workbench to
undo them if needed. By default, the number of changes kept in memory is unlimited.

You can reduce memory consumption by limiting the number of recent changes Sentaurus
Workbench stores. To do this, set the SWB_UNDO_STACK_SIZE environment variable to the
maximum number of changes you want Sentaurus Workbench to be able to undo. For example,
the following setting restricts Sentaurus Workbench to the latest 10 changes in the Family Tree:

setenv SWB_UNDO_STACK_SIZE 10

Tools

Tools are, in general, TCAD simulation tools. Other tools can be available depending on the
configuration of the tool databases of Sentaurus Workbench (see Tool Databases on page 193).

NOTE There can be multiple instances of the same tool in simulation flows.

Adding Tools to the Flow

In a new project, to add the first tool to the flow:

1. Choose Tool > Add or press the Insert key.

The Add Tool dialog box is displayed (see Figure 25 on page 57).

2. On the Tool Properties tab, select the tool from the Name list or click the Tools button to
select the tool from the Select DB Tool dialog box (see Figure 28 on page 59).

3. Type a unique tool label if you want to change the default label.

4. Type any command-line options if required.
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5. If applicable, select a run mode from either batch or interactive.

Sentaurus Visual has the additional batchX option, which allows you to export plots in the
batch run.

6. Type a comment associated with the tool if required.

7. Click the Input Files tab (see Figure 26 on page 58).

The table on this tab specifies all the default tool input files registered in the tool database.
Each tool input file is either a user-specified file (master file) or the output file generated
from the previous simulation step. Master files are usually involved in preprocessing.

8. If applicable, select whether grid and boundary files are provided as master files or
produced by previous tools.

9. If applicable, select whether the tool should use common or individual parameter files.

Each input master file has the default Sentaurus Workbench name specified in the tool
database. This name cannot be changed.

10. To import the content of an existing file into the master file:

a) Select the master file.

b) Click the Import button, and select the file in the Open File dialog box.

NOTE The content of the imported file replaces the content of the master file.
For convenience, Sentaurus Workbench creates a backup copy of the
existing master file with the extension .backup.

11. Click OK or Apply. 

Figure 25 Add Tool dialog box showing Tool Properties tab
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Figure 26 Add Tool dialog box showing Input Files tab

Figure 27 Add Tool dialog box showing Output Files tab
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Figure 28 Select DB Tool dialog box showing supported tools
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To add subsequent tools to the flow:

1. Select a tool icon in the tool row.

2. Choose Tool > Add or press the Insert key.

The Add Tool dialog box is displayed (see Figure 29).

3. Follow Steps 2–10 for adding the first tool in the flow (see Adding Tools to the Flow on
page 56).

4. On the Tool Properties tab, specify either the After Selected Tool or Before Selected Tool
option.

5. Click OK or Apply. 

Figure 29 Add Tool dialog box for adding next tool in the flow

Deleting Tools From the Flow

To delete a tool instance from the flow:

1. Select the required tool icon in the tool row.

Hold the Ctrl key during selection to select multiple tools.

2. Choose Tool > Delete or press the Delete key.
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3. If the tool has parameters, specify in the dialog box whether to assign the parameters to the
previous tool or the next tool, or to delete the parameters. 

4. Click OK.

Copying Tools

You can copy tools in a project as well as between projects.

To copy a tool:

1. Select one tool or multiple tools in the flow.

2. Choose Edit > Copy, or press Ctrl+C, or right-click the tool and select Copy.

3. Go to the target project (the same project or another project) and select a tool in the flow.

New tools are inserted immediately after the selected tool.

4. Choose Edit > Paste, or press Ctrl+V, or right-click the tool and select Paste or Paste
Special.

New tools are inserted with their input command files and properties. Tool input files are
copied from the source project to the target project.

Controlling the Copying of Tools

By default, Sentaurus Workbench copies tools with their parameterization, including variables
specified on the nodes of the parameterization. You can control exactly what you want to insert.
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To control the copying of a tool:

1. Choose Edit > Paste Special or press Ctrl+M.

The Paste dialog box is displayed. 

2. Select one of the following options: 

3. Click OK.

Changing Tool Properties

To change tool properties:

1. Select a tool in the tool row.

2. Choose Tool > Properties or double-click the tool icon.

The Tool Properties dialog box for that tool is displayed (see Figure 30 on page 63).

Option What is inserted into project…

Tools •  Tool with its configuration and input files.

Tools, Parameters • Tool with its configuration and input files.
• Tool parameters with default values.

Tools, Parameters with Values • Tool with its configuration and input files.
• Tool parameters with default values.
• Value variation for each parameter.

Tools, Parameters with Values, 
Variables

• Tool with its configuration and input files.
• Tool parameters with default values.
• Value variation for each parameter.
• User-defined variables specified on the nodes of the parameterization.
This is the default.
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3. Make changes as required (see Adding Tools to the Flow on page 56).

4. Click OK or Apply. 

Figure 30 Tool Properties dialog box for Sentaurus Device

NOTE If the project is in edit mode, you can commit changes on the Tool
Properties tab and Input Files tab of the Add Tool dialog box. If the
project is in running mode, all your modifications will not be supported.

Editing Tool Input Files

To edit tool input files:

1. Select a tool in the tool row.

2. Choose Tool > Edit Input and select the required input file. Alternatively, right-click the
tool icon and select Edit Input and then the required input file (see Figure 31 on page 64).

3. Edit the file and save the changes.
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Figure 31 Selecting a tool input file to edit

Alternatively, you can use the Tool Properties dialog box to edit tool input files.

NOTE You must have write permissions for the file or project to edit files.
Otherwise, the files are read only.

To edit tool input files using the Tool Properties dialog box:

1. Select the required tool in the tool row.

2. Choose Tool > Properties or double-click the tool icon.

The Tool Properties dialog box for that tool is displayed (see Figure 30 on page 63).

3. Click the Input Files tab.

4. Select the master file in the table to edit.

5. Click the Edit button.

6. Edit the file.

7. Click OK or Apply.
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Editing the Parameter File for Sentaurus Device

Sentaurus Workbench allows you to edit an optional parameter file for Sentaurus Device.

To edit a Sentaurus Device parameter file:

1. Select the required Sentaurus Device tool in the tool row.

2. Choose Tool > Edit Input > Parameter, or right-click the tool icon and select Edit Input
> Parameter.

3. Create or edit the parameter file.

4. Click OK.

If the Sentaurus Device parameter file does not exist, Sentaurus Workbench displays the Create
Parameter File dialog box (see Figure 32 on page 66) where you have the options to:

■ Create a parameter file with the included model parameters for silicon.

■ Create a parameter file with the model parameters for the selected materials.

■ Create an empty parameter file and manually write it.

NOTE Selecting the Silicon option of the Create Parameter File dialog box is
equivalent to selecting the only silicon material with the Choose
Materials option.

The dialog box provides all the materials with their aliases specified in the Synopsys
configuration database for materials (datexcodes.txt file). The materials are highlighted
with different colors:

■ Green indicates the material exists in the Sentaurus Device material database
(MaterialDB).

■ Black indicates the material does not exist in the Sentaurus Device material database.

For each selected material highlighted in green, Sentaurus Workbench creates a copy of the
corresponding Sentaurus Device MaterialDB file in the project directory and includes this file
in the generated Sentaurus Device parameter file.

For each selected material highlighted in black, Sentaurus Workbench includes a warning
string in the generated Sentaurus Device parameter file. In this case, you must specify the
model parameters for these materials.

Finally, Sentaurus Workbench opens a text editor with the content of the Sentaurus Device
parameter file.
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Figure 32 Create Parameter File dialog box: (left) Silicon option selected and (right) Choose 
Materials option selected

For example, assume that you choose the materials GatePolySilicon, PolySi, and Silicon. The
file will look like the following:

#define ParFileDir .
Material="GatePolySilicon" {

# WARNING: no parameter file found for material GatePolySilicon in the
material database

}
Material="PolySi" {

#includeext "ParFileDir/PolySi.par"
}
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Material="Silicon" {
#includeext "ParFileDir/Silicon.par"

}

Including Additional Materials to a Parameter File

To include more materials to a Sentaurus Device parameter file:

1. Select the required Sentaurus Device tool in the tool row.

2. Choose Tool > Edit Input > Include Materials, or right-click the tool icon and select Edit
Input > Include Materials.

The Include Materials in Parameter File dialog box is displayed (see Figure 33).

3. Select the required materials.

4. Click OK. 

Figure 33 Include Materials in Parameter File dialog box
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To remove materials from a Sentaurus Device parameter file:

1. Select the required Sentaurus Device tool in the tool row.

2. Choose Tool > Edit Input > Parameter, or right-click the tool icon and select Edit Input
> Parameter.

3. Manually remove blocks of the corresponding materials.

You can configure each Sentaurus Device tool instance in the tool row to work with either
common or individual parameter files, in the Tool Properties dialog box (see Figure 34):

■ Sentaurus Device tool instances with the Common File option share the same Sentaurus
Device parameter file sdevice.par.

■ Sentaurus Device tool instances with the Individual File option use their own parameter
files. 

Figure 34 Tool Properties dialog box for Sentaurus Device: (left) Common File option 
selected and (right) Individual File option selected

Included material parameter files are named differently depending on the selected option (see
Table 4). 

Table 4 Names of parameter file and material file

File Name of common file Name of individual file

Parameter file sdevice.par <tool_label>_des.par

Material file <material>.par <tool_label>_<material>.par
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Locking and Unlocking Tools

You can lock tool instances temporarily to prevent executing them. This means that nodes
belonging to a locked tool are not involved in the next simulation run of the corresponding
project. After unlocking the tool, it is a part again of the simulation project.

To lock a tool and its nodes:

1. Select the tool icon.

2. Choose Tool > Lock, or right-click the tool icon and select Lock.

All nodes, real and virtual, belonging to the selected tool are locked. The icon of the locked
tool changes to show a lock symbol to distinguish locked and unlocked tools (see Figure 35).

To unlock a tool and its nodes:

1. Select the tool icon.

2. Choose Tool > Unlock, or right-click the tool icon and select Unlock.

All nodes, virtual and real, belonging to the selected tool are unlocked. The lock symbol in the
tool icon disappears.

NOTE After unlocking a tool, the project should be preprocessed to guarantee
that the correct node dependencies are taken into account in the next
simulation run. 

Figure 35 Locked and unlocked tools in the Family Tree
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Configuring Double-Click Operations on Tools

You can configure the behavior of double-clicking a tool and link it to the required action.

NOTE If the double-click operation does not work on a VNC client, see
Appendix D on page 289.

To configure double-click operations on tools:

1. Choose Edit > Preferences or press the F12 key.

The SWB Preferences dialog box is displayed.

2. Expand Table > Double Click Action > On Tools.

3. Select one of the following options: 

4. Click Apply.

Parameters

A parameter is part of a tool and splits the flow at the insertion point to derive variations of that
tool. Each parameter is characterized by a unique name and an arbitrary number of values.

Parameters create a family of similar simulations represented as a tree structure – the
simulation tree – where levels from root to leaves (left to right) match the steps in the
simulation flow.

Option Double-clicking a tool launches

Show Properties Tool Properties dialog box (see Changing Tool Properties on page 62)

Edit Input File Corresponding editor for tool input command file (see Editing Tool Input Files on 
page 63)
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Adding Parameters to a Tool

NOTE Parameters can be added only to existing tools in a flow.

Adding the First Parameter to a Tool

To add the first parameter to a flow with only one tool:

1. Choose Parameter > Add Parameter/Values or press the Insert key.

The Add Parameter/Values dialog box is displayed (see Figure 36 on page 72).

2. In the Parameter field, type the name of the parameter.

3. (Optional) In the Process Name field, type the name of the process.

This field is available only for process tools.

4. Select the option for specifying values for the parameter:

a) List allows you to type values in the List of Values field.

Values can be any alphanumeric character and can include + (plus), - (dash), * (start),
_ (underscore), . (dot), and : (colon). Space is prohibited.

NOTE Do not use a double dash (--) as a parameter value. It is reserved for
internal Sentaurus Workbench use.

b) Lin uses linear scale to generate values. Specify the values for the various fields.

c) Log uses logarithmic scale to generate values. Specify the values for the various fields.

d) Gaussian uses a Gaussian function to generate values. Specify the values for the
various fields.

NOTE The first defined value becomes the default value of the parameter. You
can change it later in the Parameter Properties dialog box.

5. Select the sorting order for the values from Ascending, Descending, or Do Not Sort
(keeps the original order).

6. From the Format list, select how values will be formatted: none (retains the original
values), scientific, float, or integer.

7. Check the correctness of the values in the preview pane on the right of the dialog box.

Values are displayed as they will appear in the project flow.
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8. Click OK to add a new parameter and to close the dialog box.

To continue working with the Add Parameter/Values dialog box to create multiple new
parameters, click Apply. 

Figure 36 Add Parameter/Values dialog box

Adding Subsequent Parameters to a Tool

To add another parameter to a tool or to add a parameter to a tool with more than one split:

1. Select the position where the new parameter should be inserted in the parameter row.

1. Choose Parameter > Add Parameter/Values or press the Insert key.

The Add Parameter/Values dialog box is displayed (see Figure 36).

2. Repeat the procedure in Adding the First Parameter to a Tool on page 71.

3. Select where to place the new parameter as follows:

a) From the Insert list, select before or after the parameter chosen next.

a) From the Parameter list, select the name of the parameter.

By default, the Insert list shows the after option, that is, the default behavior is to insert a
new parameter after the one you chose before displaying the Add Parameter/Values dialog
box.
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4. Click OK to add a new parameter and to close the dialog box.

To continue working with the Add Parameter/Values dialog box to create multiple new
parameters, click Apply.

Adding Values to Parameters

To add new values to an existing parameter in the flow:

1. Select the parameter in the parameter row.

2. Choose Parameter > Add Parameter/Values or press the Insert key.

The Add Parameter Values dialog box is displayed.

3. Depending on the option selected, type new values as follows:

a) For List, type the new values in the List of Values field.

Values can be any alphanumeric character and can include + (plus), - (dash), * (start),
_ (underscore), . (dot), and : (colon). Space is prohibited.

NOTE Do not use a double dash (--) as a parameter value. It is reserved for
internal Sentaurus Workbench use.

b) For Lin, type the new values in the specified fields.

c) For Log, type the new values in the specified fields.

d) For Gaussian, type the new values in the specified fields.

4. Select the sorting order for the values from Ascending, Descending, or Do Not Sort
(keeps the original order).

5. From the Format list, select how values will be formatted: none (retains the original
values), scientific, float, or integer.

6. Check the correctness of the values in the preview pane on the right of the dialog box.

Values are displayed as they will appear in the project flow.

7. Click OK to add the new values to the parameter and to close the dialog box.

To continue working with the Add Parameter/Values dialog box to create new values for
multiple parameters, click Apply.

NOTE New values are added to the existing ones for the selected parameter.
Duplicates are not added. The order and the format of the new values do
not affect existing values of the selected parameter.
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Deleting New Values

In the Add Parameter/Values dialog box, click Cancel to cancel adding of new values to a
parameter.

Choose Edit > Undo to revert already added values.

Limiting the Number of Values Specified for Parameters

You can unintentionally add too many values to parameters using the Lin, Log, or Gaussian
option. For example, a typographic error using the Lin option can lead to a large
minimum–maximum range with a small step and a huge number of values. This can take
Sentaurus Workbench substantial time to accommodate so many values in the parameterization
table.

You can prevent this situation by defining the maximum number of new values in the
preferences. The default is 100.

To limit the number of new values for a parameter:

1. Choose Edit > Preferences or press the F12 key.

The SWB Preferences dialog box.

2. Expand Table > Parameter > Add Parameter/Value Defaults > Maximum Number of
Values.

3. Specify the maximum number of new values allowed.

4. Click Save.

Deleting Parameters

To delete a parameter from a flow:

1. Select the parameter in the parameter row.

2. Choose Parameter > Delete or press the Delete key.
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3. (Optional) If the parameter has more than one value, confirm which branches of the tree to
keep in the Delete Parameter dialog box.

All other branches will be deleted. 

4. Click OK.

To delete multiple parameters from a flow:

1. Select the parameters in the parameter row.

2. Choose Parameter > Delete or press the Delete key.

3. (Optional) If the parameters have more than one value, confirm the branches to retain in
the Delete Parameters dialog box. 

4. Click OK.
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Copying Parameters

You can copy parameters in a project as well as between projects.

To copy parameters:

1. Select one or multiple parameters.

2. Choose Edit > Copy, or press Ctrl+C, or right-click the parameters and select Copy.

3. Select the location in the target project (same project or another project) where to insert the
parameters. 

When you select a tool, new parameters are added to the tool after existing ones. When you
select a parameter, the new parameter is added immediately after the selected one.

4. Choose Edit > Paste, or press Ctrl+V, or right-click the parameters and select Paste or
Paste Special.

By default, parameters are copied with their parameterization, including variables specified on
the nodes of the parameterization. When parameters are inserted into an empty project,
Sentaurus Workbench also creates tool instances to which parameters belong.

Controlling the Copying of Parameters

You can control exactly what you want to insert into a project.

To control the copying of a parameter:

1. Choose Edit > Paste Special or press Ctrl+M.

The Paste dialog box is displayed. 
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2. Select one of the following options: 

3. Click OK.

Changing Parameter Properties

NOTE You can change the properties of parameters only if the project is in edit
mode.

To change the properties of a parameter:

1. Select a parameter in the parameter row.

2. Choose Parameter > Properties or double-click the parameter.

The Parameter Properties dialog box for that parameter is displayed. 

3. Rename the parameter as required.

NOTE If you change the parameter name, it changes only in the Family Tree.
All references to that parameter in input files and variables are not
changed.

4. Type a new default value as required.

Option What is inserted into project...

Parameters • Parameters with default values.

Parameters, Values • Parameters with default values.
• Value variation for each parameter.

Parameters with 
Values, Variables

• Parameters with default values.
• Value variation for each parameter.
• User-defined variables specified on the nodes of the parameterization.
This is the default.
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5. (Optional) For the parameters of process tools, change the process name as required.

6. Click OK.

Removing Parameter Values

NOTE You can remove parameter values only if the project is in edit mode.

To remove a parameter value:

1. Select the parameter in the parameter row.

2. Choose Parameter > Remove Value.

The Remove parameter Value dialog box is displayed. 

3. Select the value to be removed.

4. Click OK to remove the value and close the dialog box, or click Apply to continue
removing additional values.

Configuring Double-Click Operations on Parameters

You can configure the behavior of double-clicking a parameter and link it to the required
action.

NOTE If the double-click operation does not work on a VNC client, see
Appendix D on page 289.

To configure double-click operations on parameters:

1. Choose Edit > Preferences or press the F12 key.

The SWB Preferences dialog box is displayed.

2. Expand Table > Double Click Action > On Parameters.
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3. Select one of the following options: 

4. Click Apply.

Variables

Variables are not part of the simulation. They are intended to help you interpret the results and
for preprocessing.

You can define variables as either global or per node, where per node definitions overwrite
global definitions. Per node definitions overwrite per node definitions used earlier in the tool
flow (that is, closer to the root).

You can use the following variable types according to their priority (from highest to lowest):

■ Extracted variables result from simulation runs, and their format in output files is
DOE: <varname> <value> (see Extracted Variables on page 133).

■ Preprocessed variables are preprocessing definitions, and their format in input files is
#set <varname> <value> (see Preprocessing Variables on page 132).

■ Defined variables (or global variables) are defined globally for a node and its children. You
can add these variables using the user interface.

Option Double-clicking a parameter launches

Show Properties Parameter Properties dialog box (see Changing Parameter Properties on page 77)

Add Parameter Value Add Parameter Values dialog box (see Adding Experiments on page 90)

Remove Value Remove Parameter Value dialog box (see Removing Parameter Values on page 78)
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Adding Global Variables

To add a new global variable to a project:

1. Choose Variables > Add, or press the Insert key.

The Add Variable dialog box is displayed. 

2. In the Variable field, type the name of the variable.

3. Type the default value of the variable (the Default Value field can remain empty).

Examples of default values are:

[format %f10 @param1@]

[expr 2*@param1@ + sin(@var1@)]

[if {@param1@ > 0.5} {set var1 "passed"} else {set var1 "failed"}]

4. (Optional) If you selected another variable in the parameter row, select the option for
adding the new variable either Before Selected Variable or After Selected Variable.

5. Click OK.

The default value (or formula) of a variable can be an arbitrary string, and it is used when there
is no defined value per node. A Tcl parser preprocesses the value, and Tcl expressions in
brackets can be used as variable values. They can have references to parameters or other
variables. The references must be placed inside of a pair of @ signs.

The default value of a variable can also be used for formatting, using the Tcl format
command, which has similar arguments as the ANSI C printf command.
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Changing the Default Value of Global Variables

To change the default value of a global variable:

1. Select a variable in the parameter row of the Variables Values view.

2. Choose Variables > Properties, or right-click and select Properties.

3. In the Variable dialog box, type the new default value.

4. Click OK.

Deleting Global Variables

To delete a global variable:

1. Select a variable in the parameter row.

Hold the Ctrl key to select multiple variables.

2. Choose Variables > Delete or press the Delete key.

Copying Global Variables

You can copy global variables in a project as well as between projects.

NOTE Only global variables can be copied.

To copy global variables:

1. Select one or more variables.

2. Choose Edit > Copy, or press Ctrl+C, or right-click the variables and select Copy.

3. Select the variable in the target project (the same project or another project) where you
want to insert the variables.

New variables are added immediately after the selected one.

4. Choose Edit > Paste, or press Ctrl+V, or right-click the variables and select Paste or Paste
Special.

Inserted variables contain their values. A variable that is inserted into an empty project does
not display its value. The variable value is visible as soon as a new tool is added to the empty
project.
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Formatting Variables

To format a variable:

1. Select a variable in the parameter row.

2. Choose Variables > Format.

The Format Variable dialog box is displayed.

3. Select one of the predefined format options, or type a new format using the ANSI C
sprintf command or Tcl format command.

For examples, see the rollover text available from the text box.

4. Click OK.

Defining Variables Per Node

If you define a variable at a particular node, it will overwrite the default value of that variable
as well as any value of that variable that is defined higher in the simulation tree (that is, closer
to the root).

To define a variable per node:

1. Select a node.

2. Choose Nodes > Set Variable Value.

The Add Variable to Node dialog box is displayed.

3. In the Name field, select a variable that you want to define for this node.

4. In the Value field, type a value for the variable.

The default value of the variable is preset in the text box.

5. Click OK.

NOTE The Tcl parser does not parse the value of a variable at a node, unlike
the default value of a variable. The value of a variable is taken as a
string.
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Changing and Deleting Variable Values at a Node

NOTE Variable values at a node can be modified only for global variables. To
see which nodes have global variables, choose View > Tree Options >
Show Variables.

To change or delete a variable value at a node:

1. Select a node.

2. Choose Nodes > Edit Properties or double-click the node.

The Node Information dialog box is displayed. 

3. Under Defined Variables, select the check box next to the required variable.

Only previously defined variables are listed.
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4. Type a new value of the variable.

5. Click OK to change a value, or click Delete to delete the variable from the node.

Configuring Double-Click Operations on Variables

You can configure the behavior of double-clicking a variable and link it to the required action.

NOTE If the double-clicking operation does not work on a VNC client, see
Appendix D on page 289.

To configure double-click operations on variables:

1. Choose Edit > Preferences or press the F12 key.

The SWB Preferences dialog box is displayed.

2. Expand Table > Double Click Action > On Variables.

3. Select one of the following options: 

4. Click Apply.

Nodes

A node is a point in the Family Tree where (possibly virtual) parametric splits can occur or
where a simulation tool can be changed in the tool flow. Real nodes have simulation results. In
one sense, a node is an atom of the simulation.

Viewing and Editing Node Properties

To view and edit node properties:

1. Select a node in the flow.

2. Choose Nodes > Edit Properties.

The Node Information dialog box is displayed (see Figure 37 on page 85).

Option Double-clicking a variable launches

Show Properties Variable Properties dialog box where you can change the variable value

Specify Format Formatting Variables dialog box (see Formatting Variables on page 82)
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3. In the Value field, change the value of the node.

4. From the Status list, change the status of the node.

5. Click OK. 

Figure 37 Node information dialog box
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Changing Parameter Values Directly in Node Cells

You can change parameter values directly in node cells. By default, this feature is switched off.

To switch on this feature:

1. Choose Edit > Preferences or press the F12 key.

The SWB Preferences dialog box is displayed.

2. Expand Table and set Edit Value in a Cell to true.

3. Click Save.

To edit the parameter value in a node cell:

1. Select a node in the flow.

2. Change the value in one of the following ways:

a) Type directly in the cell.

b) Click twice with a small time interval (this is not a double-click).

c) Double-click a node.

This option is available only if the double-click operation is configured as Edit Cell (see
Configuring Double-Click Operations on Nodes on page 88).

d) Choose Nodes > Edit Value, or press the F6 key.

3. Type the necessary value.

Use the Backspace key to delete the last symbol.

4. Press the Enter key or arrow keys, or click another node, to save the change.

5. Press the Esc key to undo the change.

NOTE Even when this feature is switched off, you can edit the parameter value
of a selected node directly in the node cell by choosing Nodes > Edit
Value or pressing the F6 key.
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Figure 38 Editing a value directly in a node cell indicated by white cell under the Vd column

Editing Parameter Values of Multiple Nodes

Sentaurus Workbench allows you to change parameter values defined on several nodes at the
same time:

1. Select multiple nodes in the simulation flow.

2. Choose Nodes > Modify Multiple Parameter Values.

The Modify Multiple Parameter Values dialog box is displayed. 

3. Specify the necessary value for each node in the New Value column.

4. Click OK.
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To specify the same parameter value for all nodes:

1. Type the value in the Parameter Value for All Nodes field.

2. Click Apply.

3. Click OK.

Configuring Double-Click Operations on Nodes

You can configure the behavior of double-clicking a node and link it to the required action.

NOTE If the double-click operation does not work on a VNC client, see
Appendix D on page 289.

To configure double-click operations on nodes:

1. Choose Edit > Preferences or press the F12 key.

The SWB Preferences dialog box is displayed.

2. Expand Table > Double Click Action > On Nodes.

3. Select one of the following options: 

4. Click Apply.

Option Double-clicking a node launches

Show Properties Node Information dialog box (see Viewing and Editing Node Properties on page 84)

Edit Cell Editor for the node cells that allows you to modify a value directly in the node cell

Launch Explorer Node Explorer (see Node Explorer on page 47)

Run Run Project dialog box (see Figure 66 on page 148)

Preprocess Preprocessing of the current node.

Visualize Results Default visualizer for viewing node output files
88 Sentaurus™ Workbench User Guide
N-2017.09



4: Editing Projects
Nodes
Copying Nodes

You can copy nodes in a project and between projects.

To copy nodes:

1. Select one or multiple nodes.

You can only make horizontal or vertical selections of nodes. Rectangular selection is not
supported.

2. Choose Edit > Copy, press Ctrl+C, or right-click the nodes and select Copy.

3. Select nodes in the target project (the same project or another project) where you want to
insert the nodes.

4. Choose Edit > Paste, press Ctrl+V, or right-click the nodes and select Paste or Paste
Special.

Copying nodes means copying parameter values, with no change to the parameterization
structure. When inserting nodes into an empty project, Sentaurus Workbench creates the
necessary infrastructure: tools and parameters are copied together with the nodes.

The behavior of Sentaurus Workbench when copying nodes might differ depending on the
selection of where to insert the nodes:

■ Node values are replaced by copied ones when the geometry of the selected nodes is the
same between the source project and the target project.

■ Nodes that are copied in the tool row or the parameter row of a target project are inserted
together with their parameters.

NOTE When copying nodes, the node output files are not copied to the target
project.

Viewing Node Dependencies

You can view nodes that are prerequisites of selected nodes. Both implicit and explicit node
dependencies are taken into account.

To view prerequisite nodes:

1. Select one or more nodes.

2. Choose Nodes > Extend Selection To > Prerequisite Nodes.

Sentaurus Workbench selects all nodes that are prerequisites of the originally selected ones.
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Experiments and Scenarios

An experiment or parameter setting is a tuple that contains one value for each parameter of the
flow. A scenario is a subtree of a simulation tree that contains a particular subset of
experiments. Scenarios can overlap, that is, a particular node or path can be part of more than
one scenario. Scenarios can be run and edited independently.

NOTE All projects have the scenario all that includes all the experiments of a
project. Every experiment in the project is included in at least one
scenario all. An experiment can be included in multiple scenarios.

Adding Experiments

An experiment can be added only if parameters are defined in a flow.

To add a single experiment:

1. Choose Experiments > Add New Experiment, or press the Insert key.

The Add New Experiment dialog box is displayed. 

2. From the Scenario list, select a scenario where the new experiment will be added.

The default is the current scenario.
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3. Select or type values for all parameters.

If an experiment is selected, the values are preset to those of the selected experiment.

4. Click Apply to add more experiments, or click OK to add the experiment and close the
dialog box.

To add experiments by adding parameter values:

1. Choose Experiments > Add Parameter/Values.

The Add Parameter/Values dialog box is displayed (see Figure 36 on page 72).

2. Select a scenario where the new experiment will be added.

The default is the current scenario.

3. Select a parameter for which you want to add a value.

4. Select a minimum value for the parameter.

It can be alphanumeric if only one value is added. It must be numeric if more than one value
is added.

5. Repeat Steps 3–7 as specified in Adding Values to Parameters on page 73.

If some experiments have been preselected, there is an option to add the new parameter
values to all experiments (full factorial) or only to the selected experiments. By default,
new values are added to selected experiments only.

It can be helpful to add a default experiment to an empty scenario. Default experiments are
defined by the tuple of all project parameters with their default values. Usually, the default
value of a parameter is the first value of its variation, which means the value the parameter takes
in the first experiment in the Family Tree. However, you can change this in the Parameter
Properties dialog box (see Changing Parameter Properties on page 77).

To create a default scenario:

1. Choose Experiments > Create Default Experiment.

2. In the Create Default Experiment dialog box, select a scenario where the new experiment
will be added.

3. Click OK.
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Excluding Experiments

Excluding experiments removes them from the current scenario but retains them in other
scenarios in which they are included.

To exclude an experiment from the current scenario:

1. Select an experiment in the experiments column.

2. Choose Experiments > Exclude Experiments.

NOTE Experiments cannot be excluded from the scenario all. To do this, you
must delete experiments.

Deleting Experiments

Deleting experiments excludes them from all project scenarios and removes them permanently
from a project.

To delete experiments:

1. Select experiments in the experiments column.

2. Choose Experiments > Delete Experiments, or press the Delete key.

NOTE Apply this operation cautiously. If you want to delete experiments from
the current scenario only, the correct procedure is to exclude
experiments (see Excluding Experiments).

Sorting Experiments

You can sort experiments according to the values of a selected parameter.

To sort experiments:

1. Select experiments.

2. Choose Experiments > Sort Experiments.

The Select Parameters to Sort dialog box is displayed.

3. Select the scenario, parameter, and sorting order as required.

4. Click OK.
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Figure 39 Select Parameters to Sort dialog box

NOTE Experiments are sorted in the given order inside each subtree rather than
on the entire simulation tree. That is why two experiments with the same
value of the sorting parameter do not necessarily become neighbors.

Importing Experiments From a File

You can import experiments from a text file that contains character-separated values, for
example, a .csv file:

To import experiments from a file:

1. Choose Experiments > Import From File.

The Import From File dialog box is displayed.

2. Select the required file and click Open.

The Import Experiments dialog box is displayed (see Figure 40 on page 94).

3. Select or type a scenario where the experiment will be imported.

4. For each parameter or variable, select either a column number in the file from which you
want to take this parameter value (the column number starts from 0) or a constant value that
will be used for all imported experiments.

5. Select a delimiter between columns in the file.

6. Select the number of first lines that will be omitted when reading experiments.

7. Select how many experiments (lines) are read from the file.

This number is preset to the number of lines in the file.

8. (Optional) Select the Treat Consecutive Delimiters as One option.

This option is often used for space-separated values.
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9. Click Preview to view which experiments will be imported.

10. Click OK. 

Figure 40 Import Experiments dialog box
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Viewing Experiment Properties

To view the properties of an experiment:

1. Select an experiment in the experiments column.

2. Choose Experiments > Properties, or double-click the experiment.

Adding Scenarios

To add a scenario to the simulation tree:

1. Choose Scenario > Add.

The Add Scenario dialog box is displayed. 

2. Type a new scenario name.

3. (Optional) Specify a node expression as described in the node expression references syntax
(see Node Expressions on page 265).

If a valid node expression is specified, Sentaurus Workbench includes matching
experiments in the new scenario.

4. Click OK.
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Removing Scenarios

To remove a scenario from the simulation tree:

1. Choose Scenario > Remove.

The Remove Scenarios dialog box is displayed. 

2. Select a scenario.

Hold the Ctrl key during selection to select multiple scenarios.

3. (Optional) Select the Delete Included Experiments From Project option.

If you select this option, the included experiments are deleted permanently from the
project.

By default, experiments are excluded only from the scenarios you delete and are included
in the scenario all.

4. Click OK.
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Including Experiments in Different Scenarios

You can manage which experiments are included in different scenarios.

To include experiments into different scenarios:

1. Select the experiments in the experiments column.

Hold the Ctrl key during selection to select multiple experiments.

2. Choose Experiments > Manage Membership in Scenarios.

The Manage Membership in Scenarios dialog box is displayed. 

3. In the Common Scenarios for Selected Experiments field, list the scenarios in which you
want to include selected experiments.

Any scenario added to this field will include all the selected experiments.

4. Add scenarios from the Available Scenarios field to the Common Scenarios field by
clicking the -> button.

5. Remove scenarios from the Common Scenarios field by clicking the <- button.

If a scenario does not exist yet, click Add New Scenario to create it, and then add it to the
Common Scenarios field.

6. Click OK.
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When you click OK, Sentaurus Workbench ensures that selected experiments are included in
all the scenarios listed in the Common Scenarios field. Sentaurus Workbench excludes the
selected experiments from all other scenarios that are not listed in the Common Scenarios
field.

Another option is to copy or move experiments between scenarios.

To copy experiments between scenarios:

1. Select the experiments to be copied in the experiments column.

Hold the Ctrl key during selection to select multiple experiments.

2. Choose Edit > Copy to copy experiments, or choose Edit > Cut to move experiments.

3. Select the scenario where you want to copy experiments from the scenario box in the
toolbar, or choose Scenario > Next or Scenario > Previous.

4. Choose Edit > Paste.

Excluding Experiments From Scenarios

To exclude experiments from dedicated scenarios:

1. Select the experiments to be included in the experiments column.

To select multiple experiments, hold the Ctrl key during selection.

2. Choose Experiments > Manage Membership in Scenarios.

The Manage Membership in Scenarios dialog box is displayed (see Including Experiments
in Different Scenarios on page 97).

3. In the Common Scenarios field, remove the scenarios that should not have the selected
experiments.

4. (Optional) Click Reset Scenario Inclusion to exclude the selected experiments from all
the common scenarios and to clear the Common Scenarios field.

5. (Optional) Click Add New Scenario to create a new empty scenario in the Available
Scenarios field.

6. Click OK.

When you click OK, Sentaurus Workbench ensures that selected experiments are included in
all the scenarios listed in the Common Scenarios field. Sentaurus Workbench excludes the
selected experiments from all other scenarios that are not listed in the Common Scenarios
field.
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Copying and Moving Experiments Between Projects

To copy and move experiments between projects if both projects have same number of
parameters in the flow:

1. Select the experiments to be copied in the experiments column.

Hold the Ctrl key during selection to select multiple experiments.

2. Choose Edit > Copy to copy experiments, or choose Edit > Cut to move experiments.

3. Open a project where you want to copy experiments in the same instance of Sentaurus
Workbench.

4. Select the scenario where you want to copy experiments from the scenario box in the
toolbar, or choose Scenario > Next, or Scenario > Previous.

5. Choose Edit > Paste.

NOTE When copying experiments into an empty project, Sentaurus
Workbench creates the corresponding infrastructure (tool steps and
parameters).

When copying experiments into a project with experiments, the
experiments are copied only if the source and target projects have the
same number of parameters and the parameters in both projects have the
same names and appear in the same order.

Pruning and Unpruning

Pruning removes superfluous paths from a simulation tree. An entire subtree can be removed,
reducing the simulation tree.

NOTE Pruning and unpruning are not as important as in previous versions of
Sentaurus Workbench, since it is no longer necessary to use a full
factorial tree. This feature is provided for backward compatibility and
special applications that require partial trees.

To prune a simulation tree:

1. Select the nodes.

The entire subtree starting with these nodes will be pruned.

2. Choose Nodes > Configuration > Prune, or press Ctrl+E.
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To unprune a tree:

1. Select the nodes.

The entire subtree starting with these nodes will be unpruned.

2. Choose Nodes > Configuration > Unprune, or press Ctrl+U.

To show or hide pruned nodes:

■ Choose View > Tree Options > Show Pruned, or press the F8 key.

Locking Nodes

Node locking is useful for large projects where preprocessing all nodes is cumbersome. In
addition, if you need to keep the current status of the preprocessing results for a specific tool,
scenario, or node, the corresponding nodes can be locked. Locking prevents nodes from being
preprocessed. These nodes can be unlocked if preprocessing is required.

To lock nodes:

1. Select the nodes.

2. Choose Nodes > Configuration > Lock.

To unlock nodes:

1. Select the nodes.

2. Choose Nodes > Configuration > UnLock.

Quick-Running Nodes

The quick-running of nodes submits nodes directly to the queue specified, and nodes are run
based on the function of the queue. The project is set to a running state.

To quick-run a node:

1. Select the nodes.

2. Choose Nodes > Quick Run, and select the required queue.

NOTE The queue list is loaded from the global queue definition file or the site
queue definition file, if it is specified by the environment variable
SWB_SITE_SETTINGS_DIR.
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Folding and Unfolding Nodes

It can be difficult to navigate projects having large tables with thousands of experiments. You
can reduce the size of the table by folding multiple experiments into one experiment. You can
apply folding to split points of the parameterization tree. Where new experiments appear, these
are nodes having two or more child nodes.

To fold nodes:

1. Select the nodes.

The entire subtree starting with these nodes will be folded.

2. Choose Nodes > Configuration > Fold.

Figure 41 shows how the view of the project tree changes after two folding operations:

■ Folding nodes 6 and 44

■ Folding nodes 2 and 3 

Figure 41 Original and folded project tree

The fold operation is applied from left to right. If the selected node does not have direct child
nodes, Sentaurus Workbench tries to fold all the nodes to the right of this node.

Nodes belonging to collapsed experiments represent several nodes and are shown with the
specific folded status. These nodes display a range of values of all the nodes behind them. You
can apply almost all operations to folded nodes, that is, you can preprocess, run, terminate, and
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clean up nodes, and you can visualize node results. You can consider the folded node as a
multiple-node selection that includes the folded node and all the nodes hidden behind it.

NOTE Folding nodes does not remove any experiments or result files. The fold
operation simply hides nodes behind the folded node. You can display
hidden nodes and experiments at any time using the unfold operation.

To unfold nodes:

1. Select the folded nodes or nodes to the left.

2. Choose Nodes > Configuration > UnFold.

This operation unfolds the experiments collapsed at that point. If you fold experiments to the
right of this node, the folding will be retained.

To unfold all experiments in the scenario:

■ Choose Scenario > Unfold All.

This operation unfolds all folded experiments and restores the project tree to its original
configuration.

NOTE The configuration of folded nodes is stored with the project and is
applied the next time you load the project.

Project Consistency Control

Project consistency control prevents you from running simulations that could be based on
invalid results from previous simulations. Sentaurus Workbench automatically identifies nodes
that might need to be reexecuted after making changes in the project structure and tool input
files. Project consistency control can be helpful after the following user actions:

■ Modifying a tool input file and reloading the project

■ Modifying the project parameterization table, for example:

• Modifying the value of one or more parameters on a node level

• Inserting a new parameter, or removing a parameter

■ Modifying the project tool flow, for example, adding a new tool or removing a tool

■ Modifying user-defined variables that are involved in the simulations (are used in tool input
files)

■ Removing experiments that contain nodes whose simulation results are referenced in other
experiments
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Switching On Project Consistency Control

To switch on project consistency control:

1. Choose Edit > Preferences or press the F12 key.

The SWB Preferences dialog box is displayed. 

2. Expand Project > Consistency Control.

3. For Actions on Inconsistent Nodes, select one of the following values: 

Value Description

Nothing Default. Project consistency control is switched off.

Clean Up This is the most rigorous mode. Sentaurus Workbench determines ambiguous nodes and 
ultimately cleans them up.
Use this mode with caution because automatic cleanup might result in loss of simulation 
results. Use this mode with automatic backup switched on (see Backing Up Node Files 
Automatically on page 175).
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4. Click Apply. 

Figure 42 After modifying the parameter value in node 12, successive ambiguous nodes 
have red exclamation mark

Removing Exclamation Marks

You must remove red exclamation marks if you decide some marked nodes should not be rerun.

To remove exclamation marks:

1. Select the nodes.

2. Choose Nodes > Unmark Ambiguous.

Reexecuting Marked Nodes

You must clean up nodes if you need to reexecute marked nodes.

To reexecute marked nodes:

1. Select the nodes.

2. Choose Nodes > Clean Up Node Output.

Mark Ambiguous This is an information mode. Sentaurus Workbench marks nodes that are potentially not up-
to-date and that might need to be reexecuted with a red exclamation mark (see Figure 42). 
The red exclamation mark means that you must decide whether to rerun this node after the 
latest changes in the project have been completed.
Sentaurus Workbench does not take any other actions at this point, such as deleting the node 
simulation results or extracted variables.
See Removing Exclamation Marks and Reexecuting Marked Nodes.

Value Description
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If you leave nodes marked, Sentaurus Workbench will reexecute nodes depending on the
setting for Rerun Ambiguous Nodes Next Time in the SWB Preferences dialog box (expand
Project > Consistency Control). The options are:

■ Never (default): Sentaurus Workbench considers marked nodes as up-to-date nodes and
does not restart them the next time you execute simulations.

■ Always: Sentaurus Workbench reruns ambiguous nodes.
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Taguchi Wizard

This chapter describes the Design-of-Experiments (DoE) Wizard
and the Taguchi Wizard that are available in Sentaurus Workbench.

Design-of-Experiments (DoE) Wizard

This wizard facilitates the use of tools for DoE available in Sentaurus Workbench. You
sequentially specify settings of different factors that determine the type of design to generate.

Step 1: Selecting the Design-of-Experiments Option

In Step 1 (see Figure 43), you choose one of the design options. These design options implicitly
relate to the objectives of users for that design. Each option is explained briefly in the lower
part of the window. 

Figure 43 DoE Wizard - Step 1

NOTE Although a stochastic design is used to implement an uncertainty
analysis instead of an optimization process, this design option is
included in the DoE Wizard because an uncertainty analysis can be
performed more efficiently with an appropriate stochastic design, such
as the one provided by the probabilistic collocation method.
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Step 2: Selecting Parameters

In Step 2 (see Figure 44), you select which parameters will be included in the study. The listed
parameters in the left pane are those in the current project.

You must move the parameters under investigation to either:

■ The DoE field (upper-right pane).

Parameters in this field define a DoE suitable to achieve the objective selected in Step 1.

■ The SDoE field (middle-right pane).

The SDoE button becomes active only when the Stochastic Design option is selected in
Step 1, that is, only if the goal is to perform an uncertainty analysis. Therefore, you cannot
mix, in the same experimental plan, parameters that by definition have different objectives,
such as deterministic parameters that are used to optimize the response and stochastic
parameters intended to perform an uncertainty analysis.

■ The USERD (user-defined) field (lower-right pane).

Parameters in this field allow for the previously mentioned DoE to be run under different
conditions, with each parameter measuring a different response. 

Figure 44 DoE Wizard - Step 2

Unselected parameters remaining in the left pane are considered to be constants during the
simulation. Their values are those belonging to the experiment selected. If you did not select
an experiment when launching the DoE Wizard, their values are the default ones assigned by
you when creating the project.
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NOTE If you selected multiple experiments, the DoE Wizard takes the values
of the first selected experiment as constant parameters.

The next steps differ depending on the option selected in Step 1.

Step 3: Screening Option

For a screening process, in Step 3, you must specify the levels for each parameter and the scale
in which they are measured (see Figure 45). 

Figure 45 DoE Wizard - Step 3 for screening

When you have specified the parameters, Step 4 provides a list of suitable designs to fit a first-
order model. The length of the list depends on the number of parameters selected in the DoE
field (Step 2).

In Step 4, the Runs column displays the required number of runs to complete each design and
the Resolution column shows the resolution of each design (see Figure 46 on page 110).

You must choose one design. Consider that the higher the resolution, the better the quality of
the fitted model will be and the higher the cost of the experimental plan will be.
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Figure 46 DoE Wizard - Step 4 for screening

Step 3: Response Surface Model Option

Step 3 for a response surface model (RSM) is the same as for screening (see Figure 45 on
page 109). Nevertheless, you must be aware that, for the Response Surface Model option, the
objective is to fit a second-order model. This implies that the DoE Wizard adds at least one
more level to each parameter automatically.

Step 4 for an RSM provides a list of designs that allow the fitting of a second-order model. The
second column in the table shows the number of simulations or runs required to complete each
experimental plan.

If Central Composite Complete or Central Composite Small is selected, you must define the
axial distance in a special step (see Figure 47 on page 111).
110 Sentaurus™ Workbench User Guide
N-2017.09



5: Design-of-Experiments Wizard and Taguchi Wizard
Design-of-Experiments (DoE) Wizard
Figure 47 DoE Wizard - Step 5 for response surface model

Step 3: Stochastic Design Option

Step 3 for stochastic design (see Figure 48) allows you to define the characteristics of
stochastic parameters. This means that you must associate each parameter with a probabilistic
distribution and a number of collocation points (parameter settings). 

Figure 48 DoE Wizard - Step 3 for stochastic design
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The stochastic design produces experiments by combining random values that are generated
according to user settings for each involved parameter: the random distribution and the number
of values. The alternative is to generate an independent set of experiments. You can define the
final number of experiments to generate, and Sentaurus Workbench creates experiments by
generating a random value for each parameter variation.

To use this mode of DoE:

1. Select the Monte Carlo Design option (see Figure 49).

2. In the Experiments box, specify the final number of experiments to generate. 

Figure 49 DoE Wizard – Step 3 for Monte Carlo stochastic design

Step 3: Square Design Option

Square designs are deterministic designs that are used to study more than two levels for each
parameter effectively, using Latin or Greco Latin or Hyper Greco Latin square.

In this case, in Step 3, you define from three to eight levels for each parameter (see Figure 50
on page 113).
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Figure 50 DoE Wizard - Step 3 for square design

Step 3: Sensitivity Analysis Option

Sensitivity analysis is used to analyze model outputs as a function of very small changes to a
single parameter with all other parameters fixed. Therefore, sensitivity analysis reveals only the
local gradient of the response surface of the model with regard to a given parameter.

Sentaurus Workbench supports the following sensitivity analysis modes:

■ The standard mode provides a powerful and flexible way of generating experiments based
on the involved parameters.

■ The Taurus™ Workbench–compatibility mode implements the Taurus Workbench style of
creating experiments for sensitivity analysis.
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Standard Mode

Step 3 for sensitivity analysis consists of the following group boxes.

TWB Compatibility Group Box

In this group box, you leave the TWB Sensitivity Analysis option unselected to use the
standard mode (see Figure 51). 

Figure 51 DoE Wizard – Step 3 for standard mode of sensitivity analysis

Global Settings Group Box

In this group box, you can specify settings that apply to all of the involved parameters. This can
save time when several parameters have similar values of the sensitivity range and the number
of samples inside that range.

The Sensitivity Range box refers to the range around the nominal value that covers the area of
the parameter variations. The default range is 10% and symmetric. For the nominal value ,
the corresponding sensitivity range is .

The Points box specifies the number of samples inside the sensitivity range (the default is 3).

When you click the Apply to All Parameters button for Sensitivity Range and Points, the
global values overwrite the corresponding parameter-specific settings in the Parameter Settings
group box.

X
X 10%±
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Parameter Settings Group Box

In this group box, you define settings specifically for each involved parameter. 

By default, the symmetric sensitivity range is defined by the parameter nominal value and the
value of Range% (in percent from the nominal value). You can redefine the default sensitivity
range by the direct specification of the Min. and Max. values. In this case, the Range% value
is removed to avoid confusion.

After applying the standard mode, Sentaurus Workbench generates the experiments as shown
in Figure 52 on page 116.

Table 5 Parameter settings

Parameter setting Description

Lin or Log Select either linear scale or logarithmic scale.

Nominal Nominal value of the parameter. By default, this is the value of the selected experiment. 
Otherwise, it is the default parameter value.

Points The number of parameter variations (samples).

Range% The sensitivity range. By default, this is a symmetric range around the nominal value.

Min. The lower point of the sensitivity range.

Max. The upper point of the sensitivity range.

Smooth Points Specifies an additional number of sample points inside the smooth range (the interval 
around the nominal value). The default is 0.
The Smooth Points setting can be helpful when the evaluation of the response leads to an 
unwanted increase or noise at the nominal value of the parameter. In that case, additional 
points around the parameter nominal value can help to interpolate the response curve 
(surface).

Smooth Range% Specifies a smooth range around the nominal value, where additional points (samples) 
are defined.

Smooth Min. The lower point of the smooth sensitivity range.

Smooth Max. The upper point of the smooth sensitivity range.
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Figure 52 Experiments generated by the standard mode of sensitivity analysis

Taurus Workbench–Compatible Mode

Step 3 for sensitivity analysis consists of the following group boxes.

TWB Compatibility Group Box

In this group box, you select the TWB Sensitivity Analysis option for the Taurus
Workbench–compatibility mode (see Figure 53). 

Figure 53 DoE Wizard - Step 3 for Taurus Workbench–compatible mode of sensitivity 
analysis: Sensitivity V model
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After you select this option, additional options are available to allow you to switch between two
models:

■ Sensitivity V

■ Sensitivity R

The window changes depending on the selected model (see Figure 53 on page 116 and
Figure 54). 

Figure 54 DoE Wizard - Step 3 for Taurus Workbench–compatible mode of sensitivity 
analysis: Sensitivity R model

Global Setting Group Box

In this group box, you specify the sensitivity range, which is a global option for all of the
involved parameters. The default is 10%.

Parameter Settings Group Box

In this group box, you can define the following parameter-specific values:

■ Nominal

■ Minimal and maximal (Sensitivity R model only)

■ Mean (Sensitivity V model only)
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After applying the Sensitivity R model, Sentaurus Workbench generates the following sample
values for each involved parameter:

■ <nominal> 

■ (<min + max>) / 2 

■ (<min> + <max>) / 2 + <sensitivity range> * 0.01 * (<min> + <max>) / 2 

After applying the Sensitivity V model, Sentaurus Workbench generates the following sample
values for each involved parameter:

■ <nominal>

■ <mean>

■ <mean> + <sensitivity range> * 0.01 * <mean> 

Figure 55 Experiments generated by Sentaurus Workbench for (left) Sensitivity V model 
and (right) Sensitivity R model

Step 3: User-Defined Parameters

So far, only DoE and SDoE parameters have been explained, but user-defined parameters can
be defined in the same way, despite the option selected in Step 1. These parameters can be
defined as either continuous with any number of levels or categorical.
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Figure 56 DoE Wizard - Step 3 for user-defined parameters

Final Step: Summary

This step is common to all the design options chosen in Step 1 and summarizes all the relevant
information about the design you will generate. It helps you to detect problems such as
unfeasible combinations or excessive runs for the resources and time available for the
experimental plan. 

Figure 57 DoE Wizard - Final Step
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Taguchi Wizard

The Taguchi Wizard helps you to create a Taguchi DoE. This wizard offers basic options that
allow for the definition of the characteristics of the required Taguchi design. An optional step
shows the values generated according to user specifications in the last steps. The wizard also
allows for the generated design to be copied to the main worksheet of Sentaurus Workbench as
a new scenario.

Step 1: Selecting the Design

In Step 1 (see Figure 58), you select the number level of the Taguchi design. 

Figure 58 Taguchi Wizard - Select Design

Note that:

■ Choices are divided between 2 Level and Multilevel With Noise.

■ When a Multilevel With Noise design is selected, the Select Outer Array Design options
are available to allow you to define the design to be used as noise.

Step 2: Specifying the Inner Array

In the next step:

■ The Factors column is read only and contains the experiment references designated
alphabetically, A, B, C, and so on.
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■ The Parameters column allows for the selection of one of the valid parameters from
Sentaurus Workbench. When a parameter is selected, it is not available for any further
selection in the other boxes.

In Step 2 for the 2 Level designs (see Figure 59), you define the design corresponding to the
Taguchi inner array. In the Center and Shift columns, you must define parameter values as
center shift. 

Figure 59 Two Level design - Step 2

Step 2 for the Multilevel With Noise designs (see Figure 60) contains entries to select
parameter values for each level. In the columns L1 to Ln, you must set the values of the levels
for the selected parameter. 

Figure 60 Multilevel With Noise - Step 2

 ±
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Step 3: Specifying the Outer Array

Step 3 of Multilevel With Noise models (see Figure 61) contains entries to specify the values
of the outer (noise) array. The No Noise, N1, and N2 columns allow you to insert three levels
of error factor that will be used to create the error design to be applied.

If the Percentage column is selected, the error factor is applied as a percentage of the value
(Value With Error = value + value * error / 100). Otherwise, the factor is applied as a simple
value (Value With Error = value + error). 

Figure 61 Multilevel With Noise - Step 3
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Final Step: Viewing the Design

You can click the View Design button (see Figure 61 on page 122) to display the View Design
dialog box (see Figure 62), where you can see the design that will be generated. 

Figure 62 Taguchi Wizard - View Design dialog box

After clicking the Finish button (see Figure 61), the selected design is created in Sentaurus
Workbench (see Figure 63).

Figure 63 Taguchi Wizard results
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CHAPTER 6 Preprocessing Projects

This chapter discusses how Sentaurus Workbench preprocesses
projects.

Introduction to Project Parameterization

An important feature of Sentaurus Workbench is support for project parameterization. A
parameterized project consists of a set of experiments where certain sensible input variables
take different values. A parameterized project is represented as a tree structure called gtree.

In a project, you provide the set of input file templates for each tool as defined in the tool
database. You can express variations in templates using the preprocessor language of Sentaurus
Workbench. The categories of preprocessor language constructs are:

■ Preprocessor #-commands (see Preprocessor #-Commands on page 126)

■ @-references (see @-References and Tree Navigation on page 127)

The Sentaurus Workbench preprocessor also supports special Tcl command blocks, which
contain arbitrary Tcl commands (see Using Tcl Command Blocks on page 136).

To differentiate nodes in gtree and to take into account already computed results, the
Sentaurus Workbench preprocessor (the spp utility) automatically generates actual input files
at runtime. Dynamic preprocessing allows a simulation to depend on the results of other
simulations, that is, the behavior of a node can vary as a function of variables extracted at other
nodes.

Global and Runtime Preprocessing

NOTE Locked nodes are not preprocessed.

Preprocessing is performed in two phases:

1. The global projectwide preprocessing phase, before project execution, does not create real
input files (pp*). Instead, it scans the user input templates of the tool to extract the job
interdependencies and to produce the project execution graph (file gexec.cmd), and finds
the #set commands and inserts variable values into the project variable file (gvars.dat).
In addition, global preprocessing can apply to expressions, nodes, and scenarios (see Node
Expressions on page 131).
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2. The second phase is the generation of job input files before you start a job. All preprocessor
commands and @-references are resolved and replaced at that time. A variable reference
is replaced with the most recently extracted value or with the value given at the closest
#set command if there is no extracted value. Finally, all preprocessor Tcl blocks are
extracted, evaluated, and substituted with the result of the Tcl evaluation (standard output).

To perform phase 1 only, use the command:

spp PROJECT

To perform both phases for the entire project (create the execution graph and variable file, and
generate all pp* input files), use the command:

spp -input PROJECT

NOTE In the global preprocessing phase, the variable references are replaced
with #set values, not with extracted values.

The gsub utility automatically performs phase 1 preprocessing when required (if any input file
has been modified since the last global preprocessing), before job submission.

The gjob utility automatically performs phase 2 preprocessing before job execution, unless the
project is in Editable runtime editing mode or the -nopp command-line option is specified
explicitly.

Preprocessor #-Commands

The #-commands give instructions to the Sentaurus Workbench preprocessor (the spp utility).
They are used when simple @-references are not sufficient to modify the behavior of a tool.
For example, conditional commands instruct spp to create different sections of an input file for
different nodes (or groups of nodes). Conditions typically refer to parameters, as shown in the
following input file fragment of Sentaurus Device:

#if @WithHydro@ == 1
coupled { Poisson Electron Hole eTemperature }
#else
coupled { Poisson Electron Hole }
#endif

The following example shows a template with two sections, one for even and one for odd node
indices:

#if @node:index@ % 2 == 0
# section for even node indices
#else
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# section for odd node indices
#endif

The following example shows how to test for the next or previous tool:

#if "@tool_label|+1@" == "shell2"
next tool is shell2

#else
next tool is something else

#endif

See #-Commands on page 262 for a list of all the available #-commands of Sentaurus
Workbench.

@-References and Tree Navigation

Since Sentaurus Workbench must control all tool input and output files in the simulation tree
and determine job interdependencies, file names must appear only as file references in input
files.

Do not use absolute, hard-coded file names. Use node references instead of hard-coded node
keys. At runtime, the Sentaurus Workbench preprocessor substitutes file references and node
references with the corresponding file names or node keys.

The following conventions and notations are used:

■ Each node is uniquely identified by its key noted nkey. 

■ Node keys can be displayed in the Project Editor.

■ Tool output file names are prefixed with n<nkey>_<acronym>, where <acronym> is a
three-character string identifying a specific tool.

■ The set of nodes at a certain tree level represents all occurrences of the tool at that level.
These nodes are indexed from 1 to , where 1 denotes the leftmost node and  is the
rightmost node. A node index is the absolute position of the node in its tree level.

@-references can be parameters, variables, expressions, or commands that are enclosed in a
pair of at signs (@). The preprocessor evaluates and substitutes the enclosed content. A simple
reference of Sentaurus Workbench usually refers to the current node (@node@).

Navigation operators can be used to move the reference from the current node to another node
in the simulation tree. Relative navigation can be in all directions around the current node: up,
down, left, right, and also in absolute indices.

n n
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To illustrate the use of file references, a typical Sentaurus Device File section is:

File {
grid = "@grid@"
doping = "@doping@"
plot = "@dat@"
current = "@plot@"
output = "@log@"

}

NOTE For historical reasons, the meaning of the keyword plot is different in
Sentaurus Device and Sentaurus Workbench. In Sentaurus Device,
plot refers to the plots of primary and derived quantities over the
computational domain. In Sentaurus Workbench, plot refers to I–V
curves.

@-Expressions

Sentaurus Workbench supports two @-expression types that are evaluated during
preprocessing: @[...]@ and @<...>@.

Both types of @-expression can be nested in any way, for example:

@< ... @[...]@ ...>@

@[ ... @<... @[...]@ ...>@ ...]@

The following expressions are equivalent:

@< @HaloDose@ + 1e-14 >@

@[ expr {@HaloDose@ + 1e-14} ]@

Combined with #-commands, @-expressions help you to make your command files even more
flexible.

Expression @[...]@

When the preprocessor finds an expression of @[...]@ type, it extracts the expression from
the brackets and evaluates it in Tcl interpreter like this:

% eval <expression>
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For example, the expression:

@[string compare @HaloDose@ 1e-14]@

will be processed as follows:

■ @HaloDose@ is substituted with the corresponding Sentaurus Workbench value for the
current node.

■ The following command is evaluated in the Tcl interpreter:

% eval string compare <HaloDoseValue> 1e-14

Expression @<...>@

When the preprocessor finds an expression of @<...>@ type, it extracts the expression from
the angle brackets and evaluates it in Tcl interpreter like this:

% eval expr { <expression> }

For example, the expression:

@< @HaloDose@ + 1e-14 >@

will be processed as follows:

■ @HaloDose@ is substituted with the corresponding Sentaurus Workbench value for the
current node.

■ The following command is evaluated in the Tcl interpreter:

% eval expr {<HaloDoseValue> + 1e-14}

Redefining Delimiters

NOTE Redefining delimiters works only when the Sentaurus Workbench
preprocessor (the spp utility) is used.

As mentioned in @-References and Tree Navigation on page 127, the preprocessor recognizes
the at sign (@) as a delimiter for parameters, variables, expressions, or commands. At the same
time, the input language syntax of some tools integrated into Sentaurus Workbench allows the
use of the at sign (@) internally in language-specific constructions, for example, internal
variables for Taurus TSUPREM-4.

To avoid problems during preprocessing, all such character expressions in the input file must
be protected with the #verbatim keyword. However, this can overload the input file with
preprocessor commands and instructions, making the file difficult to read. Other preprocessing
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problems might arise when a preprocessor reference @...@ is used on the same line as an @…
language construction.

To avoid such problems, the default delimiter symbol can be redefined for a tool by setting up
a particular tool database instruction, for example:

set WB_tool(<tool_name>,substitution_delimiter) <delimiter>

where <tool_name> is the tool name. The delimiter can be either a single character or a
combination of characters (space is not allowed).

The at sign (@) remains a valid delimiter for input files of other tools. The redefined delimiter
takes effect for all of the tool-related files involved in the preprocessing. At the same time, tool-
specific setup, prologue, and epilogue scripts from the tool database, as well as the variable
extraction commands, can be specified only using the standard @-delimiter.

Preprocessing Nodes

You can use node filters and node expressions when preprocessing projects.

Node Filters

A node filter is a Tcl expression that evaluates to true (!=0) or false (0) for any existing node
in the simulation tree. The syntax of a filter is:

filter: "{" EXPR "}"

EXPR is a Tcl expression that evaluates to a number and can refer to parameters or variables
existing in the current tree using the $NAME notation. For example, the following expression
will evaluate to true for nodes where the value of parameter P2 is equal to 3 and the value of
variable V1 is greater than 2:

{ $P2 == 3 && $V1 > 2 }

Nodes for which a referenced parameter or variable is not defined are rejected (evaluated to
false). In other words, the previous expression is equivalent to:

{ ([info exists P2] && $P2 == 3) && ([info exists V1] && $V1 > 2) }

In addition, EXPR recognizes the predefined functions min(NAME) and max(NAME). The
following example will evaluate to true for nodes where the value of parameter P2 is equal to
the minimal value of P2:

{ $P2 == min(P2) }
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Node Expressions

Sentaurus Workbench provides expressions – abbreviated to gexpr – to selected nodes in the
simulation tree. A node expression gexpr returns a list of node keys and is used especially in
the Scheduler to submit nodes for execution. See Node Expressions on page 265 for the syntax
of node expressions.

The following example returns the leaf nodes belonging to both scenarios sc1 and sc2, where
parameter P1 is equal to 1:

"sc1|last:{$P1 == 1} * sc2|last:{$P1 == 1}"

Split Points

A parameter introduces a new level in the simulation tree to the right of the tool step. Viewed
from the tree, a parameter splits the overall tool simulation phase into two subphases. This is
only an abstract view because each tool instance usually executes the entire simulation phase
from the beginning to end in one run.

As a result, the same first subphase (or subphases) is unnecessarily executed several times. This
is only true for tools whose command file defines a linear control flow (that is, a flow executed
sequentially from the beginning to end, command after command). These tools are linear tools.
Typically, process simulation tools are linear tools.

Sentaurus Workbench provides a splitting facility so that linear tools can save and restore their
state; each intermediate branch in the tree can be executed only once. This facility can save
considerable computing time, especially for lengthy jobs with multiple phases.

A tool can be split only when the Save and Load commands are defined in the tool database.
For example, Sentaurus Process has the following two lines in the standard tool database:

set WB_tool(sprocess,split,save_cmd) "struct tdr=n@node@"
set WB_tool(sprocess,split,load_cmd) "init tdr=n@previous@"

NOTE To ensure that Sentaurus Workbench shows the real status of
intermediate nodes, confirm whether View > Tree Options > Check
Virtual Nodes is selected (see Nodes on page 38).
Sentaurus™ Workbench User Guide 131
N-2017.09



6: Preprocessing Projects 
Preprocessing Variables
Preprocessing Variables

Like parameters, variables hold a value and can be referenced in any form of @-references. The
main difference is that a variable does not create a split in the simulation flow and, therefore,
does not change the shape of the simulation tree.

The #set command defines a preprocessed variable and assigns a value to it:

#set <varname> <value>

A defined variable can then be referenced by its name in any @-reference notation. A variable
reference creates an execution dependency from the node where the reference is performed to
the first ancestor where the variable has been set. The scope of a variable is similar to that of a
parameter, that is, from the node with the first #set directive to all of its descendants.

You can reassign a variable in one of the following ways:

■ Use another #set directive, that is, override it with another preprocessed value.

■ Perform an extraction, that is, override it with an extracted value (see Extracted Variables
on page 133).

All variables are shown in the Family Tree.

A typical use of #set commands is to define a set of variables bound to a parameter, such as
the fields of a record:

#if @PARAM@ == 1
#set PARAM_V1 1.5
#set PARAM_V2 2.5
#elif @PARAM@ == 2
#set PARAM_V1 11.5
#set PARAM_V2 12.5
#endif

This construct avoids the declaration of two artificial parameters and reduces the size of the
overall project tree.
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Extracted Variables

Another common use of variables is to extract a value from the tool output file and refer to it
in the next tool input file.

Values are extracted from node output files. After the node has been successfully executed, its
output file is parsed for strings that match the following mask:

DOE: <varname> <value>

Then, the values found are written to the gvars.dat file. If the specified variable already
exists, the extracted value will overwrite the existing one. If the specified variable does not
exist, that is, it was not defined globally or with the #set command, a new variable will be
created. After that, the extracted variable can be referenced in any subsequent tool input files
by using standard preprocessor @-references.

The only way to inform Sentaurus Workbench that a value must be extracted during the
simulation and assigned to some variable is to provide the DOE: <varname> <value> string
in the node output file. Usually, it should be printed in the tool command file. The
corresponding command strictly depends on the tool and its command syntax. For example, for
Sentaurus Process, it can be a simple Tcl command:

puts "DOE: ENERGY 120.56"

Inspect supports another way of exporting values to the Family Tree. You can use the
ft_scalar function in the Inspect command file:

ft_scalar <varname> <value>

This function assigns the value to the specified variable of Sentaurus Workbench. If the
variable does not exist, it will be created. In this way, nothing is sent to the node output file; the
exported value goes directly to the variable definition.

Extracted values and preprocessed values are separated. Extracted values become available
during the simulation running phase, and preprocessed values are already known at the
preprocessing stage.

NOTE A common cause of errors when using extracted variables is that a
corresponding variable does not exist during preprocessing. In this case,
preprocessing of the project can fail if there are any references to this
variable in the input files of other tools. To avoid this error, globally
declare the variable or use the #set preprocessing command.
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The following example demonstrates how the algorithm extracts values from the simulation
step and accesses them in the subsequent simulation steps:

1. In the tool where the extraction is performed, an arbitrary default value must be assigned
to the extracted variable:

#set EXTRACTED_VAR 0

This command can be also specified in any preceding tools if they exist.

2. In the tool where the extraction is performed, the printing command must be specified in
the tool command file. In the case of Sentaurus Process, it could be one of the following:

puts "DOE: ENERGY 120.56"

puts "DOE: ENERGY @ENERGY_2@"

where ENERGY_2 is another variable.

3. The variable EXTRACTED_VAR can be referenced in any subsequent tool input files by
using standard preprocessor @-references and #-commands, for example:

@EXTRACTED_VAR@
@< @EXTRACTED_VAR:+1@ / 2 >@
#if @EXTRACTED_VAR@ > 1.5e15
...
#endif

NOTE Extracted variables work only for tools for which the extracting
algorithm has been defined in the tool database. For example, the global
tool database defines it for Sentaurus Process in this way: 
set WB_tool(sprocess,epilogue) { extract_vars $wdir
@stdout@ @node@; ... }
where the extract_vars function is defined also in the global tool
database. This definition means that the values for each executed node
will be extracted from the output file on the basis of the DoE: the pattern
specified in the function. In the global tool database, this extraction
algorithm is defined for Sentaurus Process, Taurus TSUPREM-4,
Raphael™, and Inspect. To enable other tools to support extracted
variables, the corresponding definition must be specified in the user or
project tool database. It is also possible to define a user-specific
extracting algorithm for extracting values between Family Tree steps.
134 Sentaurus™ Workbench User Guide
N-2017.09



6: Preprocessing Projects
Execution Dependencies
Execution Dependencies

During preprocessing, all dependencies in the files are analyzed in the following way.

If there is a file reference @file_type@ with possible, additional, relative direction suffixes
(see Appendix A on page 257 for information about @-references and tree navigation) in any
of the command files or parameterized input files, the execution is made dependent on the
successful completion of the pointed node.

NOTE @node@ references do not create any dependencies and there are no
implicit child-to-parent dependencies.

Dependencies can be forced using the #setdep command. For example, the following
command creates a barrier before the current level, that is, no node at the current level can start
execution before all nodes at the previous level have been successfully completed:

#setdep @node|-1:all@

The Sentaurus Workbench preprocessor (spp) checks for circular references and fails if one is
found.

You can view dependencies by extending the selection to prerequisite nodes (see Viewing Node
Dependencies on page 89).

You can remove dependencies explicitly using the #remdep command, for example:

#remdep @node|+1@

NOTE Although the reference @previous@ is, in principle, equivalent to
@node|-1@, the difference is that @previous@ creates a dependency,
while @node|-1@ does not.

Setting and Unsetting Dependencies

The order in which dependencies are set or unset is important. Unsetting a dependency does
not have any effect if the dependency is reset later in the same input file, either implicitly or
explicitly. Therefore, a #remdep command at the beginning of a file does not have any effect.
This command typically appears at the end of an input file.
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Using Tcl Command Blocks

The concept of Tcl command blocks is to bring the power of Tcl to the complex languages used
by some tools incorporated in Sentaurus Workbench.

Creating Tcl Command Blocks

Tcl command blocks consist of an arbitrary set of Tcl command lines that are delimited by
"!(" and ")!". During the final stage of preprocessing, the preprocessor extracts and
evaluates Tcl command blocks. In the node input file, each Tcl block is replaced with the
standard output of its Tcl evaluation.

The following example illustrates the use of Tcl command blocks to power some Sentaurus
Device code. Consider the following part of an input file for Sentaurus Device (Tcl blocks are
italicized):

#if @<polarization>@ == "on"
!(
#=============================================================
# Computation of piezo/spontaneous charge
# using SWB capability to interpret Tcl command blocks
#=============================================================
set q 1.602e-19; # elementary charge
set Psp_AlN [expr -8.1e-6/$q]; # AlN build-in spontaneous polarization
set Psp_GaN [expr -2.9e-6/$q]; # GaN build-in spontaneous polarization
set Psp_AlGaN [expr @x@*$Psp_AlN+(1-@x@)*$Psp_GaN]; # AlGaN spontaneous 
polarization
set DPsp [expr $Psp_GaN-$Psp_AlGaN]; # interface charge due to spontaneous 
polarization
set e33i [expr (@x@*1.46e-4+(1-@x@)*0.73e-4)/$q]
set e31i [expr (@x@*-0.60e-4+(1-@x@)*-0.49e-4)/$q]
set c13i [expr @x@*108+(1-@x@)*103]
set c33i [expr @x@*373+(1-@x@)*405]
set straini [expr @x@*(3.189-3.112)/(@x@*3.112+(1-@x@)*3.189)]
set Ppz_AlGaN [expr 2*$straini*($e31i-$c13i/$c33i*$e33i)]
set DPpz $Ppz_AlGaN
set intCharge [expr $DPsp+$DPpz]; # resulting value of the interface charge
# Transfer the resulting charge to the project Family Tree as SWB variable
set SWB_VARIABLES(Charge) [format %.6e $intCharge]
)!
* Spontaneous polarization for AlGaN: !(puts -nonewline [format %.2e 
$Psp_AlGaN])!
* Piezopolarization for AlGaN: !(puts -nonewline [format %.2e $Ppz_AlGaN])!
* Total AlGaN Polarization: !(puts [format %.2e [expr 
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$Psp_AlGaN+$Ppz_AlGaN]])!
* Total GaN Polarization: !(puts [format %.2e $Psp_GaN])!
#endif
...
Physics(materialinterface="GaN/AlGaN")
{
#if @<polarization>@ == "on"

Charge( Conc=!(puts -nonewline [format %.4e $intCharge])! )
#endif
#if [string match "*NL*" "@model@"]
* hetero barrier non-local barrier tunneling
Recombination(eBarrierTunneling(nonlocal))

#endif
}
...

This file is preprocessed to the following node file:

* Spontaneous polarization for AlGaN: -5.06e+13
* Piezopolarization for AlGaN: -1.85e+13
* Total AlGaN Polarization: -6.91e+13
* Total GaN Polarization: -1.81e+13
...
Physics(materialinterface="GaN/AlGaN")
{

Charge( Conc=1.3925e+13 )

* hetero barrier non-local barrier tunneling
Recombination(eBarrierTunneling(nonlocal))

}
...

NOTE If a Tcl command block prints nothing (no Tcl puts command is used),
the standard output of the Tcl evaluation is empty. This is the reason
why there will be nothing from this block in the preprocessed node input
file.

Preprocessing Tcl Command Blocks

The Sentaurus Workbench preprocessor evaluates Tcl command blocks automatically at the
final stage of project preprocessing. After the evaluation of preprocessor #-commands, @-
references, and @-expressions is completed, Sentaurus Workbench starts evaluating Tcl
command blocks (see Preprocessor #-Commands on page 126, @-References and Tree
Navigation on page 127, and @-Expressions on page 128).
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In the node input file, each Tcl command block is replaced with the standard output of its Tcl
evaluation. Evaluation of Tcl command blocks follows the experiment-wise rule: Tcl blocks
appearing in the input files of the nodes belonging to the same experiment are evaluated in the
context of the same Tcl interpreter, from the first node to the last node. This rule makes it
possible to organize an experiment-wise logic of Tcl command blocks that appear in the nodes
of the same experiment. For example, a Tcl variable that you set in the Tcl command block of
the first node in the experiment is accessible in Tcl command blocks appearing in all other
nodes of the same experiment.

Tcl command blocks cannot be used in preprocessor #-commands because Tcl blocks are
evaluated only at the final stage of project preprocessing. As the result, the evaluation of #-
commands fails.

For example, using Tcl blocks in an #include preprocessor command is incorrect:

#include "!(puts -nonewline "[file join /the/path myfile.cmd]")!"

In such a case, use an @-expression instead:

#include "@[file join /the/ myfile.cmd]@"

To reduce the preprocessing time, you can call Tcl preprocessing explicitly in one of the
following ways:

■ Choose Project > Operations > Preprocess Tcl Blocks.

■ Press Ctrl+B.

■ Right-click a project and select Project > Preprocess Tcl Blocks.

In this preprocessing mode, only Tcl command blocks in the tool input files are Tcl evaluated.
All unresolved Sentaurus Workbench parameters and expressions (@...@, @<...>@,
@[...]@) are substituted with dummy values. This light preprocessing mode is useful for
testing purposes only. To obtain the expected results, the entire preprocessing procedure must
be activated.

Tcl Command Blocks and Sentaurus Workbench 
Variables

Tcl command blocks provide a possibility to create or update Sentaurus Workbench variables.
They are equivalent to preprocessing variables created with the #set command. For this
purpose, a special SWB_VARIABLES Tcl array must be updated in the Tcl command block. This
array is global.
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To instruct the Sentaurus Workbench preprocessor to initialize the Sentaurus Workbench
variable "myvar" with the value "myval", the following Tcl instruction must be inserted into
the Tcl command block:

set SWB_VARIABLES(myvar) "myval"

The following example creates the variables var1, var2, and var3 with the values 1, 2, and 3:

!(
...
set SWB_VARIABLES(var1) 1
set SWB_VARIABLES(var2) 2
set SWB_VARIABLES(var3) 3
...

) 

Figure 64 Creation of three variables

Input and Output Operations Inside Tcl Command Blocks

It is necessary to force flushing of output streams in Tcl command blocks. Use the Tcl flush
command when writing files inside a Tcl command block. Otherwise, the file will not be
available until the node has been executed, for example:

set FID [open "@pwd@/tmp_n@node@_ins.cmd" w]
...
...
puts $FID "Hello World"
flush $FID
close $FID
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When to Use Tcl Command Blocks

Using Tcl command blocks is helpful in the following circumstances:

■ For comprehensive calculations that are difficult to implement in the language of the tool
and that use the result value in the native language constructions of the tool. For example,
in the case of Sentaurus Device, you could implement in the sdevice_des.cmd file:

!(
if { "@Type@" == "nMOS" } {

set SIGN 1.0
set HFS1 "eHighFieldSaturation( CarrierTempDrive )"
set HFS2 "hHighFieldSaturation( GradQuasiFermi )"
set DG "eQuantumPotential"
set cTemp "eTemperature"
set EQN0 "Poisson eQuantumPotential Electron Hole"
set EQNS "Poisson eQuantumPotential Electron Hole Temperature 
eTemperature"

} else {
set SIGN -1.0
set HFS1 "hHighFieldSaturation( CarrierTempDrive )"
set HFS2 "eHighFieldSaturation( GradQuasiFermi )"
set DG "hQuantumPotential"
set cTemp "hTemperature"
set EQN0 "Poisson hQuantumPotential Electron Hole"
set EQNS "Poisson hQuantumPotential Electron Hole Temperature 
hTemperature"

}
)!

■ For enhancing the capabilities of native tool languages. For example, the following Tcl
command block will write 100 Sentaurus Device Physics sections with different
concentrations in the preprocessed command file of Sentaurus Device (imitation of for-
loop):

!(
for {set i 0} {$i < 100} {incr i} {
puts "Physics (materialInterface=\"Silicon/Oxide\")"
puts "Charge(Conc=[expr 6.0e11 + $i*1e11])" 
}
)!

NOTE Using Tcl command blocks for Tcl-aware tools such as Sentaurus
Process is allowed but provides no additional benefits. Such a practice
might lead to confusion since Tcl command blocks and the native Tcl
flow are evaluated on different scopes. In addition, it makes the tool
command file less readable.
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Summary of Rules for Using Tcl Command Blocks

When using Tcl command blocks, note the following requirements:

■ A Tcl block contains an arbitrary number of native Tcl instructions between a "!(" and
")!" pair of symbols.

■ Tcl blocks cannot be nested.

■ A Tcl block can be inserted in any place of any preprocessed file, such as tool command
files and parameter files for Sentaurus Device.

■ Each file can contain an arbitrary number of Tcl blocks.

■ All Tcl blocks are evaluated by a separate Tcl interpreter, which is specific for each
experiment in the project.

■ All Tcl blocks are evaluated for each tool, from left to right, and from the beginning to the
end of each file.

■ A Tcl block can contain a reference to the Tcl variable set in a previous block, which can
be placed in the same file or another file of the same experiment.

■ Sentaurus Workbench replaces each Tcl block with the result of its output (standard
output). Therefore, to extract the value of the Tcl variable "aaa", you must specify
"puts $aaa". This provides transparency when interpreting Tcl blocks; all blocks are
evaluated in the same way. If a Tcl block does not provide any output, nothing will go to
the preprocessed file. However, all the Tcl variables and procedures declared in that block,
of course, will exist in the interpreter of the current experiment and could be used further.

■ The Sentaurus Workbench preprocessor evaluates all the Tcl blocks after the standard
preprocessing of #... commands and the resolving of @...@, @<...>@, and @[...]@
expressions. This means that you can use any of these standard preprocessing directives
inside the Tcl blocks. However, you cannot use Tcl blocks in preprocessor #-commands
and @-expressions.

■ Sentaurus Workbench has a preprocessing mode (choose Project > Operations >
Preprocess Tcl Blocks) that evaluates only Tcl command blocks without standard
Sentaurus Workbench preprocessing. This preprocessing mode is reasonably fast and can
be used for checking purposes.

■ Sentaurus Workbench provides a way to show the values of the Tcl variables in the
Sentaurus Workbench variables table. The Tcl block must contain a special Tcl command
such as:

set out ... (comprehensive calculations)
set SWB_VARIABLES(myvar) $out

After the successful evaluation of a Tcl command block, you can see the new Sentaurus
Workbench variable "myvar" in the Sentaurus Workbench variables table. This feature
works like the standard Sentaurus Workbench #set var value instruction.
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CHAPTER 7 Running Projects

This chapter discusses how to run projects in Sentaurus Workbench.

Projects can be run from the Project Editor, the command line, or the Scheduler.

Running Projects From the Project Editor

To run a project:

1. Browse the projects on the tree.

2. Open the project in the Project Editor.

3. Select the nodes or open the required scenario.

You can run multiple selected projects from the projects browser.

To run the selected nodes:

1. Select nodes (see Selecting Nodes With Mouse and Keyboard Operations on page 40).

2. Choose Project > Operations > Run, or press Ctrl+R, or click the Run button.

To run a scenario:

1. Select the required scenario (default is all).

2. Select the nodes to run from either remaining (all nodes that do not have the status done)
or all.

By default, Sentaurus Workbench submits remaining nodes.

3. Choose Project > Operations > Run, or press Ctrl+R, or click the Run button.

The Run Project dialog box is displayed and nodes are assigned, based on the queue definitions
and tool assignments of the user. The Run button submits the nodes to the corresponding
scheduler or queues.
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Running Projects From the Command Line

You can submit jobs to queues or launch a specific job.

Submitting Jobs to Queues

The gsub utility is the actual backend system, which performs the following:

■ Preprocesses a project (on demand).

■ Reads queue assignments.

■ Expands the generic expression to determine the node or takes the nodes from the list
provided.

■ Submits jobs to the queues, calls gjob on several machines, and executes the jobs.

The syntax of the gsub command is:

gsub [options] (FILENAME | PROJECT) 

Table 6 Command-line options of the gsub command

Option Description

-e[xpr] "GEXPR" Nodes resulting from the GEXPR expression.

-h[elp] Displays help information.

-max[Experiments] <number> Defines the maximum number of concurrently running experiments.

-n[odes] [<scenario> | 
"<list of nodes>"]

Remaining nodes in <scenario>, or given node numbers.

-q[ueue] "queue name" Submits all the jobs to a queue.

-startTime <datetime> Start date and time of the submission (default: immediately). Format is:
"mm/dd/yyyy hh:mm:ss AM|PM"

-v[ersion] Displays version information.

-verbose Displays additional initialization and loading information.

Arguments

FILENAME Text file defining a list of jobs.

PROJECT Project directory.
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Example

gsub -verbose -e all -q local:default @STDB@/folder/project

This command launches all nodes of the given project locally.

Launching a Specific Job

The gjob utility runs a given job or the node of a project locally. It performs the following:

■ Preprocesses the node of the given project.

■ Runs the given job or the node of the given project locally.

The syntax of the gjob command is:

gjob [options] -job NAME (FILENAME | PROJECT) 

NOTE The gjob command cannot use the node-queue or tool-queue
assignments as the gsub command does. The gjob command
essentially runs the given node locally.

Table 7 Command-line options of the gjob command

Option Description

-h[elp] Displays help information.

-nice NUMBER Job scheduling priority (default: 0):
• Highest: -20
• Lowest: 19

-nopp Does not overwrite node input files of the project while preprocessing (only valid if 
the project is in the Editable runtime editing mode).

-p[ack] Does not generate empty lines while preprocessing.

-v[ersion] Displays version information.

-verbose Displays additional initialization and runtime information.

Arguments (one of the following)

-j[ob] NAME Job name or node number.

FILENAME Text file defining jobs.

PROJECT Project directory.
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Example

gjob -verbose -job 2 -nopp -nice -10 @STDB@/folder/project

This command launches node 2 of the given project locally with a priority of -10, and it
instructs Sentaurus Workbench to not overwrite the node input files.

Running Projects From the Scheduler

Sentaurus Workbench submits nodes in the order that is defined by implicit and explicit node
dependencies of the project:

■ Implicit node dependencies come from the tool input or output interface specified in the
tool database.

■ Explicit node dependencies are usually those you define in the tool input files using
#setdep or @previous@ preprocessor instructions and references.

The set of these node dependencies defines the submission order of project nodes.
Dependencies can be viewed by extending the selection to prerequisite nodes (see Viewing
Node Dependencies on page 89).

Sentaurus Workbench implements a strict dependency model. A node is launched only when
all its prerequisite nodes have been executed successfully and appear with the status done. If
the execution of, at least, one prerequisite node fails or is terminated, Sentaurus Workbench
does not launch the next node and removes this node from the execution list.

There can be exceptions to this strict dependency model. In certain cases, you might want to
execute the entire simulation project in one run despite some failed nodes. Assume you run a
large design-of-experiments (DoE) project and you want to build a model based on this DoE.
To build the model, all of the project nodes must be executed. However, some Sentaurus Device
nodes might fail because of convergence problems or because your device is punch-through.
Despite failures, Sentaurus Device might have already stored important results such as Vtlin and
Vtsat. Then, you want the corresponding Sentaurus Visual or Inspect extraction step to execute
and extract these results.

Sentaurus Workbench allows you to relax the strict dependency model for Sentaurus Visual,
Inspect, gtclsh, cshell, and bash. These tools are used typically for extracting and
visualizing the results produced by Sentaurus Device simulations, so they can complete their
tasks even though a Sentaurus Device node failed or was terminated.
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You relax the strict dependency model in the Tool Properties dialog box (see Figure 65). The
options in the Tool Properties dialog box for the Dependency field are:

■ strict (default): Sentaurus Workbench launches a node only when all its prerequisite nodes
have the status done.

■ relaxed: Sentaurus Workbench launches a node even when its prerequisite nodes have the
status done, failed, or aborted. 

Figure 65 Dependency control in the Tool Properties dialog box for Sentaurus Visual

Runtime Editing Modes for Projects

Projects can have different runtime editing modes.

Locked Runtime Editing Mode

As soon as a project is running, it is locked for any changes in the parameterization table. All
you can do is run additional nodes, or terminate selected nodes or the entire running project.

Sentaurus Workbench implements strict safeguards to prevent any kind of inconsistency
between input project data and the simulation results. Changes made to the tool database files
and the tool input files result in the failure of currently running nodes as well as the failure to
run pending nodes due to background file timestamp checks.
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Runtime preprocessing is a mandatory part of the execution of a project with the Locked mode.
All your changes made on the node input files will be lost during the execution; while each
node input file will be replaced with the preprocessed tool input file. 

Figure 66 Run Project dialog box for a project in Locked mode

Sentaurus Workbench provides a direct and consistent way of scheduling project nodes. The
node can be submitted for execution only when the nodes on which it depends (prerequisite
nodes) are executed successfully. Sentaurus Workbench automatically determines a list of all
the prerequisite nodes from the nodes that you select for submission. All you need to do is
select the nodes to run, and Sentaurus Workbench will handle what is required for this.

Editable Runtime Editing Mode

In contrast to projects in Locked mode, a running project in Editable mode is not locked for
changes. You can add or remove tools, parameters, and experiments, and edit tool input files
and Sentaurus Workbench configuration files, and so on. In addition, you can edit node input
files and rerun them without the obligatory preprocessing and node file regeneration. To do
this, select the Just run, do not preprocess option in the Run Project dialog box (see Figure 67
on page 149).

However, Sentaurus Workbench does not provide background checks of file timestamps. This
might result in inconsistency between the tool input file and the simulation result of a certain
node. To prevent this, you can preprocess certain nodes or the entire project at any time.

NOTE Preprocessing the entire project is highly recommended after making
changes to the parameterization table.
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A node can be executed when some prerequisite nodes are not yet completed, have not started,
or have failed. When submitting a group of nodes, the order of the node execution takes into
account node dependencies inside the group, but it ignores external node dependencies. 

Figure 67 Run Project dialog box for a project in Editable mode

Choosing the Appropriate Runtime Editing Mode for 
Projects

Sentaurus Workbench creates new projects using the runtime editing mode specified in the
preferences (see Changing the Default Runtime Editing Mode of Projects on page 13). The
Editable mode is the default.

Changing the runtime editing mode of an existing project must be performed manually (see
Changing the Runtime Editing Mode of a Project on page 12).

You cannot change the runtime editing mode of a running project, which is why it is highly
recommended to specify the appropriate mode for your project before you launch it. If you
regularly work with typical simulation setups, it is worthwhile making a reasonable choice for
the default runtime editing mode for your new projects in the preferences.

For many use cases where you need to change parts of your simulation project and to run them
while other project parts keep running, the Editable mode can be the best choice. It gives you
maximum flexibility.
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The properly chosen runtime editing mode for a project saves time when you create and run
your simulations in Sentaurus Workbench.

Concurrency Mode for Experiments

The order in which projects are scheduled for execution is defined by node dependencies (see
Running Projects From the Scheduler on page 146). This approach guarantees the most
effective project execution because Sentaurus Workbench immediately submits all nodes that
are ready for execution, that is, all their prerequisite nodes have been executed already. Most
simulation projects are scheduled in an order that is close to a stepwise order. This is a typical
node dependency scheme where a node depends on a previous node of the same experiment.

However, in some cases, you might want to change this predefined project execution order.
Sentaurus Workbench allows you to do this by setting a concurrency mode for experiments in
the Run Project dialog box in the Concurrency Mode field:

■ Unlimited: Default. Sentaurus Workbench uses the standard job-scheduling approach. In
general, all project experiments run simultaneously, and you observe a stepwise execution
order (see Figure 67 on page 149).

■ Limited: You specify the maximum number of running experiments that can be executed
simultaneously. Sentaurus Workbench ensures this limit is respected during the entire
project execution. This number must be between 1 and , where  is the total number
of experiments. The default is 1, which gives you a strict experiment-wise project execution
order (see Figure 68 on page 151).

By default, Sentaurus Workbench uses the Unlimited concurrency mode.

To change the mode:

1. Choose Edit > Preferences or press the F12 key.

2. In the SWB Preferences dialog box, expand Scheduler > General Settings.

3. Set Default Concurrency of Running Experiments to Limited.

4. Click Apply.

NOTE You cannot change the concurrency mode of an already running project.
To change it, you must stop the project and rerun it in the required mode.

Although the Unlimited concurrency mode generally leads to a stepwise execution order, it is
not a fully strict stepwise order. For example, if your project has nonstandard node
dependencies, these dependencies can affect the execution order.

N 1– N
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The Limited concurrency mode allows your project to be executed in an experiment-wise
manner. However, this can affect the overall project scheduling performance. 

Figure 68 Run Project dialog box with Limited selected as the concurrency mode

In the Unlimited concurrency mode, only node dependencies should be fulfilled, and ready
nodes are immediately submitted. In the Limited concurrency mode, Sentaurus Workbench
does not execute nodes despite that they are ready to run, so as to respect the given limitation.
This approach is much less effective than the Unlimited concurrency mode. Typically, the
difference in the overall project execution time between these two modes increases with the
number of steps in the Family Table view. The more steps you have, the longer it takes to
execute the project.

If a project has nonstandard node dependencies, it can lead to exceeding the maximum number
of running experiments in the Limited concurrency mode. For example, assume a node depends
on all the nodes in the previous step. Such a dependency requires that all experiments are
executed up to the current step. Sentaurus Workbench can prevent a deadlock in such a
situation by executing a larger number of experiments, which might temporarily exceed the
given limit.

NOTE You cannot use the Limited concurrency mode when run limits are set
(see Defining Run Limits on page 155).
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Auto-Allocation of CPUs for Parallel Jobs on Clusters

Sentaurus Workbench supports job execution on several job scheduling systems (clusters or
farms) (see Chapter 11 on page 215). Typically, these schedulers provide an infrastructure for
executing parallel jobs. However, the schedulers need information regarding the number of
requested parallel slots (CPUs) for the parallel jobs during the submission of the job to the
cluster.

Sentaurus Workbench allows for automatically synchronizing the number of requested parallel
slots between a simulation job and a scheduler.

Sentaurus Workbench follows these steps for each node you launch on a cluster:

1. Preprocesses the node (if needed).

2. Inspects the node command file and identifies parallelization-specific keywords that might
depend on the tool syntax.

3. Checks the command-line arguments in the tool properties (some tools support command-
line options specifying the number of CPUs for parallelization).

4. Inspects the input TDR files (some tools store parallelization keywords there).

5. Considers the highest of all found numbers as the required number of threads.

6. Submits the job for execution on a chosen scheduling queue of the cluster. The number of
parallel slots (CPUs) to allocate is communicated to the cluster using the resource
requirements part of the job submission command.

NOTE Only multithreaded parallel jobs are supported. Multiple CPUs are
allocated on the same host.

Sentaurus Workbench supports auto-allocation of CPUs for the following tools:

■ Sentaurus Band Structure

■ Sentaurus Device

■ Sentaurus Device Electromagnetic Wave Solver (EMW)

■ Sentaurus Device QTX (Subband-BTE solver)

■ Sentaurus Interconnect

■ Sentaurus Mesh

■ Sentaurus Process

■ Sentaurus Topography 3D
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Sentaurus Workbench supports auto-allocation of CPUs for the following batch clusters:

■ IBM Platform LSF

■ Univa Grid Engine

■ Oracle Grid Engine

■ TORQUE Resource Manager

■ Runtime Design Automation NetworkComputer

By default, the auto-allocation of CPUs for parallel jobs is switched off in Sentaurus
Workbench. To switch it on, add the following instructions to the tool database:

set WB_tool(sprocess,parallel,mode) tool
set WB_tool(sdevice,parallel,mode) tool
set WB_tool(sinterconnect,parallel,mode) tool
set WB_tool(sptopo3d,parallel,mode) tool
set WB_tool(emw,parallel,mode) tool
set WB_tool(snmesh,parallel,mode) tool
set WB_tool(sband,parallel,mode) tool
set WB_tool(sbte,parallel,mode) tool

To deactivate the auto-allocation capability for a certain tool, either change the corresponding
instruction to user or delete the instruction from the tool database, for example:

set WB_tool(sdevice,parallel,mode) user 

Be careful with thread-related instructions in the case of Sentaurus Process split nodes.
Sentaurus Process stores thread-related settings in a TDR file. If you want to change the
number of requested CPUs for a job explicitly, ensure that the input TDR file does not contain
other thread-specific instructions inherited from previous nodes.

Table 8 Sentaurus Workbench behavior when submitting parallel jobs

Tool database setting Result

set WB_tool(<tool>,parallel,mode) tool Thread synchronization is switched on.
Sentaurus Workbench detects the required number of CPUs 
to allocate and submits a job with the required allocation of 
CPUs.

set WB_tool(<tool>,parallel,mode) user Thread synchronization is switched off.
Sentaurus Workbench does not analyze the tool command file 
and submits a serial job.

– Thread synchronization is switched off.
Sentaurus Workbench does not analyze the tool command file 
and submits a serial job.
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For example, the following Sentaurus Process code executes in four nodes with assessed
multithreading requirements as 4, 8, 8, and 8 corresponding to the numThreadsMC value in the
third node:

...
math numThreads=4
...
#split @implant@ 
...
math numThreads=1
math numThreadsMC=8
...
#split @mask@ 
... 
math numThreads=1
math numThreadsMC=1
...
#split @temp@ 
...
math numThreads=2
math numThreadsMC=2
...

If you want the last two nodes to execute with one and two threads, you must change the
numThreadsMC value in the last two splits:

...
#split @mask@ 
... 
math numThreadsMC=1
...
#split @temp@ 
...
math numThreads=2
...

NOTE For complex process flows, it is recommended to split the flow into
simpler parts with definitive multithreading requirements. Otherwise,
Sentaurus Workbench might provide an unexpected assessment of the
resource requirements.

Limiting the Number of Threads Requested

The auto-allocation capability might lead to requesting too many threads to be allocated, which
can potentially exceed the limit provided by the hardware. To prevent such a situation, you can
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specify the maximum number of threads to be allocated, on a per-tool basis, by modifying the
following settings in the tool database:

set WB_tool(sprocess,parallel,tool_cmd) {tool_check_mt $wdir @node@ @commands@ 0}

set WB_tool(sdevice,parallel,tool_cmd) {tool_check_mt $wdir @node@ @commands@ 0}

set WB_tool(sinterconnect,parallel,tool_cmd) {tool_check_mt $wdir @node@ @commands@ 0}

set WB_tool(sptopo3d,parallel,tool_cmd) {tool_check_mt $wdir @node@ @commands@ 0}

set WB_tool(emw,parallel,tool_cmd) {tool_check_mt $wdir @node@ @commands@ 0}

set WB_tool(snmesh,parallel,tool_cmd) {tool_check_mt $wdir @node@ @commands@ 0}

set WB_tool(sband,parallel,tool_cmd) {tool_check_mt $wdir @node@ @commands@ 0}

set WB_tool(sbte,parallel,tool_cmd) {tool_check_mt $wdir @node@ @commands@ 0}

The last argument specifies the maximum number of threads to be requested. If the number of
threads detected by the auto-allocation algorithm exceeds this number, the algorithm will be
restricted to this number. The value 0 means that no restriction applies to this tool.

For example, the following setting ensures that the auto-allocation capability will never request
more than 16 threads for Sentaurus Process:

set WB_tool(sprocess,parallel,tool_cmd) {tool_check_mt $wdir @node@ @commands@ 16}

NOTE This restriction applies only if the auto-allocation capability is switched
on for a given tool.

Defining Run Limits

Sentaurus Workbench helps you to organize effective use of both available TCAD Sentaurus
licenses and corporate computational resources for a group of users sharing the same
installation of TCAD Sentaurus. This goal is achieved by controlling the maximum number of
simultaneously running simulations of a certain tool by a user. Hereafter, this maximum
number is referred to as run limits.

NOTE You cannot use run limits together with the Limited concurrency mode
(see Concurrency Mode for Experiments on page 150).

Defining the User Quota

The following example illustrates how run limits are taken into account when running
simulations. Assume you want to run no more than four Sentaurus Process instances
simultaneously. When the next Sentaurus Process job is ready to be submitted, Sentaurus
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Workbench checks the number of your currently running Sentaurus Process jobs. When this
number is less than four, Sentaurus Workbench submits this job. Otherwise, the job is not
submitted and remains in a ready status until the next free job slot to run the simulation.

Sentaurus Workbench allows a flexible definition of run limits (see Run Limits Settings on
page 196). The simplest case is defining constant run limits for certain tools. You can go further
and define a run limits timetable where run limits depend on the day of the week, the time of
the day, holidays, and so on. With the timetable approach, TCAD users can establish a flexible
and dynamic run limits schedule taking into account resource availability.

Depending on corporate resource-sharing strategies, you can define run limits on a centralized
level (global or site) or allow users to apply their own run limits on the user level. As a TCAD
installation administrator, you have full control over run limits settings. When needed, you can
prohibit redefinition of global run limits on a user level. You can modify run limits at any time
without interrupting already running projects. Run limits restrictions that are agreed upon and
applied inside a group provide a fair distribution of available licenses between users, as well as
the possibility of the temporary concentration of available resources for urgent work.

Sentaurus Workbench calculates the number of currently running simulations of a certain tool
on a user-based mode. All the simulations that you launch in Sentaurus Workbench are taken
into account. The number of currently running jobs is controlled by the daemon process
swblm, which runs in the background. Before submitting a simulation job, Sentaurus
Workbench checks with swblm as to whether the number of currently running jobs of the same
type exceeds the allowed maximum number and, if not, Sentaurus Workbench submits the job.

When all available job slots are occupied, Sentaurus Workbench tries to resubmit a job in case
an available slot appears. You can set up a maximum number of times that Sentaurus
Workbench tries to resubmit a job. After that number is reached, Sentaurus Workbench can
either report the job as failed (default behavior) or proceed with the job submission ignoring
the run restrictions.

NOTE Run limits are defined as the maximum number of slots for a given tool
to run simultaneously. It is not related to the number of specific licenses
the tool checks out at runtime.

Run limits are switched off by default, which means that no restrictions are applied. To activate
run limits, they must be specified in the global, site, or user run limits files (see Run Limits
Settings on page 196).

NOTE Only those simulations you launch from Sentaurus Workbench are taken
into account by run limits control in Sentaurus Workbench. If you
launch a tool outside of Sentaurus Workbench, for example, on the
command line, Sentaurus Workbench is not aware of this job.
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Run limits defined on a centralized level (global or site) or on user levels specify a user quota.
Sentaurus Workbench ensures that you do not exceed your user quota when running your
simulation projects.

Defining Project Run Limits

Another important aspect of organizing effective use of available TCAD Sentaurus licenses
and corporate computational resources is the ability to partition your user quota among
different projects that you want to run simultaneously. By default, Sentaurus Workbench does
not control how the user quota is distributed among projects. If you launch several projects
simultaneously, your user quota might be reached in a single project run, while other running
projects must wait until a free slot becomes available.

Sentaurus Workbench allows you to control how your run limits quota is partitioned among
your projects by setting up optional project run limits.

Project run limits are additional restrictions that affect only a given project and can be defined
only if the user quota has been configured (see Defining the User Quota on page 155).

When launching a project, you specify project run limits directly in the Run Project dialog box
(see Figure 69 on page 158). If you do not see the project run limits part of the dialog box, click
the Show Project Run Limits button.

NOTE Only tools with the defined user quota are available for setting the
project run limits in the Run Project dialog box.

By default, the project run limits are switched off. All tools in a project have the default project
run limits of 0, which means that no restrictions on the project level apply. In this case, the
number of simultaneously running tools is defined exclusively by the user quota.

If you want to set up a project run limits for specific tools, type the appropriate limits in the
corresponding entries, using 0 for other tools. In general, specify project run limits as follows:

■ 0: You do not want to limit this tool in the current project.

■ Not 0: You want to limit the number of concurrently running instances of this tool in the
current project to the given number. For low-priority projects, you would specify a smaller
number than for high-priority projects. The minimum value is 1. The maximum number is
set by the corresponding user quota defined by the run limits on the global, site, or user
level.
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NOTE If you specify project run limits that exceed the corresponding user
quota, the user quota takes effect. Regardless of what you specify for
project run limits, Sentaurus Workbench ensures that the user quota is
not exceeded. 

Figure 69 Run Project dialog box with options for project run limits shown

The project run limits are stored in the Sentaurus Workbench project and are applied to this
specific project only. The next time you launch the project, you will see a dialog box that
requires confirmation as to whether you want to use the same project run limits as you used on
the previous run. You can change or remove the project run limits by specifying 0 for all tools.

The project run limits take effect during the overall project execution. However, you can
change the project run limits of a running project in one of the following ways:

■ If you plan to submit additional project nodes for execution:

Select those nodes and click Run. Change the project run limits in the Run Project dialog
box and click OK to launch the selected nodes.

Sentaurus Workbench launches the selected nodes and applies the new project run limits.

■ If you do not want to submit additional project nodes for execution:

Select any node and click Run. Change the project run limits in the Run Project dialog box
and click Apply Run Limits Only.
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Sentaurus Workbench sends the new project run limits to the running project (see
Figure 70).

NOTE It might take some time until the new project run limits take effect for a
running project, in case you decided to lower the previously specified
project run limits. Sentaurus Workbench does not interrupt already
running jobs. New project run limits are applied as soon as possible, that
is, when some of the running jobs are finished. 

Figure 70 Changing the run limits of a running project in the Run Project dialog box

Changing the Order of the Execution of Nodes

NOTE This feature is available only if run limits are active. When run limits are
not active, use the concurrency mode to access the same functionality
(see Concurrency Mode for Experiments on page 150).

When there are no node dependencies or there is a choice as to which nodes to run first, you
can specify how Sentaurus Workbench should submit nodes. You can choose from the
following node orders:

■ Depth_First: Sentaurus Workbench tries to complete the current experiment and then
proceeds to the next experiment.
Sentaurus™ Workbench User Guide 159
N-2017.09



7: Running Projects 
Delaying the Execution of Projects and Nodes
■ Breadth_First: Sentaurus Workbench tries to execute as many experiments as possible.
This is the default.

To change the order of submitted nodes:

1. Choose Edit > Preferences or press the F12 key.

2. In the SWB Preferences dialog box, expand Scheduler > General Settings.

3. Set Nodes Running Order Under Run Limits to Depth_First.

4. Click Apply.

When a project has node dependencies (which is the case for most Sentaurus Workbench
simulation projects), you will not see a difference between the different node orders because
node dependencies take priority and define the node submission order.

Delaying the Execution of Projects and Nodes

The Delayed Execution button on the Run Project dialog box allows you to define the time at
which a project or selected nodes are submitted (see Figure 71). 

Figure 71 Delayed Project Run dialog box

Sentaurus Workbench preprocesses launched nodes immediately, while nodes submission is
suspended until the given time. By default, the Delayed Project Run dialog box populates the
fields with the current date and time, that is, nodes are submitted immediately.

Delayed execution in Sentaurus Workbench has some limitations as follows:

■ You cannot submit multiple node groups with a different submission time.

■ Sentaurus Workbench does not mark nodes waiting for submission with a specific status
(or color), so it might be difficult to distinguish such nodes without analyzing of the project
submission log file (glog.txt).
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Given that the main goal of delayed execution is to optimize the use of available computational
resources and TCAD Sentaurus licenses, it is highly recommended to use a dynamic run limits
schedule to maximize flexibility (see Defining Run Limits on page 155).

Configuring a Delay Between Simulations

You might have a situation where node execution fails unexpectedly because the simulation
process cannot source some input files. For example, the TDR file stored on the previous node
cannot be loaded for the next node. Such a problem could appear on slow (or busy) network
file systems, which require more time to synchronize file content between file servers.

To configure a delay between simulations:

1. Choose Edit > Preferences or press the F12 key.

2. In the SWB Preferences dialog box, expand Scheduler > General Settings.

3. Set Delay After Simulation (msec) to the time to wait after completing the simulation.

4. Click Apply.

The longer the delay, the less likely a node failure will occur.

NOTE A correctly configured network file system does not require such fine-
tuning.

Protecting Executed Nodes

When working with a large project, you might accidentally select and submit nodes that have
been completed already, which will delete the previous results. Such an error might cost
substantial time and computational resources.

Sentaurus Workbench provides a mechanism to protect executed nodes with the done status
from being rerun. By default, this mechanism is switched off.

To protect executed nodes:

1. Choose Edit > Preferences or press the F12 key.

2. In the SWB Preferences dialog box, expand Scheduler > General Settings > Protecting
of Done Nodes.

3. Set Allow Rerun Done Nodes to No.

4. Click Apply.
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With this protection, Sentaurus Workbench does not launch completed nodes with the done
status. At the bottom of the project log file (glog.txt), Sentaurus Workbench prints a
summary that includes nodes that did not start because they had the done status:

SCHEDULING REPORT
+++ done: 10 11 13 22 23 25
+++ protected: 12 24

The only way to rerun completed nodes is to clean them up explicitly (see Cleaning Up the
Output of Nodes on page 172).

You can set up a notification to inform you when you try to submit done nodes before the
execution starts.

To switch on this notification:

1. Choose Edit > Preferences or press the F12 key.

2. In the SWB Preferences dialog box, expand Scheduler > General Settings > Protecting
of Done Nodes.

3. Set Show Warning if No Rerun Allowed to Yes.

4. Click Apply.

A warning message appears only if protection for executed nodes is switched on.

Protecting executed nodes does not prevent these nodes from being preprocessed. In general,
it might lead to inconsistency between the preprocessed node command file and the actual
simulation results. To ensure overall consistency, consider activating project consistency
control (see Project Consistency Control on page 102).

Preprocessing Projects

Preprocessing is the initial step before jobs actually run and can be performed separately from
execution either from the GUI (choose Project > Operations > Preprocess or press Ctrl+P)
or from the command line (call the Sentaurus Workbench preprocessor (spp utility)).

NOTE The spp utility is executed as a separate process from the GUI, and the
result of spp is stored in the file preprocessor.log, which can be
accessed by choosing Project > Logs > Preprocessor.

You can preprocess multiple selected projects from the projects browser.
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The spp utility preprocesses the given tool input file to standard output or performs a global
preprocessing pass in a project, for example:

spp "BOR_IMPL_ENRGY80" "N_DOSE1e15" @STDB@/nmos,process/lig.cmd
spp -verbose @STDB@/nmos,process
spp -expr "scnr_name" @STDB@/nmos,process 

Terminating Projects and Nodes

You can terminate projects and nodes as required.

Terminating Projects

You can terminate a running project from the Project Editor or the projects browser.

To terminate a project from the Project Editor:

1. Select a project.

2. Double-click the selection, or right-click and select Open.

The project opens in running mode.

Table 9 Command-line options of spp

Option Description

-e[xpr] Preprocess based on an expression.

-h[elp] Displays help information.

-i[nput] Generates all of the initial, preprocessed pp* files in project.

-n[odes] Preprocess just these nodes.

-onlytcl Preprocess only Tcl blocks in command files.

-p[ack] Does not generate empty lines while preprocessing.

-v[ersion] Displays version information.

-verbose Displays additional initialization and runtime information.

Arguments

FILENAME Marked tool input file.

PROJECT Project directory.
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3. Choose Project > Operations > Abort, or press Ctrl+T, or click the corresponding toolbar
button.

4. Confirm that the project is to be terminated.

To terminate a project from the projects browser:

1. Select a project.

2. Choose Project > Operations > Abort, press Ctrl+T, or right-click and select Project >
Abort.

3. Confirm that the project is to be terminated.

NOTE You can terminate multiple selected projects from the projects browser.

Terminating Nodes

You can terminate specific running nodes in a project from the Project Editor, the Scheduler,
or the command line.

To terminate a running node from the Project Editor:

1. Select a project.

2. Double-click the selection, or right-click and select Open.

The project opens in running mode.

3. Select a node.

4. Choose Nodes > Abort, press Ctrl+T, or right-click and select Abort, or click the
corresponding toolbar button.

5. Confirm that the node is to be terminated.

To terminate a running node from the Scheduler:

1. Select a node from the right pane of the Scheduler, which displays the current list of
running nodes.

2. Choose Nodes > Abort, press Ctrl+T, or right-click and select Abort.

3. Confirm that the node is to be terminated.

NOTE If you want to terminate the entire project, it is more efficient to
implement that at the project level (see Terminating Projects on
page 163) rather than selecting all the project nodes and terminating
them.
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Unexpected Termination of Running Projects

If the terminal from which Sentaurus Workbench was launched is closed or crashes, it might
lead to the unexpected termination of Sentaurus Workbench and the running projects you
launched in this Sentaurus Workbench instance. In this case, gsub processes receive the signal
to terminate from the operating system.

If closing the terminal is inevitable and you must terminate running projects, you can force
Sentaurus Workbench and gsub to run in a daemon mode by setting the environment variable
SWB_DAEMONIZE to 1:

setenv SWB_DAEMONIZE 1

This will launch Sentaurus Workbench and the gsub processes that are disconnected from the
parent terminal process from where you launched Sentaurus Workbench. As a result, your
running projects will be completed even if the terminal process crashes or is terminated.

Updating Node Statuses and Extracted Variables

Sentaurus Workbench updates the node statuses of running projects and extracts simulation
results automatically as soon as the node status changes.

Simulation results are extracted from a node output file as soon as the simulation is completed.
However, for long-running simulations, it might be helpful to see completed results before the
simulation itself is finished. You can force the status updating of all project nodes as well as
the values of extracted variables at any time. In this case, Sentaurus Workbench reads the
statuses of nodes and the values of extracted variables from the project files.

To update the status of nodes at any time:

■ Choose View > Refresh or press the F5 key.

NOTE You should refresh project nodes rather than reload the project when
you need to monitor the progress of running projects. Refreshing the
status of nodes is much faster than reloading a project.
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Customizing the Execution of Projects and Nodes

You can customize the execution of projects and nodes.

Customizing Project Execution

Sentaurus Workbench allows you to customize project execution by defining optional prologue
and epilogue Tcl scripts in the tool database. The syntax is:

set WB_tool(gsub,prologue) { ... arbitrary Tcl script ... }

set WB_tool(gsub,epilogue) { ... arbitrary Tcl script ... }

The prologue Tcl script is evaluated at the beginning of the execution session when you launch
the project (start of gsub process). The epilogue Tcl script is evaluated at the end of the
execution session (end of gsub process).

The prologue script can be useful to prepare for project execution, for example, to clean up the
disk space, while the epilogue script can be used for user-specific report generation on an
executed project.

Customizing Node Execution

A similar approach to project execution can be used to customize node execution. Sentaurus
Workbench allows you to customize node execution by defining tool-specific prologue and
epilogue Tcl scripts in the tool database. The syntax is:

set WB_tool(<tool>,prologue) { ... arbitrary Tcl script ... }

set WB_tool(<tool>,epilogue) { ... arbitrary Tcl script ... }

For example, the prologue and epilogue Tcl scripts defined in the tool database for Sentaurus
Mesh (snmesh) are:

set WB_tool(snmesh,prologue) { snmesh_prologue $wdir @node@ @commands@ @tdr@ 
@tdrboundary@ }

set WB_tool(snmesh,epilogue) { extract_vars "$wdir" @stdout@ @node@ }

Both prologue and epilogue scripts are optional.

If you define a tool prologue Tcl script, Sentaurus Workbench evaluates it immediately before
the node simulation task starts.
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You can define an epilogue script for almost all supported tools. If you define a tool epilogue
Tcl script, Sentaurus Workbench evaluates it immediately after the node simulation task
finishes only if the node is successful (node status is done). However, you can instruct
Sentaurus Workbench to evaluate a tool epilogue Tcl script for failed and terminated simulation
tasks as follows:

1. In the SWB Preferences dialog box, expand Scheduler > General Settings.

2. Set Run Epilogue on Failed and Aborted Nodes to true.

3. Click Apply.

NOTE Be careful when redefining tool prologue and epilogue Tcl scripts in the
tool database. The best practice is to append your Tcl commands to the
end of the existing Tcl script (if any).

Viewing Project Files

To view a project log file:

1. Select a project.

2. Choose Project > Logs > Project, press Ctrl+J, or right-click and select Project > View
Log.

To view a project history file:

1. Select a project.

2. Choose Project > Logs > History, press Ctrl+H, or right-click and select Project > View
History.

Viewing the Project Summary

The project summary provides a short description of a project that was run. The summary file
is stored under gsummary.txt in the project directory and is generated automatically when
the project finishes.

To view the project summary:

■ Choose Project > Properties > Summary or press Ctrl+Y.
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The following information is provided in this file:

■ Project details:

• Current status 

• When the last modification occurred

• Who modified the file

• On which host it was run

■ Total number of nodes: active nodes and virtual nodes

■ Nodes by status: list of nodes sorted by status

■ Hosts and execution information followed by a list of hosts and runtime on each host and
number of nodes executed

■ Total runtime

Recognizing Suspended Jobs

For some TCAD Sentaurus simulators, such as Sentaurus Process and Sentaurus Device, you
can suspend and resume their execution.

Sentaurus Workbench can recognize suspended jobs that were launched from Sentaurus
Workbench locally or remotely. Information is communicated to users in the project execution
log file (glog.txt), for example:

Node 50 has been SUSPENDED

Suspended nodes are displayed with a red pause icon in the lower-left corner of the node cell
(see Figure 72). 

Figure 72 Icon indicating that node has been suspended: second cell under LDD_Dose 
column
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As soon as you resume a suspended job, Sentaurus Workbench recognizes it and provides the
following output to the project execution log file and removes the icon from the node cell:

Node 50 has been RESUMED

NOTE Sentaurus Workbench does not allow you to suspend and then to resume
running nodes.
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CHAPTER 8 Cleaning Up Projects

This chapter describes how to clean up projects from the graphical
user interface or from the command line.

Cleaning Up Projects

You can clean up multiple selected projects from the projects browser.

To clean up a project:

1. Choose Project > Operations > Clean Up or press Ctrl+L.

The Clean Up Options dialog box is displayed. 

2. Select the required options: 

Option Description

Preprocessor Data
    Preprocessed Files
    Set Variables

Deletes preprocessor data. Forces preprocessing before running a project:
Deletes all preprocessor files (pp*).
Deletes variables set by preprocessor from gvars.dat.

Simulation Data
    Output Files
    Extracted Variables

Deletes data remaining after simulation:
Deletes all output files (n<nkey>*, pp<nkey>*, and so on).
Deletes extracted variables from gvars.dat.
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3. Click Cleanup or Fast Cleanup.

NOTE The Fast Cleanup button initiates a faster project cleanup, which is
especially noticeable on large projects with many files. The original
project directory is removed and then is re-created during this type of
cleanup. Therefore, it is highly recommended to close all other
applications that are working with project files to avoid unexpected
errors or possible loss of data.

Cleaning Up the Output of Nodes

To delete the output and preprocessor data of selected nodes:

1. Select nodes (see Selecting Nodes With Mouse and Keyboard Operations on page 40).

2. Choose Nodes > Clean Up Node Output.

3. Select whether you want to delete simulation-extracted variables from gvars.dat.

4. Select whether you want to delete preprocessed variables from gvars.dat.

5. Select output and preprocessor files to be deleted.

All output and preprocessor files associated with the selected nodes are preset.

6. Click OK.

Project Data
Log Files

Backup Files
Reset Project Status
Renumber the Tree

Deletes data on the project level (in the project directory):
Deletes project log files (glog.txt, gsummary.txt, 
preprocessor.log, .history, and so on).
Deletes the subdirectory .backup inside the project directory.
Deletes project status file (.status).
Renumbers the tree.
The Renumber the Tree option is available only if all the options under 
Preprocessor Data and Simulation Data are selected.
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Cleaning Up Projects From the Command Line

The gcleanup utility can clean up a project from the command line, for example:

gcleanup -default /folder/project 

Detecting Files to Remove

The default Sentaurus Workbench cleanup scenario detects a reproducible part of a project and
removes it. All files that appear as the result of project preprocessing and execution are
considered to be reproducible files.

Table 10 Command-line options of gcleanup

Option Description

-back Clean up backup files.

-d[efault] Switches on the following options:
-back, -log, -pp, -res, -sv, -xv, -unlock

-f[ast] Perform fast cleanup.
CAUTION The original project directory is removed and then is recreated. You 
should close all other applications that are working with project files to avoid 
unexpected errors or possible loss of data.

-h[elp] Display help information.

-log Clean up log files.

-n "node list" Clean up given nodes only.

-pp Clean up preprocessed files.

-ren Renumber; automatically switches on the following options:
-pp, -res, -sv, -xv

-res Clean up output files.

-sv Clean up set variables.

-unlock Delete the project status file.

-v[ersion] Display version information.

-verbose Display additional information.

-xv Clean up extracted variables.

Arguments

PROJECT Project directory.
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To detect files to remove from a project and at node levels, Sentaurus Workbench uses cleanup
patterns declared in the tool database. Reproducible node files are set up for each tool. For
example, the following line sets up output file patterns for Sentaurus Device nodes:

set WB_tool(sdevice,output,files) "n@node@_* pp@node@_* *_n@node@_*"

Node files are removed during the overall project cleanup and the cleanup of selected nodes.

Specifying Project Exclude File Patterns

Sentaurus Workbench allows you to specify several exclude file patterns. These patterns define
the project files that must be excluded from the project packaging and must be removed during
project cleanup. The default Sentaurus Workbench patterns are:

set WB_tool(garbage_exclude_patterns) ".nfs* core core.*"

set WB_tool(export_exclude_patterns) ""

set WB_tool(cleanup_exclude_patterns) ""

The WB_tool(garbage_exclude_patterns) setting defines the files to appear as the
result of system crashes or the deleting of open files. These files must be removed during
project cleanup and must not appear in exported project packages.

The WB_tool(export_exclude_patterns) setting defines the files not to be included in
the package when you export a project (see Exporting and Importing Projects on page 20).

The WB_tool(cleanup_exclude_patterns) setting defines the files that must be
removed during project cleanup; however, they can be included in exported project packages.

Table 11 summarizes the impact of the project exclude file patterns and the node file patterns
on project export and project cleanup operations. 

Table 11 Pattern settings affecting project operations

Pattern setting Cleanup Export Export as clean

WB_tool(garbage_exclude_patterns) + + +

WB_tool(export_exclude_patterns) – + +

WB_tool(cleanup_exclude_patterns) + – +

WB_tool(<tool>,output,files) + – +
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Backing Up Node Files Automatically

Sentaurus Workbench allows you to back up simulation results automatically. The automatic
backup stores a copy of each node file being deleted after automatic or manual node-level
cleanup under the .backup subdirectory inside the project folder.

The backup feature is switched off by default.

In an emergency, you can restore deleted files by copying them from the project .backup
subdirectory to the project folder.

To switch on automatic backup:

1. Choose Edit > Preferences or press the F12 key.

2. In the SWB Preferences dialog box, expand Safety and set Backup Node Files Before
Deletion to true.

3. Click Apply.

NOTE Automatic project backup takes effect only during node-level cleanup in
Sentaurus Workbench. The node files are not backed up when cleaning
up the overall project.

The Sentaurus Workbench backup system provides a simple one-level
backup only. When a file is being backed up, it overwrites the file with
the same name if that file exists in the .backup subdirectory (such a file
could be saved when cleaning up nodes of another project).
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CHAPTER 9 Configuring Sentaurus Workbench

This chapter discusses how to configure Sentaurus Workbench.

Preferences

Sentaurus Workbench preferences combine different settings that control the appearance and
the overall behavior of Sentaurus Workbench (see Available Preferences on page 182).

Preference Levels

Typically, preferences are configured on the user level. You can configure Sentaurus
Workbench as required. However, in some cases, the systems administrator must configure
some settings on the global level and propagate them to all users of TCAD Sentaurus. This is
especially important for settings related to computational resource sharing, job scheduling, and
the location of standard executables. Therefore, Sentaurus Workbench preferences can be
defined on three levels: global, site, and user.

Global preferences are usually set up by the systems administrator and are not writable. When
your company has multiple groups of users of TCAD Sentaurus, distributed to different sites,
it might be useful to customize global preferences for all users at a specific site. To do this, site
preferences must be created. The global and site preferences are optional.

To create or access the site tool database, set up the following environment variable to refer to
the directory that stores the site settings:

% setenv SWB_SITE_SETTINGS_DIR <path_to_site_directory>

Like global preferences, site preferences are usually not writable.

Sentaurus Workbench stores preference files at:

■ Global level: $STROOT/tcad/$STRELEASE/lib/glib2/gpref2.$STRELEASE.xml 

■ Site level: $SWB_SITE_SETTINGS_DIR/gpref2.$STRELEASE.xml 

■ User level: $STDB/gpref2_<username>.$STRELEASE.xml 

Preferences are release specific. Sentaurus Workbench provides automatic conversion of the
preferences from the existing preference file of the latest available TCAD Sentaurus release.
This conversion is applied separately to the global, site, and user levels. Conversion does not
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trigger saving the preference file automatically. To store the preference file, in the SWB
Preferences dialog box, click Save or Apply.

User preferences override global and site preferences. Site preferences override global
preferences. The hierarchical order is (in descending order):

■ User preferences

■ Site preferences

■ Global preferences

Configuring User Preferences

To configure user preferences:

1. Choose Edit > Preferences or press the F12 key.

The SWB Preferences dialog box is displayed (see Figure 73 on page 179).

2. Select a preference.

3. Type a new value in the text box.

4. Click the Accept Changes button or press the Enter key.

5. Click Apply or Save.
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Figure 73 User settings in SWB Preferences dialog box

Configuring Global and Site Preferences

NOTE You can configuring global and site preferences only if you have write
permission to the corresponding preference file.

To configure global or site preferences:

1. Choose Edit > Preferences or press the F12 key.

The SWB Preferences dialog box is displayed.

2. Select either the Site option or the Global option at the top of the dialog box (see Figure 74
on page 180).

3. Select a preference.

4. Type a new value in the text box.
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5. (Optional) Select the False option for Editable in the upper-right corner of the dialog box
to prohibit changing the new value on lower preference levels.

6. Click the Accept Changes button or press the Enter key.

7. Click Apply or Save.

NOTE Click Apply when switching between user, site, and global preferences
to store your updates in the corresponding preference file. 

Figure 74 Global settings in SWB Preferences dialog box

NOTE XML preference files have a distinct main tag depending on the
preference level: <GlobalPreferences>, <SitePreferences>,
and <UserPreferences>. If you want to use an existing preference
file as a template for another level, you must change the main tag
accordingly.
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Forcing Global Preferences to All Users

The standard hierarchical order of overriding settings can be changed in the site or global
preferences. For each individual preference setting, you can prohibit changing lower
precedence levels. To do this, set the attribute Editable of the required preference setting to
False. This setting takes effect regardless of the corresponding settings at lower levels.

As the TCAD administrator, you might want to propagate certain Sentaurus Workbench
settings to all users and to ensure that users do not change them at the user level. Use this
approach to propagate global preferences at the user level (see Figure 74 on page 180, upper-
right corner of dialog box).

Propagating Default Preferences to Users

As the TCAD administrator, you might want to establish a corporate set of Sentaurus
Workbench settings, so that new users start working with Sentaurus Workbench using your
default settings rather than the Synopsys defaults. To do this, ensure that your new default
settings are specified in the global or site preferences. The standard hierarchical order of
overriding settings applies.

NOTE The changed defaults are propagated only to new users of Sentaurus
Workbench. If a user already has user preferences stored for the current
version or older versions of Sentaurus Workbench, these stored settings
take precedence.

Restoring Default Preferences

To restore the default user settings, run Sentaurus Workbench with the -default command-
line option.

Alternatively, you can remove the user preference file and run Sentaurus Workbench.

NOTE It is highly recommended to store the restored default preferences to
ensure that they take effect when using utilities such as gjob, gsub, and
swbopt.
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Available Preferences

The following tables describe all of the supported Sentaurus Workbench preferences. 

Table 12 Project preferences

Preference Type Default value Description

Consistency Control Specifies Sentaurus Workbench project consistency 
mode and settings.

Actions on Inconsistent
Nodes

Enumeration Nothing Specifies what Sentaurus Workbench does with 
inconsistent nodes. Options are:
• Nothing: Sentaurus Workbench ignores 

inconsistent nodes.
• Clean Up: Sentaurus Workbench automatically 

cleans up ambiguous nodes (this is the most 
critical option and must be used with caution).

• Mark Ambiguous: Sentaurus Workbench 
automatically marks ambiguous nodes with a red 
exclamation mark.

Rerun Ambiguous
Nodes Next Time

Enumeration Never Specifies how Sentaurus Workbench treats marked 
ambiguous nodes. Options are:
• Never: Does not rerun ambiguous nodes.
• Always: Reruns ambiguous nodes.

Safety Setting that helps to recover data that might be lost.

Backup Node Files
Before Deletion

Boolean false Switches on and off automatic backup during node-
level cleanup. Files are saved in the .backup 
subdirectory located in the project directory. This 
functionality takes effect only during manual or 
automatic (project consistency control) node-level 
cleanup.

Export Settings for exporting projects.

Compress Package Boolean true Switches on and off package compression (gzip).

Encrypt Package Boolean true Switches on and off package encryption (openssl).

Encryption Key String swb Specifies default encryption key.

Export Project As Clean Boolean false Switches on and off exporting projects as clean 
projects.

Export Text File: Settings for export data to a text file.

Include Column
Names

Boolean true Switches on and off including column names when 
exporting a DoE table to a text file.

Default Separator String , Selects the default separator when exporting a DoE 
table to a text file.
182 Sentaurus™ Workbench User Guide
N-2017.09



9: Configuring Sentaurus Workbench
Preferences
Organization Settings related to hierarchical project organization.

Convert From 
Traditional Project
Organization:

Default settings for dialog box when converting a 
project from traditional project organization to 
hierarchical project organization.

Convert Command
Files

Enumeration Yes Specifies whether the tool input command files 
should be converted.

Display Changes in
Files

Enumeration Yes Specifies whether to display applied changes versus 
original file in the default diff application.

Display Conversion
Log

Enumeration Yes Specifies whether to display a log file with the 
conversion results.

Existing Result Files Enumeration Relocate Specifies what to do with existing node files. Options 
are:
• Relocate: Moves existing files from the root 

project directory to the nodes hierarchy.
• Remove: Deletes existing node files.

Save Backup Project Enumeration Yes Specifies whether to save a backup copy of the 
traditional project organization before conversion.

GUI Settings for
Hierarchical Mode:

Settings for the main window when Sentaurus 
Workbench is launched in hierarchical mode.

Background Enumeration bisque Background color of the main window of Sentaurus 
Workbench.

Foreground Enumeration System default 
(white/gray)

Foreground color of the main window of Sentaurus 
Workbench.

Settings for
Hierarchical Project
Organization:

Settings that take effect on a project with hierarchical 
organization.

Link Input Files in
Node Folder

Enumeration No Specifies whether to create symbolic links to files in 
the root project directory in each node folder.

Project Output Files
Location

Directory @STDB@ Specifies where to store output files of the project. If 
it is set to @STDB@, output files are stored together 
with core project files. Otherwise, activates the 
separate storage of project files.

Location of
Temporary Node Files

Directory Specifies temporary storage of node files when 
running the project.

Table 12 Project preferences (Continued)

Preference Type Default value Description
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Runtime Editing Mode Settings related to a project configuration.

Settings for Editable
Mode:

Options for Editable mode.

How to run nodes
by default

Enumeration Preprocess, then 
run (rewrites 
node input files)

Specifies the default action in the Run Project dialog 
box. Options are:
• Just run, do not preprocess: Runs the node as 

is, without runtime preprocessing. User changes 
made in the node input files (if any) take effect.

• Preprocess, then run (rewrites node input 
files): Initiates runtime preprocessing and runs 
the node. User changes made in the node input 
files (if any) do not take effect.

Default Mode Enumeration Editable Specifies the default runtime editing mode for new 
projects as well as old projects without the mode 
attributes. Options are:
• Locked: Maximum automation and consistency 

level. Running project is locked for changes.
• Editable: Running project is open for changes, 

node-level changes in input files are allowed, and 
all the internal consistency safeguards are 
switched off.

Auto Save Setting for automatic saving of projects.

Project Auto Save
Interval (min)

Integer 0 The interval in minutes for periodical automatic 
saving of the currently opened project. When set to 
0, automatic saving is switched off.

Other Settings Miscellaneous settings.

Polling Interval for
Project Database (msec)

Integer 1000 The interval for periodical querying of the project 
database (.database) when it is locked (busy).

Show Project Log Boolean true Switches on or off the automatic display of the 
Project Log window when a project is launched.

Table 12 Project preferences (Continued)

Preference Type Default value Description
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Table 13 Table preferences

Preference Type Default value Description

Background Enumeration System default 
(white/gray) or 
from 
.Xdefaults 

Background color of table.

Double Click Action

On Nodes Enumeration Launch Explorer Specifies the action when double-clicking nodes. 
Options are:
• Show Properties: Displays the Node 

Information dialog box.
• Launch Explorer: Displays the Node Explorer.
• Run: Displays the Run Project dialog box.
• Preprocess: Preprocesses the current node.
• Edit Cell: Displays an editor that allows you to 

modify a value directly in the node cell.
• Visualize Results: Opens the default visualizer 

for viewing node output files.

On Parameters Enumeration Show Properties Specifies the action when double-clicking 
parameters. Options are:
• Show Properties: Displays the Parameter 

Properties dialog box.
• Add Parameter Value: Displays the Add 

Parameter Values dialog box.
• Remove Value: Displays the Remove Parameter 

Value dialog box.

On Tools Enumeration Show Properties Specifies the action when double-clicking tools. 
Options are:
• Show Properties: Displays the Tool Properties 

dialog box.
• Edit Input File: Opens the corresponding editor 

for tool input command files.

On Variables Enumeration Show Properties Specifies the action when double-clicking variables. 
Options are:
• Show Properties: Displays the Variable 

Properties dialog box where you can change the 
variable value.

• Specify Format: Displays the Formatting 
Variables dialog box.

Edit Value in a Cell Boolean false Switches on value-editing in a node cell.

Foreground Enumeration System default 
(white/gray) or 
from 
.Xdefaults 

Foreground color of table.
Sentaurus™ Workbench User Guide 185
N-2017.09



9: Configuring Sentaurus Workbench 
Preferences
Font Font used in project view and projects browser.

Family Enumeration System default or 
customized font 
selected by user

Specifies the font family to use.

Size Integer – Specifies the font size.

Slant Enumeration roman Specifies slant of the font. Options are:
• roman: Font is not italicized.
• italic: Font is italicized.

Weight Enumeration normal Specifies the weight of the font. Options are:
• normal: Font is not bold.
• bold: Font is bold.

Mouse Wheel Integer 1 Number of experiments moved when moving the 
mouse wheel (if supported).

Node Status Color

List of node statuses Color RGB color code Colors specified as RGB designations for each node 
status.

Parameter

Add Parameter/Value
Defaults:

Specifies defaults for Add Parameter/Values dialog 
box.

Format Enumeration None Default format of new values. Options are:
• None 
• Scientific 
• Float 
• Integer 

Maximum Number 
of Values

Integer 100 Maximum number of values to generate at the same 
time.

Order Enumeration Ascending Default sorting of new values. Options are:
• Ascending 
• Descending 
• Do not sort 

Scale Enumeration User Defined List Default scale (mode) of new values. Options are:
• Linear 
• Logarithmic 
• Gaussian 
• User Defined List 

Table 13 Table preferences (Continued)

Preference Type Default value Description
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Scenario

Remove: What to do with experiments when removing 
scenarios.

Action on
Experiments

Enumeration Keep in the 
Project

Options are:
• Keep in the Project (include in scenario all)
• Delete from Project 

Title

Background Enumeration Gray Background color of table title.

Foreground Enumeration Black Foreground color of table title.

Default View Options Default options when showing the tree.

Check Virtual Nodes Boolean True View > Tree Options > Check Virtual Nodes.

Default Project
Orientation

Enumeration horizontal View > Flow Orientation.

Display Tool Labels Boolean False View > Table Options > Show Tool Labels.

Show Experiment
Numbers

Boolean True View > Table Options > Show Experiment 
Numbers.

Hint Tool Labels Boolean False View > Tree Options > Hinting Tool Labels.

Display Additional
Node Data

Enumeration Parameter Values Options are:
• Parameter Values: Choose View > Tree 

Options > Parameter Values.
• Node Numbers: Choose View > Tree Options > 

Node Numbers.
• Host: Choose View > Tree Options > Host.
• Date: Choose View > Tree Options > Date.
• Execution Time: Choose View > Tree Options 

> Execution Time.
• Variables: Choose View > Tree Options > 

Variables.
• Job Identifier: Choose View > Tree Options > 

Job Identifier.

Show Parameter Tag
Names

Boolean false View > Table Options > Show Parameter Process 
Names.

Display Comments Boolean false View > Table Options > Show Comment.

Show Exp Plan Boolean false View > Tree Options > Show Experimental Plan.

Show Info Titles Boolean false View > Table Options > Show Information Titles.

Show Node Numbers Boolean false View > Tree Options > Show Node Numbers.

Table 13 Table preferences (Continued)

Preference Type Default value Description
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Show Parameters Boolean false View > Tree Options > Show Parameters.

Show Parameter and
Variable Names

Boolean false View > Table Options > Show Parameter and 
Variable Names.

Show Pruned Boolean true View > Tree Options > Show Pruned.

Show Tool Icons Boolean true View > Table Options > Show Tool Icons.

Show Tree Boolean true View > Tree Options > Show Tree.

Show Variables Boolean true View > Tree Options > Show Variables.

Show Merged Cells Boolean true View > Tree Options > Show Merged Cells.

Automatically Update
Variables

Boolean false Variables > Automatically Update Variables.

Table 14 Scheduler preferences

Preference name Type Default value Description

General Settings General settings of the Sentaurus Workbench 
scheduler.

Default Concurrency of
Running Experiments

Enumeration Unlimited Specifies concurrency running mode for 
experiments. Options are:
• Unlimited: Sentaurus Workbench runs all 

experiments concurrently.
• Limited: Sentaurus Workbench runs a limited 

number of experiments concurrently. You can set 
the limit in the Run Project dialog box.

Nodes Running Order
Under Run Limits

Enumeration Breadth_First Specifies the order of running nodes when run limits 
are active:
• Breadth_First: Sentaurus Workbench tries to 

complete an entire parametric step of the 
simulation.

• Depth_First: Sentaurus Workbench tries to 
complete an entire experiment before starting 
another one.

Run Epilogue on Failed
and Aborted Nodes

Enumeration No Specifies whether to launch an epilogue Tcl script if 
the simulation job failed or was terminated. Options 
are Yes or No. Useful for debugging purposes

Delay After Simulation
(msec)

Integer 0 Specifies an optional delay between simulation jobs 
in milliseconds (0: no delay). Useful for slow 
network file systems.

Table 13 Table preferences (Continued)

Preference Type Default value Description
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Protecting of Done
Nodes:

Allow Rerun Done
Nodes

Enumeration Yes Specifies whether already executed nodes with the 
done status can be rerun.

Show Warning if No
Rerun Allowed

Enumeration No Specifies whether to show a warning message if 
users try to run already executed nodes with the done 
status. This option takes effect only if these nodes are 
not allowed to be rerun.

Update Interval of GUI
Scheduler Tab (msec)

Integer 15000 Idle task frequency for updating node statuses in the 
Sentaurus Workbench GUI.

Local Jobs Settings applied to locally submitted jobs.

Job Polling interval
(msec)

Integer 1000 The interval between sequential checks of the status 
of the running job (in milliseconds).

Maximum Number of
Simultaneous Jobs

Integer 1 Maximum number of jobs that can be launched on a 
local machine simultaneously.

Default Nice Level Integer 19 The priority of locally submitted jobs (an argument 
for the UNIX nice command). The range is from 0 
to 19.

LSF Jobs Setting applied to jobs submitted to LSF.

Job Polling interval
(msec)

Integer 1000 The interval between sequential checks of the status 
of the running job (in milliseconds).

Project Name
Command-Line Option

String -P Creates the bsub command in LSF with the -P or 
-J option. The same option also is applied to the 
bjob command.

DMW Jobs Setting applied to jobs submitted to DMW.

Job Polling interval
(msec)

Integer 1000 The interval between sequential checks of the status 
of the running job (in milliseconds).

Default Nice Level Integer 19 The priority of jobs submitted remotely using rsh/ssh 
(an argument for the UNIX nice command). The 
range is from 0 to 19.

SGE Jobs Setting applied to jobs submitted to Oracle Grid 
Engine and Univa Grid Engine, as well as other SGE 
derivatives.

Job Polling interval
(msec)

Integer 1000 The interval between sequential checks of the status 
of the running job (in milliseconds).

Table 14 Scheduler preferences (Continued)

Preference name Type Default value Description
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TM Jobs Setting applied to jobs submitted to the TORQUE 
Resource Manager.

Job Polling interval
(msec)

Integer 1000 The interval between sequential checks of the status 
of the running job (in milliseconds).

RTDA Jobs Setting applied to jobs submitted to the 
NetworkComputer.

Job Polling interval
(msec)

Integer 1000 The interval between sequential checks of the status 
of the running job (in milliseconds).

Table 15 Visualization preferences

Preference name Type Default value Description

Default S-Visual 
Interface

Enumeration Last Used Sets where to visualize selected files. Options are:
• Last Used: In the last-used Sentaurus Visual 

instance.
• Last Created: In the last-launched Sentaurus 

Visual instance.
• New Instance: In a new Sentaurus Visual 

instance.

File Filters Predefined file filters available from the Visualize > 
Sentaurus Visual (Select by Type) menu.

Boundary String *bnd.tdr All Boundary Files.

Mesh String *msh.tdr All Mesh Files.

TDR String *.tdr All TDR Files.

XY-Plot String *.plt, *.plx All XY-Plot Files.

Table 14 Scheduler preferences (Continued)

Preference name Type Default value Description
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Table 16 Utilities preferences

Preference name Type Default value Description

PDF Reader File evince Location of the tool for viewing PDF files.

Internet Browser File firefox Location of browser for viewing the TCAD 
Sentaurus Tutorial (training material).

Diff Tool File tkdiff Location of diff tool executable file.

Editor File sedit Location of text editor executable file. Sentaurus 
Workbench launches it for both viewing and editing 
text files.

Spreadsheet 
Application

File oocalc Location of spreadsheet executable file or tool to use 
when choosing Experiments > Export > Run 
Spreadsheet Application.

Layout Viewer File none Location of layout viewer. If none is specified, no 
layout viewer will be launched.

Terminal File xterm Location of terminal executable file. Sentaurus 
Workbench launches it when opening a command 
prompt in a project directory as a separate shell.

Table 17 Auto Exit When Inactive preferences

Preference name Type Default value Description

Inactivity Time-Out 
(hours)

Number 0 Sentaurus Workbench automatically exits after the 
specifies idle time has lapsed. If 0, no automatic exit 
is activated.

Alert Before Time-Out 
(min)

Number 0 Sentaurus Workbench opens a warning dialog box a 
given number of minutes before it automatically 
exits. You can cancel the automatic exit by clicking 
the mouse or pressing a key in the Sentaurus 
Workbench window.
If set to 0, no warning dialog box opens. This option 
takes effect only if Inactivity Time-Out is not 0.
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Table 18 Miscellaneous preferences

Preference name Type Default value Description

Attach Applications 
Library on Start Up

Boolean true Attaches Applications Library when Sentaurus 
Workbench opens.

Attached Roots on Start 
Up

Root 1 to Root 5 Directory 
(subentries)

Path to 
Applications 
Library

Attached roots when Sentaurus Workbench opens. 
Up to five roots are supported.

Number of Bookmarks Integer 10 Number of last projects visited in Project > Recent 
Projects. The range is from 0 to 200.

Manuals Front Page File Path to manuals Location of front page for Help > Manuals.

Idle Task Frequency Idle task frequency for refreshing (milliseconds).

Automatically Calculate
Refresh Rate

Boolean true When true, calculates the refresh rate automatically.

Explorer Nonnegative 
integer

30000 Projects browser.

Node Refresh Rate Nonnegative 
integer

10000 Status of nodes (when running).

Sentaurus Device 
Material Database

Directory – Path to the MaterialDB file.

Obsolete Tools String List of obsolete 
tools

Comma list of tool names. The tools specified here 
are no longer available in the Add Tool dialog box.

Tailing File Size Integer 1024 Specifies the maximum size of a node output file, 
which should be displayed without tailing (in 
kilobytes). If this size is exceeded, only the tail of the 
file is displayed in Sentaurus Workbench.

Tailing Lines Number Integer 1000 Specifies the number of lines of a node output file to 
be displayed in the tailing mode.

Temp Directory Directory STDB/tmp Location of the temporary directory of Sentaurus 
Workbench.

Training Documentation File – Path to TCAD Sentaurus Tutorial.

SWB Exit Warning Boolean false Asks for a confirmation from the user when closing 
Sentaurus Workbench.
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Tool Databases

All tools are defined in the tool databases of Sentaurus Workbench. The tool databases
(tooldb) are global, site, user, and project.

To access a tool database in Sentaurus Workbench, choose the appropriate command:

■ Edit > Tool DB > Global.

■ Edit > Tool DB > Site.

■ Edit > Tool DB > User.

■ Edit > Tool DB > Project.

Entries in the user tool database complement or override entries in the global and site tool
databases, and entries in the project tool database complement or override entries in the other
tool databases. The hierarchical order is (in descending order):

1. Project tool database

2. User tool database

3. Site tool database

4. Global tool database

Simulation tools are divided into the following categories:

■ Sentaurus Process Simulation, Structure Generation, Interconnect Simulation, Lithography

■ Sentaurus Grid Generation

■ Sentaurus Device Simulation

■ Sentaurus Visualization

Table 19 TWB to SWB Converter preferences

Preference name Type Default value Description

Parameter Name 
Concatenation Symbols

String – Set of symbols (string). When a Taurus Workbench 
parameter under conversion contains spaces, the 
specified set of symbols replaces every space to 
match Sentaurus Workbench requirements (no 
spaces are allowed).

Merge Sequential Tool 
Instances

Boolean false Converts multiple sequential instances of the same 
Taurus Workbench tool into one Sentaurus 
Workbench tool instance by merging several input 
files into one file.
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■ Extraction

■ TCAD to SPICE

■ Utilities

■ Taurus Process and Device Simulation

■ Process Emulation

The order of these categories (from top to bottom) reflects the order in which the corresponding
simulation phases link to each other (apart from the utilities). For example, it is not typical for
a grid generation tool to precede a process simulation tool in the tool flow.

Configuring Tool Databases

The global tool database is usually set up by the systems administrator and is not writable.
Initially, the global tool database contains the complete set of TCAD simulation tools and an
example of the definition of a user tool such as mytool.

If your company has multiple groups of users of the TCAD Sentaurus platform, distributed in
different sites, it might be useful to customize global database settings for all users at a specific
site. To do this, the site tool database must be created. The site tool database is optional.

To create the site tool database:

1. Place your site-specific tool database settings into the tooldb.tcl file stored under an
arbitrary directory.

2. Set up the following environment variable to refer to this directory:

% setenv SWB_SITE_SETTINGS_DIR <path_to_site_directory>

Like the global tool database, the site tool database is usually not writable.

You can add your own tools or modify existing ones by changing the user or project tool
database.

The global, site, and user tool databases are loaded when starting Sentaurus Workbench or any
utilities such as gsub and gjob. You should restart Sentaurus Workbench to ensure that your
changes in these tool databases take effect.

The project tool database is loaded with the project and is applied only to that project. You
should reload the project in Sentaurus Workbench to ensure that your changes take effect.

User functions can be defined in the user and project tool databases. These functions can
customize standard Sentaurus Workbench preprocessing.
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For example, you can extend the standard value extraction algorithm (see Extracted Variables
on page 133). First, create your own extract function in the user or project tool database where
you traverse the output file from_file of the node nkey stored in the project directory wdir,
and extract those values that are not covered by the standard Sentaurus Workbench value
extraction.

The function returns a Tcl list of pairs (name and value). For example, the function can look
like:

proc ::my_extract_func { wdir from_file nkey } {
# extract results from input file
set extracted_results [list]
set in_file [file join $wdir $from_file]
set in_strm [open $in_file r]
while { [eof $in_strm] == 0 } {

set line [gets $in_strm]
# here you look for names and values to extract
# ...
# extracted variable "myVar" has the value stored in the variable "myVal"
lappend extracted_results [list myVar $myVal]

}
return $extracted_results

}

Then, in the same tool database file, redefine the tool epilogue for the required tool. In the case
of Sentaurus Topography 3D, it would look like:

set WB_tool(sptopo3d,epilogue) { extract_vars "$wdir" @stdout@ 
@node@ ::my_extract_func }

The results extracted by these functions are added to the results extracted by the standard
Sentaurus Workbench extraction algorithm. However, if you want to overwrite the default
extraction, include an additional Boolean flag at the end of the extract_vars call in the tool
epilogue:

set WB_tool(sptopo3d,epilogue) { extract_vars "$wdir" @stdout@ 
@node@ ::my_extract_func true }

In this case, only the results that the function extracts appear in Sentaurus Workbench.
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Project Tool Database

Sentaurus Workbench handles the project tool database in a different way to other tool
databases. Global, site, and user tool databases are sourced in a global Tcl namespace. The
project tool database is sourced in a separate Tcl namespace for each loaded project. Use the
following technique when configuring a project tool database:

■ Do not globalize Tcl variables (for example, WB_tool) with the global keyword or the
double-colon (::) prefix. Otherwise, your project-specific settings might affect other
projects.

■ Provide the :: prefix for user-defined functions in a project tool database:

proc ::my_extract_funv {wdir from_file nkey}

■ Use the globalexists function to check whether a Tcl variable has been set up on a
higher hierarchical level of the tool database (global, site, user):

if { [globalexists WB_tool(sdevice,input)] } {
...

}

■ Use the getglobal function to access the value that has been set up on a higher
hierarchical level of the tool database (global, site, user):

set global_tools [getglobal WB_tool(all)]

■ Use the getactual function to access the value that has been set up in a project tool
database or in a higher hierarchical level of the tool database:

set project_tools [getactual WB_tool(all)]

NOTE It is better to use the getactual function rather than the getglobal
function. The getactual function returns the actual value that takes
into account all hierarchies of the tool database.

Run Limits Settings

Run limits are switched off by default, which means that no restrictions are applied. To switch
on run limits, they must be specified on the global, site, or user levels in XML-compatible files.

The systems administrator typically sets up the file runlimits.xml for the global run limits
settings, which is not writable.

When companies have multiple groups of users of TCAD Sentaurus, distributed over different
sites, it might be useful to customize global run limits settings for all users at a specific site. To
do this, the site run limits file must be created. This file is optional.
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To create the site run limits file:

1. Place your site-specific run limits settings into the runlimits.xml file stored under an
arbitrary directory.

2. Set up the following environment variable to refer to this directory:

% setenv SWB_SITE_SETTINGS_DIR <path_to_site_directory>

Like the global run limits settings, the site run limits settings are usually not writable.

The user run limits settings complement the ones defined on the global and site levels. The site
run limits settings complement the ones defined on the global level. The hierarchical order is
(in descending order):

1. User run limits: $STDB/runlimits_<user>.xml 

2. Site run limits: $SWB_SITE_SETTINGS_DIR/runlimits.xml 

3. Global run limits: $STROOT/tcad/$STRELEASE/lib/glib2/runlimits.xml 

When a part of the run limits settings is defined on more than one level, it is overridden in
accordance with the hierarchical order.

You can completely or partially prohibit the overriding of run limits settings on the user and
site levels by defining a corresponding flag in the global run limits settings.

To access a run limits settings, choose the appropriate command:

■ Edit > Run Limits > Global.

■ Edit > Run Limits > Site.

■ Edit > Run Limits > User.

You can define different types of run limits for each tool:

■ Constant run limits, without any specific day or time restriction

■ Weekday run limits (Mon–Fri)

■ Weekend run limits (Sat, Sun)

■ Run limits on specific days of the week (Mon, Tue, Wed, Thu, Fri, Sat, Sun)

■ Run limits on special dates (such as public holidays and vacations)

Run limits must be defined separately for each tool over which you want to have run limits
control. Any combination of different types of run limits can be used. You can bind an arbitrary
number of time frames with different run limits for each tool. The only exception is constant
run limits: No time frames are allowed for this type of run limits.
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Sentaurus Workbench prioritizes the run limits settings in the following way (1=lowest priority
and 4=highest priority):

1. Constant run limits

2. Weekday, weekend run limits

3. Run limits on specific days of the week

4. Run limits on special dates

Optional project run limits are defined in Sentaurus Workbench when launching the project
(see Defining Run Limits on page 155). Sentaurus Workbench stores the project run limits in
a plain text file (runlimits.txt) in the project directory. The file has a very simple structure:

sprocess 5

snmesh 5

sdevice 3

Only those tools that have nonzero project run limits are stored in the file. You can change the
project run limits directly in the runlimits.txt file before you launch a project in Sentaurus
Workbench or on the command line using the gsub command. However, changes to the file
will not take effect if the project is already running.

Format of XML-Compatible Run Limits Settings File

Table 20 on page 199 describes the available tags, their attributes, and the attribute value types
for specifying run limits settings.

NOTE The attribute names and values are case sensitive. All values must be
enclosed in double quotation marks. 
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Table 20 Available tags, their attributes, and attribute value type

Tag Attribute Attribute value type
[Predefined values]

Description

RunLimitsTable Version String
[0.0]

Attribute not used. Reserved for future 
extensions. Use 0.0.

Editable String 
[true, false]

If false, prohibits changing any run 
limits settings on the next levels (site, 
user). Default: true.

RestrictionModel String
[per_user, none]

If none, switches off a run limits quota, 
so that no limits are applied.
If per_user, a run limits quota is 
applied to all user projects.
Default: per_user.

MaxTrials Integer Specifies the maximum number of 
attempts to acquire a running slot.
Default: 17280.

PollInterval Integer Defines the time interval, in 
milliseconds, between two sequential 
attempts to acquire a running slot. 
Default: 5000 ms (5 s).

ProceedAnyway String 
[true, false]

Instructs Sentaurus Workbench how to 
proceed when the maximum waiting 
time has been reached but no running 
slot is available. If false, the job is 
considered to have failed. If true, the 
execution of the job proceeds.
Default: false.

Tool Name String Name of tool.

RunLimit Value Integer Defines the maximum number of 
simultaneously running instances of a 
tool.

TimeSegment Begin Time: HH:MM Time in 00:00–24:001 format.

End Time: HH:MM Time in 00:00–24:001 format. Must be 
later than Begin. Otherwise, values 
will be swapped.
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Holiday Begin Date: DD/MM/[YYYY] Date in 10/07/2017 format. Year is 
optional; if not defined, it means every 
year.

End Date: DD/MM/[YYYY] Date in 28/07/2017 format. Year is 
optional; if not defined, it means every 
year.

Editable String 
[true, false]

Prohibits (false) or allows (true) 
tag editing. Default: true.

Weekdays Editable String 
[true, false]

Prohibits (false) or allows (true) 
tag editing. Default: true.

Weekends Editable String 
[true, false]

Prohibits (false) or allows (true) 
tag editing. Default: true.

Mon Editable String 
[true, false]

Prohibits (false) or allows (true) 
tag editing. Default: true.

Tue Editable String 
[true, false]

Prohibits (false) or allows (true) 
tag editing. Default: true.

Wed Editable String 
[true, false]

Prohibits (false) or allows (true) 
tag editing. Default: true.

Thu Editable String 
[true, false]

Prohibits (false) or allows (true) 
tag editing. Default: true.

Fri Editable String 
[true, false]

Prohibits (false) or allows (true) 
tag editing. Default: true.

Sat Editable String 
[true, false]

Prohibits (false) or allows (true) 
tag editing. Default: true.

Sun Editable String 
[true, false]

Prohibits (false) or allows (true) 
tag editing. Default: true.

1. For TimeSegment tag, only one attribute is mandatory, either Begin or End. If the second attribute is 
omitted, the missing value is generated as follows: 00:00 for Begin attribute and 24:00 for End attribute.

Table 20 Available tags, their attributes, and attribute value type

Tag Attribute Attribute value type
[Predefined values]

Description
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Example 1

Assume you want to define the following run limits for Sentaurus Process (sprocess), which
can be redefined on a user level:

Weekdays:
08:00-17:00: run limit = 10
17:00-22:00: run limit = 30

Nights, weekends, the rest of time: run limit = 80

The following timetable is applicable:
General run limits for tool "sprocess": 80
Weekdays (Mon-Fri): 

08:00-17:00: run limit = 10
17:00-22:00: run limit = 30

This is the run limits settings file that would implement these specifications:

<RunLimitsTable Version="0.0" RestrictionModel="per_user">
<Tool Name="sprocess">

<RunLimit Value="80" />
<Weekdays>

<TimeSegment Begin="08:00" End="17:00"> 
<RunLimit Value="10" />

</TimeSegment>

<TimeSegment Begin="17:00" End="22:00">
<RunLimit Value="30" />

</TimeSegment>
</Weekdays>

</Tool>
</RunLimitsTable>
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Example 2

Assume you want to implement a more complex run limits timetable for Sentaurus Process
(sprocess), which cannot be redefined on a user level:

General: run limit = 20

Weekdays: run limit = 20
08:00-17:00: run limit = 5
18:00-24:00: run limit = 30

Weekends: run limit = 40

Monday: 13:00-14:00: run limit = 10
Tuesday: 15:00-17:00: run limit = 15
Wednesday: 17:00-24:00: run limit = 15
Thursday: 15:00-17:00: run limit = 15
Friday: 15:00-24:00: run limit = 35
Saturday: 00:00-07:00: run limit = 50
Sunday: 20:00-24:00: run limit = 5

Exceptions (for example, vacation):
10 July 2017 – 28 July 2017

General: run limit = 15
17:00-24:00: run limit = 5

1 August every year
General: run limit = 60

This is the run limits settings file that would implement these specifications:

<RunLimitsTable Version="0.0" Editable="false" RestrictionModel="per_user">
<Tool Name="sprocess">

<RunLimit Value="20" />
<Weekdays>

<RunLimit Value="20" />
<TimeSegment Begin="08:00" End="17:00">

<RunLimit Value="5" />
</TimeSegment>

<TimeSegment Begin="18:00" End="24:00">
<RunLimit Value="30" />

</TimeSegment>
</Weekdays>
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<Weekends>
<RunLimit Value="40" />

</Weekends>

<Mon>
<TimeSegment Begin="13:00" End="14:00">

<RunLimit Value="10" />
</TimeSegment>

</Mon>

<Tue>
<TimeSegment Begin="15:00" End="17:00">

<RunLimit Value="15" />
</TimeSegment>

</Tue>

<Wed>
<TimeSegment Begin="17:00" End="24:00">

<RunLimit Value="15" />
</TimeSegment>

</Wed>

<Thu>
<TimeSegment Begin="15:00" End="17:00">

<RunLimit Value="15" />
</TimeSegment>

</Thu>

<Fri>
<TimeSegment Begin="15:00" End="24:00">

<RunLimit Value="35" />
</TimeSegment>

</Fri>

<Sat>
<TimeSegment Begin="00:00" End="07:00">

<RunLimit Value="50" />
</TimeSegment>

</Sat>

<Sun>
<TimeSegment Begin="20:00" End="24:00">

<RunLimit Value="5" />
</TimeSegment>

</Sun>

<Holiday Begin="10/07/2017" End="28/07/2017">
<RunLimit Value="15" />
Sentaurus™ Workbench User Guide 203
N-2017.09



9: Configuring Sentaurus Workbench 
Run Limits Settings
<TimeSegment Begin="17:00" End="24:00">
<RunLimit Value="5" />

</TimeSegment>
</Holiday>

<Holiday Begin="01/08">
<RunLimit Value="60" />

</Holiday>
</Tool>

</RunLimitsTable>

Changing the Run Limits Settings

Sentaurus Workbench automatically recognizes any changes you apply to the global, site, or
user run limits settings. Changes in the corresponding files apply to both already running
projects and projects you will launch after the changes.

You can use this capability when organizing a fair distribution of licenses among your work
group. For example, you can implement a script that monitors the availability of licenses on the
license server (for example, using the lmstat command) and updates the global run limits file
accordingly.
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With Other Tools

This chapter discusses how to use other tools and features from
Sentaurus Workbench.

Creating Symbolic Links to Node Output Files

In some process simulation projects, it can be useful to look for simulation results not by node
number, but by a combination of experiment number, parameter name, or parameter process
name. Sentaurus Workbench allows you to create these symbolic links automatically.

NOTE This feature applies only to process tool steps.

To create symbolic links to node output files:

1. Select a process tool step.

2. Choose Tool > Create Process Output Links.

NOTE The symbolic link is not created when there is a file with the same name.

Process simulators store simulation results in TDR files with the following naming convention:

n<node>_<tool_acronym>.tdr

As the result of automatic linking, all available node output TDR files are linked using the
following symbolic links:

<experiment_number>_<parameter>_<process_name>.tdr

NOTE Sentaurus Workbench allows a node to belong to multiple experiments.
In this case, the first matching experiment number is used to create the
symbolic links.
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Visualizing Response Surface Models

You can visualize a surface corresponding to a response surface model (RSM).

To visualize a response surface model:

1. Run Sentaurus Workbench and open a project containing response values (see Figure 75).

2. Choose Optimization > RSM Visualization.

The RSM Visualization window opens (see Figure 76 on page 207).

3. See Step 1 of RSM Visualization. 

Figure 75 Example of project with parameterization and responses

Step 1 of RSM Visualization

In Step 1 of RSM visualization (see Figure 76), specify the following fields to define the RSM
to be visualized: 

Scenario The scenario in the loaded project that will be used to create the RSM.

X-axis The parameter to be used as the x-axis of the plot.

Y-axis The parameter to be used as the y-axis of the plot.

Z-axis The response to be used as the z-axis of the plot.

Type The type of RSM model (standard or Kriging).

Model The RSM model degree (first order or second order).
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All project parameters that are not assigned to the x-axis or y-axis can be included in the
modeling. 

Figure 76 RSM Visualization - Step 1

If any project parameters or responses have any nonnumeric values, Sentaurus Workbench
specifies their names in the Scenario group box. You cannot include these parameters and
responses in the modeling.
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Including Parameters in the Modeling

To include parameters in the modeling:

1. Select the corresponding check box in the Include column.

2. Specify the fixed value in the Value for Model column.

3. Click Next to continue. 

4. See Step 2 of RSM Visualization.

Step 2 of RSM Visualization

In Step 2 of RSM visualization (see Figure 77), select the values that determine the plot ranges
and the number of points for the parameters attached to the x-axis and y-axis of the resulting
plot. Sentaurus Workbench automatically calculates the minimum and maximum parameter
values from the project data. The default value for the number of points is 30. 

Figure 77 RSM Visualization - Step 2
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Visualization Options

Sentaurus Workbench offers different visualization options to display the RSM. 

Model Information

Click the Model Info button to see information about the model (see Figure 78). 

Figure 78 Model Info dialog box for an RSM

The following information about a model is available: statistics, coefficients, variance,
ANOVA table, and evaluation of the experiments that were used to create the RSM. In addition,
you can use the Evaluation tab to evaluate the model for any combination of parameter values.

Table 21 Visualization options

Option Description

2D Displays an xy plot when one parameter and a response are selected.
When you select two parameters and a response, the response is displayed as a contour plot.

3D Displays a 3D surface.
This is the default setting when you select two parameters and a response.

Boundary Sets the plotting style. Displays the boundaries of the surface.

Contour Sets the plotting style. Displays the surface as a contour plot.
When you select this option, you can specify whether x, y, or the response should be used as 
the contour variable. By default, the response is selected as the contour variable. The 
parameters and the response can be displayed in a logarithmic or linear scale.

Mesh Sets the plotting style. Displays the surface as a mesh plot.

Shade Sets the plotting style. Displays the surface as a shade plot.
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Visualizing the Model

To visualize the model, click the Generate button (see Figure 77 on page 208). 

Figure 79 Example of 2D RSM contour plot visualized in Sentaurus Visual

Taurus Workbench to Sentaurus Workbench Converter

To import a Taurus Workbench project into Sentaurus Workbench:

■ Double-click a Taurus Workbench project folder.

Sentaurus Workbench searches for a file called <projectName>.vfl. If this file exists, you
have a valid Taurus Workbench project and conversion starts.

After that, you must specify the destination path to store the converted project (see Figure 80
on page 211).
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Figure 80 Save Project As dialog box

During conversion, the converter performs the following operations:

■ Generates a new Sentaurus Workbench project.

■ Creates a tool flow according to the existing one inside the Taurus Workbench project.

■ Creates experiments according to the experiment tree structure and the control values in the
Taurus Workbench project.

■ Copies all relevant files such as the mask files and the root wafer file.

■ Creates simulator command files according to instructions that are stored in the different
modules, inside the .vfl file.

■ Saves the Taurus Workbench module names in the Sentaurus Workbench project as tool
comments. 

Figure 81 Taurus Workbench project converted to Sentaurus Workbench project
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Merging Taurus Workbench Tool Instances

In the Taurus Workbench simulation flow, it is common to have multiple sequential instances
of the same tool, for example, Taurus TSUPREM-4. This approach is used for splitting
purposes.

Unlike Taurus Workbench, in Sentaurus Workbench, you usually create one instance of a
process tool with one compound input command file, which has #split preprocessor
instructions inside to separate split parts.

By default, the converter creates a tool flow that is symmetric to the one in the original Taurus
Workbench project. However, Sentaurus Workbench allows you to make an alternative
conversion. This mode is switched off by default.

To activate the alternative conversion:

1. Choose Edit > Preferences or press the F12 key.

The SWB Preference dialog box is displayed.

2. Expand TWB to SWB Converter and set Merge Sequential Tool Instances to true.

3. Click Apply.

In this mode, Sentaurus Workbench merges input files of the sequential instances of the same
Taurus Workbench tool into one input command file of the corresponding Sentaurus
Workbench tool and automatically inserts #split preprocessor instructions into this
compound input file.

NOTE Sentaurus Workbench merges only those input files of the sequential
instances of the same Taurus Workbench tool, which share the same
Taurus Workbench driver name.

Adapting Parameter Names

During the conversion process, the converter analyzes the parameter names used in Taurus
Workbench input files. The converter looks for spaces inside a parameter name and replaces
them with the set of user-defined concatenation symbols. By default, Sentaurus Workbench
uses underscores (_). For example, the Taurus Workbench parameter IMPLANT DOSE is
converted to IMPLANT_DOSE.
212 Sentaurus™ Workbench User Guide
N-2017.09



10: Integrating Sentaurus Workbench With Other Tools
Taurus Workbench to Sentaurus Workbench Converter
To change the default symbol:

1. Choose Edit > Preferences or press the F12 key.

The SWB Preference dialog box is displayed.

2. Expand TWB to SWB Converter and change the symbol for Parameter Name
Concatenation Symbols (see Figure 82).

3. Click Apply. 

Figure 82 Specifying a new default symbol when converting parameter names
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CHAPTER 11 Schedulers

This chapter describes the schedulers used in Sentaurus Workbench.

Scheduling Systems

Parameter studies involving several parameters usually require a large number of simulation
runs. The limited interdependency of the individual simulation steps makes this type of
application an excellent candidate for exploiting coarse-grain parallelism on a network of
workstations.

Sentaurus Workbench offers access to different, more or less sophisticated, backend job
scheduling systems. Access to these systems is transparent. However, the installation and
initialization of a distributed scheduling system is usually a complicated task, as it requires
many conditions to be fulfilled in the network environment. A distributed system is also much
more difficult to troubleshoot than a conventional application.

Sentaurus Workbench provides a unified scheduling approach, by which you can submit jobs
to any scheduler or queue. Each node can be assigned to any queue defined by the systems
administrator in the global queue file or site queue file.

This section provides guidelines to set up, test, and successfully operate the scheduling
facilities of Sentaurus Workbench. Details about installing and configuring the IBM Platform
LSF system, the Oracle Grid Engine system, the Univa Grid Engine system, the TORQUE
Resource Manager system, and the Runtime Design Automation NetworkComputer can be
found in the appropriate vendor manuals.

Supported Schedulers

Sentaurus Workbench supports the following backend execution engines:

IBM® Platform™ LSF (Load Sharing Facility)

IBM Platform LSF offers a wide range of scheduling options and a complete set of
administration tools. LSF is a corporate-size solution to consolidate computational
resources into a cluster. See LSF Scheduler on page 217.
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Oracle Grid Engine (formerly, Sun Grid Engine)

The Sun Grid Engine (SGE) was originally developed by Sun Microsystems as an open-
source batch-queuing system. Now, Univa supports it as the Oracle Grid Engine. There are
several open-source and proprietary derivatives of the Sun Grid Engine, for example, the
Univa® Grid Engine™. Such SGE-based solutions are typically used on a computer farm
or computer cluster, and are responsible for accepting, scheduling, dispatching, and
managing the remote execution of large numbers of standalone, parallel, or interactive user
jobs. In addition, it manages and schedules the allocation of distributed resources such as
processors, memory, disk space, and software licenses. SGE is better suited to large
corporate networks. See SGE Scheduler on page 221.

TORQUE Resource Manager

TORQUE Resource Manager (TM), supported by Adaptive Computing, Inc., provides
control over batch jobs and distributed computing resources. It is an advanced open-source
product based on the original PBS project and incorporates the best of both community and
professional development. See TM Scheduler on page 225.

Runtime Design Automation NetworkComputer™

NetworkComputer (RTDA) is an enterprise-grade high-performance job scheduler,
otherwise known as a batch processing system or a distributed resource management
system (DRMS). It provides a cost-effective solution for distributing an IT workload over
any compute farm (cluster) topology. NetworkComputer can manage farms with many
thousands of processors, with instantaneous workloads in excess of 2 million jobs, and
throughput of millions of jobs per day. RTDA Scheduler on page 227.

Local

The local scheduler executes jobs sequentially on the local machine. It does not require any
special setup and does not produce any scheduling overhead. It is useful for running short
simulations, or setting up and debugging more complex projects.

NOTE DMW is no longer recommended. Use alternatives such as the
TORQUE Resource Manager.

The LSF, SGE, TM, and RTDA systems work on a cluster of heterogeneous workstations
sharing a common file namespace. Therefore, the following conditions are mandatory for their
proper use:

■ Synopsys TCAD simulation software is installed on all of the workstations that will be
used. STROOT is identical (same absolute path) on all workstations. The easiest way to
obtain this is to share (NFS mount) the file system where the Synopsys software is
installed.
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■ The user project space is shared by all participating workstations and accessible through
the same absolute path. Again, the easiest way to obtain this is to NFS mount the file system
where the STDB of the user resides.

■ A global queue definition file and, when necessary, a site queue definition file must be set
up by the systems administrator, who provides the list containing queue names.

LSF Scheduler

Sentaurus Workbench provides an interface to the Load Sharing Facility (LSF) system, which
integrates a cluster of heterogeneous workstations into a single system environment and
provides sophisticated job scheduling policies. It can be used to submit and distribute project
simulation jobs over the local network.

To use LSF, the following conditions must be fulfilled:

1. The local host (the one running Sentaurus Workbench and gsub) is a LSF client or server.

2. On the local host, the LSF binaries are accessible through the environment variable PATH
(add $LSF/bin to your PATH variable before starting Sentaurus Workbench).

3. Synopsys TCAD simulation software is accessible to all LSF server workstations.

4. The project space is accessible to all LSF servers with the same absolute path.

To confirm points 1 and 2, the following two commands should succeed on the local host:

% lsid
IBM Platform LSF Standard 9.1.1.0, Feb 27 2013
Copyright International Business Machines Corp, 1992-2013.
US Government Users Restricted Rights - Use, duplication or disclosure 
restricted by GSA ADP Schedule Contract with IBM Corp.

My cluster name is snps
My master name is snpsemt317

% bqueues
QUEUE_NAME      PRIO STATUS          MAX JL/U JL/P JL/H NJOBS PEND   RUN SUSP
bhigh           100 Open:Active       -    -    -    -     0     0     0     0
vg              100 Open:Active       -    -    -    -     1     1     0     0
normal          100 Open:Active       -    -    -    -     0     0     0     0
nightly_build   100 Open:Active       -    -    -    -     1     1     0     0
ams_cae         100 Open:Active       -    -    -    -     0     0     0     0
bnormal          40  Open:Active       -    -    -    -    28    18    10     0
lost_and_found    1 Closed:Inact      -    0    0    -    22    22     0     0
...
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The gsub utility uses the bsub command to submit jobs to LSF, the bjobs command to track
the job status, and the bkill command to terminate jobs. You can specify additional bsub
command-line options using queue options (see Configuring Scheduling Systems on
page 230).

To execute each node, gsub does not directly submit the corresponding tool command line, but
launches a job wrapper, the gjob utility. The latter updates the job status and locally executes
the prologue tool and epilogue of the corresponding tool as defined in the tool database.

NOTE Tool database settings control which bsub, bjobs, and lsid
commands will be executed. The corresponding settings are
WB_binaries(tool,bsub), WB_binaries(tool,bjobs), and
WB_binaries(tool,lsid).

You can control which command-line option the LSF command bsub uses to link a submitted
job to a specific LSF project name or to LSF job name attributes. By default, LSF uses the –P
option and specifies the LSF project name. Alternatively, you can use the –J option, which
specifies the LSF job name.

To switch to the -J option:

1. Choose Edit > Preferences or press the F12 key.

The SWB Preferences dialog box is displayed.

2. Expand Scheduler > LSF Jobs.

3. Set Project Name Command-Line Option to -J.

4. Click Apply.

You can specify LSF resource requirements on a per-tool basis. Different resource
requirements can be set up for specific tools in a Sentaurus Workbench project. For the syntax
of the LSF resource requirement string, refer to the definition of the -R option of the bsub
command in the LSF documentation.

The per-tool LSF resource requirements can be set up in the Sentaurus Workbench tool
database (on the global, user, or project level) using the syntax:

set WB_tool(<tool_name>,LSF,resource) {<resource_string>}

where <tool_name> is the database name of the tool, and <resource_string> defines the
resource requirements. For example:

set WB_tool(sprocess,LSF,resource) {rusage[sprocess_all=1,sprocess3d_all=1]}
set WB_tool(sprocess,LSF,resource) {rusage[sprocess_all=1||SK_sprocess_all=1]}
set WB_tool(sdevice,LSF,resource) {mem>5000 rusage[sdevice_all=1]}
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The resource requirement string, specified in the tool database, overwrites the one specified in
the LSF queue in the Sentaurus Workbench global or site queue configuration files
(gqueues.dat). For example, when the following LSF queue name is defined in the queue
configuration file:

queue lsf:mylsfqueue "bsub -R \"swp > 5 && mem > 10\" -q normal"

and you run a Sentaurus Process simulation over this LSF queue, the tool-related resource
setting rusage[sprocess_all=1,sprocess3d_all=1] replaces the global setting
swp > 5 && mem > 10.

NOTE Do not specify the -R option for the resource requirement string.
Sentaurus Workbench adds it automatically.

If automatic allocation of CPUs for parallel jobs is switched on (see Auto-Allocation of CPUs
for Parallel Jobs on Clusters on page 152), Table 22 specifies the behavior of Sentaurus
Workbench regarding the CPU allocation command-line options of the job submission
command. 

Table 22 Behavior of Sentaurus Workbench regarding CPU allocation

Thread synchronization setting Result

set WB_tool(sprocess,parallel,mode) tool Thread synchronization is switched on.
Sentaurus Workbench detects the required number of 
CPUs to allocate and submits an LSF job with the 
following resource requirement:
-n <nbCPUs> -R "span[host=1]"
This setting is appended to the arguments of the bsub 
command specified in
WB_tool(sprocess,LSF,resource)
or the queue definition. If the same setting already 
appears there, the above setting takes precedence.

set WB_tool(sprocess,parallel,mode) user Thread synchronization is switched off.
Sentaurus Workbench does not analyze the tool input file 
and submits an LSF job with the resource requirements 
specified in
WB_tool(sprocess,LSF,resource)
and the queue definition file.

– Thread synchronization is switched off.
Sentaurus Workbench does not analyze the tool input file 
and submits an LSF job with the resource requirements 
specified in
WB_tool(sprocess,LSF,resource)
and the queue definition file.
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Troubleshooting LSF

This section describes how to solve two typical issues you might experience with the LSF
cluster.

Nodes Submitted But Not Executed

This issue can appear on overworked or slow LSF clusters. After Sentaurus Workbench
submits node jobs in the LSF environment with the bsub command, it starts periodical
checking of job polling by calling the bjobs command to obtain the status of the submitted
jobs. In some cases, the first call of bjobs occurs before the LSF scheduler completes the
actual job submission. This results in an empty output of the bjobs command, which
Sentaurus Workbench considers to be the end of the LSF execution session.

Workaround

Sentaurus Workbench provides options to control the job-polling algorithm, which you can
fine-tune to allow the LSF cluster to work more effectively with Sentaurus Workbench:

■ The tool database setting:

WB_tool(bjobs,delay)

specifies the time interval between the submission of the first node and the first call of the
bjobs command to check the status of the jobs. Set the value in seconds. By default,
Sentaurus Workbench defines it as 15 s.

■ The preferences setting Scheduler > LSF Jobs > Job Polling Interval (sec) specifies the
time interval between two sequential calls of bjobs. This value is set in seconds (default
is 1 s). Increasing this time interval might be helpful for LSF clusters that are overworked
with many requests.

Nodes Not Executed and Log File Contains Complaints About bjobs 
Output

This issue can appear when the LSF bjobs command provides output in a format that is not
expected by Sentaurus Workbench, for example, when a user-specific script or application is
called instead of the standard LSF bjobs command.
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Workaround

You can adapt nonstandard bjobs output by defining your own parsing algorithm. Implement
the following Tcl function and put it into the tool database:

proc ::glsf::ParseBjobsOutput { text } {
...
}

This Tcl function overwrites the standard one that Sentaurus Workbench uses for parsing the
bjobs output. The function returns the output of the bjobs call as the input (text) and parses
it. Sentaurus Workbench expects this function to return the Tcl list of the following data triplets
for each LSF job:

■ jobID 

■ status 

■ execution_host 

For example, the returning Tcl list can look like:

{ {1234 DONE tcadxps1} {3343 EXIT tcadcat3} {1123 PEND myhost} }

Supported status values are:

■ DONE 

■ EXIT 

■ PEND 

■ RUN 

■ PSUSP 

■ USUSP 

■ SSUSP 

SGE Scheduler

As an alternative to the LSF scheduler, Sentaurus Workbench provides an interface to the SGE
scheduler. SGE is a queuing facility that manages various system resources, running different
operating systems, and helps you to submit and manage your jobs.

To use SGE, the following conditions must be fulfilled:

1. Correct SGE environment settings are specified. Check with your systems administrator on
which SGE configuration script to source or how to modify your environment settings
Sentaurus™ Workbench User Guide 221
N-2017.09



11: Schedulers 
SGE Scheduler
manually. In particular, the SGE binaries are accessible through the environment variable
PATH.

2. The local host (the one running Sentaurus Workbench and gsub) is an SGE submit or
admit host.

3. Synopsys TCAD simulation software is accessible to all SGE hosts.

4. The project space is accessible to all SGE hosts with the same absolute path.

To confirm points 1 and 2, the following command should succeed on the local host:

% qconf -sconf global

This command displays the SGE scheduler configuration. If point 2 is not fulfilled, you will
see the following output:

% qconf -sconf global
denied: host "myhostname" is neither submit nor admin host

In this case, check with your systems administrator.

The gsub utility uses the qsub command to submit jobs to SGE, the qstat command to track
the job status, and the gdel command to terminate jobs. You can specify additional qsub
command-line options using queue options (see Configuring Scheduling Systems on
page 230). To execute each node, gsub does not directly submit the corresponding tool
command line, but launches a job wrapper, the gjob utility. The latter updates the job status
and locally executes the prologue tool and epilogue of the corresponding tool as defined in the
tool database.

You can specify SGE resource descriptions on a per-tool basis. Different resource descriptions
can be set up for specific tools in a Sentaurus Workbench project. For descriptions of the SGE
resource flags, refer to the definition of the -l option of the qsub command in the SGE
documentation.

The per-tool resource descriptions can be set up in the Sentaurus Workbench tool database (on
the global, user, or project level) using the syntax:

set WB_tool(<tool_name>,SGE,resource) {<resource_description>}

where <tool_name> is the database name of the tool, and <resource_description>
defines the comma list of resource flags. For example:

set WB_tool(sprocess,SGE,resource) 
{arch=glinux,kernel_version=2.6.9,num_proc=4,mem_inst=2G}

set WB_tool(tsuprem4,SGE,resource) {arch=glinux,kernel_version=2.4.21}
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The resource description, specified in the tool database, overwrites the one specified in the SGE
queue in the Sentaurus Workbench global or site queue configuration files (gqueues.dat).
For example, when the following SGE queue name is defined in the queue configuration file:

queue sge:normal64 "qsub -V -cwd -now n -P bnormal -l
arch=glinux,kernel_version=2.6.9"

and you run a Sentaurus Process simulation over this SGE queue, the tool-related resource
description arch=glinux,kernel_version=2.6.9,num_proc=4,mem_inst=2G 
replaces the global setting arch=glinux,kernel_version=2.6.9.

NOTE Do not specify the -l option for the resource requirement string.
Sentaurus Workbench adds it automatically.

Before setting up resource descriptions in the tool database and the global or site queue file, it
is recommended to check the validity of the descriptor and the availability of the requested
resources. You can do this by using the following command:

% qhost -l <resource_descriptor>

If automatic allocation of CPUs for parallel jobs is switched on (see Auto-Allocation of CPUs
for Parallel Jobs on Clusters on page 152), Table 23 specifies the behavior of Sentaurus
Workbench regarding the CPU allocation command-line options of the job submission
command. 

Table 23 Behavior of Sentaurus Workbench regarding CPU allocation

Thread synchronization setting Result

set WB_tool(sprocess,parallel,mode) tool Thread synchronization is switched on.
Sentaurus Workbench detects the required number of 
CPUs to allocate and submits an SGE job with the 
following qsub command-line argument:
-pe mt <nbCPUs>
This argument is appended to the arguments of the qsub 
command specified in
WB_tool(sprocess,SGE,resource)
or the queue definition. If the same argument already 
appears there, the above setting takes precedence.

set WB_tool(sprocess,parallel,mode) user Thread synchronization is switched off.
Sentaurus Workbench does not analyze the tool input file 
and submits an SGE job with the command-line 
arguments specified in
WB_tool(sprocess,SGE,resource)
and the queue definition file.
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Other useful SGE commands are:

% qhost

Returns the list of SGE hosts that fulfill your resource descriptor.

% qaccess

Allows you to check which SGE hosts you have access to.

% qconf -sc

Provides you with detailed information on the resource flags that you can use in your resource
descriptors.

% qconf -se <SGE_hostname>

Informs you on the resource flags that are supported by the given SGE host.

Troubleshooting SGE

Systems administrators of overworked SGE clusters might receive complaints from Sentaurus
Workbench users about job polling occurring too frequently. This section describes how to
fine-tune Sentaurus Workbench schedule settings in this case.

Job Polling Occurs Too Frequently

This issue can occur on overworked or slow SGE clusters. After Sentaurus Workbench submits
node jobs in the SGE environment with the qsub command, it starts a periodical check of job
polling by calling the qstat command to obtain the status of the submitted jobs.

Workaround

You can reduce this frequency in the Sentaurus Workbench preferences and the tool database.

– Thread synchronization is switched off.
Sentaurus Workbench does not analyze the tool input file 
and submits an SGE job with the command-line 
arguments specified in
WB_tool(sprocess,SGE,resource)
and the queue definition file.

Table 23 Behavior of Sentaurus Workbench regarding CPU allocation

Thread synchronization setting Result
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The preferences setting Scheduler > SGE Jobs > Job Polling Interval (sec) specifies the time
interval (in seconds) between two sequential calls of qstat (default: 1 s). Increasing this time
interval might be helpful for SGE clusters that are overworked with many requests.

TM Scheduler

As an alternative to LSF and SGE, Sentaurus Workbench provides an interface to the TORQUE
Resource Manager (TM) scheduler. This scheduler is an advanced open-source product and
incorporates the best of both community and professional development. It incorporates
significant advances in the areas of scalability, reliability, and functionality.

TM can be freely used, modified, and distributed, which is an important advantage over LSF
and proprietary derivatives of SGE.

To use TM, the following conditions must be fulfilled:

1. Correct TM environment settings are set up. Check with your systems administrator about
which TM configuration script to source or how to modify your environment settings
manually. In particular, the TM binaries are accessible through the environment variable
PATH.

2. The local host (the one running Sentaurus Workbench and gsub) is a TM submit or admit
host.

3. Synopsys TCAD simulation software is accessible to all TM hosts.

4. The project space is accessible to all TM hosts with the same absolute path.

To confirm points 1 and 2, the following command should succeed on the local host:

% qstat -u non_existing_user

If this command does not work properly, check with your systems administrator.

The gsub utility uses the qsub command to submit jobs to TM, the qstat command to track
the job status, and the qdel command to terminate jobs. You can specify additional qsub
command-line options using the queue options (see TM Queues on page 234). To execute each
node, gsub does not directly submit the corresponding tool command, but launches a job
wrapper, the gjob utility. The latter updates the job status and locally executes the prologue
tool and the epilogue of the corresponding tool as defined in the tool database.

You can specify TM resource descriptions on a per-tool basis. Different resource descriptions
can be set up for specific tools in a Sentaurus Workbench project. For descriptions of the TM
resource flags, refer to the definition of the -l option of the qsub command in the TORQUE
Resource Manager documentation.
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The per-tool resource descriptions can be set up in the Sentaurus Workbench tool database (on
the global, user, or project level) using the syntax:

set WB_tool(<tool_name>,TM,resource) {<resource_description>}

where <tool_name> is the database name of the tool, and <resource_description>
defines the comma list of resource flags.

NOTE Do not specify the -l option for the resource requirement string.
Sentaurus Workbench adds it automatically.

The resource description, specified in the tool database, overwrites the one specified in the TM
queue in the Sentaurus Workbench global or site queue configuration files (gqueues.dat).

If automatic allocation of CPUs for parallel jobs is switched on (see Auto-Allocation of CPUs
for Parallel Jobs on Clusters on page 152), Table 24 specifies the behavior of Sentaurus
Workbench regarding the CPU allocation command-line options of the job submission
command. 

Table 24 Behavior of Sentaurus Workbench regarding CPU allocation

Thread synchronization setting Result

set WB_tool(sprocess,parallel,mode) tool Thread synchronization is switched on.
Sentaurus Workbench detects the required number of 
CPUs to allocate and submits a TM job with the 
following qsub command-line argument:
-l nodes=1:ppn=<nbCPUs>
This argument is appended to the arguments of the qsub 
command specified in
WB_tool(sprocess,TM,resource)
or the queue definition. If the same argument already 
appears there, the above setting takes precedence.

set WB_tool(sprocess,parallel,mode) user Thread synchronization is switched off.
Sentaurus Workbench does not analyze the tool input file 
and submits a TM job with the command-line arguments 
specified in
WB_tool(sprocess,TM,resource)
and the queue definition file.

– Thread synchronization is switched off.
Sentaurus Workbench does not analyze the tool input file 
and submits a TM job with the command-line arguments 
specified in
WB_tool(sprocess,TM,resource)
and the queue definition file.
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Troubleshooting TM

Systems administrators of overworked TM clusters might receive complaints from Sentaurus
Workbench users about job polling occurring too frequently. This section describes how to
fine-tune the Sentaurus Workbench schedule settings in this case.

Job Polling Occurs Too Frequently

This issue can occur on overworked or slow TM clusters. After Sentaurus Workbench submits
node jobs in the TM environment with the qsub command, it starts a periodical check of job
polling by calling the qstat command to obtain the status of the submitted jobs.

Workaround

You can reduce this frequency in the Sentaurus Workbench preferences and the tool database.

The preferences setting Scheduler > TM Jobs > Job Polling Interval (sec) specifies the time
interval (in seconds) between two sequential calls of the qstat command (default: 1 s).
Increasing this time interval might help the TM clusters that are overworked.

RTDA Scheduler

Sentaurus Workbench provides an interface to the Runtime Design Automation (RTDA)
NetworkComputer. It is used to manage a computer farm or computer cluster, and is
responsible for accepting, scheduling, dispatching, and managing the remote execution of
standalone, parallel, or interactive user jobs. It also manages the allocation of resources such
as processors, memory, disk space, software licenses, and custom objects to jobs that require
them. RTDA uses a unique event-driven scheduler that results in very low overhead per job,
usually in the millisecond range.

To use RTDA, the following conditions must be fulfilled:

1. Correct RTDA environment settings are set up. Check with your systems administrator
about which RTDA configuration script to source or how to modify your environment
settings manually. In particular, the RTDA binaries are accessible through the environment
variable PATH.

2. The local host (the one running Sentaurus Workbench and gsub) is an RTDA submit or
admit host.

3. Synopsys TCAD simulation software is accessible to all RTDA hosts.

4. The project space is accessible to all RTDA hosts with the same absolute path.
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To confirm points 1 and 2, the following command should succeed on the local host:

% vovarch

If this command fails, check with your systems administrator.

The gsub utility uses the nc run command to submit jobs to RTDA, the nc list command
to track the job status, and the nc stop command to terminate jobs. In addition, the
nc forget command is called for completed jobs to ensure they no longer appear in the list
of jobs returned by the nc list command.

You can specify additional nc run command-line options using the queue options (see RTDA
Queues on page 234). To execute each node, gsub does not directly submit the corresponding
tool command, but launches a job wrapper, the gjob utility. The latter updates the job status
and locally executes the prologue tool and the epilogue of the corresponding tool as defined in
the tool database.

You can specify RTDA resource descriptions on a per-tool basis. Different resource
descriptions can be set up for specific tools in a Sentaurus Workbench project. For descriptions
of the RTDA resource flags, refer to the definition of the -r option of the nc run command
in the NetworkComputer documentation.

The per-tool resource descriptions can be set up in the Sentaurus Workbench tool database (on
the global, user, or project level) using the syntax:

set WB_tool(<tool_name>,RTDA,resource) {<resource_description>}

where <tool_name> is the database name of the tool, and <resource_description>
defines the space list of resources preceded by the -r+ and -r- options, for example:

set WB_tool(sprocess,RTDA,resource) { -r+ CPUS/4 -r- linux64 -r+ RAM/500 }

The resource description, specified in the tool database, is added to the one specified in the
RTDA queue in the Sentaurus Workbench global or site queue configuration files
(gqueues.dat).

If automatic allocation of CPUs for parallel jobs is switched on (see Auto-Allocation of CPUs
for Parallel Jobs on Clusters on page 152), Table 25 on page 229 specifies the behavior of
Sentaurus Workbench regarding the CPU allocation command-line options of the job
submission command. 
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Troubleshooting RTDA

Systems administrators of overworked RTDA clusters might receive complaints from
Sentaurus Workbench users about job polling occurring too frequently. This section describes
how to fine-tune Sentaurus Workbench schedule settings in this case.

Job Polling Occurs Too Frequently

This issue can occur on overworked or slow RTDA clusters. After Sentaurus Workbench
submits node jobs in the RTDA environment with the nc run command, it starts a periodical
check of job polling by calling the nc list command to obtain the status of the submitted
jobs.

Workaround

You can reduce this frequency in the Sentaurus Workbench preferences and the tool database.

Table 25 Behavior of Sentaurus Workbench regarding CPU allocation

Thread synchronization setting Result

set WB_tool(sprocess,parallel,mode) tool Thread synchronization is switched on.
Sentaurus Workbench detects the required number of 
CPUs to allocate and submits an RTDA job with the 
following nc run command-line argument:
-r+ CPUS/<nbCPUs>
This argument is appended to the arguments of the 
nc run command specified in
WB_tool(sprocess,RTDA,resource)
or the queue definition. If the same argument already 
appears there, the above setting takes precedence.

set WB_tool(sprocess,parallel,mode) user Thread synchronization is switched off.
Sentaurus Workbench does not analyze the tool input file 
and submits an RTDA job with the command-line 
arguments specified in
WB_tool(sprocess,RTDA,resource)
and the queue definition file.

– Thread synchronization is switched off.
Sentaurus Workbench does not analyze the tool input file 
and submits an RTDA job with the command-line 
arguments specified in
WB_tool(sprocess,RTDA,resource)
and the queue definition file.
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The preferences setting Scheduler > RTDA Jobs > Job Polling Interval (sec) specifies the
time interval (in seconds) between two sequential calls of the nc list command (default:
1 s). Increasing this time interval might help RTDA clusters that are overworked.

Configuring Scheduling Systems

Scheduling systems require a queue configuration file gqueues.dat to be defined on a global
or site level. The systems administrator must set up this file.

In addition to the queue configuration, tools must be properly associated with the queues in
scheduling systems.

Global Queue Configuration File

A queue configuration file (gqueues.dat) combines definitions of all resources available to
you for running simulations in Sentaurus Workbench. The file contains a list of Sentaurus
Workbench queue definitions.

Each Sentaurus Workbench queue consists of the name of the scheduler, a unique queue name,
and optional parameters. Sentaurus Workbench and the command-line job submission utilities
(gsub and swbopt) use these queues when launching simulations.

From the Sentaurus Workbench side, in the global queue configuration, the systems
administrator lists all the queues that you can access in your corporate computation
environment. The systems administrator must also set up the resource strings, specifying
applicable resource restrictions.

In the gqueues.dat file, lines starting with a hash (#) character are considered comments and
are ignored. An example of a queue definition file is:

#local queues
queue local:default "19"
queue local:priority "10"

#lsf queues
queue lsf:normal "bsub"
queue lsf:mylsfqueue "bub -R \"swp > 5 && mem > 10\" -q normal"
queue lsf:sp "bsub -R \"rusage[mem=410] span[hosts=1]\" -n 4 -P tcad -q normal"

#sge queues
queue sge:normal "qsub"
queue sge:normal64 "qsub -V -cwd -now n -P bnormal -l arch=glinux"
queue sge:mt4 "qsub -V -cwd -now n -P bnormal -pe mt 4"
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#tm queues
queue tm:normal "qsub"
queue tm:mt4 "qsub -l nodes=1:ppn=4"

#rtda queues
queue rtda:normal "nc run -C swb"
queue rtda:mt4 "nc run -r+ CPUS/4 -r+ RAM/500 -r+ linux64"

Sentaurus Workbench looks for the global queue file in the following order:

1. Release-independent directory: $STROOT/queues/gqueues.dat 

2. Release-specific directory: $STROOT/tcad/$STRELEASE/lib/gqueues.dat 

3. Release-specific directory: $STROOT/tcad/$STRELEASE/lib/glib2/gqueues.dat 

The global queue file also can be specified on a site level: $SWB_SITE_SETTINGS_DIR/
gqueues.dat. When this file exists, it replaces the global one (see Site Queue Configuration
on page 235).

Sentaurus Workbench supports different schedulers, which can be used simultaneously: local,
LSF, SGE, TM, and RTDA. The global queue file can combine queues for all available
resources. As a minimum requirement, the global queue file must contain at least one local
queue to launch Sentaurus Workbench jobs locally.

Local Queues

The queue configuration for local queues (that is, for jobs that are run on a local machine) is
set up as follows:

queue local:<queue_name> <desired nice level>

For example, a priority queue can have a lower nice level:

queue local:priority "10"

Sentaurus Workbench provides the following predefined local queues in the $STROOT/tcad/
$STRELEASE/lib/glib2/gqueues.dat file:

queue local:default "19"
queue local:priority "0"
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LSF Queues

For installing and setting up LSF queues, refer to the LSF installation manual.

The format of the LSF queue specification string for the global queue configuration file is:

queue lsf:<lsf_queue_name> "bsub <constraint_options>"

where:

■ <lsf_queue_name> is the name of the corresponding LSF queue.

■ <constraint_options> contains arbitrary constraint specifications and the command-
line options of the bsub command.

For example, a queue <mylsfqueue> with additional resource constraints can be defined for
Sentaurus Workbench as:

queue lsf:mylsfqueue "bsub -R \"linux && mem>1000\""

When Sentaurus Workbench runs a job using this queue, the following command will be
generated on the basis of the queue definition:

bsub -R "linux && mem>1000" -o <log_file> -q mylsfqueue -P <project_id> \
 -J <job_name> <gjob command string>

NOTE You must use the backslash (\) in the specification of an LSF resource
string to protect double quotation marks. Otherwise, Sentaurus
Workbench removes double quotation marks during Tcl evaluation and
the LSF bsub command fails on the incorrect syntax.

The name of a real LSF queue and the name of the corresponding queue in the global or site
queue configuration file of Sentaurus Workbench usually are the same, but it is not mandatory.
Sentaurus Workbench allows you to create queue aliases, where Sentaurus Workbench queues
have different names and resource strings, and refer to the same LSF queue. For example:

queue lsf:refqueue1 "bsub -R \"swp > 5 && mem > 10\" -q normal"

queue lsf:refqueue2 "bsub -R \"swp > 10 && mem > 20\" -q normal"

queue lsf:refqueue3 "bsub -R \"swp > 15 && mem > 30\" -q normal"

These Sentaurus Workbench queues refqueue1, refqueue2, and refqueue3 are not real
LSF queues, that is, they do not exist in the LSF environment. In fact, these queues refer to the
same LSF normal queue. The LSF bsub command supports multiple -q command-line
options, but the last one specifies the LSF queue for the execution. That is why, in the above
example, simulations scheduled among these three queues will be submitted to the same LSF
queue normal, but with different resource restrictions.
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When the lsf:default queue for LSF is specified in the global or site queue configuration
file, Sentaurus Workbench expects explicit specification of the LSF queue in the constraint
options, for example:

queue lsf:default "bsub -R \"linux && mem>1000\" -q mylsfqueue"

For additional bsub options, refer to the LSF documentation.

SGE Queues

For installing and setting up SGE queues, refer to the SGE documentation.

The format of the SGE queue specification string for the global or site queue configuration file
is:

queue sge:<sge_queue_name> "qsub <arguments>"

where:

■ <sge_queue_name> is the SGE queue name that you will see in Sentaurus Workbench.

■ <arguments> contains the list of options. It can contain arbitrary resource descriptors to
filter out hosts with requested resources.

The main option is -P, which specifies the name of the associated SGE project. The SGE
project specifies the group of SGE hosts where the simulation job is to be scheduled.

For example, a queue <mysgequeue> with additional resource descriptors can be defined for
Sentaurus Workbench as:

queue sge:mylsfqueue "qsub -P bnormal -l arch=glinux,kernel_version=2.6.9"

When Sentaurus Workbench runs a job using this SGE queue, it first packs the gjob call into
the shell script:

#!/bin/sh
#$ -S /bin/sh
trap "kill -INT $!;sleep(5);kill -TERM $$" USR1 USR2
<gjob command string>

and then submits this script to the SGE engine using the command:

qsub -notify -V -cwd -now n -P bnormal -l arch=glinux,kernel_version=2.6.9 
-o <log_file> -e <sge_error_file> -N <project_name> <shell script above>

This command returns the job ID, which Sentaurus Workbench uses to monitor the progress of
the job by periodically calling the command:

qstat -u <user_name> -j <jobID from qsub>
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For additional qsub and qstat options, refer to the SGE documentation.

TM Queues

For installing and setting up TM queues, refer to the TORQUE Resource Manager
documentation.

The syntax of TM queues is similar to that for SGE queues since both schedulers are based on
the same PBS scheduling system:

queue tm:<sge_queue_name> "qsub <arguments>"

Note that qsub arguments might differ in SGE and TM. For additional qsub and qstat
options, refer to the TORQUE Resource Manager documentation.

RTDA Queues

For installing and setting up RTDA queues and job classes, refer to the NetworkComputer
documentation.

The format of the RTDA queue specification string for the global queue configuration file is:

queue rtda:<rtda_queue_name> "nc run <options>"

where <rtda_queue_name> is the name of the corresponding RTDA queue, and <options>
contains arbitrary constraint specifications and instructions for the nc run command.

For example, a queue <mt4> with additional resource constraints can be defined for Sentaurus
Workbench as:

queue rtda:mt4 "nc run -C swb -r+ CPUS/4 -r+ RAM/500 -r+ linux64"

When Sentaurus Workbench runs a job using this queue, the following command is generated
on the basis of the queue definition:

nc run -C nc_swb0 -r+ CPUS/4 -r+ RAM/500 -r+ linux64 -l <log_file> \
-J <job_name> -v 1 -rundir <project_dir> <log_file>

For additional nc run options, refer to the NetworkComputer documentation.
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Site Queue Configuration

When your company has multiple groups of users of the Sentaurus platform, distributed in
different sites, it might be useful to redefine global queue configuration settings for all users of
the specific site.

To do this:

1. Create your site-specific settings in the gqueues.dat file.

2. Place the file under an arbitrary directory.

3. Set up the following environment variable to refer to this directory:

% setenv SWB_SITE_SETTINGS_DIR <path_to_site_directory>

Like the global queue configuration file, its site counterpart is usually not writable.

The directory referenced by the environment variable SWB_SITE_SETTINGS_DIR can also
contain the site tool database settings file tooldb.tcl. Unlike the site tool database file, the
site queue configuration file completely replaces the settings provided by its global
counterpart. Therefore, when a site-specific gqueues.dat file is specified, the global
gqueues.dat file is not mandatory.

NOTE The site-level queue configuration file allows you to create your own
queue settings that differ from those at the global level.

Tool Associations

Sentaurus Workbench supports the following levels of tool-queue associations: global, user,
project, and node. The systems administrator sets up the global tool-queue association. You can
configure the other three levels to meet your requirements.

NOTE You cannot use the queue keyword in user-project queues files. This
means you cannot set up new queues on the user and project levels.
These levels have permission to assign the tools and the nodes to
specific queues.

Global, user, and project tool-queue associations have a specific format:

tool <tool_name> "options" <scheduler:queue_name>
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The following example defines the running of all nodes associated with the Sentaurus Process
tool on the hosts specified by the lsf:normal queue:

tool sprocess "" lsf:normal

You can use the keyword default to specify all tools. For example, the following assignment
means that all tools will run in the sge:mt4 queue with the subset of hosts provided in the
options field:

tool default "" sge:mt4

Options are specific to the scheduler used and differ accordingly (see Global Queue
Configuration File on page 230).

NOTE Of the following options, the user tool associations and project tool
associations can be modified on the Scheduler tab. The node-specific
constraints can be edited manually from the Scheduler tab or by using
a text editor (see Modifying Project-Level Tool Queues on page 52).

Global Tool Associations

Global tool associations are written to the global queue configuration file or site queue
configuration file or both, and are loaded with the setup. These associations apply to all users.

Sentaurus Workbench delivers the following default tool associations in the global queue file
$STROOT/tcad/$STRELEASE/lib/glib2/gqueues.dat:

tool tecplot "" local:default
tool inspect "" local:default
tool svisual "" local:default
tool bridge "" local:default
tool enigma "" local:default
tool enigma_garand "" local:default
tool enigma_mystic "" local:default
tool enigma_randomspice "" local:default
tool default "" local:default

These tool associations are used to run interactive tools locally regardless of the queue to which
they are scheduled.

User Tool Associations

You can use the list of queues and prepare the assignment of tools to queues. Options can be
modified according to the requirements. The user tool associations are stored in the file
gqueues_<username>.dat in the $STDB directory of the user. All the definitions specified
complement and override any definitions at the global level and apply to all of your projects.
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Project Tool Associations

You can configure the tool queue associations at the project level. These definitions are stored
in the gqueues.dat file in the project directory.

All definitions override any setting at the global level or user level, and apply to the current
project only.

For the local scheduler, the option field represents the nice level at which the tool must be run.
For other schedulers, the option field redefines the resource string.

Node-Specific Constraints

Node-specific constraints are handled by expanding the expression and applying the
constraints to the nodes that match the expression. Node-level constraints are applied during
runtime:

node "gexpr" <queue:name> "options"

For example:

node "all:{ @P1@ > 2.0 }" local:default "11"

Node-specific constraints can be set up at the global, user, or project level. These settings are
stored in the respective definition files as previously mentioned.

NOTE Definitions are cascaded with the latest setting overwriting the setting of
the previous level, that is, the global and site queue files are loaded
initially, and the global or site tool-queue associations and their
corresponding strings are loaded. Then, the user-queue definition file is
loaded. Any previous definition related to a particular tool is
overwritten. Similarly, the project queue definition overwrites the user
definitions.

NOTE You can set up queues on the global and site levels only. However, tool
queue assignments can be overwritten on other levels.

Extended Scheduler Log

The Sentaurus Workbench Scheduler can generate detailed log information, which can help to
debug scheduling-related problems. This additional information is accumulated in the project
log file (glog.txt) and in the node-related job files (n<nkey>_<acr>.job).
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The GSUB_ADVANCED_LOG environment variable controls the volume of data logged. To
switch on the advanced log feature, specify:

GSUB_ADVANCED_LOG 1

By default, this feature is switched off (0 or undefined).

NOTE The advanced log feature must be used cautiously, since it adds large
amounts of data to project-related files.

Launching Sentaurus Workbench as an Interactive Job on 
the Cluster

Some clusters offer the possibility to launch interactive jobs. For example, the LSF and SGE
schedulers can launch an interactive terminal job on the cluster, which can be used to work with
Sentaurus Workbench. Alternatively, clusters allow direct launching of dedicated interactive
jobs, in which case, a so-called pseudo-terminal job starts automatically.

To launch an interactive terminal job on LSF, use the following command:

bsub -q <iqueue> -I xterm

where <iqueue> is the name of the LSF queue on your cluster that supports interactive jobs.

To launch an interactive terminal job on SGE, use the following command:

qsh -cwd -P <iproject>

where <iproject> is the name of the SGE project on your cluster that supports interactive
jobs.

NOTE Ensure that you have either correctly set up your DISPLAY environment
variable or specified a correct X display name on the command line of
the submission command.

NOTE The actual submission commands might look different. Check with
your corporate IT team for details and usage policy.

Running GUI applications as interactive jobs on compute clusters has become more common
because many companies want to reduce the number of dedicated Linux machines. To benefit
from this way of working with Sentaurus Workbench, you must consider the CPU resources
your interactive job requires to prevent unwanted performance slowdown. The cluster allocates
CPU resources for your interactive job (slot). You need to take into account that Sentaurus
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Workbench itself and every additional process you launch from Sentaurus Workbench will
share the same slot that the cluster has allocated for your interactive jobs.

Batch Processes

Sentaurus Workbench is a serial process. However, the Sentaurus Workbench infrastructure
includes other batch processes running in the background. Sentaurus Workbench launches
these processes on the same host, that is, they run on your interactive slot and share the same
resources:

■ swblm 

This daemon process facilitates communication between all the Sentaurus Workbench
processes run by one user. It is a TCAD release–specific process, so if you run different
releases of Sentaurus Workbench concurrently, you will have multiple swblm instances on
the same host.

This daemon process typically does not consume much CPU or memory resources.
However, if you run large DoE projects with fast-running simulations, swblm can run in
parallel (up to 20 threads) and consume significant CPU resources.

■ gsub 

For every project you run, Sentaurus Workbench launches the gsub process that manages
project scheduling. Each gsub is a serial process. However, for large DoE projects, gsub
can consume significant CPU time.

■ gjob + simulation processes

By default, Sentaurus Workbench redirects Sentaurus Visual and Inspect jobs to local
execution regardless of which cluster queue you selected in Sentaurus Workbench for
project execution, unless it is redefined in the queue file ($STROOT/queues/
gqueues.dat). Depending on the specified maximum of the simultaneously running local
jobs (see the Sentaurus Workbench preferences; default is 1), you might have one or
multiple Sentaurus Visual or Inspect processes running concurrently on the same
interactive slot where Sentaurus Workbench runs. In addition, for each of these processes,
you will have a Sentaurus Workbench job wrapper process gjob. Despite gjob being a
serial process, it can consume significant CPU time during runtime preprocessing of the
project.

If you encounter performance issues when running Sentaurus Workbench as an interactive job
on the cluster, do the following:

1. Check with your corporate IT team about which CPU resources are allocated for interactive
jobs. By default, it is typical to have one or even fewer CPU cores per interactive job.

2. Try to allocate more CPU resources to an interactive job. 
Sentaurus™ Workbench User Guide 239
N-2017.09



11: Schedulers 
Launching Sentaurus Workbench as an Interactive Job on the Cluster
For example, you can allocate four CPUs for a terminal job on the same host as follows:

LSF: bsub -q <iqueue> -R "span[hosts=1]" -n 4 -I xterm
SGE: qsh -cwd -P <iproject> -pe mt 4

The optimal CPU resources for a Sentaurus Workbench interactive job depend on the way you
work with Sentaurus Workbench. If you run a few small or medium-sized projects in one
Sentaurus Workbench instance, one CPU core is sufficient for a Sentaurus Workbench
interactive job on the cluster. If you launch several large DoE projects in the same Sentaurus
Workbench instance, the Sentaurus Workbench infrastructure would require more resources.

In the case of performance slowdown, you can try to increase the number of cores and to find
reasonable CPU resources required for Sentaurus Workbench interactive jobs.
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This chapter describes the hierarchical project organization as an
alternative to the traditional project organization in Sentaurus
Workbench.

Limitations of the Traditional Project Organization

Sentaurus Workbench traditionally supports the organization of projects where all files are
placed inside one directory that contains the following (see Figure 83):

■ Core data such as tool inputs, simulation tool flow, design-of-experiments (DoE) table, and
variables. This includes other user-specific data such as preferences, queue settings, and
project run limits quota.

■ Reproducible data such as preprocessed inputs, results, log files, and error files. 

Figure 83 Traditional project organization of files in Sentaurus Workbench
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While the traditional project organization is simple and easy to use, it has limitations when
working with large DoE projects. As soon as the number of experiments exceeds a certain
number (usually, one hundred or more), Sentaurus Workbench slows down on multiple queries,
such as:

■ Deleting experiments, parametric steps, and tool instances.

■ Copying and pasting selected experiments.

■ Saving experiments as a new project.

■ Cleaning up selected nodes and the entire project.

To identify files belonging to a given node, Sentaurus Workbench launches queries on a
traditional project directory using output file patterns defined in the tool database. This is the
main cause of the slowdown, because querying a directory with thousands of files takes
substantial time.

With the traditional project organization, you cannot split project files to store them on different
disks. In addition, Sentaurus Workbench does not allow renumbering of nodes without losing
the simulation results.

Hierarchical Project Organization

While the traditional project organization is the default in Sentaurus Workbench, to address its
limitations, in Version N-2017.09, you can use the hierarchical project organization.

Location of Project Files

With the hierarchical project organization (see Figure 84 on page 243):

■ Core data files are separated from reproducible data files. Core data files are stored under
the root project directory as in the traditional project organization.

■ Reproducible data files are stored in a node-wise hierarchy.
242 Sentaurus™ Workbench User Guide
N-2017.09



12: Organization of Projects
Hierarchical Project Organization
Figure 84 Hierarchical project organization of files in Sentaurus Workbench
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Figure 85 Example of how files are stored comparing (left) the traditional project 
organization with (right) the hierarchical project organization

Advantages of the Hierarchical Project Organization

Better Performance

The hierarchical project organization significantly improves performance with large DoE
projects.

For example, deleting and cleaning up operations on a simulation project with 1300
experiments (~3000 nodes and ~80000 files) take only several seconds to complete. In
contrast, the same operations take more than 20 minutes on a simulation project that uses the
traditional project organization. Similarly, saving selected experiments as a new project (see
Saving Projects on page 17) is much faster compared to the traditional project organization.
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Split Storage of Project Files

Activating the hierarchical project organization allows you to split the storage of project files
on to different disks (see Separate Storage of Project Files on page 250).

Renumbering Nodes Without Cleaning Up a Project

With the traditional project organization, you can renumber nodes only when cleaning up a
projects. With the hierarchical project organization, you can renumber nodes without losing the
simulation results (see Renumbering Nodes Without Cleaning Up a Project on page 249).

Activating the Hierarchical Mode of Sentaurus Workbench

Sentaurus Workbench has two modes of project organization: traditional and hierarchical. Each
mode has its own set of binaries. You work with traditionally organized projects in the
traditional mode of Sentaurus Workbench, which is the default.

To work with hierarchically organized projects, you must launch Sentaurus Workbench in
hierarchical mode by specifying the -hierarchical option on the command line (see
Launching Sentaurus Workbench From the Command Line on page 3):

swb -hierarchical

The traditional mode creates new projects with traditional organization. It does not support
hierarchical projects and generates an error message if you open a hierarchical project in
traditional mode.

The hierarchical mode creates new projects with hierarchical organization. In this mode, you
can also open a traditionally organized project and convert it to hierarchical organization (see
Compatibility With the Traditional Project Organization on page 246).

Every Sentaurus Workbench project stores its organization (traditional or hierarchical) in the
project file .organization. If this file is omitted, Sentaurus Workbench assumes that the
project has traditional organization. The project organization is stored when you create a new
project. You cannot later change the project organization from hierarchical to traditional.
However, you can change the project organization from traditional to hierarchical using a
converter (see Compatibility With the Traditional Project Organization on page 246).

To revert to the traditional mode of Sentaurus Workbench, you must launch Sentaurus
Workbench specifying the -traditional option on the command line, or you can omit this
option (see Launching Sentaurus Workbench From the Command Line on page 3).
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For example, both of the following commands launch Sentaurus Workbench in traditional
mode:

swb -traditional

swb

You can work simultaneously with two Sentaurus Workbench sessions launched in both
traditional and hierarchical modes.

When Sentaurus Workbench starts in hierarchical mode, its background color differs from that
in traditional mode. By default, it is bisque. You can change the background and foreground
colors of the main window of Sentaurus Workbench in hierarchical mode in user preferences
(expand Project > Organization > GUI Settings for Hierarchical Mode).

When you load a project, Sentaurus Workbench displays an additional label in the title of the
main window showing the organization of the project (see Figure 86). 

Figure 86 Sentaurus Workbench in hierarchical mode, indicated by additional label in title 
(red box)

Compatibility With the Traditional Project Organization

Sentaurus Workbench in hierarchical mode recognizes projects with traditional organization.

When you open a traditionally organized project in Sentaurus Workbench that is launched in
hierarchical mode, Sentaurus Workbench displays a dialog box with several options (see
Figure 87 on page 247).
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Figure 87 Options for a project with traditional organization

Converting Projects to Hierarchical Organization

The Convert Project to Hierarchical Organization option (this is the default) allows you to
configure the conversion from traditional to hierarchical project organization.

NOTE This converter has limitations and cannot convert all use cases.

The default conversion options are configured according to user preference settings under
Project > Organization > Convert From Traditional Project Organization:

■ If the Save Backup option is selected, Sentaurus Workbench saves a backup copy of the
original project with the given name in the same directory where the original project
resides.

■ If the Convert Command Files option is selected, Sentaurus Workbench parses tool input
command files and applies changes required for hierarchical project organization.

■ For Result Files, you specify what action to take with existing log files and node files if
the original project has been preprocessed or executed:

• With the Relocate option selected, Sentaurus Workbench recognizes existing files and
moves them into the corresponding results hierarchy.

• With the Remove option selected, Sentaurus Workbench deletes these files and cleans
the project.
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■ If the Display Changes option is selected, Sentaurus Workbench launches a diff tool for
every tool input file changed during conversion.

■ If the Display Log option is selected, Sentaurus Workbench displays the conversion log file
(results/logs/convert.log) with a report of the project conversion. This file might
contain warnings with references to the instructions Sentaurus Workbench could not
convert, in which case, you might need to make required changes manually.

Loading Projects Without Conversion

The Load Project Without Conversion (Read-Only) option opens a project as is, with no
conversion and no changes applied (see Figure 87 on page 247). The project retains its
traditional organization, which Sentaurus Workbench displays in the title of the main window.
In this mode, Sentaurus Workbench does not recognize existing node files, so the project looks
like a cleaned project.

This mode can be useful for viewing purposes. You cannot preprocess or run the project with
the traditional organization unless you convert it to hierarchical organization.

Loading Projects in Traditional Mode

The Open in Traditional Mode option launches a new Sentaurus Workbench session in
traditional mode and opens the project in this session (see Figure 87 on page 247). Then, you
can proceed working with the project as usual.

NOTE Sentaurus Workbench does not provide a converter for forward
compatibility. As soon as you convert a project to hierarchical
organization, you cannot convert it back to traditional organization
automatically. However, with manually applied changes, you still can
work with this project in traditional mode.

Navigating Through Node Files

Typically, you use the Node Explorer to navigate through node files, analyzing simulation
results, and tracking simulation problems. It supports both traditional and hierarchical project
organizations (see Node Explorer on page 47).

For projects using the hierarchical project organization, you can also navigate through node
files using the Web Node Explorer.

To open the Web Node Explorer:

■ Choose Extensions > Web Node Explorer.
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The Web Node Explorer opens in your default browser showing the project simulation tree (see
Figure 88). Each node except virtual nodes has a hypertext link. When you click a hypertext
link, you can see the files in the node directory and visualize those in text or graphical format.

NOTE TDR files cannot be visualized in the Web Node Explorer. 

Figure 88 Web Node Explorer

Renumbering Nodes Without Cleaning Up a Project

You can renumber nodes without cleaning up a project in one of the following ways:

■ Choose Nodes > Renumber All Nodes.

■ Press Ctrl+Alt+R.

■ Right-click a node and select Renumber All Nodes.

Renumbering nodes is also possible when cleaning up projects.

To renumber nodes:

1. Choose Project > Operations > Clean Up, or press Ctrl+L.

2. In the Cleanup Options dialog box, select the Renumber the Tree option.

3. Clear the Node Files (Output, Preprocessed) option.

4. Click Cleanup.

Sentaurus Workbench restores standard tree-based node numbering and ensures that node files
are renamed appropriately. However, the content of node files might still contain references to
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previous node numbers. The next time you preprocess or run a project, the content of the node
files will be updated.

Separate Storage of Project Files

Sentaurus Workbench projects usually require substantial storage space due to the size of TDR
files, even though TDR files are compressed internally.

With the hierarchical project organization switched on, you can store the core and reproducible
data files of projects separately, thereby optimizing the use of disk space. For example, you
might want to store core data files on the backup disk and reproducible data files on the scratch
disk.

By default, core data files and reproducible data files are stored together (see Figure 84 on
page 243). In other words, the results subdirectory containing project log files and node files
is stored under the root project directory.

To change the location of the reproducible data files:

1. Choose Edit > Preferences, or press the F12 key.

2. In the SWB Preferences dialog box, expand Project > Organization > Settings for
Hierarchical Project Organization > Project Output Files Location.

3. Specify the path where you want to store the output files of projects.

The default is @STDB@, indicating that core data files and reproducible data files are stored
together.

4. Click Apply.

All projects under the current STDB directory share the same output storage rules (see
Figure 89 on page 251). Each preprocessed or executed project under the current STDB
directory stores its reproducible data files in the same hierarchical structure. Practically,
Sentaurus Workbench works with two separate hierarchies in the file system:

■ The core files hierarchy (STDB) contains only core data files.

■ The output files hierarchy (from preferences, expand Project > Organization > Settings
for Hierarchical Project Organization > Project Output Files Location) contains only
reproducible data files. 

Both the core files and output files hierarchies have a symmetric structure related to their root
directories, that is, a project has the same relative path in both hierarchies. For example, if the
core data files of a project are stored in the following folder:

$STDB/the/path/to/myTestProject
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the reproducible data files of this project are stored in the following folder:

[Project > Organization > Settings for Hierarchical Project Organization > 
Project Output Files Location]/the/path/to/myTestProject

The core files hierarchy referenced by STDB is the one that Sentaurus Workbench displays in
the projects browser (Projects panel). The output files hierarchy is used only to store generated
files and is not shown in Sentaurus Workbench. 

Figure 89 Example of the hierarchy used for the separate storage of (left) core files and 
(right) output files

Sentaurus Workbench supports projects stored outside the STDB directory, provided the
required file system permissions are available. If you instructed Sentaurus Workbench to store
the output files of a project separately from the core files, the path in the output files hierarchy
cannot be the same as its relative path in the core files hierarchy. In this case, Sentaurus
Workbench adds the absolute path of the core project directory to the root output files hierarchy
(see Figure 90 on page 252).

NOTE A Sentaurus Workbench project itself does not contain any information
about where its output data is stored.

NOTE If you want to copy, move, delete, or export a project outside Sentaurus
Workbench (for example, in a terminal window), you must take care of
the files stored in the output files hierarchy.

STDB= /home/jsmith/swb/DB

Project > Organization > Settings for Hierarchical Project

/slowfs/tmp2/swb_out
Organization > Project Output Files Location=
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A TCAD administrator can establish the output storage policy for Sentaurus Workbench users.
That is, you can force the default location of output files to all users or propagate it to new
Sentaurus Workbench users. 

Figure 90 Example of rules for the location of output files

The path to the location of output files can include environment variables enclosed in @...@.
Sentaurus Workbench substitutes these settings with the real values of the corresponding
environment variables to detect the target path.

For example, a TCAD administrator can set up the following user-specific path in a convenient
file system to store reproducible data files:

In preferences:
Project > Organization > Settings for Hierarchical Project Organization > Project
Output Files Location = /sim/tmp/@USER@/tcad/ 

The following setting will make this path release-specific:

In preferences:
Project > Organization > Settings for Hierarchical Project Organization > Project
Output Files Location = /sim/tmp/@USER@/tcad/@STRELEASE@ 

ValueName

STDB /home/jsmith/swb/DB

Preferences: Miscellaneous >
Project Output Files Location /slowfs/tmp2/swb_out

Use Case 1: Project inside STDB

Path to core files:

Path to output files:

Use Case 2: Project outside STDB

Path to core files:

Path to output files:

/home/jsmith/swb/DB/cust/CMOS/test/iter2

/slowfs/tmp2/swb_out/cust/CMOS/test/iter2

/remote/dist/app/MyCMOS

/slowfs/tmp2/swb_out/remote/dist/app/MyCMOS
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If you work with multiple STDB directories, there might be a conflict when multiple STDB
directories have the same project in the same place. To prevent this, include STDB in the path,
for example:

In preferences:
Project > Organization > Settings for Hierarchical Project Organization > Project
Output Files Location = /sim/tmp/@USER@/tcad/@STDB@ 

Migration to the Hierarchical Project Organization

The following rules will help you to migrate from the traditional project organization to the
hierarchical project organization:

■ Remember the following:

• Node files (preprocessed and results) are stored in individual node folders.

• Each simulation is executed in a node folder, rather than in a root project directory.

■ Stop assuming that all project files are stored under the root project directory.

■ If necessary, apply changes to old projects, that is, adjust tool input files, so that the projects
work using the hierarchical project organization.

Example: Sentaurus Visual input file assumes all node files are in the same directory

With the traditional project organization, you would use:

load_file IdVg_n@node|sdevice@_des.plt -name PLT($N)

With the hierarchical project organization, you would use:

load_file ../@node|sdevice@/IdVg_n@node|sdevice@_des.plt -name PLT($N)

Example: Sentaurus Process input file assumes the current directory is the root 
project directory

With the traditional project organization, you would use:

icwb filename= "SRAM_lyt.mac" scale=1e-3

With the hierarchical project organization, you would use:

icwb filename= "@pwd@/SRAM_lyt.mac" scale=1e-3
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Changes to the Preprocessor Syntax

With the hierarchical project organization switched on, Sentaurus Workbench launches
simulation tasks in the dedicated node folders. The preprocessor substitutes @...@ references
to node files, with their corresponding relative path to the current node folder. In addition,
Sentaurus Workbench introduces new syntax (see Table 26). 

Linking Input Project Files in Node Folders

NOTE Sentaurus Workbench provides this capability solely to improve user
experience with the hierarchical project organization and to allow you
to work with legacy projects that are difficult to convert. Avoid using
this capability for all your projects, and switch it on only for projects
that are too expensive to change. This capability might be removed in
future releases.

Tool input command files can contain code that cannot be converted automatically. For
example, you can source other files in your Tcl command file for Sentaurus Process, and these
sourced files might source other files, and so on. The converter cannot follow such a source
chain, which might be arbitrarily complex.

Table 26 Preprocessor references and their substitution

Preprocessor syntax Description Traditional project 
organization

Hierarchical project 
organization

@node@ Node number 8 8

@node|sdevice@ Node of the last Sentaurus 
Device tool instance

6 6

@tdr@ TDR file n8_fps.tdr ../8/n8_fps.tdr

@tdr|-1@ TDR file generated on the 
previous step

n7_fps.tdr ../7/n7_fps.tdr

@plot@ Plot file n12_des.plt ../12/n12_des.plt

@pwd@ Project path in core files 
hierarchy (STDB)

$STDB/path/to/prj $STDB/path/to/prj

@pwdout@ Project path in output files 
hierarchy

Not applicable /out_root/path/to/prj

@nodedir@ Path to node folder, relative 
to @pwd@ 

Not applicable results/nodes/8
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If you face such challenges, consider the following best practices:

■ Introduce manual changes to input command files and other related files.

■ Reconsider the scripting technique you use in tool command files.

If neither of these approaches is feasible but you want to work with such a project in
hierarchical mode, Sentaurus Workbench provides an option to reflect all input project files in
node folders.

When you preprocess or run your project, Sentaurus Workbench creates symbolic links to all
project files (except internal Sentaurus Workbench files and the results/ folder) residing in
the root directory inside each node folder, just before the node is preprocessed or executed. In
other words, Sentaurus Workbench partially mimics the traditional project organization on the
node level. With this option switched on, the traditional-based complex scripting in tool input
command files works as expected even under hierarchical project organization.

To enable this capability:

1. Choose Project > Properties > Link Input Files in Node Folders.

2. Set it to Yes.

The project stores this setting until you change it to No.

If your project does not yet have this setting, the default value is taken from user preferences.
To enable this capability:

1. Choose Edit > Preferences, or press the F12 key.

2. In the SWB Preferences dialog box, expand Project > Organization > Settings for
Hierarchical Project Organization > Link Input Files in Node Folder.

3. Change the value to Yes.

4. Click Save.

By default, this capability is switched off in user preferences.
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Syntax

This appendix discusses the syntax of @-references and
preprocessor commands.

@-References and Tree Navigation

The syntax of @-references in EBNF notation is:

reference: simple_reference [ operator [operator] ]

simple_reference: ("node" | "previous" | file_type ["/i"] | ["/o"] |
"experiment" | "experiments" | "process_name" | "swb_parameter" |
parameter_name | variable_name)

operator: (":"|"|") (["+"|"-"] number | tool_label | "first" | "last" | 
"index" | "all" | "min" | "max")

where: 

file_type One of the file types defined in the tool database.

/i and /o Extensions to file_type refer to the corresponding input and output
files of the current tool. Without extensions, an implicit input file
generated by a preceding tool is searched further up the tree.

parameter_name One of the declared parameters.

variable_name One of the known variables.

tool_label The label of a tool instance in the simulation flow. The corresponding
tool is defined in the tool database of Sentaurus Workbench.

experiment Returns the first experiment to which a node belongs.

experiments Returns all experiments to which a node belongs.

process_name Returns the process name to which the current node belongs.

swb_parameter Returns the parameter name of the current node.
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The following relative direction suffixes can be used (depending on the flow orientation): 

Vertical and horizontal navigation operators can be combined.

Horizontal Flow Orientation

In the vertical direction, a unit represents an entire simulation phase. Intermediate nodes
(virtual nodes or split points) are not taken into account. For horizontal operators, the following
additional keywords can be used instead of numbers: 

| Horizontal flow orientation: horizontal navigation operator.
Vertical flow orientation: vertical navigation operator.

: Horizontal flow orientation: vertical navigation operator.
Vertical flow orientation: horizontal navigation operator.

+number Horizontal flow orientation: relative reference in right horizontal or downward
vertical direction.
Vertical flow orientation: relative reference in downward vertical or right
horizontal direction.

-number Horizontal flow orientation: relative reference in left horizontal or upward
vertical direction.
Vertical flow orientation: relative reference in upward vertical or left horizontal
direction.

number Horizontal flow orientation: absolute index reference in right horizontal or
downward vertical direction.
Vertical flow orientation: absolute index reference in downward vertical or
right horizontal direction.

"all" Returns a list of all references at the indicated horizontal level.

"first" Returns the first, leftmost reference at the indicated level.

"last" Returns the last, rightmost reference at the indicated level.

"index" Returns the horizontal index of the node at the respective level instead of the
node number, with 1 being the index of the leftmost node.

"min" Returns the index of the leftmost node at the respective level (always 1).

"max" Returns the index of the rightmost node at the respective level.
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With a vertical operator, you also can use the tool instance label (tool_label) as an absolute
position indicator.

The reference evaluates to:

■ A horizontal node index if index, min, or max is used as the horizontal operator.

■ A parameter value if parameter_name is used as the reference.

■ A file name if file_type is used as the reference.

■ A tool label if tool_label is used as the reference.

■ A node key if node or previous is used as the reference.

If several values result from the reference, a space-separated list is returned. Examples are: 

@node@ Current node key (the key of the output node of the current tool
instance).

@node:all@ List of all node keys at the current tree level, that is, at the level of the
current tool output nodes.

@node:2@ Node key of the second node at the current tree level.

@node:+2@ Node key two positions below the current node (in the same column).

@node:-1@ Node key immediately above the current node (in the same column).

@node:first@ Uppermost node key at the current tree level (column).

@node|-1:all@ All nodes on the previous level (column).

@node|+3@ Node keys at the third generation of siblings of the current node
(virtual nodes are ignored), three real levels to the right.

@node:index@ Index of the current node.

@node:min@ First index at the current tree level (always 1).

@file_type@ Output file of the first preceding matching tool.

@file_type:all@ List of all file names of type file_type produced by the tool at the
current tree level.

@file_type:3@ File name of type file_type of the third tool instance at the current
tree level.

@file_type:+1@ File of type file_type at the node below the current node (in the
same column).

@file_type:last@ Rightmost file of type file_type at the current level.
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Vertical Flow Orientation

In the horizontal direction, a unit represents an entire simulation phase. Intermediate nodes
(virtual nodes or split points) are not taken into account. For vertical operators, the following
additional keywords can be used instead of numbers: 

With a horizontal operator, you also can use the tool instance label (tool_label) as an
absolute position indicator.

@file_type/i@ Input file of type file_type of the current tool (for example,
n5_mesh.tdr).

@file_type/o@ Output file of type file_type of the current tool if defined as an
output file.

@file_type/o|-1@ Output file of type file_type of the previous tool if defined as an
output file.

@node:max@ Last index at the current tree level, the number of nodes at the current
level.

@tool_label@ Label of the tool at the current node.

@tool_label|all@ List of labels of tools appearing in the simulation flow.

@tool_label|1@ Label of the first tool in the simulation flow, the tool at absolute level
1.

@tool_label|+1@ Label of the following tool.

@tool_label|-1@ Label of the previous tool.

@tool_label|first@ Label of the first tool in the simulation flow.

@tool_label|last@ Label of the last tool in the simulation flow.

"all" Returns a list of all references at the indicated vertical level.

"first" Returns the first, upward reference at the indicated level.

"last" Returns the last, downward reference at the indicated level.

"index" Returns the vertical index of the node at the respective level instead of the node
number, with 1 being the index of the upward node.

"min" Returns the index of the upward node at the respective level (always 1).

"max" Returns the index of the downward node at the respective level.
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The reference evaluates to:

■ A vertical node index if index, min, or max is used as the vertical operator.

■ A parameter value if parameter_name is used as the reference.

■ A file name if file_type is used as the reference.

■ A tool label if tool_label is used as the reference.

■ A node key if node or previous is used as the reference.

If several values result from the reference, a space-separated list is returned. Examples are: 

@node@ Current node key (the key of the output node of the current tool
instance).

@node:all@ List of all node keys at the current tree level, that is, at the level of the
current tool output nodes.

@node:2@ Node key of the second node at the current tree level.

@node:+2@ Node key two positions to the right of the current node (in the same
row).

@node:-1@ Node key immediately to the left of the current node (in the same
row).

@node:first@ Leftmost node key at the current tree level (row).

@node|-1:all@ All nodes on the previous level (row).

@node|+3@ Node keys at the third generation of siblings of the current node
(virtual nodes are ignored), three real levels to the bottom.

@node:index@ Index of the current node.

@node:min@ First index at the current tree level (always 1).

@file_type@ Output file of the first preceding matching tool.

@file_type:all@ List of all file names of type file_type produced by the tool at the
current tree level.

@file_type:3@ File name of type file_type of the third tool instance at the current
tree level.

@file_type:+1@ File of type file_type at the node to the right of the current node
(in the same row).

@file_type:last@ Downward file of type file_type at the current level.
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You can use additional references that returns the current directory without suffixes only: 

#-Commands

Any preprocessor command starts with a hash (#) as the first character on a line. Space or tab
characters are allowed after the initial # for indentation. The spp utility recognizes the
following commands: 

@file_type/i@ Input file of type file_type of the current tool (for example,
n5_mesh.tdr).

@file_type/o@ Output file of type file_type of the current tool if defined as an
output file.

@file_type/o|-1@ Output file of type file_type of the previous tool if defined as an
output file.

@node:max@ Last index at the current tree level, the number of nodes at the current
level.

@tool_label@ Label of the tool at the current node.

@tool_label|all@ List of labels of tools appearing in the simulation flow.

@tool_label|1@ Label of the first tool in the simulation flow, the tool at absolute level
1.

@tool_label|+1@ Label of the following tool.

@tool_label|-1@ Label of the previous tool.

@tool_label|first@ Label of the first tool in the simulation flow.

@tool_label|last@ Label of the last tool in the simulation flow.

@pwd@ Absolute path of project.

@pwd@/@file_type@ File reference with absolute path.

#<string> This is a comment. spp strips all comment lines from the
preprocessed file and replaces them with empty lines. <string> is
any string not listed here as a preprocessor command.

#define <name> 
<string>

Defines a new macro <name>. spp replaces subsequent instances of
<name> with <string>.
262 Sentaurus™ Workbench User Guide
N-2017.09



A: Preprocessor and Reference Syntax
#-Commands
#setdep 
<list of nodes>

Explicitly sets dependencies of these nodes.

#remdep 
<list of nodes>

Explicitly removes dependencies from these nodes.

#include 
"<filename>"

Includes the contents of file name at this point. spp processes the
included file as if it were part of the current file.

#includeext 
"<filename>"

Same as the #include command, but with advanced processing of
<filename>. It allows <filename> to contain macros already
defined with the #define command.

#if <expression> Subsequent lines up to the matching #else, #elif, or #endif
commands appear in the output only if <expression> evaluates to
nonzero. <expression> is any standard Tcl expression that
evaluates to a number. Before evaluation, all @-substitutions are
expanded in <expression>.

#if in <gexpr> Same as the previous #if command, but evaluated to true when the
current node belongs to the nodes returned by gexpr (see Node
Expressions on page 131).

#elif <expression> Any number of #elif commands can appear between an #if
command and a matching #else or #endif command. If the
expression evaluates to nonzero, subsequent #elif and #else
commands are ignored up to the matching #endif. Any expression
allowed in an #if command is allowed in an #elif command. The
lines following the #elif command appear in the output only if all of
the following conditions are met:
– The expression in the preceding #if command is evaluated to zero.
– The expressions in all preceding #elif commands are evaluated to
zero.
– The current expression evaluates to nonzero.

#else Inverts the sense of the conditional command otherwise in effect. If
the preceding conditional indicates that lines are to be included, lines
between the #else and the matching #endif are ignored. If the
preceding conditional indicates that lines would be ignored,
subsequent lines are included in the output. Conditional commands
and corresponding #else commands can be nested.

#endif Ends an #if section.

#exit Stops preprocessing at this line. The following lines are stripped.

#verbatim <string> A line starting with #verbatim is not stripped, that is, the prefix
#verbatim is removed, but the rest of the line is not touched.
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Split Commands

The following preprocessor commands handle split points: 

NOTE Multiple split points are valid only if they appear in the same order as
the corresponding parameters in the simulation flow. If that is not the
case, the preprocessor takes only the best possible match, ignoring
certain split points.

#rem <string> A line starting with #rem is not stripped, but @-substitutions are
expanded in the rest of the line.

#noexec Does not execute (submit to scheduler) the current node.

#set <varname> 
<value>

Sets the value of <varname>.

#header Marks the first line of the header section. The header section is copied in
the beginning of each partial input file before the load command. Only
one header can be defined.

#endheader Last line of the header section, replaced by a blank line.

#postheader A postheader is an input file section that is copied after the load
command in each partial input file. This is useful to define simulator
defaults, which must be reset after a load command. Any number of
postheaders can be defined at any position in the original input file. They
are appended after the load command in the order of their definition.
Nesting or overlapping postheaders are not allowed.

#endpostheader Last line of a postheader section, replaced by a blank line.

#split @PNAME@ Defines a split on parameter PNAME. The input file is cut at this point into
(1) a partial input file from the previous split point to the current line and
(2) another partial input file from the current line to the next split point
(or to the end of the file). The current line is replaced with a save
command at the end of the first partial input file. The second partial input
file starts with the header, followed by the simulator load command, the
optional postheaders and, finally, the real partial input section.
param_name denotes the tree level where the split applies.
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A partial input file (corresponding to a split section) is considered a conventional tool input file
regarding forward references. A common mistake is to introduce a split point after a parameter
@-reference, when the referenced parameter appears after the split parameter in the simulation
flow.

Every #-preprocessor command that should be unique (common) to all split files must be
placed in the header section (#header ... #endheader). For example, the following three
macro definitions will appear in all files produced by #split:

#header
...
#define macro1 string1
#define macro2 string2
#define macro3 string3
...
#endheader

Otherwise, these macro definitions will be placed in the first file only and will be unknown to
the other files that were created after splitting. It can result in a preprocessing error.

Node Expressions

The EBNF syntax of a node expression GEXPR is:

gexpr : gterm [operator gterm]
operator : "+" | "*" | "-" | "^"
gterm : scnr["|"level][":{" filter "}"] | tool_label[":{" filter "}"] |

node | "(" gterm ")" | "~" gterm
node : integer
scnr : "all" | identifier
level : integer | "last" | tool
tool : identifier
filter : tcl_expr

where: 

scnr Name of a scenario

tool_label Label of a tool instance

node Node number

level Tree level, starting from 0

last Last tree level
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A: Preprocessor and Reference Syntax
Node Expressions
"+" The ‘or’ or ‘union’ binary operator

"*" The ‘and’ or ‘intersection’ binary operator

"-" The ‘difference’ binary operator

"^" The ‘exclusive-or’ binary operator

"~" The ‘extend-to-root’ binary operator

filter Tcl expression
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APPENDIX B Menus and Toolbar Buttons of 
Graphical User Interface

This appendix lists the menus and the toolbar buttons of the
graphical user interface of Sentaurus Workbench.

Project Menu

Table 27 Project menu commands

Command Toolbar 
button

Shortcut keys Description

New:

New Project Ctrl+N Creates a new project.

New Folder Creates a new folder in the projects browser.

Open Ctrl+O Opens a project.

Close Ctrl+F4 Closes currently opened project.

Save Ctrl+S Saves project under an existing name.

Save As:

Project Saves project under another name.

Clean Project Saves project under another name but does not copy. output 
and preprocessed files.

Save Selected Experiments 
As:

Project Creates a new project based on the selected experiments. 
The new project contains the simulation results of the 
selected nodes.

Clean Project Creates a new project based on the selected experiments. 
The new project does not contain the simulation results of 
the selected nodes.
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Project Menu
Command Toolbar 
button

Shortcut keys Description

Operations:

Reload Ctrl+D Reloads project.

Stop Loading Esc key Stops project loading or reloading.

Preprocess Ctrl+P Preprocesses current project.

Preprocess Tcl Blocks Ctrl+B Preprocesses Tcl command blocks.

Run Ctrl+R Runs current project.

Abort Ctrl+T Terminates running project.

Clean Up Ctrl+L Shows several project cleanup options.

Rename Renames project in the projects browser.

Reset Status Ctrl+K Resets project status to None.

Properties: Project properties:

Runtime Editing Mode:

Locked Specifies the Locked mode for a project.

Editable Specifies the Editable mode for a project.

Link Input Files in Node
Folders:

Only available in hierarchical mode.

Yes Creates symbolic links to project files inside each node 
folder.

No Does not create symbolic links.

Summary Ctrl+Y Shows project summary.

Readme Opens an editor with the project readme file.

Documentation Opens a project documentation file greadme.pdf in the 
default PDF viewer.

Logs: Options for viewing project-related logs:

Preprocessor Views preprocessor log.

Project Ctrl+J Views project log.

History Ctrl+H Views history log.

Export Packages the contents of a project to a .gzp file according 
to user settings in the Export to Package dialog box.

Table 27 Project menu commands
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Edit Menu
Edit Menu

Command Toolbar 
button

Shortcut keys Description

Import Extracts a zipped or tarred file containing a project into a 
directory and opens it.

Recent Projects List of recently opened projects.

Exit Ctrl+Q Exits Sentaurus Workbench.

Table 28 Edit menu commands

Command Toolbar 
button

Shortcut keys Description

Undo Ctrl+Z Undoes previous operation.

Cut Ctrl+X Cuts a selection of experiments.

Copy Ctrl+C Copies a selection of experiments.

Paste Ctrl+V Pastes a cut or copied selection of experiments.

Paste Special Ctrl+M Allows you to specify what to insert.

Delete Delete key Deletes currently selected item.

Attach Root Attaches a new root in the projects browser.

Detach Root Detaches root selected in the projects browser.

Tool DB: Options for viewing tool database files:

Global Global tool database.

Site Site tool database; available when 
SWB_SITE_SETTINGS_DIR is defined.

User User tool database.

Project Project tool database.

Table 27 Project menu commands
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Scheduler Menu
Scheduler Menu

Command Toolbar 
button

Shortcut keys Description

Run Limits: Options for viewing run limits settings files:

Global Global run limits settings.

Site Site run limits settings; available when 
SWB_SITE_SETTINGS_DIR is defined.

User User run limits settings.

Preferences F12 key Opens SWB Preferences dialog box.

Table 29 Scheduler menu commands

Command Toolbar 
button

Shortcut keys Description

Show Scheduler Opens Scheduler.

Configure Queues: Configures tool associations and node expressions:

User Queues Configures user queues, using user interface.

Project Queues Configures project queues, using user interface.

User DMW Queues Configures user DMW queues, also stored under 
user_queues, using user interface.

Project DMW Queues Configures project DMW queues, also stored under 
user_queues, using user interface.

Edit User Queues Edits user queues using standard text editor.

Edit Project Queues Edits project queues using standard text editor.

View Global Queues Views the global queue settings in read-only mode.

View Site Queues Views the site queue settings in read-only mode; available 
when SWB_SITE_SETTINGS_DIR is defined.

Table 28 Edit menu commands
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View Menu
View Menu

Table 30 View menu commands

Command Toolbar 
button

Shortcut keys Description

Flow Orientation: Configures simulation flow orientation:

Horizontal Horizontal orientation (default).

Vertical Vertical orientation.

Flow View Mode: Configures simulation flow display:

Full Displays full simulation flow (default).

Compact Displays only varying parameters and responses.

Customize Current View Configures project view by hiding or showing different 
parts of the simulation flow.

Tree Options: Submenu for options of viewing tree:

Show Tree F1 key When true, shows the simulation tree.

Show Experimental Plan F2 key When true, shows the experimental plan.

Show Parameters F3 key When true, shows parameter information.

Show Variables F4 key When true, shows variable information.

Show Pruned F8 key When true, shows pruned nodes.

Show Node Numbers F9 key When true, always shows node numbers with parameter 
values.

Hinting Tool Labels Ctrl+F9 When true, shows rollover text with the tool labels when the 
pointer is positioned over the tool icon.

Check Virtual Nodes Ctrl+0 When true, checks the node status of virtual nodes when 
running. Distinguishes virtual and real nodes using different 
colors. Displays virtual nodes in blue.

Show Merged Cells When true, merges node cells with the same parameter 
value.

Parameter Values Ctrl+1 Shows parameter values in node cells of the loaded project.

Node Numbers Ctrl+2 Shows node numbers in node cells.

Host Ctrl+3 Shows the last host on which the node was run.

Date Ctrl+4 Shows the time when the last run of the node was 
completed.
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View Menu
Execution Time Ctrl+5 Shows the time taken for the last run of the node or an error 
message.

Variables Ctrl+6 Shows information about the variables associated with the 
nodes.

Job Identifier Ctrl+7 Shows the job identifier assigned to the node when running 
on a cluster (farm, grid).

Table Options: Submenu for options of viewing simulation table:

Show Information Titles Shows the row with titles such as Family Tree and Variable 
Values.

Show Tool Icons Shows the row with tool icons.

Show Tool Labels Shows the rows with tool labels.

Show Comments Shows the row with tool comments (arbitrary multiline 
text).

Show Parameter Process 
Names

Shows the row with the process names of parameters (for 
process tools only).

Show Parameter and 
Variable Names

Shows the row with the names of parameters and variables.

Show Experiment Numbers Shows the column with the numbers of experiments.

Change Table Font Displays a dialog box where you can select the font.

Zoom In Ctrl+Plus sign Zooms in to the project view.

Zoom Out Ctrl+Minus 
sign

Zooms out of the project view.

Zoom Off Ctrl+0 Resets zoom to the default.

Freeze Rows/Columns Freezes selected rows or columns or both from scrolling

Unfreeze Rows/Columns Unfreezes selected rows or columns or both

Restore Default Cell Size Ctrl+7 Restores default cell size for all project nodes.

Restore Default View 
Options

Ctrl+8 Restores default view options from preferences.

Refresh F5 key Refreshes the tree or browser view.

Properties Shows the basic properties of the tree.

Table 30 View menu commands

Command Toolbar 
button

Shortcut keys Description
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Scenario Menu
Scenario Menu

Tool Menu

Table 31 Scenario menu commands

Command Toolbar 
button

Shortcut keys Description

Add Adds a new scenario to the tree.

Remove Removes scenarios from the tree.

Next Alt+ Shows next scenario in the tree.

Previous Alt+ Shows previous scenario in the tree.

Lock Locks all nodes of current scenario from preprocessing.

Unlock Unlocks all nodes of current scenario for preprocessing.

Unfold All Ctrl+Alt+A Unfolds all folded nodes of the current scenario.

Preprocess Preprocesses current scenario.

Table 32 Tool menu commands

Command Toolbar 
button

Shortcut keys Description

Add Insert key Adds a new tool, parameter, experiment, or variable to the 
tree.

Delete Delete key Deletes selected tool, parameter, experiment, or variable 
from the tree.

Properties Shows basic properties of selected tool.

Edit Input Opens submenu for editing input files of selected tool.

Clean and Synchronize With 
Parent Project

Synchronizes parameters and variables with a parent project 
with cleanup of a previous synchronization. This command 
is available only for the Bridge tool.

Synchronize With Parent 
Project

Synchronizes parameters and variables missing after the 
previous synchronization with a parent project. This 
command is available only for the Bridge tool.

Synchronize with Flow Obtains parameter and process names from a Ligament 
input flow and inserts them into the Sentaurus Workbench 
project; command appears only for process tools that use 
Ligament.

→

←
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Parameter Menu
Parameter Menu

Command Toolbar 
button

Shortcut keys Description

Create Process Output Links Allows creation of symbolic links to TDR output files; 
command appears only for process tools.

Preprocess Preprocesses all nodes belonging to the selected tools.

Hide Hides selected tools.

Show Shows a hidden tool.

Lock Locks selected tool with all its nodes.

Unlock Unlocks selected tool with all its nodes.

Table 33 Parameter menu commands

Command Toolbar 
button

Shortcut keys Description

Add Parameter/Values Insert key Displays the Add Parameter/Values dialog box where you 
can add a new parameter with variation to the flow or add 
values to the selected parameter.

Delete Delete key Deletes selected parameter from the flow.

Properties Shows properties of selected parameter.

Edit Values Displays dialog box to edit values of the selected parameter.

Remove Value Removes a value of the selected parameter.

Hide Hides selected parameters.

Show Shows a hidden parameter.

Table 32 Tool menu commands
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Experiments Menu
Experiments Menu

Table 34 Experiments menu commands

Command Toolbar 
button

Shortcut keys Description

Create Default Experiment Creates a new experiment for a specified scenario; default 
values are used for all parameters.

Add New Experiment Insert key Adds a new experiment to the tree (the default values are 
preset to a selected experiment if there is one).

Add Parameter/Values Adds parameter values to all experiments (full factorial) or 
selected experiments.

Manage Membership in 
Scenarios

Displays the Manage Membership in Scenarios dialog box 
where you can manage scenarios and associated 
experiments.

Exclude Experiments Delete key Excludes selected experiments from the current scenario.

Delete Experiments Deletes selected experiments from the flow.

DoE: Design-of-experiments options (see Chapter 5 on 
page 107):

DoE Wizard Opens the DoE Wizard.

Taguchi Wizard Opens the Taguchi Wizard.

Export: Submenu for exporting current project view:

Text File Exports view into a Microsoft Excel–compatible file.

Plot File Exports view into an Inspect-compatible file.

Run Inspect Exports view into a file and opens it with Inspect.

Run Spreadsheet 
Application

Exports view into a file and opens it with a spreadsheet 
application configurable in preferences.

Import From File Imports experiments from a text file.

Sort Experiments Sorts experiments according to a defined parameter.

Properties Shows parameter values of selected experiment.
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Nodes Menu
Nodes Menu

Table 35 Node menu commands

Command Toolbar 
button

Shortcut key Description

Select: Nodes selection submenu:

All Ctrl+A Selects all nodes.

By Expression Selects nodes according to an expression.

By Status Submenu for selecting nodes by their status; all submitted 
and all not yet running nodes.

Inverse Of Submenu for selecting nodes by the inverse of their status or 
their current selection.

Deselect All Esc key Deselects all selected cells.

Extend Selection To: Submenu for extending selected nodes to:

Root Root.

Leaves Leaves.

Experiments Experiments.

Prerequisite Nodes Prerequisite nodes.

Edit Value F6 key Switches selected node cell to edit mode to allow modifying 
the value; only single-node selection is supported.

Edit Properties Sets properties of a single selected node or allows you to 
modify the status of multiple selected nodes.

Modify Multiple Parameter 
Values

Sets parameter values on multiple nodes at the same time.

Set Variable Value Sets a variable value for the selected node; creates a variable 
if it does not exists.

Preprocess Preprocesses selected nodes.

Run Ctrl+R Runs selected nodes.

Quick Run Runs selected nodes in a selected queue immediately.

Abort Ctrl+T Terminates running of selected nodes.

Visualize Visualizes output files for selected nodes (see Viewing the 
Output Files of Nodes on page 41).
See Table 36 on page 278 for details of the Nodes > 
Visualize submenu commands
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Nodes Menu
Quick Visualize Quickly visualizes output files for selected nodes with the 
default visualizer.

Node Explorer F7 key Displays the Node Explorer.

View Output Ctrl+W Views standard output and error files of selected nodes.

Clean Up Node Output Delete key Shows cleanup options for selected node.

Configuration: Nodes configuration submenu:

Tool DB Info Shows input and output file names of selected nodes 
according to the tool database.

Lock Locks selected nodes from preprocessing.

Unlock Unlocks selected nodes from preprocessing.

Mark Ambiguous Marks selected nodes with a red exclamation mark.

Unmark Ambiguous Removes red exclamation mark from selected nodes.

Prune Ctrl+E Prunes selected nodes.

Unprune Ctrl+U Unprunes selected nodes.

Fold Folds selected nodes; nodes that do not have child nodes are 
not folded.

Unfold Unfolds selected nodes; if a node is not folded, this 
operation unfolds the nearest preceding folded node (if any).

Table 35 Node menu commands

Command Toolbar 
button

Shortcut key Description
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Nodes Menu
Table 36 Visualize submenu commands

Command Toolbar 
button

Shortcut keys Description

Sentaurus Visual Visualizes output files for selected nodes in Sentaurus 
Visual (see Viewing the Output Files of Nodes on 
page 41):
• Select File: Displays a dialog box where you select 

files for visualization.
• All Files: Visualizes all supported files.

Sentaurus Visual (Select by 
Type):

Visualizes specific output files for selected nodes in 
Sentaurus Visual (see Viewing the Output Files of Nodes 
on page 41):

All XY-Plot Files Files with the extensions .plt and .plx.

All Boundary Files Files with the extension *_bnd.tdr.

All Mesh Files Files with the extension *_msh.tdr.

All TDR Files Files with the extension .tdr.

Tecplot SV Visualizes output files for selected nodes in Tecplot SV:
• Select File: Displays a dialog box where you select 

files for visualization.
• All Files: Visualizes all supported files.

Inspect Visualizes output files for selected nodes in Inspect:
• Select File: Displays a dialog box where you select 

files for visualization.
• All Files: Visualizes all supported files.

Text Visualizes text files for selected nodes.

SDE Visualizes .sat files for selected nodes in Sentaurus 
Structure Editor.

Sentaurus Visual - Sentaurus 
Process Link

Launches Sentaurus Visual with the Sentaurus Process 
interface with the process flow of the selected Sentaurus 
Process node loaded.

XML LogFile Visualizes .xml files for selected nodes in the TCAD 
Logfile Browser.

HTML LogFile Visualizes .html files for selected nodes in the default 
browser.

Run Selected Visualizer 
Nodes Together

Preprocesses selected visualizer nodes (Sentaurus Visual 
or Inspect), merges their input command files into one 
file, and runs the merged file in the visualizer locally 
(see Viewing Visualizer Nodes Simultaneously on 
page 45).
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Variables Menu
Variables Menu

Compare Command Files of 
Selected Nodes

Compares the content of command files of selected 
nodes using a comparison application (see Comparing 
Command Files of Nodes on page 46).

PCM Studio: Export Current 
Scenario

See Table 40 on page 281.

PCM Studio: Configure 
Export

See Table 40 on page 281.

Table 37 Variables menu commands

Command Toolbar 
button

Shortcut keys Description

Add Insert key Adds a new variable to the project.

Delete Delete key Deletes selected variables from the project.

Properties Shows default formula of selected variable.

Format Displays a dialog box with formatting options for selected 
variable.

Update Variables Updates variables view if variables file (gvars.dat) has 
changed on disk.

Hide Hides selected variables.

Show Shows a hidden variable.

Table 36 Visualize submenu commands

Command Toolbar 
button

Shortcut keys Description
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Optimization Menu
Optimization Menu

NOTE This menu is shown only in Sentaurus Workbench Advanced mode. 

Calibration Menu

NOTE This menu is shown only in Sentaurus Workbench Advanced mode. 

Table 38 Optimization menu commands

Command Toolbar 
button

Shortcut keys Description

Edit Input Opens an editor with Optimizer input file.

Run Runs Optimizer.

View Log Views Optimizer log file.

View Optimization Plot Views optimization plot using Inspect.

RSM Visualization Displays RSM Visualization dialog box.

Optimization GUI Displays graphical user interface to create the optimization 
command file.

Table 39 Calibration menu commands

Command Toolbar 
button

Shortcut keys Description

Project Wizard See the Calibration Kit User Guide.

Scenario Wizard See the Calibration Kit User Guide.

Process Wizard See the Calibration Kit User Guide.

Parameter Wizard See the Calibration Kit User Guide.

Optimization Wizard See the Calibration Kit User Guide.
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PCM Studio Menu
PCM Studio Menu

NOTE This menu is shown only when a license for Sentaurus PCM Studio is
available. Refer to the Sentaurus™ PCM Studio User Guide for more
information. 

Extensions Menu

Table 40 PCM Studio menu commands

Command Toolbar 
button

Shortcut keys Description

Export Current Scenario Exports the current scenario to a temporary CSV file, then 
starts Sentaurus PCM Studio with this file.

Save Current Scenario to 
CSV Files

Exports the current scenario to a CSV file 
<scenario_name>.csv and stores it in the project 
directory.

Configure Export Displays dialog box to configure exporting to a CSV file.

Table 41 Extensions menu commands

Command Toolbar 
button

Shortcut keys Description

File Browser F11 key Browses directory files of project.

Command Prompt Here Opens a command prompt in the selected project.

New Script Creates and opens a new file for a Tcl script.

Run Script Runs a Tcl script.

Edit Script Edits a file containing a Tcl script.

Web Node Explorer Launches the Web Node Explorer for navigating through 
node files. Only available in the hierarchical mode.

Run Sentaurus Structure 
Editor

Launches Sentaurus Structure Editor.

Run Sentaurus Process Launches Sentaurus Process.

Run Sentaurus Visual Launches Sentaurus Visual.

Run Inspect Launches Inspect.

Run Tecplot SV Launches Tecplot SV.

Run Merger Launches Merger.
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Help Menu
Help Menu

Command Toolbar 
button

Shortcut keys Description

Run Log Browser Launches TCAD Logfile Browser to view .xml and .html 
log files of the selected node.

Run Sentaurus Visual - 
Sentaurus Process Link

Launches Sentaurus Visual with Sentaurus Process interface 
where you can load the process flow of the selected 
Sentaurus Process node and interactively run it.

Run Layout Viewer Launches the layout viewer as specified in the preferences: 
Utilities > Layout Viewer.

Reconstruct Extracted 
Results

Parses all the node output files n*_*.out, finds the 
extracted results, and updates the Variables field in the 
project.

Save Extracted Results 
Summary

Parses all the node output files n*_*.out, finds the 
extracted results, and saves them in the given .csv file.

Table 42 Help menu commands

Command Toolbar 
button

Shortcut keys Description

About Ctrl+B Provides version information.

Manuals Opens a front page to the technical documentation (PDF) in 
Adobe Reader.

Training Opens TCAD Sentaurus Tutorial (HTML training material) 
in a browser.

Table 41 Extensions menu commands
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Toolbar Buttons of Project Editor
Toolbar Buttons of Project Editor

Table 43 Project Editor toolbar buttons

Toolbar 
button

Description Toolbar 
button

Description

Creates a new project. Runs selected visualization nodes together.

Opens a project. Displays information (properties) about the 
currently selected item.

Saves a project under an existing name. Runs current project or selected nodes.

Reloads a project. Terminates running project or selected nodes.

Stops the loading of a project. Zooms in to the project view.

Closes the currently opened project. Zooms out of the project view.

Cuts a selection. Resets zoom to the default.

Copies a selection. Changes the current project view to the next 
view.

Pastes a cut or copied selection. Opens a spreadsheet application with the 
current view.

Undoes previous operation. Displays a simulation project vertically.

Adds a new tool, parameter, experiment, or 
variable to the tree.

Displays a simulation project horizontally.

Deletes selected tool, parameter, experiment, 
or variable from the tree.

Displays a simulation project in compact 
mode.

Adds a new experiment to the tree (the 
default values are preset to a selected 
experiment if there is one).

Displays a simulation project in full mode.

Adds parameter values to either all (full 
factorial) or selected experiments.

Opens a command prompt in a project 
directory as a separate shell.

Opens submenu for editing input files of 
selected tool.

Opens manuals in PDF format using the 
Adobe® Reader® application.

Visualizes output files for selected nodes. Opens TCAD Sentaurus Tutorial (HTML 
training material) in the default browser.

Quickly visualizes output files for selected 
nodes with the default visualizer.
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Keyboard Navigation Keys

Table 44 Keyboard navigation keys

Key Description

Tab Moves between the projects browser and project viewer panel.
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APPENDIX C Sentaurus Workbench Files

This appendix lists the different files relevant to Sentaurus
Workbench.

Project Files

The following project files are specific to Sentaurus Workbench: 

gtree.dat Contains the simulation tree.

gvars.dat Contains all variables of a project.

gtooldb.tcl The tool database of a project.

glog.txt Contains the project log data.

greadme.txt The readme file of a project.

greadme.pdf The documentation file of a project.

preprocessor.log Contains preprocessor log data.

gexec.cmd Jobs execution graph.

gopt.cmd Optimizer input file.

gopt.log Optimizer log file.

gqueues.dat Queues configuration file.

gsummary.txt Summary of a project.

gcomments.dat Contains comments for project tool steps.

runlimits.txt Contains project run limits.
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Hidden Files
Hidden Files

The following hidden files are not necessarily visible in the directory listings of a project: 

User Configuration Files

All these files are in the env(STDB) directory: 

Global Configuration Files

These files are in the following directories:

■ $STROOT/queues; $STROOT/tcad/$STRELEASE/lib/glib2:

gqueues.dat Queues configuration file.

.database Database of project view settings.

.history Events history of a project (including preprocessing, runs, and cleanup).

.organization Project organization, either traditional or hierarchical.

.project Empty file indicating that the current directory is a project directory.

.status Project status.

gqueues_<user>.dat Queues configuration file.

tooldb_<user> The tool database of the user.

runlimits_<user>.xml Run limits settings of the user.

gpref2_<user>.<release>.xml Preference file. There is one preference file for each release
of TCAD Sentaurus, including feature and service pack
releases. For example:
– Sentaurus Workbench, Version M-2016.12, would use the
gpref2_jsmith.M-2016.12.xml file.
– Sentaurus Workbench, Version M-2016.12-SP1, would
use the gpref2_jsmith.M-2016.12-SP1.xml file.
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Site Configuration Files
■ $STROOT/tcad/$STRELEASE/lib/glib2:

tooldb.tcl Global tool database.

runlimits.xml Global run limits settings.

gpref2.$STRELEASE.xml Global preferences.

Site Configuration Files

These files are in the following directories:

■ SWB_SITE_SETTINGS_DIR:

gqueues.dat Queues configuration file.

tooldb.tcl Site tool database.

runlimits.xml Site run limits settings.

gpref2.$STRELEASE.xml Site preferences.

Typical Input and Output Files

These are some typical file patterns seen in projects. The actual file names depend on the
definitions of the tool database:

<tool_label>_<tool_acronym>.cmd Input file template: the command file of a tool.

<tool_label>_<tool_acronym>.* The other input files of a tool that are configurable in
the tool database.

pp<node_number>_<tool_acronym>.* Node input files created by preprocessing.

n<node_number>_<tool_acronym>.* Node output files.
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Typical Input and Output Files
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APPENDIX D Known Issues on VNC Clients

This appendix discusses known issues related to running Sentaurus
Workbench on VNC clients.

Double-Clicking Operation Does Not Work

On some VNC clients, double-clicking a node, parameter, tool, or variable does not work as
expected. For example, if the action of double-clicking a tool is bound to editing the tool input
file in the preferences, the expected text editor does not open after double-clicking.

In particular, this problem appears on the TightVNC client where the double-clicking operation
is prevented by the default mouse settings on the TightVNC client. 

Figure 91 TightVNC connection options
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Double-Clicking Operation Does Not Work
Workaround

In the Connection Options dialog box (see Figure 91 on page 289), the Emulate 3 buttons
(with 2-button click) option is selected by default, which results in incorrect double-clicking
action in Sentaurus Workbench. This option must be cleared.

This problem has not been observed on other VNC clients, in particular, RealVNC.
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APPENDIX E Troubleshooting Network Issues

This appendix describes how to diagnose network issues affecting
the communication between Sentaurus Workbench components.

Sentaurus Workbench Diagnostics Tool

Synopsys’ customers work in differently configured distributed environments. It might be that
networking issues or incorrect environment settings affect Sentaurus Workbench operations.

Investigations of various issues that customers have experienced working with Sentaurus
Workbench have shown that most of these issues seem to be due to specific operating system
configurations or network issues. Examples include, but are not limited to:

■ TCP ports of the host are closed.

■ Host A does not see host B with the ping command, and so on.

■ A significant network latency.

The Sentaurus Workbench Diagnostics tool checks whether the Sentaurus Workbench
infrastructure can run properly on two given hosts, so that detected issues can be addressed
promptly from the customer side.

Troubleshooting the Sentaurus Workbench Network

To test and debug possible issues with the communication architecture of Sentaurus
Workbench, the Sentaurus Workbench Diagnostics tool must be executed.

This batch tool detects and addresses specific issues in the working environment that can affect
the behavior of Sentaurus Workbench. In particular, this tool checks that the:

1. Sentaurus Workbench infrastructure can communicate among two or more hosts.

2. Sentaurus Workbench environment variables STROOT, STRELEASE, STROOT_LIB, and
STDB are set correctly.

For item 1, given a list of machines, the tool iterates through all combinations, starting the
swblm daemon process on one machine and having all other machines, iteratively, trying to
ping it and, if successful, trying to connect to the daemon.
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In more detail, the steps for item 1 are:

1. Select a machine (the server) to host the swblm daemon and connect to it.

2. Terminate any previous instance of swblm on the host machine.

3. Start a new swblm daemon.

4. Check for the ~/.swb/swblm/<release>/swblm.conf file.

5. Iterate through the rest of the machines and:

a) Connect to the selected machine (the client).

b) Ping from the client machine to the server machine.

6. Request a connection to the swblm daemon on the server machine.

7. Return to Step 1.

For item 2, the tool checks the following environment variables:

■ STROOT: It issues a warning if the variable is not set.

■ STRELEASE: It issues a warning if the variable is not set.

■ STROOT_LIB:

• It does not issue a warning if the variable is not set. Typically, users do not set this
variable.

• If you set this variable, the tool issues a warning if the variable is not set to the default
value of $STROOT/tcad/$STRELEASE/lib, since there might be a library mismatch
between different TCAD Sentaurus releases.

■ STDB: It issues a warning if the variable is not set.

Limitations and Assumptions

The Sentaurus Workbench Diagnostics tool does not check the validity of host names. It
assumes these follow the proper rules of the system.

The entire Sentaurus Workbench infrastructure must be switched off during such tests since the
swblm daemon must be restarted. You must stop all your running projects and exit all
Sentaurus Workbench instances of the current release.

A silent remote connection is required (no password is needed or other interactive
authentication) in the case of remote host checking.

It is assumed that all checked hosts share the file system, which is also the assumption for
Sentaurus Workbench operations.
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Usage

To start the test, execute the following command in the shell:

% swbdiag [options] [HOSTS]

The options are:

-h[elp] 

Displays details about how to use the Sentaurus Workbench Diagnostics tool.

-v[ersion] 

Displays the current version of the tool.

-f[ile] 

Allows you to specify a file containing a list of hosts to test. If this option is defined, any
list of hosts specified outside the file is ignored.

Instead of a file, you can directly provide a list of hosts as arguments. The following example
illustrates the differences:

■ Hosts specified through a file:

% swbdiag -f hosts.txt

■ Hosts specified as direct arguments:

% swbdiag hostA rsh:hostB ssh:hostC

If the list of hosts is provided in a file, it must be a plain text file containing the name of the
hosts separated by space, tabs, or newlines.

The Sentaurus Workbench Diagnostics tool requires and accepts the rsh: and ssh: prefixes
to specify the connection type to the remote host. The tool assumes that hosts without a prefix
correspond to the local host.

Report and Log File

The Sentaurus Workbench Diagnostics tool prints to the screen the current step of the test. If
the tool successfully terminates any previous instance of the swblm daemon (item 1, Step 2),
at the end of the test, a report is generated and saved to:

~/.swb/swblm/<RELEASE>/swblm.test
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This file contains exactly the same information that has been printed to the screen.

The report is delimited as follows:

■ Each test to check the Sentaurus Workbench infrastructure (item 1) is delimited by two
lines composed of the hash (#) character.

■ Each connection test between the local host and the remote host is delimited by one line
composed of the equal sign (=).

■ At the end of the test, the Sentaurus Workbench environment variables are checked. The
results are printed immediately after the last pair of lines composed of the # character:

• If everything is acceptable with a variable, you should see only the following message:

<Timestamp> - INFO: Checking variable <Variable under test>

• If the case is not set, a warning is issued.

• The only exception is STROOT_LIB since it is not a problem if this environment
variable is not set (only an information message is printed). However, a warning is
issued if the variable is set but does not match the following path:

$STROOT/tcad/$STRELEASE/lib

If an error is detected during the testing of the Sentaurus Workbench infrastructure, a summary
table is printed at the end of the log file. The report groups the error messages into the following
categories:

■ Initialization: SWBLM could not be initialized 

■ Release mismatch: SWBLM release version mismatch or not found 

■ Configuration file: SWBLM configuration file not found or corrupted 

■ Connection: These hosts could not connect to server/SWBLM or host does
not exist 

Here is an example of the report:

Server Issue

us01acme01 SWBLM could not be initialized
cl01narf03 SWBLM release version mismatch or not found
cn04kung12 SWBLM configuration file not found or corrupted
us03acmerh05 These hosts could not connect to server/SWBLM or host does not

exist: * us03acmerh01,* us03acmerh02,* us03acmerh03

The Server column indicates the machine that it is hosting the swblm daemon during that stage
of the test.
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