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Правила и алгоритми за разполагане на компоненти 

 

1. Подготовка на платката за разполагане на компоненти 
Преди започване на процеса на разполагане на компонентите на платката е необходимо са 

бъдат зададени подходящи конфигурационни параметри на платката. За целта трябва да 
бъдат направени следните проверки: 

1.1. Проверка на очертанието на платката очертанието за разполагане 

Check the board outline and place outline 
 

Board outline – граница на печатната платка, дефинирана на глобалния слой; 
Place outline – дефинира размер на област за разполагане на графичното изображение на 
корпуса на компонент. Всеки корпус трябва да има такава област. Layout използва Place 
Outline,  за да определи дали възникват нарушения на разстоянията между компонентите по 
време на процеса на разполагане. 
Алгоритъм 

- Избор на електронната таблица Spreadsheet Toolbar button => Obstacles или 
команда Tool => Obstacle=>Select From Spreadsheet (Фиг. 1); 
- Преглед на колоната Oblstacle Type в електронната таблица  за проверка на 
Board outline и Place outline за широчина или височина и слой. 

 

 

Фиг. 1. Проверка на очертанието на платката очертанието за разполагане 

1.2. Проверка за мрежата за разполагане 

Check the place grid 
По подразбиране мрежата за разполагане е 100 mils, когато е зареден технологичен 

шаблон по подразбиране (default.tch). 
Алгоритъм 

- Избор на Options => System Settings 
1.3. Проверка на огледалните и библиотечните слоевете 

Check the mirror layer or Library Layer 
- Проверява се кои слоеве са конфигурирани да имат огледално разположени 
очертания, стекове петна и текст на друг слой по време на разполагането;  



- Проверява се съответствието на име на слой и библиотечен слой; 
Алгоритъм 

- Избор на електронната таблица Spreadsheet Toolbar button => Layers или 
Tool  => Layers  => Select from spreadsheet 
- Проверка на установяванията в колона Mirror Layer и  Layer Name да бъдат 
противоположни; 
- Проверка на съответствието между име на слой и подходящ библиотечен слой; 

1.4. Задаване на тегло,  осветеност  и цветен код на мрежата 
Weighting and color-coding nets 

Мрежи с тегло (Weighting nets) – Мрежите с по-голямо тегло и техните компоненти се 
запазват заедно, като Layout задава по-висок приоритет за тях в процеса на разполагане. 
Теглата ма мрежите се задават в линеен мащаб от 0 до 100. 
Алгоритъм 

- Избор на електронната таблица Spreadsheet Toolbar button => Nets или 
Tool  => Nets  => Select from spreadsheet; 
- Избор на клетка с името на мрежата, за която ще се променя тегло и осветеност. 
Изпълнява се команда от pop-up menu => Properties или двоен клик на ляв бутон; 
- Промяна на теглото на мрежата и избор на опция за осветеност Highlight в 
диалоговия прозорец Edit Net; 
- Промяната на друг цвят на избраната мрежа става от pop-up menu => Change Colors. 

 

 

Фиг. 2. Промяна на тегло, осветеност и цветен код на мрежа  

1.5. Проверка на информацията за поделементите и изводите в пакетите 

Check gate and pin data 
Информацията в електронната таблица за пакетите (Package Spreadsheet) се използва 

за да се провери дали може да се осъществява размяна (swap) на поделементи между еднакви 
компоненти или само в един пакет, как са подредени поделементите в пакета. 



Алгоритъм 
- Избор на електронната таблица Spreadsheet Toolbar button => Package или 

Tool  => Package  => Select from spreadsheet; 

 

Фиг. 3. Проверка на  информацията за пакетите  

1.6. Проверка и закрепване на предварително поставените компоненти  

Check and secure preplaced components 
1.6.1. Понятие за предварително поставени компоненти 
Предварително поставени компоненти (Preplaced components)  

- Компоненти или корпуси, които са поставени още на ниво схематика или като част от 
технологичен шаблон или шаблон на платка; 
- Тези компоненти трябва да бъдат подходящо поставени преди да започне 
разполагането на останалите компоненти; 
- Предварително поставените компоненти могат да включват: 

 съединители, монтажни отвори, памети, интегрални схеми с голям брой изводи; 
 предварително дефинирани схеми, които трябва да бъдат разполагани в 

специфични позиции, поради механични или температурни ограничения. 
1.6.2. Закрепване на предварително поставените компоненти 

След разполагането на предварително поставените компоненти, те трябва да бъдат  
установени в избраните позиции, за да не могат да бъдат местени при разполагането на 
другите компоненти. Това може да бъде реализирано  по два начина със следните команди: 

- Команда Lock – за временно заключване на компонент в определена позиция; 
- Команда Fix – за трайно фиксиране на компонент в определена позиция. 

Алгоритъм за заключване/фиксиране: 
· Маркиране на компонент; 
· Pop-up меню => Fix/Lock или 
· Команда Tool=>Component=>Fix/Lock. 

1.6.3. Алгоритъм за отмяна на заключване/фиксиране 

- Отмяна на заключване – избор на заключения компонент  (или заключените 
компоненти)  и избор на бутон OK при поява на диалоговите съобщения от Фиг. 4. 

- Отмяна на фиксиране  
· Избор на електронната таблица Spreadsheet Toolbar button => Components 
или команда Tool => Components=>Select From Spreadsheet; 
· в електронната таблицата се избира компонентът, който има вдигнат флаг Yes; 
· в диалоговия прозорец Edit Component и се отменя опцията Fix (виж. Фиг. 5). 

   



 

   

Фиг. 4. Отмяна на временно заключени с команда Lock компоненти 

 

 

 

 

Фиг. 5. Отмяна на постоянно фиксирани с команда Fix компоненти 



1.7. Дефиниране на области на включване/изключване на компоненти 
        (keepin/keepout) 

Creating height or group keepins and keepouts 

1.7.1.  Понятие за области на включване/изключване на компоненти 
· област на включване на компоненти (Keepin) – област, дефинирана върху 
определен слой на платката, предназначена да съдържа всички компоненти от дадена 
група, определена по някакъв признак. 
· област на изключване на компоненти (Keepоut) – област, дефинирана върху 
определен слой на платката, предназначена да изключва всички компоненти от дадена 
група, определена по някакъв признак. 

1.7.2.  Видове области на включване/изключване на компоненти 
OrCAD Layout дава възможност за ограничаване на разполагането на компонентите на 

базата на физически ограничения и принадлежност към група, като се използват следните 
видове очертания: 

- Comp height  keepins - съдържа всички компоненти с височина равна или по-
голяма от зададената; 
- Comp height keepouts - изключва всички компоненти с височина равна или по-
голяма от зададената; 
- Comp group keepins - съдържа всички компоненти от дадена група; 
- Comp group keepouts - изключва всички компоненти от дадена група. 

Алгоритъм 
- Избор на Obstacle Toolbar button => pop up menu New или команда Tool => 
Obstacle=> New; 
- Изчертаване на правоъгълна затворена област, която да дефинира желаната keepin 
или keepout област; 
- Избор на команда от pop up menu Properties или двоен клик с ляв бутон на 
мишката в дефинирания правоъгълник; 
- В диалоговия прозорец Edit Obstacle, показан на Фиг. 6,  се редактират следните 
полета: 

· Поле Oblstacle Type – избира се Comp height  keepins или Comp height 
keepouts; 
· Поле Height -  въвежда се желаната височина на компонента. 

- В диалоговия прозорец Edit Obstacle се редактират следните полета: 
· Поле Oblstacle Type – избира се Comp group  keepins или Comp group 
keepouts; 
· Поле Group - въвежда се число, съответстващо на номера на групата 
компоненти. 

1.8. Зареждане на файл-стратегия за разполагане 

Файловете-стратегии конфигурират дисплея на системата т.е. какво е необходимо да се 
вижда по време на разполагане на компонентите – например очертания на компонентите, 
електрически връзки, означения. Препоръчва се да се зареди файл-стратегия за разполагане 
PLSTD.sf, преди изпълнение на ръчно разполагане на компонентите. 

Алгоритъм 
- Избор на команда File => Load; 
- В диалоговия прозорец Load File се променя типът на файловете да бъде *.sf ; 
- Избор на файл-стратегия за разполагане PLSTD.sf. 

1.9. Групиране на компонентите за разполагане 

Grouping Components for Placement 

Групирането на компонентите с цел подобряване на процеса на разполагане може да се 
извърши както на ниво схематика, така и в Layout. 

Алгоритъм 
· Избор на електронната таблица Spreadsheet Toolbar button => Components или 
команда Tool => Components=>Select From Spreadsheet; 
· в електронната таблицата се избират компонентите, които трябва да бъдат групирани; 
· в диалоговия прозорец Edit Component в поле Group # се въвежда цяло число за 
номера на групата (виж. Фиг. 7). 



 

Фиг. 6. Дефиниране на области на включване/изключване на компоненти 

 

Фиг. 7. Създаване на групи от компоненти за подобряване на  процеса на разполагане 



1.10. Забрана на мрежите „захранване” и  „земя” 

Disabling the power and ground nets 
Ако мрежите „захранване” и  „земя” не са критични по отношение на разполагането,  то 

трябва да се забрани опроводяването на всички мрежи, присъединени към плоскостните 
слоеве (plane layers). Това би довело до значително подобряване на работата на системата в 
процеса на разполагане. 
Алгоритъм 

- Избор на електронната таблица Spreadsheet Toolbar button => Nets или 
Tool  => Nets  => Select from spreadsheet; 
- В електронната таблица на мрежите се избират с натиснат клавиш CNTL всички мрежи, 
присъединени към  плоскостните слоеве  (обикновено VCC и GND); 
- Избор на команда Enable => Disable от pop-up menu и в резултат флагът в колоната 
Routing Enable на електронната таблица за тези мрежи  се променя на No (Фиг. 8). 

 

Фиг. 8. Забрана на мрежите „захранване” и  „земя” в процеса на разполагане на компоненти 

2.  Правила за разполагане на компоненти 

При разполагане на компонентите върху печатната платка трябва да бъдат спазвани 
следните общи правила: 

- Куплунзи, конектори и компоненти за управление и настройка се разполагат в края на 
платката; 
- Най-напред се разполагат компонентите с голям брой изводи и връзки (обикновено в 
средата на платката); 
- Интегралните схеми се разполагат хоризонтално по редове или вертикално в колони с 
еднакво ориентиран първи извод; 
- Филтриращите кондензатори трябва да се разполагат близо до интегралните схеми 
(спрямо захранването); 
- Еднотипните дискретни елементи (резистори, кондензатори диоди) се разполагат в 
групи (вертикално или хоризонтално ориентирани), като стремежът е минимална 
дължина на връзките; 
- Компонентите могат да бъдат групирани и разполагани на функционален принцип 
(вход, изход, управление и т.н.); 
- Компонентите могат да бъдат групирани и разполагани по признак захранване, 
особено в случаите, когато трябва да бъдат разделени аналоговите и цифровите 
захранване и земя, което налага да се разделят (split) на плосткостните слоеве на 
отделни зони, присъединени към съответните мрежи; 
- Компонентите могат да бъдат разполагани на базата на физически рестрикции или 
принадлежност към група (дефиниране на области keepins, keepouts); 
- SMТ елементи могат да се разполагат на огледалния (mirror) слой, като се използват 
огледални надписи и очертания. 



3.  Правила и команди за разполагане на компонентите 
3.1. Индивидуално разполагане на компоненти 

(Place components individually) 
Алгоритъм 

- Избор на команда Tool => Components или  
- Избор на Component toolbar button команда Pop-up меню => Query for Placement; 
- В диалоговия прозорец  Component Selection Criteria се въвеждат означение, корпус 
или критерии за разполагане (виж Фиг. 9). Могат да бъдат използвани символите “?”, “*” 
за избор на група компоненти; 
- Избор на команда Edit => Select Next или Pop-up меню => Select Next; 
Компонентът се прикрепя към курсора. Ако е избрана група компоненти (например R*), 
към курсора най-напред се присъединява елементът с най-голям номер на мрежата. 
- Избраният компонент (или компоненти) се влачи до желаната позиция и се разполага 
с клик на ляв бутон на мишката в избраната позиция. 
 

 

Фиг. 9. Диалогов прозорец  Component Selection Criteria 

 

3.2. Разполагане на групи компоненти 
(Placing component groups) 

3.2.1. Създаване на групи компоненти на ниво схематика 
- Функционално свързаните компоненти могат да бъдат обединени в група още на ниво 
схематика; 
- Създаването на група компоненти в Capture става като за всеки компонент от групата 
с редактора на свойствата бъде създадено ново свойство със следните атрибути: 

 – име на свойството -  Component Group; 
 - стойност на свойството - номерът на групата, към която ще принадлежи 
съответния компонент. Номерът е цяло число в интервала от 0 до 7500.  

3.2.2. Алгоритъм за разполагане на групи компоненти 
- Избор на команда Tool=> Components => Select Filtered  или  
- Избор на Component toolbar button => Pop-up меню => Select Any 
- В диалоговия прозорец  Component Selection Criteria в поле Group Number все 
въвежда номера на групата, дефиниран на ниво схематика (Фиг. 9). Всички компоненти 
от групата се присъединяват към курсора и се разполагат едновременно. 
- Избраната група компоненти се влачи до желаната позиция и се разполага с клик на 
ляв бутон на мишката в избраната позиция. 



5. Минимизиране на връзките за оптимално разполагане 
5.1. Понятие за неопроводена връзка (ratsnest) 

- представлява връзка (т.е. електрически път между два извода) с нулева дължина, 
оцветена в жълт  цвят, която предстои да бъде опроводявана (Фиг. 18); 
- при неопроводена платка показва мрежата от връзки с нулева дължина (връзки, които 
водят директно от петно на горен слой към петно на долен слой без движение в X, Y 
посока), които предстои да бъдат опроводявани за да се формират пистите на платката. 

 

Фиг. 18. Мрежа от неопроводени връзки (ratsnest) 

5.2. Команда за преизчисляване на неопроводените връзки 

- В Layout е предвидена възможност за оценяване и преизчисляване на връзките в 
мрежите за намиране на най-оптимален (минимален) път в мрежата. Тази възможност 
може да  бъде реализирана по два начина: 

 преизчисляване на връзките за избрани обекти от платката (един или няколко 
компонента), при което командата се изпълнява като локална команда; 

 преизчисляване на връзките за цялата платка, при което командата се изпълнява 
като глобална команда.  

Алгоритъм 
- Избор на определени компоненти и мрежи при изпълнение на локалната команда; 
- Изпълнение на команда Auto => Refresh => Minimize Connection или 
-  Component Toolbar => Pop-up => Minimize Connection; 

6.  Проверки на разполагането на компоненти 

6.1. Проверкa за нарушения на разстоянията при разполагане на  компонентите 
(Placement Spacing Violations) 

6.1.1. Особености 
- Използва се очертанията на  компонентите (place outline) за проверка на 
разстоянията; 
- Всеки проблем се маркира с кръг, както е показано на Фиг.19; 
- Информация за проблема се получава при натискане на Query Toolbar button (виж 
Фиг. 20); 
- При възникване на грешка се избира Error Toolbar бутон, посочва се грешката и 
информацията за грешката се появява в прозорец за запитване Query Window. 

6.1.2. Алгоритъм за проверка на разстоянията при разполагане на компоненти 
- Избор на команда Auto => Design Rule Check; 
- В диалоговия прозорец  Check  Design Rules избор на бутон Clear All (виж Фиг. 21); 
- Избор на опция Placement Spacing Violations; 
- DRC процесът в Layout проверява платката и маркира грешките с кръгове. 

 



 

Фиг. 19. Маркиране на грешките при разполагане на компоненти с кръг 

 

Фиг. 20. Извеждане на информация за грешките при разполагане на компоненти 

6.2. Проверки на плътността на разполагане на компоненти 

6.2.1. Понятие за граф на плътността  

- Граф на плътността (Density Graph) – показва графично представяне на плътността 
при разполагане на компонентите и при опроводяването (Фиг. 22); 
-  Използва цветно кодиране: 

  от син цят до зелен цвят – малка, допустима плътност; 
  до розов цвят  или червен цвят –  голяма и най-голяма плътност. 

- Представлява степента на трудност, която ще се срещне при опроводяването на 
платката; 
- Визуализира два вида данни: 

 плътност на платката (board density) – показва брой на петна и връзки в дадена 
област  в платката и се визуализира като цветни области вътре в платката; 

 плътност на пистите (track density) – демонстрира плътността на опроводяването 
и се визуализира като бар граф отгоре и отдясно на платката. 



 
Фиг. 21. Диалогов прозорец за проверка на грешки при разполагане 

6.2.1. Команда за извеждане на граф на плътността 
- Команда за извеждане на граф на плътността  
 View => Density Graph => Fine, Medium, Coarse 
- Команда за връщане към проекта View => Design 

 

Фиг. 22. Граф на плътността за разполагане на компонентите и за плътността на опроводяване 



6.3. Статистика на разполагането на компоненти 
(Placement Statistics) 

Разполагането на всички компоненти на платката се проверява чрез извеждане на 
статистика на разполагането, която е показана на Фиг. 23. 
Алгоритъм 

- Команда за извеждане на статистика на разполагането  
    View => Database Spreadsheets => Statistics или  
    Spreadsheet toolbar button => Statistics; 
- Показва се елетронната таблица за статистиката; 
- Търсят се редовете за разполагане на компонентите -  %Placed Row. 

 

 

Фиг. 23. Електронна таблица за статистика за разполагане на компонентите 


